These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
 

The new launcher and the web server issues on the 21st of May: FAQ and update thread

First post First post
Author
Smoking Blunts
ZC Omega
Goonswarm Federation
#741 - 2013-06-14 07:14:30 UTC
CCP Atropos wrote:
Alphea Abbra wrote:
What I read is that the work on the launcher is complete.
Fine, that was what I expected, although I'm a little sad.

I have 2 alt accounts whose subs will run out in the next few months. I liked the extra things I could with those alts, but CCP clearly opted out of customers having more than one account.
Sad, I know, but that is the quality of your work.

I'm sorry that you feel that way, but I have to say that you're wrong: we're not finished on the EVE Launcher. We've been going over all of the issues that people have been reporting, working on fixing any bugs, and planning how we might handle further changes to the user interface.

Rather than rush out a fix, and leave both of us in a situation that's worse, we're trying to make it better; that means not rushing it out, not screwing things up further and not antagonising everyone. The alternative is to just push it out, and hope for the best. I would hope that you would agree that a position of prudence and careful diligence would prove the saner, better route.



you rushed the launcher out and now you have decided rushing half finished crap out is a bad idea?...lol

anyhow. for multiboxers you have added more steps. it needs to be
1. click on exe
2. enter pass
3. hit return

it needs to be that simple and the log off button for alt swapping has to restart the launcher. this is the most important thing, as people do not want you dam add machine running for no reason on their pc's

OMG when can i get a pic here

Alphea Abbra
Project Promethion
#742 - 2013-06-14 09:23:09 UTC
CCP Atropos wrote:
Alphea Abbra wrote:
What I read is that the work on the launcher is complete.
Fine, that was what I expected, although I'm a little sad.

I have 2 alt accounts whose subs will run out in the next few months. I liked the extra things I could with those alts, but CCP clearly opted out of customers having more than one account.
Sad, I know, but that is the quality of your work.

I'm sorry that you feel that way, but I have to say that you're wrong: we're not finished on the EVE Launcher. We've been going over all of the issues that people have been reporting, working on fixing any bugs, and planning how we might handle further changes to the user interface.

Rather than rush out a fix, and leave both of us in a situation that's worse, we're trying to make it better; that means not rushing it out, not screwing things up further and not antagonising everyone. The alternative is to just push it out, and hope for the best. I would hope that you would agree that a position of prudence and careful diligence would prove the saner, better route.
I'm sorry, I can't read the lies you post, I have to watch what you do instead.
Y'know, the stuff that actually matters?

As for the last paragraph ... I know it's "PR-talk" to placate us, but when you actually do realise that, please apply that thinking before you send out alpha-versions of flawed designs.
I'll look forward to when that happens.

Quote:
Blink
Seth Toralen
Deep Core Mining Inc.
Caldari State
#743 - 2013-06-14 15:56:22 UTC
I appreciate that CCP has acknowledged that there are some significant problems that need to be worked through. Among many, many people with current and last gen nVidia cards are having problems with EVE and drivers (some so severe it's crashing their games). Many people are unable to login through the launcher, because for varied reasons, it's broken for them. Some people (myself included) can't login into any of EVE's website services (API, Account Management, ect.) ever since you tried to create this 'unified login' system. Oh and on top of all the bugs, you've had people DDoS'ing your servers. CCP is having a bad month.

But at least we're all on the same page that these problems exist. I feel like CCP Atropos is getting some unfair heat for all this here. The launcher isn't a bad thing.... if they get it working. And I am sure usability tweaks will be made once they actually get this simplified version working. As long as ALL of our bugs are getting attention to get resolved, I am okay. Just try and get them all fixed as quickly as you can. EVE players are impatient people.
Fedajin
Rin Logistic Services
#744 - 2013-06-14 22:18:48 UTC
Well after trying to download the game from www.eveonline.com it gave me an Archive exstraction 3 error.

So I decided to download EvE online from Steam which worked fine - only to get stuck at

1/4 validating Client: 0.0%

I´ve tried everything you guys have suggested on this forum

Eve repair.exe gives me an error after running for 4 seconds - i´ve tried running EvE repair over 50 times.. thats how stubborn I was and I always got the same error message.

File "repairTool\repairUI.pyc", line 97, in Start
File "repairTool\repairLogic.pyc", line 199, in Repair
File "repairTool\repairLogic.pyc", line 359, in Restore
File "zsync\zsync.pyc", line 377, in RestoreFolder
File "zsync\zsync.pyc", line 668, in GetInfo
File "zsync\dataPackage.pyc", line 198, in __init__
File "stuff\bundle.pyc", line 119, in __init__
error: unpack requires a string argument of length 4
Total Runtime: 0h00m04s


Even Tried the famous Exefile in the EvE online bin folder - Guess what................. yeb you guessed it.

it din´t fkn work

I even downloaed the Chribba 50mb zip file .... and copy & paste it in the eve online folder and said yes & replace all

Then tried using Exefile application only to see alot of unverfied Steam message ...

you´re really outdone your self CCP - thanks for sending me that Eve online newsletter email when you´re game is broken - apparently its been that way since you´re release on the newest update of your´s

bought a 2 months subscription for nothing Sad
CCP Atropos
C C P
C C P Alliance
#745 - 2013-06-15 01:34:04 UTC
Fedajin wrote:
Well after trying to download the game from www.eveonline.com it gave me an Archive exstraction 3 error.

So I decided to download EvE online from Steam which worked fine - only to get stuck at

1/4 validating Client: 0.0%

I´ve tried everything you guys have suggested on this forum

Eve repair.exe gives me an error after running for 4 seconds - i´ve tried running EvE repair over 50 times.. thats how stubborn I was and I always got the same error message.

File "repairTool\repairUI.pyc", line 97, in Start
File "repairTool\repairLogic.pyc", line 199, in Repair
File "repairTool\repairLogic.pyc", line 359, in Restore
File "zsync\zsync.pyc", line 377, in RestoreFolder
File "zsync\zsync.pyc", line 668, in GetInfo
File "zsync\dataPackage.pyc", line 198, in __init__
File "stuff\bundle.pyc", line 119, in __init__
error: unpack requires a string argument of length 4
Total Runtime: 0h00m04s


Even Tried the famous Exefile in the EvE online bin folder - Guess what................. yeb you guessed it.

it din´t fkn work

I even downloaed the Chribba 50mb zip file .... and copy & paste it in the eve online folder and said yes & replace all

Then tried using Exefile application only to see alot of unverfied Steam message ...

you´re really outdone your self CCP - thanks for sending me that Eve online newsletter email when you´re game is broken - apparently its been that way since you´re release on the newest update of your´s

bought a 2 months subscription for nothing Sad

Do you have any antivirus or firewall software running? We've been in contact with the manufacturers behind Spybot Search and Destroy regarding their proxy software causing issues with the EVE Launcher. We've also seen reports of issues with Kaspersky Internet Security but haven't been able to reproduce them ourselves.
Lors Dornick
Kallisti Industries
#746 - 2013-06-15 09:36:09 UTC
Sorry for messing up the feedback thread but.

Seth Toralen wrote:
I feel like CCP Atropos is getting some unfair heat for all this here.


The launch of the launcher wasn't exactly perfect.

But Atropos and team has been here and done their bit to try to solve the issues.

So grovelling done, accept our thanks, now get back to to solving the remaining ones ;)

CCP Greyscale: As to starbases, we agree it's pretty terrible, but we don't want to delay the entire release just for this one factor.

Alphea Abbra
Project Promethion
#747 - 2013-06-15 10:14:53 UTC
Lors Dornick wrote:
Sorry for messing up the feedback thread but.

Seth Toralen wrote:
I feel like CCP Atropos is getting some unfair heat for all this here.


The launch of the launcher wasn't exactly perfect.

But Atropos and team has been here and done their bit to try to solve the issues.

So grovelling done, accept our thanks, now get back to to solving the remaining ones ;)
Not to rain too much on CCP Atropos' parade, but the launcher still doesn't work, and CCP Atropos has yet to even ACKNOWLEDGE that there might be design issues with the whole ordeal.
It wasn't just the bugs that are inherent when you release a beta WIP as "finished".
It was the whole design around the SSO and the webserver and the 3 extra steps to have active alts.

I haven't seen CCP Atropos work on other issues than bugs that were released due to sloppy QA, and as said, it doesn't even seem that CCP is aware that the launcher itself is a bug.
The whole "launcher" thing isn't just "not exactly perfect", it's the perfect example of "Working? Ruin it. Doesn't work? Don't fix."

It doesn't really surprise me anymore, CCP Atropos has been pretty dishonest through this thread and the one before, I just hoped that someone at CCP could take a look at the new launcher and go "Why do we double the steps necessary to log in, when all we can say as positives are stuff we might maybe get to look at in the SOON(tm) future?"
The "new" "SSO" "launcher" reeks of bad QA, no use-case testing, and an overzealous designer.

Quote:
Blink
bongpacks
Rules of Acquisition
#748 - 2013-06-15 12:23:20 UTC
Guess what, the launcher can still be completely broken by a simple double-click on the arrow for the drop-down box for username, then hitting backspace. Sure who's gonna do that? Not the point is it?
Par'Gellen
#749 - 2013-06-15 12:54:52 UTC
CCP Atropos wrote:
With user login moved into the EVE Launcher, we need to follow up on the release of the new EVE Launcher by adding in either the ability to switch characters or to relaunch the EVE Launcher and switch users, or supply a way to improve this flow. We're aware of this and are planning accordingly.

Any update on this yet? I highlighted the important bit that we need.

"To err is human", but it shouldn't be the company motto...

Alphea Abbra
Project Promethion
#750 - 2013-06-15 17:27:35 UTC
Par'Gellen wrote:
CCP Atropos wrote:
With user login moved into the EVE Launcher, we need to follow up on the release of the new EVE Launcher by adding in either the ability to switch characters or to relaunch the EVE Launcher and switch users, or supply a way to improve this flow. We're aware of this and are planning accordingly.

Any update on this yet? I highlighted the important bit that we need.
Don't count on it.
Check, for example, this post.
We got an enormous load of garbage and bovine excrements now, and it might, possibly and without any promises, get worked upon so that improvements can happen in the very undefined future.
In the meantime, enjoy the launcher!

In the words of CCP Atropos:
Quote:
Blink
THE SMUDGE
ALIMONY INC
#751 - 2013-06-15 23:30:09 UTC  |  Edited by: THE SMUDGE
Been playing a long time, have a few accounts, like using Isboxer.. Have never felt the need to come to the forums and whinge..



Until now.


Eve life has been painful since this launcher was released upon us like some lab-made plague. It can take up to 40 times longer to launch my accounts than before... And that's when they launch..

I have had to do different things to launch on different days, sometime make sure that other clients aren't just sitting there in the background, sometime launch from the exe.. Is this the new hacking mini game? If so, I don't like it can I have my spaceships back please?

Last night, Saturday night here, I wrestled with 4 accounts and almost lost ships many times.. Finally 2 accounts froze.. Ships still in space, wouldn't let me log off, had to close from program manager.. Fine... it's fine I'll take all this abuse to play my game...


This morning woke up with big plans involving just one account, plans that we had worked on for a few weeks..


MY launcher is offline (yet my girlfriend is logged in next to me)... Told to petition. sigh.....

What are you guys trying to do? We sell your game to our friends so hard, we finally get them into it then you do this stuff. My Sunday is fast ticking away... Petitioning and going to do something else..

This launcher needs to be scrapped rolled back and salted from the internet. Don't break our games when we put so much time into them. This is like being locked out of my apartment!
THE SMUDGE
ALIMONY INC
#752 - 2013-06-16 00:02:37 UTC  |  Edited by: THE SMUDGE
CCP Atropos wrote:
[
Do you have any antivirus or firewall software running? We've been in contact with the manufacturers behind Spybot Search and Destroy regarding their proxy software causing issues with the EVE Launcher. We've also seen reports of issues with Kaspersky Internet Security but haven't been able to reproduce them ourselves.



Well I just disabled all my security (why I should have to to play a game that has run fine for me since 2005 I have no idea)

And zip, nada, same offline message.....

Any more ideas?



I tried the repair tool.....

Failed to repair the EVE Online client. You can get help on the EVE Online forums at https://forums.eveonline.com/

Then it updated again and seems to be working.

Edit.. Nope the online green turned to offline red,, I;ll just watch the other thread I just noticed.

Working now running the exe from the bin folder. Will have to figure out my isboxer stuff later at least I'm in! ;)

Hahha emergency shutdown in 50 seconds.. FML lol
Fedajin
Rin Logistic Services
#753 - 2013-06-16 03:41:21 UTC
CCP Atropos wrote:
Fedajin wrote:
Well after trying to download the game from www.eveonline.com it gave me an Archive exstraction 3 error.

So I decided to download EvE online from Steam which worked fine - only to get stuck at

1/4 validating Client: 0.0%

I´ve tried everything you guys have suggested on this forum

Eve repair.exe gives me an error after running for 4 seconds - i´ve tried running EvE repair over 50 times.. thats how stubborn I was and I always got the same error message.

File "repairTool\repairUI.pyc", line 97, in Start
File "repairTool\repairLogic.pyc", line 199, in Repair
File "repairTool\repairLogic.pyc", line 359, in Restore
File "zsync\zsync.pyc", line 377, in RestoreFolder
File "zsync\zsync.pyc", line 668, in GetInfo
File "zsync\dataPackage.pyc", line 198, in __init__
File "stuff\bundle.pyc", line 119, in __init__
error: unpack requires a string argument of length 4
Total Runtime: 0h00m04s


Even Tried the famous Exefile in the EvE online bin folder - Guess what................. yeb you guessed it.

it din´t fkn work

I even downloaed the Chribba 50mb zip file .... and copy & paste it in the eve online folder and said yes & replace all

Then tried using Exefile application only to see alot of unverfied Steam message ...

you´re really outdone your self CCP - thanks for sending me that Eve online newsletter email when you´re game is broken - apparently its been that way since you´re release on the newest update of your´s

bought a 2 months subscription for nothing Sad

Do you have any antivirus or firewall software running? We've been in contact with the manufacturers behind Spybot Search and Destroy regarding their proxy software causing issues with the EVE Launcher. We've also seen reports of issues with Kaspersky Internet Security but haven't been able to reproduce them ourselves.





YOU WERE CORRECT! it was Spybot Search & Destroy software that denied me from updating my game.. but now after you had to reboot EvE online after 23:55 or 00:55 the game no longer works.. it wont start up when I click the EvE.exe - nor do I have Exefile anymore - ... im so tired and frustrated - completely exhausted
Zeb DaMadMan2
Duckling System
#754 - 2013-06-16 12:05:08 UTC  |  Edited by: Zeb DaMadMan2
Are we ever getting an update to the odyssey login theme?
http://i.imgur.com/aXaEopX.jpg
It's been a few weeks, and having no effects or music is really dull.

Also why are you ignoring every post about why were being forced to use the launcher? - All we've seen so far is the fact you don't care about the old login screen according to your actions with only 1 post acknowledging how "it's iconic" yet here we are, with a ******* plain login screen still. WTF?

We've already proven that majority of the community hates the launcher. We don't care if you want to continue working on it, but DON'T take away how we experience eve and expect us to like it.

If you don't want take the time to put a proper login screen, at least return retribution.
Hell even Incarna had a better login screen - http://www.youtube.com/watch?v=J8oNeuXzx6c

"As soon as we stop asking about the launcher design, CCP will assume we already love it.

We won't." - Eve Community

Alphea Abbra
Project Promethion
#755 - 2013-06-16 12:57:43 UTC
Zeb DaMadMan2 wrote:
Are we ever getting an update to the odyssey login theme?
http://i.imgur.com/aXaEopX.jpg
It's been a few weeks, and having no effects or music is really dull.

Also why are you ignoring every post about why were being forced to use the launcher? - All we've seen so far is the fact you don't care about the old login screen according to your actions with only 1 post acknowledging how "it's iconic" yet here we are, with a ******* plain login screen still. WTF?

We've already proven that majority of the community hates the launcher. We don't care if you want to continue working on it, but DON'T take away how we experience eve and expect us to like it.

If you don't want take the time to put a proper login screen, at least return retribution.
Hell even Incarna had a better login screen - http://www.youtube.com/watch?v=J8oNeuXzx6c
I'm not too surprised the way it turned out.
CCP Atropos already stated that the bin/ExeFile.exe bugfix to the "new" "SSO" "launcher" would be removed later.
Why work on something that is due for removal anyway?

The really sad thing is, when CCP went ahead with a "new" login "mechanic", they made a very clear and distinct choice to remove functionality (for anyone who doesn't have the same number of pc's as alts), remove a very iconic theme/mood-setter (login screen and music), removed the option of splash screens on login screen, and for me also removed any way of easy patching. These are things we had before, but does not have now.
Furthermore, they made a number of mistakes, that can mostly be summed up to the sentiment that logging into your game should be easy. "EVE is hard", "you need to adapt to survive", "choices are real and have both costs and benefits", "dystopia", the whole thing, whether that part is true or not you can only sell it if the game is accessible. Spending a minute for each small patch-day to let your "launcher" verify the game? No, it's not a lot of time, but it shouldn't even be necessary. The web-page-SSO "launcher" ordeal isn't an improvement either, since getting online now requires two things to be in perfect order (Gameservers and webservers), three if on patchday.
What I saw with this "new" "SSO" "launcher" was a removal of functionality and a very iconic (if intangible) feature, burdened with slower access for the game and issues if I wanted to do access the (UNCHANGED!) ingame content the way I did before.
Of course, there was a workaround/bugfix to the issues CCP released, which CCP Atropos promised to remove.

The most tragicomic thing is that I still enjoy the game, I very much enjoy the changes in Oddysey!
My ability to access that improved or new content, as well as participating in a war, has just been limited to 1 account per computer, per CCP Atropos' intended login "mechanic". The hilarious idiocy of it all? The launcher is in my way to enjoy the game!
The way the "new" "SSO" "launcher" has been designed is in my way, that is.
This design in itself is the bug I wish to report.

Alphea Abbra wrote:
Don't worry, Atropos has avoided any uncomfortable questions regarding the launcher the whole thread.
As soon as we stop asking about the launcher design, CCP will assume we already love it.

We won't.
From here, in case anyone wonders

And, as always:
CCP Atropos wrote:
Blink
Par'Gellen
#756 - 2013-06-16 13:11:00 UTC  |  Edited by: Par'Gellen
CCP Atropos wrote:
I still want all feedback on the EVE Launcher and it's user experience; if people stop talking about it, it doesn't mean they're magically feeling great about it, it simply means they're not talking about it. The lengthy feedback threads, and my full EVEMail inbox, are still there, and the points people made need to either be acknowledged and worked on, or acknowledged and dismissed. I'll consider the matter closed when people start posting "I ran the new EVE Launcher today, and it was awesome!" or threads/posts/EVEMail to that effect.

That's all well and good, but when we stop seeing any progress (as we have with the launcher) what do you expect us to think? There are lots of things promised in the OP of this thread that we haven't seen or even heard a peep about since. Just stating something on the forums does not make it so.

We need to see you actually implementing the good ideas like switching characters without having to log out before we will believe that you are actually listening to us. It's not our first day dealing with CCP's antics and you cannot expect us to be anything but skeptical based on past experiences.

You want us to believe you are taking us seriously? Prove it.

"To err is human", but it shouldn't be the company motto...

Sanyo Santiago
Homicidal Nomads
#757 - 2013-06-16 15:24:38 UTC
I hate the EVE launcher for several reasons. For the sake of brevity, here's *one* of them. I use two monitors when playing Eve. I want one of my accounts to open the client and show up on one monitor, while the other two clients for my other accounts should open on the other monitor. BUT everytime I log in, my client settings are reset and they each open on the same monitor! Do you realize how ridiculous it is to have to set monitor settings for my clients each time I want to play? Seriously, fix this **** real soon CCP. It's gone on too long now and my patience is running very thin, especially considering the previous login mechanic worked perfectly fine and you broke it all!
Ian Hood
Black Spiral Dancers
#758 - 2013-06-17 00:10:59 UTC  |  Edited by: Ian Hood
The Odyssey launcher has been a royal pain in the neck since it was rolled out. It took me 3 days to finally update to Odyssey because the updates hang *EVERY* *SINGLE* *TIME* - sometimes at 0%, sometimes at 5%, sometimes at 16% and, most annoyingly, at 100%.

Since then there have been *6* updates and I cringe every time because I *KNOW* that it's going to take me 3-4 hours of restarting the launcher to get the update installed.

THE LAUNCHER IS *BROKEN*.... FIX IT!

I'm so frustrated now that I am about to cancel my subscription and forget about the game entirely. It's THAT badly broken.
Rommiee
Mercury Inc.
#759 - 2013-06-17 14:10:26 UTC
Seth Toralen wrote:
I appreciate that CCP has acknowledged that there are some significant problems that need to be worked through. Among many, many people with current and last gen nVidia cards are having problems with EVE and drivers (some so severe it's crashing their games). Many people are unable to login through the launcher, because for varied reasons, it's broken for them. Some people (myself included) can't login into any of EVE's website services (API, Account Management, ect.) ever since you tried to create this 'unified login' system. Oh and on top of all the bugs, you've had people DDoS'ing your servers. CCP is having a bad month.

But at least we're all on the same page that these problems exist. I feel like CCP Atropos is getting some unfair heat for all this here. The launcher isn't a bad thing.... if they get it working. And I am sure usability tweaks will be made once they actually get this simplified version working. As long as ALL of our bugs are getting attention to get resolved, I am okay. Just try and get them all fixed as quickly as you can. EVE players are impatient people.


Are you completely brain dead ? Why cannot you grasp the situation here ?

It is not the fact that the launcher is buggy, more time consuming to use, and very unfriendly to people using more than one character. All these are issues that could be worked on and resolved. We are not complaining about that.

The issue here is the fact that this launcher was introduced onto the test server. Yes, the server used for testing. Despite feedback about how crappy it was CCP, brought it onto Tranquillity anyway. They have been bringing in half arsed, unusable crap from Sisi to TQ for a long time, and NEVER learn by their mistakes.

You are complementing CCP for trying to repair the crap they have created, when it should never have been brought on to TQ in the first place.

THAT is the issue. Wake up and smell the coffee.
Rommiee
Mercury Inc.
#760 - 2013-06-17 14:13:07 UTC
CCP Atropos wrote:
The alternative is to just push it out, and hope for the best.


Isn't that what you already did ?


CCP Atropos wrote:

I would hope that you would agree that a position of prudence and careful diligence would prove the saner, better route.


Like keeping it on SISI until it was ready ? oh wait.....