These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
 

The new launcher and the web server issues on the 21st of May: FAQ and update thread

First post First post
Author
Oraac Ensor
#841 - 2013-07-04 15:48:38 UTC
Par'Gellen wrote:
I can't log in. Any ideas Atropos? Nothing has changed on my end. I logged in this morning with no problems but now I'm getting this crap:

http://www.neoncranium.com/WTFLauncher.jpg

How do you suggest I log in based on what you see there? X

I have exactly the same situation. One minute my launcher (which the repair tool insists I don't have Roll) was working normally, five minutes later I get the result shown in the link.
YourDeathAngel
The Legion of Spoon
Curatores Veritatis Alliance
#842 - 2013-07-04 15:56:23 UTC
Same here. Worked all until half an hour ago. 2 chars logged in, then launcher turned into that black hole as in the picture linked above. Repair tool made no change. Deleting launcher folder and reinstalling made no change. There is some hidden error message behind that black hole error 18 something...

Went to customer service site; impossible to log in. Same on the account page. Finally found this page and - miracle - could log in and type this.

This is hard to believe. Glad I took off time from work to do this instead of enjoying a game I pay serious $ for...

What's going on and when can I play?

Arlee Emery
Caldari Provisions
Caldari State
#843 - 2013-07-04 15:56:37 UTC
Same. Logged in last night no problems, now no username or password fields visible in the launcher. By holding my mouse down I can see some black text:

Error -118 when loading url https://login.eveonline.com/oauth/authorize/?client_id=eveLauncherTQ&lang=en&response_type=token&redirect_uri=https://login.eveonline.com/launcher?client_id=eveLauncherTQ&scope=eveClientToken
Seth Toralen
Deep Core Mining Inc.
Caldari State
#844 - 2013-07-04 16:00:45 UTC  |  Edited by: Seth Toralen
Oh my gosh.... now you all understand the pain of our 324 Errors. This is exactly what happens to us.

If you're experiencing the same problem, you just have a black space on the launcher with black text (convenient) hiding an error message. And this is likely the only EVE website you can get into because all of the login pages won't work. This one only lets you in cause of cookies. Did CCP try to fix this and break it for more people? lolololol
Par'Gellen
#845 - 2013-07-04 16:03:59 UTC
Here is what it might as well look like when you open the launcher. This is how it feels at least.

http://www.neoncranium.com/WTFLauncher2.jpg

"To err is human", but it shouldn't be the company motto...

Oraac Ensor
#846 - 2013-07-04 16:14:18 UTC  |  Edited by: Oraac Ensor
YourDeathAngel wrote:
Same here. Worked all until half an hour ago. 2 chars logged in, then launcher turned into that black hole as in the picture linked above. Repair tool made no change. Deleting launcher folder and reinstalling made no change. There is some hidden error message behind that black hole error 18 something...

Went to customer service site; impossible to log in. Same on the account page. Finally found this page and - miracle - could log in and type this.

This is hard to believe. Glad I took off time from work to do this instead of enjoying a game I pay serious $ for...

What's going on and when can I play?


I can play via the Bin/Exefile.exe route, but my subscription is about to expire, so the lack of access to Account Management is a pain.

On the other hand, given the current situation, should I bother?

[Edit] Everything seems to be back to normal now.
YourDeathAngel
The Legion of Spoon
Curatores Veritatis Alliance
#847 - 2013-07-04 16:39:29 UTC
Yes, seems to be back to normal after 2 hours. Bad luck/timing for us - doesn't work if I would tell that my customers. These issues seem to be come too regular recently. I can imagine without being an IT specialist how tricky this all is but well that's why people like me pay money to make it work and play a decent game. I haven't figured out yet in what sense this launcher is better than what was there before - no issues in the past years but two serious issues with this "new" launcher make me wonder why to change things that worked better before.
Oraac Ensor
#848 - 2013-07-06 18:43:19 UTC  |  Edited by: Oraac Ensor
Oraac Ensor wrote:
CCP Atropos wrote:
As for the EVEMail, I don't know the dispatch date; it will go out as part of a general player base survey that we run every year, I believe.
I don't understand this reply. When our conversation ended you still had no idea what was causing my problem and asked if it was ok to Eve-mail me. Why would you need to ask my permission to send me a general player base survey and how would it help with my problem?

Bump.
Smoking Blunts
ZC Omega
Goonswarm Federation
#849 - 2013-07-11 11:26:48 UTC  |  Edited by: Smoking Blunts
so ccp Atropos, the bog standard surveys out, hardly any mention of the launcher. not sent via email annoyingly, had to click on the link in the launcher, glad some one told me about it or I would have missed it, well played on that btw

when do we get the survey about the launcher you said was coming out to us?

OMG when can i get a pic here

Rommiee
Mercury Inc.
#850 - 2013-07-12 09:44:45 UTC  |  Edited by: Rommiee
Smoking Blunts wrote:
so ccp Atropos, the bog standard surveys out, hardly any mention of the launcher. not sent via email annoyingly, had to click on the link in the launcher, glad some one told me about it or I would have missed it, well played on that btw



Nicely played CCP :)

Seeing as half the players don't bother to use the launcher, they would never have seen it. Excellent way to try and limit the users carrying out the survey to CCP fanbois.

I salute your cunning attempt at subterfuge.

Awesome stuff.
Alphea Abbra
Project Promethion
#851 - 2013-07-12 13:55:33 UTC
Rommiee wrote:
Smoking Blunts wrote:
so ccp Atropos, the bog standard surveys out, hardly any mention of the launcher. not sent via email annoyingly, had to click on the link in the launcher, glad some one told me about it or I would have missed it, well played on that btw



Nicely played CCP :)

Seeing as half the players don't bother to use the launcher, they would never have seen it. Excellent way to try and limit the users carrying out the survey to CCP fanbois.

I salute your cunning attempt at subterfuge.

Awesome stuff.
Thanks for noticing this.
If I hadn't been told, I wouldn't be able to complete this survey.

This is really poor, and along with CCP Atropos refusing to engage in any honest way here, I think the debate is over.
Good fight dishonest CCP employees, you won.
Par'Gellen
#852 - 2013-07-16 14:38:48 UTC  |  Edited by: Par'Gellen
Saw the launcher update today. Still no requested features... What?

"To err is human", but it shouldn't be the company motto...

Alphea Abbra
Project Promethion
#853 - 2013-07-16 15:36:57 UTC
Par'Gellen wrote:
Saw the launcher update today. Still no requested features... What?
Doing something with/to the Mac launcher is, by virtue of not fixing past mistakes or acknowledging errors, understandably more appropiate conduct than fixing past mistakes.
I have no idea why I am continued to be surprised.

CCP, I look forward to the day when you don't have to say you'll listen to community outrage.
It will be a day to behold.
Smoking Blunts
ZC Omega
Goonswarm Federation
#854 - 2013-07-16 15:45:21 UTC
so opened the launcher 8 times to patch 8 clients today.

it patched them, I then closed them and used the bin/exe short cuts and I got easy fast access to my accounts and my log off button or alt swapping.

also didn't have to leave 8 useless programs running to open 8 clients, that's winning.


so ccp, when can we have that level of functionality added to the game please?

OMG when can i get a pic here

Niding
Lowlife.
Snuffed Out
#855 - 2013-07-17 11:24:16 UTC  |  Edited by: Niding
Well, I did complete the survey and gave the launcher appropiate level of attention in the free-text parts.

Other than that; I havent really given the launcher much thought since last post since I only use it for updating
the patches and /bin exefile for the actual launching of the game.
Alphea Abbra
Project Promethion
#856 - 2013-07-17 12:34:30 UTC
Niding wrote:
Well, I did complete the survey and gave the launcher appropiate level of attention in the free-text parts.

Other than that; I havent really given the launcher much thought since last post since I only use it for updating
the patches and /bin exefile for the actual launching of the game.
For the game itself, I can +1 that.
But the problem, as I know you're aware, is that the team that gave us the launcher wants to remove the login mechanics.
It's a showcase of their "work" that players desire to circumvent it to play the game.
Rodsmith
The Scope
Gallente Federation
#857 - 2013-07-20 23:27:05 UTC
Alphea Abbra wrote:
Niding wrote:
Well, I did complete the survey and gave the launcher appropiate level of attention in the free-text parts.

Other than that; I havent really given the launcher much thought since last post since I only use it for updating
the patches and /bin exefile for the actual launching of the game.
For the game itself, I can +1 that.
But the problem, as I know you're aware, is that the team that gave us the launcher wants to remove the login mechanics.
It's a showcase of their "work" that players desire to circumvent it to play the game.



Your doing better than i am. All of a sudden yesterday no matter how i get to the exefile it immediately goes "non-responsive" anything after that just brings up the standard option to check for an updated solution becasue your program isn't working with windows.
Alphea Abbra
Project Promethion
#858 - 2013-07-21 07:21:08 UTC
Rodsmith wrote:
Alphea Abbra wrote:
Niding wrote:
Well, I did complete the survey and gave the launcher appropiate level of attention in the free-text parts.

Other than that; I havent really given the launcher much thought since last post since I only use it for updating
the patches and /bin exefile for the actual launching of the game.
For the game itself, I can +1 that.
But the problem, as I know you're aware, is that the team that gave us the launcher wants to remove the login mechanics.
It's a showcase of their "work" that players desire to circumvent it to play the game.



Your doing better than i am. All of a sudden yesterday no matter how i get to the exefile it immediately goes "non-responsive" anything after that just brings up the standard option to check for an updated solution becasue your program isn't working with windows.
I have no idea what could be the cause for that.
But my guess (From the lack of outrage here) is that it might as well be a problem on your end.

Still, I would love CCP Atropos to either accept that her work is detrimental to the enjoyment of the game, or for CCP Atropos to actually, honestly, productively, fix the design issues, give the launcher the former capabilities (Which also means removing a lot of junk - such as SSO), and maybe learn something from this sad story.
Of course given CCP Atropos' track record since summer of 2011, the odds are in disfavour.

To quote CCP Atropos:
Quote:
Blink
Haulin Gneiss
Ministry of War
Amarr Empire
#859 - 2013-07-21 19:58:17 UTC  |  Edited by: Haulin Gneiss
Raging Beaver wrote:
I'm posting in this topic because I am constantly experiencing launcher failures.
The scenario is always the same:
1. Client/launcher update is released. (At this moment the launcher is operational)
2. I download an update (usually via the client itself, you know, the file that says it's a patch but in fact isn't, being a file that is supposed to initiate the actual download through the launcher).
3. The launcher starts showing the "Downloading Launcher Update" window
4. Once the download is complete - the window disappears. At this moment the launcher is already dead, and by dead I mean that I won't start (AT ALL). If I start the launcher at this point, I get the "Dowloading Launcher Update" window, for more details on what happens later, go to point 3.
5. I launch the repair tool, which downloads the actual patch and updates the client to a working state (thank God...). Launcher remains dead.

The only method of restoring the launcher is to reinstall an earlier version.

This has happened numerous times since the new launcher was introduced. Every single time - this was the effect.

Now, gentlemen, from my perspective, the new launcher is a disaster and the fact that you HAVE TO use it to patch the client (or the repair tool, but that's another story) is ridiculous. Please also note, that the fact that running the repair tool doesn't fix the launcher, doesn't improve the customer experience in this area.


While playing game froze then crashed. Have since not been able to log on. When i can get the launcher up, i press play, button reads launching, then turns back to play and at this point disappears. Also when downloading the launcher again i log on as usual at which point the launcher is visible to my eyes - but disappears when it is installing files. However, task manager has the launcher still running i just cant see it.

Have tried all steps in the following:
http://wiki.eveonline.com/en/wiki/EVE_Launcher_Issues_and_Workarounds

http://cdn1.eveonline.com/EveOnlineLauncher/release/EVEOnlineLauncher_2_1_545736.exe

1) C:\CCP\EVE\repair.exe 1a) If the repairer fails - re-run it until it completes.
2) C:\CCP\EVE\bin\ExeFile.exe

STEP 1: Delete everything in .../Eve/BulkData
STEP 2: Run .../Eve/repair.exe
STEP 3: Run .../Eve/eve.exe

Have tried via .exe, cleared cache, downloaded launchers: 2.1.545736 / 2.1.559197 / 2.1.539169 / no luck.

Have pinged, many places many times with many packets, no issue's

no other issue on any sites, audio visual or any other manner, nor any other game disc or online. Speaking with and reading yet more forums, aparently this is called a ghost launcher.

Also, have posted a bug report 164816 - NR so far. Which in my experience is shocking Shocked but am i surprised? No.

26 £ and no game play for 7 hours. WTF?! XCry
CCP Atropos
C C P
C C P Alliance
#860 - 2013-07-22 11:38:48 UTC  |  Edited by: CCP Atropos
You can install the latest version of the EVE Launcher from here: http://content.eveonline.com/EveOnlineLauncher/release/EVEOnlineLauncher_2_1_571330.exe

There was an issue with an earlier Launcher build that would stop it from terminating correctly, but that was fixed some time ago. If you can provide logs and attach them to your bug report I'll see what issues they mights identify.

EDIT: you can find the logs from the EVE Launcher in a folder named launcher\cache inside your EVE installation. Additionally, if you could let me know what the Repair Tool reports when running, that would help narrow down any problems.