These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

POS Tracker - FGV - 5.2.1

Author
Frozen Guardian
The Scope
Gallente Federation
#81 - 2012-01-09 18:15:32 UTC
Gloria Lena Koraka wrote:
Frozen Guardian, do you plan to release an update for the fuel block a bit in advance so that we can update our pos tracker installation before the switchover so that we have time to plan with the new fuel block requirement in advance.

Thanks !


Sir yes sir. I be thinking hopefully sometime this week with a for sure of early next week. As I said on Google Project: the majority of it is pretty much functional though but there are still a few random ends that need to be updated. If it were to be released today it would be technically usable.
Gloria Lena Koraka
State War Academy
Caldari State
#82 - 2012-01-10 21:14:50 UTC
Thanks !
Militaer Biber
Biber Enterprise
#83 - 2012-01-14 23:49:03 UTC

Hello

i try the version 5.1.7 :)


When i try my API Code ...

Error Code: 203::Authentication failure. :(

i try IGB and Normal PC Browser

Greetings
Biber
Johnathan Roark
Quantum Industries
#84 - 2012-01-15 04:18:28 UTC
Militaer Biber wrote:

Hello

i try the version 5.1.7 :)


When i try my API Code ...

Error Code: 203::Authentication failure. :(

i try IGB and Normal PC Browser

Greetings
Biber


It means your api key is wrong, make sure you have it entered in correctly. Another thing that can cause this is an incorrectly configured php, check your php.ini for input and output paramater.

EVEVERIFY - A recruiting API Verification and Audit Tool

Also try out Yapeal for your php api needs

Frozen Guardian
The Scope
Gallente Federation
#85 - 2012-01-16 06:23:41 UTC  |  Edited by: Frozen Guardian
After some testing the tracker code looks pretty good to go. So here are the patch notes in advance, patch/full installer should be out tomorrow along with more details after one final test that deals with the actual full installer/patch happens.

Version 5.1.7 to 5.2.0 Changes:

  • Support for Fuel Blocks added.
  • Manufacturing fuel blocks is now listed on the Fuel Bill page at the bottom. The blueprint it uses to calculate has "perfect" ME 40. The manufacturing time is set at 4 minutes per run to help gauge how much time it will take.
  • Removed some minor CSS errors.
  • View/Edit POS now states Empty/Full instead of 0 under Online for silos.
  • Production page updated so the entire line for the silo is turned a color when Empty/Full. Will also change to a warning color once it passes under 24 hours till Empty/Full. Colors can be changed in the theme.css files.
  • Added support for API Proxies.
  • POS Tower Sov Status now updates alliance info via API key.
  • Fixed optimal to make sure to include charters if charters are being used.
  • Fixed View/Edit POS to display the correct m3 for charters.
  • POS Tower renders updated to the new non-crooked better looking versions.
  • POS Track now loads faster - Thanks Solo Drakban!
  • Refuel button added to ViewPOS for immediate optimal fillup.
  • Buttons!
  • Fuel Bill page sovereignty now only shows if the tower is in sovereignty friendly territory.
  • Various pointless calls to the DB and redundant code removed, speeding up various pages in the tracker.
  • Add a New Tower can now specify charters.
  • Mailer will now display charters if needed.

-FG
Frozen Guardian
The Scope
Gallente Federation
#86 - 2012-01-16 23:41:16 UTC
First the links but make sure to read the additional information below!!!:

http://iceneko.com/eve/downloads/test/FGVFull_5_2_0_Test.zip

and

http://iceneko.com/eve/downloads/test/FGVUpgrade_5_2_0_Test.zip - DB Upgrade Required

As you can see these are tests but will most likely be the final/official release files unless someone notices an issue I need to correct.

Hangars - Have been left alone besides removing the "required" column. Trying to decide what to do with these as from what I understand not many people use them anyhow.

Outposts - Have been left alone also. Most likely going to add in manufacturing fuel blocks and some other features when actually getting to this. However you'll still be able to store information on your POS Fuel Block materials.

EVE-Marketdata pull for Gallente Fuel Block - The site is sending back 0.00isk for them so if you use the pull you'll still need to find out a price for these Fuel Blocks until EVE-Marketdata fixes their site.

The config.php file(does not contain your DB information) - This file has been updated to support API proxies so if you have any customization within this file currently you may just wish to copy over the lines of code that have changed instead of replacing your current config file.



IMPORTANT NOTE: If you upgrade your tracker to 5.2.0 you will no longer be able to see the old POS fuels for actual fueling. 5.2.0 only runs on Fuel Blocks.



Let me know also if there are any changes you like, hate, love, want changed asap, etc by either here, EVEMail, or Google Code. I'll be checking constantly until a few days after the 24th as I want to make sure this release goes smoothly as possible for all of you.

If everything does goes smoothly with no glaring issues I'll put the "official" release of 5.2.0 out on Friday/Saturday of this week.

Lastly, if you approves of my hard work and love the POS Tracker please consider sending me some isk(or Plex) even if a little bit. :)
snipereagle1
Mostly Snuggly
Initiative Mercenaries
#87 - 2012-01-18 08:30:03 UTC
So..... no matter what I do I can't get the moon mining tracking to work. Please help!
Frozen Guardian
The Scope
Gallente Federation
#88 - 2012-01-18 16:37:34 UTC
snipereagle1 wrote:
So..... no matter what I do I can't get the moon mining tracking to work. Please help!


Uhh what version, did it work in previous versions, what exactly are you talking about? What page are you on?
Kismeteer
Bat Country
Pandemic Horde
#89 - 2012-01-18 20:50:14 UTC
Keep up the great work, FG.


BTW, the time out is the major problem our dudes have with the application these days. Just because it takes like an hour to fuel some of our pos's, and it times out in like 10-20 minutes. I'd like to extend that time, but I have not gone through that process yet.
Frozen Guardian
The Scope
Gallente Federation
#90 - 2012-01-18 21:11:29 UTC
Kismeteer wrote:
Keep up the great work, FG.


BTW, the time out is the major problem our dudes have with the application these days. Just because it takes like an hour to fuel some of our pos's, and it times out in like 10-20 minutes. I'd like to extend that time, but I have not gone through that process yet.


Your welcomes! The timeout should be based on your host as there is no actual limit set within the program. If I remember correctly session.gc_maxlifetime you can set on your php.ini for the moment past something over 1440 seconds = 24 minutes. That should work out for you until I dive into cookies. Which I got some free times right now so I just may do that :)
Kepuh Harjo
Gradient
Electus Matari
#91 - 2012-01-20 01:19:39 UTC  |  Edited by: Kepuh Harjo
Hi all,

FG, thx for the great app! Took me a while to get it setup on windows/IIS but it's all working now.

Here's the main bugs i ran into (aside from stupid windows stuff)

I was getting some errors when loading our corp's towers into the table because the powergrid and cpu did not have default values.

I just dropped the table and re-created it with default values and it worked great!

I'm new to towers so no idea if there is something specia/funky with my corp's specific installations, so it may be some weird edge case, but either way it was a fairly easy fix.

I do still get one error when trying to import Jobs:

ERROR Failed to Add Job info ; Out of range value for column 'containerID' at row 1



thx again for all the hard work that's gone into this!

Cheers,

Kep
Frozen Guardian
The Scope
Gallente Federation
#92 - 2012-01-20 04:37:30 UTC
Kepuh Harjo wrote:
Hi all,

FG, thx for the great app! Took me a while to get it setup on windows/IIS but it's all working now.

Here's the main bugs i ran into (aside from stupid windows stuff)

I was getting some errors when loading our corp's towers into the table because the powergrid and cpu did not have default values.

I just dropped the table and re-created it with default values and it worked great!

I'm new to towers so no idea if there is something specia/funky with my corp's specific installations, so it may be some weird edge case, but either way it was a fairly easy fix.

I do still get one error when trying to import Jobs:

ERROR Failed to Add Job info ; Out of range value for column 'containerID' at row 1



thx again for all the hard work that's gone into this!

Cheers,

Kep


Hi!

What version did you install? Also...It sounds like you are missing tables/structure in the DB and/or your installation isn't correctly installed.

"I was getting some errors when loading our corp's towers into the table because the powergrid and cpu did not have default values." <--that tells me something is quite wrong.

"ERROR Failed to Add Job info ; Out of range value for column 'containerID' at row 1" <--even more confirms my suspicions

The tracker on any setup is pretty much drop the php files in, install the DB files, add your API key, done. Then on versions 5.1.7 and earlier you would go in and add structures as it mattered for fuel purposes. No longer the case of 5.2.0 because Fuel Blocks don't care what your CPU/PG is at so you wouldn't even need to add structures for it to tell you the correct times left on your tower. But even if you didn't add structures on 5.1.7 and earlier versions the tracker still functions without error. I know it runs on IIS setups because I've walked several people through it. So I would suggest wiping everything and re-install because something is definitely not right.

If you are using IIS or this windows setup because all you got is a Windows box laying around, you may want to look into using something like WAMP which I know works flawless with the tracker pretty much right out of the box.

Best of luck,
-FG
Kepuh Harjo
Gradient
Electus Matari
#93 - 2012-01-20 08:34:11 UTC
Hi FG, thx for the quick reply.

Looks like i'm using 5.1.6 which i used the full installer from here:

http://iceneko.com/eve/?q=node/4

I notice there is an update to 5.1.7, but I don't see anything for 5.2?

I just did the upgrade to 517, but still the same error. I'll look @ wiping the install and re-doing later today.

where can I find 5.2?

cheers,

kep
Frozen Guardian
The Scope
Gallente Federation
#94 - 2012-01-20 15:36:32 UTC
Kepuh Harjo wrote:
Hi FG, thx for the quick reply.

Looks like i'm using 5.1.6 which i used the full installer from here:

http://iceneko.com/eve/?q=node/4

I notice there is an update to 5.1.7, but I don't see anything for 5.2?

I just did the upgrade to 517, but still the same error. I'll look @ wiping the install and re-doing later today.

where can I find 5.2?

cheers,

kep


A few posts above you :)
snipereagle1
Mostly Snuggly
Initiative Mercenaries
#95 - 2012-01-20 20:01:54 UTC
Frozen Guardian wrote:
snipereagle1 wrote:
So..... no matter what I do I can't get the moon mining tracking to work. Please help!


Uhh what version, did it work in previous versions, what exactly are you talking about? What page are you on?

5.1.7, on the production page all of the silos show empty.
Kepuh Harjo
Gradient
Electus Matari
#96 - 2012-01-20 20:54:13 UTC
grrrr stupid forums... just wiped out a big post saying post can't contain HTML and then wiped everything :( :(

Basically, I did a full re-install/setup w/ version 5.2 and I get the exact same errors.

I confirmed that the scripts install the database without any default values for the cpu/powergrid as seen here from install_database.sql:

CREATE TABLE `%prefix%tower_info` (

`powergrid` int(10) unsigned NOT NULL,
`cpu` int(10) unsigned NOT NULL,
`fuelblock` int(10) unsigned NOT NULL,
PRIMARY KEY (`pos_id`)
)

Are you sure this is installing wrong, and it's not something with our corp towers?
Frozen Guardian
The Scope
Gallente Federation
#97 - 2012-01-20 21:49:19 UTC
snipereagle1 wrote:
Frozen Guardian wrote:
snipereagle1 wrote:
So..... no matter what I do I can't get the moon mining tracking to work. Please help!


Uhh what version, did it work in previous versions, what exactly are you talking about? What page are you on?

5.1.7, on the production page all of the silos show empty.


Correct because you need to do that manually. The API doesn't provide this data easily so it must be entered in manually when you setup the towers. So you will need to connect the MHA to the input silo. Just so it ends up looking like this: http://iceneko.com/eve/images/viewpos.png

Kepuh Harjo wrote:
grrrr stupid forums... just wiped out a big post saying post can't contain HTML and then wiped everything :( :(

Basically, I did a full re-install/setup w/ version 5.2 and I get the exact same errors.

I confirmed that the scripts install the database without any default values for the cpu/powergrid as seen here from install_database.sql:

Are you sure this is installing wrong, and it's not something with our corp towers?



That looks correct because there is no need to know the CPU/PG. So because nothing is in there it will revert to 0 during manual tower setup and API pulls. This information doesn't come in via API and is at this point more of a visual fyi when you add structures. So your installation is still incorrectly running because as I basically said in an earlier post there is no errors like this. In fact the two errors you're getting are probably the first time I've ever seen those. You shouldn't be having all this trouble if your installation went through right and your server is working correctly.

-FG
Kepuh Harjo
Gradient
Electus Matari
#98 - 2012-01-20 22:20:43 UTC
Maybe i'm just not understanding the app...

You mention manual tower setup, i thought the api pulled the towers/etc... ?

Do i have to do something manually to set this up?

I do see now that 5.2 is fuel blocks only, so this is only useful post-24 correct? or to start identifying fuel block needs for when the cutover is made.

Basically i just joined a corp, and want to help out, they have towers, and i offered to look into some automated way to do management of them.

I've never done POS mgmt before, or used any app related, so i'm a complete noob with this :)
Frozen Guardian
The Scope
Gallente Federation
#99 - 2012-01-21 00:29:21 UTC
Kepuh Harjo wrote:
Maybe i'm just not understanding the app...

You mention manual tower setup, i thought the api pulled the towers/etc... ?

Do i have to do something manually to set this up?

I do see now that 5.2 is fuel blocks only, so this is only useful post-24 correct? or to start identifying fuel block needs for when the cutover is made.

Basically i just joined a corp, and want to help out, they have towers, and i offered to look into some automated way to do management of them.

I've never done POS mgmt before, or used any app related, so i'm a complete noob with this :)


I've always wanted to make a demo tracker so gonna make one well start it at least and you can add your API and test it out for a day to see how it works. Then I'll just wipe it afterwards. This way you can actually see it working without hassle. I'll send you an EVEMail shortly on the links.
snipereagle1
Mostly Snuggly
Initiative Mercenaries
#100 - 2012-01-21 02:15:58 UTC
Frozen Guardian wrote:
snipereagle1 wrote:
Frozen Guardian wrote:
[quote=snipereagle1]So..... no matter what I do I can't get the moon mining tracking to work. Please help!


Uhh what version, did it work in previous versions, what exactly are you talking about? What page are you on?

5.1.7, on the production page all of the silos show empty.


Correct because you need to do that manually. The API doesn't provide this data easily so it must be entered in manually when you setup the towers. So you will need to connect the MHA to the input silo. Just so it ends up looking like this: http://iceneko.com/eve/images/viewpos.png

Ah ok, I thought it pulled from the API. Thank you =)