These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

EVE Launcher for Linux

First post First post
Author
Torgeir Hekard
I MYSELF AND ME
#41 - 2016-05-26 16:36:04 UTC
Natzuki Akiga wrote:

You are right, can you please share what you did to fix this?

Change the last line of evelauncher.sh to primusrun $dirname/$appname "$@"
Orbonius Primus wrote:
That's an issue that persists in the PoL version as well.

Missing fonts IIRC. Don't remember which exactly (i think there were two?), but I think winetricks corefonts should do the trick, provided it's executed with the right wineprefix.
Forlorn Wongraven
Habitual Euthanasia
Pandemic Legion
#42 - 2016-05-26 16:54:02 UTC
The launcher always was trouble to get working. This works perfect on Ubuntu 14.04 LTS. Thanks!

Winner ATXI , 3rd place ATXII, winner ATXIII, 2nd ATXIV - follow me on twitter: @ForlornW

Karbowiak
Super Villains
Pandemic Horde
#43 - 2016-05-26 19:14:25 UTC
Hey Snorlax!

Would it be ok for the Solus OS guys to put your package into their repository, so it can be installed easily in Solus? :)

For information on their OS you can visit their page: https://solus-project.com/
They're also on IRC, Freenode in #Solus
Drilla
Lockstock.
Dead Terrorists
#44 - 2016-05-26 19:19:47 UTC
Since the game and wine is 32bit, please make the launcher 32bit also for maximum support.
CCP Snorlax
C C P
C C P Alliance
#45 - 2016-05-26 19:40:25 UTC
Drilla wrote:
Since the game and wine is 32bit, please make the launcher 32bit also for maximum support.

Sure, makes sense, 64 bit was just the default when I created the project. I just need to find time for doing the change (and testing it).

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Katrina Bekers
Pandemic Horde Inc.
Pandemic Horde
#46 - 2016-05-26 20:56:07 UTC
Horza Balvedaa wrote:
I would also like to be able to specify wine launch programs and environmental variables such as:

You can always wrap the evelauncher script in another script, where you set your variables and from where you call Snorlax' sh.

For example, I put in a $PATH dir this one:

Quote:

$ cat bin/lineve
#!/bin/bash
OLDPWD=$PWD

# vvv Here you'd put the directory where you unpacked the launcher
cd "${HOME}/linux-eve/evelauncher"

# vvv Misc vars - this one is for nVidia driver, for example, but you may want to add here what you want to be available at startup
export __GL_THREADED_OPTIMIZATIONS=1

# vvv Actual script, with some logging added for good measure, and eventually prefixed with stuff like optimus wrappers, pulseaudio, mumble overlay, etc.
./evelauncher.sh 2>&1 >>./log.txt
cd $OLDPWD

<< THE RABBLE BRIGADE >>

Zari Tenjin
State War Academy
Caldari State
#47 - 2016-05-26 21:39:18 UTC
Thank you so much for this.

Cant use it yet because of the IGB problem (gotta be on siggy) but looking froward from switching to your winebuilds!

Again thank you so much for making life easier for OSX and Linux people. You've been a godsend for us!
Natzuki Akiga
Just Wing It Good
#48 - 2016-05-26 21:58:56 UTC
When I launch the script, the game works, but I get these errors about QtWebEngine and the ingame browser does not work. Opening it causes this error.

/home/neutronst4r neutronst4r@Archy% /home/neutronst4r/EVE/evelauncher/evelauncher.sh
[0526/235330:ERROR:resource_bundle.cc(691)] Failed to load /home/neutronst4r/EVE/evelauncher/qtwebengine_resources.pak
Some features may not be available.
[0526/235330:ERROR:resource_bundle.cc(691)] Failed to load /home/neutronst4r/EVE/evelauncher/qtwebengine_resources_100p.pak
Some features may not be available.
[0526/235330:ERROR:resource_bundle.cc(691)] Failed to load /home/neutronst4r/EVE/evelauncher/qtwebengine_resources_200p.pak
Some features may not be available.
[0526/235330:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
Installed Qt WebEngine locales directory not found at location /home/neutronst4r/EVE/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/neutronst4r/EVE/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0526/235330:ERROR:resource_bundle.cc(691)] Failed to load /home/neutronst4r/EVE/evelauncher/qtwebengine_resources.pak
Some features may not be available.
[0526/235330:ERROR:resource_bundle.cc(691)] Failed to load /home/neutronst4r/EVE/evelauncher/qtwebengine_resources_100p.pak
Some features may not be available.
[0526/235330:ERROR:resource_bundle.cc(691)] Failed to load /home/neutronst4r/EVE/evelauncher/qtwebengine_resources_200p.pak
Some features may not be available.
[0526/235330:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.


I am using Arch and I installed the package "qt5-webengine" , but that did nothing.
CCP Snorlax
C C P
C C P Alliance
#49 - 2016-05-27 09:50:16 UTC
I've updated the Wine version used by the launcher to use libgnutls, so https connections should now work in the ingame browser.

The Wine version is wine-1.9.10-ccp-daily-16 - if you haven't messed with Wine options you should automatically get that latest version.

There is a caveat, though - it insists on loading libgnutls.so.26 - I haven't figured out yet how to get it to load without the version number. If you don't have this version (I did not on my Ubuntu 15.10 system) then symlinking it to the latest should work.

This worked for me - use at your own risk:

sudo ln -s /usr/lib/i386-linux-gnu/libgnutls.so /usr/lib/i386-linux-gnu/libgnutls.so.26


CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Torgeir Hekard
I MYSELF AND ME
#50 - 2016-05-27 11:37:23 UTC
Confirmed. Without libgnutls.so.26 it wasn't working for me.
With a link to libgnutls.so.30.6.3 it works

PS: 32bit libs in arch are under /usr/lib32, just in case.
Slynt
Masterless Rider
#51 - 2016-05-27 13:05:07 UTC
Torgeir Hekard wrote:
Confirmed. Without libgnutls.so.26 it wasn't working for me.
With a link to libgnutls.so.30.6.3 it works

PS: 32bit libs in arch are under /usr/lib32, just in case.


Okay, I can't get it to work on my arch no matter how hard i tried.
Please share how did you make it work.
Torgeir Hekard
I MYSELF AND ME
#52 - 2016-05-27 13:32:47 UTC  |  Edited by: Torgeir Hekard
Slynt wrote:

Okay, I can't get it to work on my arch no matter how hard i tried.
Please share how did you make it work.

1) Confirm that your wine version (as shown in the launcher) is as per CCP Snorlax post.
2) Confirm that you have lib32-gnutls installed
3) Confirm that /usr/lib32/libgnutls.so exists. It should be a link to a particular version like /usr/lib32/libgnutls.so.30.6.3 in my case.
4) sudo ln -s /usr/lib32/libgnutls.so /usr/lib32/libgnutls.so.26
The first argument is the target - what are you pointing AT. The second argument is the link - the alternative name for the object you are pointing at.
DmitryEKT
AMMO INC
#53 - 2016-05-27 14:38:36 UTC
CCP Snorlax wrote:
Neirak Orlenard wrote:
Thanks for the native launcher.

I've found a problem with missing text in the price history.
http://i.imgur.com/nTe0hEt.png

Right, I had the same problem on Mac. I'll have a fix for that soon.

winetricks corefonts
Slynt
Masterless Rider
#54 - 2016-05-27 15:12:36 UTC  |  Edited by: Slynt
Torgeir Hekard wrote:
Slynt wrote:

Okay, I can't get it to work on my arch no matter how hard i tried.
Please share how did you make it work.

1) Confirm that your wine version (as shown in the launcher) is as per CCP Snorlax post.
2) Confirm that you have lib32-gnutls installed
3) Confirm that /usr/lib32/libgnutls.so exists. It should be a link to a particular version like /usr/lib32/libgnutls.so.30.6.3 in my case.
4) sudo ln -s /usr/lib32/libgnutls.so /usr/lib32/libgnutls.so.26
The first argument is the target - what are you pointing AT. The second argument is the link - the alternative name for the object you are pointing at.


Thanks. there's probably something I haven't installed yet, still can't make it work.
I'll figure this out, since my version is same as yours and yours works, so the problem is on my end.


EDIT: Ok, so I'm stupid. Actually my problem is not with https but with the browser itself. I use this to fix the issue.
WINEPREFIX=~/.eve/wineenv WINEARCH=win32 winetricks corefonts d3dx9_36 vcrun2005 vcrun2008 vcrun2010
Abbot Blueberry
Doomheim
#55 - 2016-05-27 17:50:28 UTC
Slynt wrote:
Torgeir Hekard wrote:
Slynt wrote:

Okay, I can't get it to work on my arch no matter how hard i tried.
Please share how did you make it work.

1) Confirm that your wine version (as shown in the launcher) is as per CCP Snorlax post.
2) Confirm that you have lib32-gnutls installed
3) Confirm that /usr/lib32/libgnutls.so exists. It should be a link to a particular version like /usr/lib32/libgnutls.so.30.6.3 in my case.
4) sudo ln -s /usr/lib32/libgnutls.so /usr/lib32/libgnutls.so.26
The first argument is the target - what are you pointing AT. The second argument is the link - the alternative name for the object you are pointing at.


Thanks. there's probably something I haven't installed yet, still can't make it work.
I'll figure this out, since my version is same as yours and yours works, so the problem is on my end.

Doesn't work for me either.
DmitryEKT
AMMO INC
#56 - 2016-05-27 18:07:06 UTC
Simply installing lib32-gnutls from Arch repos (I'm using Arch) was enough to make igb work for me, without any linking of files.
Cerian Alderoth
Cult of the Black Monolith
#57 - 2016-05-27 18:14:58 UTC
Jessie Wallace wrote:
Congraluations you know nothing about anything.
Having a rough day? Heh!? Twisted

I would like to see some (performance) progress for Linux users:
EVE Online is the only reason I still have a Windows installation.

Thanks for working on this! P
Beta Maoye
#58 - 2016-05-27 18:17:42 UTC
Work like a charm! Thank you so much, Snorlax!

The following steps work for me:
1.Install Ubuntu 16.04 LTS(64 bits)
2.Install latest display driver for Linux.
3.Install playonlinux.
4.Download and extract the launcher to home.
5.Run the shell script sh ./evelauncher.sh
6.Launcher pop up and start downloading files automatically.
7.Client ready and Play!
Ravow
Quebecorp
Domain Research and Mining Inst.
#59 - 2016-05-27 19:31:48 UTC
Cerian Alderoth wrote:
Jessie Wallace wrote:
Congraluations you know nothing about anything.
Having a rough day? Heh!? Twisted

I would like to see some (performance) progress for Linux users:
EVE Online is the only reason I still have a Windows installation.

Thanks for working on this! P


Two way to increase performance:

- Overclock (The OpenGL->D3D converstion in Wine take 100% of one core so overclocking allow faster conversion.

- Use the nine state tracker (Using D3D directly without converting it get rid of the CPU utilisation surge, almost double the FPS, add the shields & other effects back and take less electricity)

@Snorlax
Could you build Mesa with D3D9 support on your system and add D3D9 patch again Wine and link it with that Mesa and enable nine in the "registery"? That way, people using proper opensource drivers will get the performance gain & effect while people using proprietary drivers will still get the slower codepath. When nine is enabled in Wine, it detect D3D support and use the appropriate codepath.

Mesa already have nine support, juste need to be enabled during compilation (and you have to compile like, latest one, git if possible)
Wine patchs are these : https://github.com/sarnex/wine-d3d9-patches

If your not sure if you can trust that auto detection for D3D9 in Wine, you can build Two wine, one with and one without D3D9. And detect yourself:

To detect D3D9 support:
first that command : glxinfo | grep -i gallium | wc -l
result of first command : 0 = use wine without nine, >0 = check presence of d3dadapter9.so in /usr/lib32 or /usr/lib32/d3d.
if d3dadapter9.so is present, assume that native D3D9 support exist on that system and use nine wine, else, use normal wine.

note : some system don't have the glxinfo commande, better bundle it with the launcher.
Altairia Moltora
Fairly Odd Capsuleers
#60 - 2016-05-27 20:56:38 UTC
Linux noob here, and I am having nothing but trouble. I have run the shell script from the terminal, and the first time it worked great. Now when I try to run Eve, I have to run the shell script from terminal again, and it either tries to re-download everything or doesn't work at all. In addition, my terminal locks up with these error messages

Segmentation fault (core dumped)
[0528/065314:ERROR:resource_bundle.cc(691)] Failed to load /home/maharava/Games/EveOnline/evelauncher/qtwebengine_resources.pak
Some features may not be available.
[0528/065314:ERROR:resource_bundle.cc(691)] Failed to load /home/maharava/Games/EveOnline/evelauncher/qtwebengine_resources_100p.pak
Some features may not be available.
[0528/065314:ERROR:resource_bundle.cc(691)] Failed to load /home/maharava/Games/EveOnline/evelauncher/qtwebengine_resources_200p.pak
Some features may not be available.
[0528/065314:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
Installed Qt WebEngine locales directory not found at location /home/maharava/Games/EveOnline/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/maharava/Games/EveOnline/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0528/065314:ERROR:resource_bundle.cc(691)] Failed to load /home/maharava/Games/EveOnline/evelauncher/qtwebengine_resources.pak
Some features may not be available.
[0528/065314:ERROR:resource_bundle.cc(691)] Failed to load /home/maharava/Games/EveOnline/evelauncher/qtwebengine_resources_100p.pak
Some features may not be available.
[0528/065314:ERROR:resource_bundle.cc(691)] Failed to load /home/maharava/Games/EveOnline/evelauncher/qtwebengine_resources_200p.pak
Some features may not be available.
[0528/065314:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.

I'm guessing it needs steam to work, but damned if Steam will play nice with me either.
On Ubuntu 16.04
Any idea? I've done the standard update and upgrade