These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
123Next page
 

New Launcher

First post First post
Author
IronCat Maulerant
Snipes Incorporated UK
#1 - 2013-07-11 11:49:31 UTC
Well done for standardising the launcher's look between Windows and Mac however due to not being able to store your password on the client I have copied and pasted my password in each time (and then cleared my clipboard immediately) as I use deliberately complex 14+ character passwords containing a mix of symbols, numbers, lowercase and uppercase letters. The new launcher does not allow you to use the paste function. I understand the concern about allowing the password to be stored on the client (although a "Use at your own risk" warning should be added along with the ability to store it within the client) but this pasting restriction now only encourages me to use a short, simple password making it less secure than a) being able to store it on the client and b) being able to paste it in.

I know there are likely to be responses to the effect of "What's the big deal? just type it lazy!", it may be lazy but it is an unnecessary ball ache.
Talemecus Valta
Cosmos Industrial
#2 - 2013-07-11 12:00:12 UTC
I've not got the new mac launcher yet and I'm looking forward to it.

Can someone post screenshots of it please?

As for the pasting function not working, I think it could have been a lot worse.

Talemecus Valta, PVP Cannon Fodder, Valta Industries.

Jabloni
Ministry of War
Amarr Empire
#3 - 2013-07-11 12:08:23 UTC
Talemecus Valta wrote:
I've not got the new mac launcher yet and I'm looking forward to it.

Can someone post screenshots of it please?

As for the pasting function not working, I think it could have been a lot worse.



Very much depends on what you're password approach is. If you use generated passwords for max security it's a real pain.

I've spotted that if you invoke the internal Eve Package you still get the username/password prompt and you can still paste in the password. I've created a soft link and will use it most of the time and only revert to the launcher if i need to do a patch.
IronCat Maulerant
Snipes Incorporated UK
#4 - 2013-07-11 12:18:46 UTC
Talemecus Valta wrote:
I've not got the new mac launcher yet and I'm looking forward to it.

Can someone post screenshots of it please?

As for the pasting function not working, I think it could have been a lot worse.




Screen shot
IronCat Maulerant
Snipes Incorporated UK
#5 - 2013-07-11 12:22:58 UTC  |  Edited by: IronCat Maulerant
Jabloni wrote:
Talemecus Valta wrote:
I've not got the new mac launcher yet and I'm looking forward to it.

Can someone post screenshots of it please?

As for the pasting function not working, I think it could have been a lot worse.



Very much depends on what you're password approach is. If you use generated passwords for max security it's a real pain.

I've spotted that if you invoke the internal Eve Package you still get the username/password prompt and you can still paste in the password. I've created a soft link and will use it most of the time and only revert to the launcher if i need to do a patch.



Ha! Very nice ty the multiple client tool opens the old login screen :)

Yes I do use generated passwords.
GM Karidor
Game Masters
C C P Alliance
#6 - 2013-07-11 12:52:04 UTC
We already know of the pasting issue and will of course fix this. Unfortunately, this problem has been brought to our attention too late for a fix to still make it into this release, but we did not consider this to be a showstopper to prevent the release of the launcher altogether, even though we realize it is of course troublesome for those that are affected by this.

GM Karidor | Senior Game Master

Talemecus Valta
Cosmos Industrial
#7 - 2013-07-11 12:58:43 UTC
Thanks for the screenshot.

Will have to give it a try when I get home in 3 hrs, SadSadSad

Talemecus Valta, PVP Cannon Fodder, Valta Industries.

Basik Omaristos
Imperial Academy
Amarr Empire
#8 - 2013-07-11 13:10:22 UTC
GM Karidor wrote:
We already know of the pasting issue and will of course fix this. Unfortunately, this problem has been brought to our attention too late for a fix to still make it into this release, but we did not consider this to be a showstopper to prevent the release of the launcher altogether, even though we realize it is of course troublesome for those that are affected by this.


Any idea when a fixed launcher will be released? In the interim, I can try Jabloni's workaround, or just spend 10 minutes every day typing in my 64 character RANDOM password.
Vincent Athena
Photosynth
#9 - 2013-07-11 13:37:48 UTC
Use the Clonemaker to make a clone of your client.
When you run it you do not get the launcher, but a star field splash screen with a log in section at the bottom.
In that log in, the slot for the password can be filled via a paste.

Know a Frozen fan? Check this out

Frozen fanfiction

GM Karidor
Game Masters
C C P Alliance
#10 - 2013-07-11 14:05:06 UTC  |  Edited by: GM Karidor
Basik Omaristos wrote:
GM Karidor wrote:
We already know of the pasting issue and will of course fix this. Unfortunately, this problem has been brought to our attention too late for a fix to still make it into this release, but we did not consider this to be a showstopper to prevent the release of the launcher altogether, even though we realize it is of course troublesome for those that are affected by this.


Any idea when a fixed launcher will be released? In the interim, I can try Jabloni's workaround, or just spend 10 minutes every day typing in my 64 character RANDOM password.


Unfortunately, there is no exact ETA yet, other than "as soon as we can possibly push the change out safely". Until then, the workarounds already posted here (using the CloneMaker tool to start a cloned client) are probably your best bet if you rely on pasting your password into the password field.

GM Karidor | Senior Game Master

IronCat Maulerant
Snipes Incorporated UK
#11 - 2013-07-11 14:56:40 UTC
GM Karidor wrote:
Basik Omaristos wrote:
GM Karidor wrote:
We already know of the pasting issue and will of course fix this. Unfortunately, this problem has been brought to our attention too late for a fix to still make it into this release, but we did not consider this to be a showstopper to prevent the release of the launcher altogether, even though we realize it is of course troublesome for those that are affected by this.


Any idea when a fixed launcher will be released? In the interim, I can try Jabloni's workaround, or just spend 10 minutes every day typing in my 64 character RANDOM password.


Unfortunately, there is no exact ETA yet, other than "as soon as we can possibly push the change out safely". Until then, the workarounds already posted here (using the CloneMaker tool to start a cloned client) are probably your best bet if you rely on pasting your password into the password field.



That's great to know! Thanks for taking the time to respond! o7
CCP Atropos
C C P
C C P Alliance
#12 - 2013-07-11 17:48:00 UTC
I just published a build to Singularity that has the right click menu functionality enabled in the EVE Launcher (for both Windows and Mac).
Grinlin en Cedoulain
University of Caille
Gallente Federation
#13 - 2013-07-11 17:52:31 UTC
Since the update, i'm not able to run eve anymore.
It always says:
Konto für EVE-SSO-CONNECTION wurde deaktiviert
Letzte Anmeldung: None
Anzahl der Besuche: 0
Grund: Konto-Abonnement abgelaufen!

Jetzt abonnieren und weiterspielen!

But i don't think it has my credentials, because i have a valid account.
Very sad!

How can i disable the autoplay?
Tippia
Sunshine and Lollipops
#14 - 2013-07-11 18:07:39 UTC
Well… when I first updated the launcher, it shat itself inside out and got EVE Online.app flagged as “cannot be run on this OS”.

I could still go into the app package, find the actual launcher app inside it and launch from there, which at the moment seems to have updated and fixed the app so it can be run again. However, I'm guessing that the patcher is doing something it shouldn't be doing inside the app package that makes it mistrusted and/or just incorrectly configured as far as OSX goes.
Grinlin en Cedoulain
University of Caille
Gallente Federation
#15 - 2013-07-11 18:20:17 UTC
Ok, got it running again. Somehow managed to disable the autoplay and switched accounts.
Now it works.
Sheanne Rakis
Imperial Tectonics Limited
#16 - 2013-07-11 18:23:40 UTC
I found workaround to paste login/password on Mac - just select text and drag and drop. It works for me.

P. S. Sorry for my English.
Vincent Athena
Photosynth
#17 - 2013-07-11 18:31:52 UTC
Sheanne Rakis wrote:
I found workaround to paste login/password on Mac - just select text and drag and drop. It works for me.

P. S. Sorry for my English.

Confirmed! Good find!

Know a Frozen fan? Check this out

Frozen fanfiction

Utremi Fasolasi
La Dolce Vita
#18 - 2013-07-12 02:02:54 UTC
IronCat Maulerant wrote:
Well done for standardising the launcher's look between Windows and Mac however due to not being able to store your password on the client I have copied and pasted my password in each time (and then cleared my clipboard immediately) as I use deliberately complex 14+ character passwords containing a mix of symbols, numbers, lowercase and uppercase letters.



https://xkcd.com/936/
Salpun
Global Telstar Federation Offices
SLYCE Pirates
#19 - 2013-07-12 05:56:23 UTC
Windows client copy and paste works good. Like the auto launch after pasting now not having to hit enter twice is a great fix.

If i dont know something about EVE. I check https://wiki.eveonline.com/en/wiki/ISK_The_Guide

See you around the universe.

Pat0chan
Sebiestor Tribe
Minmatar Republic
#20 - 2013-07-12 15:49:56 UTC
Hi fellow Mac pilots,
Since the new launcher i can't run my 3 accounts.
how do you do it?
Before i used to edit the text within the application (eveonline1, eveonline2, eveonline3) and the game was starting 3 clients.
doesnt work anymore.
Thanks
123Next page