These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

phpBB 3.2 EVE SSO / ESI extension [beta]

Author
Dan Conia
Taggart Transdimensional
Virtue of Selfishness
#81 - 2017-05-26 13:54:19 UTC  |  Edited by: Dan Conia
Norian Lonark wrote:
Snitch Ashor wrote:


in principle this can be done. I did a quick search and found this: https://www.mediawiki.org/wiki/Extension:PHPBB/Users_Integration

might work.

Cheers,
Snitch


Hi Snitch,

thanks for the check I will have a go at installing it and see what happens when using it in combination with your mod.

Nori.


Nori, I noticed an extension that piggybacks on the login of the phpBB. You then just go to your wiki site and it checks phpBB to see if you're a current login.

Extension:PHPBB/Users Integration

Edit: Wow, I got so hung up on SSO, I didn't realize you had already posted THE EXACT SAME THING. LOL MOAR COFFEE!!!
Snitch Ashor
Black Rise Guerilla Forces
The Bloc
#82 - 2017-05-29 14:21:39 UTC
Dan Conia wrote:
Norian Lonark wrote:
Snitch Ashor wrote:


in principle this can be done. I did a quick search and found this: https://www.mediawiki.org/wiki/Extension:PHPBB/Users_Integration

might work.

Cheers,
Snitch


Hi Snitch,

thanks for the check I will have a go at installing it and see what happens when using it in combination with your mod.

Nori.


Nori, I noticed an extension that piggybacks on the login of the phpBB. You then just go to your wiki site and it checks phpBB to see if you're a current login.

Extension:PHPBB/Users Integration

Edit: Wow, I got so hung up on SSO, I didn't realize you had already posted THE EXACT SAME THING. LOL MOAR COFFEE!!!


No problem, as my time to code/play is limitd tjese days, any help is appreciated.
Snitch Ashor
Black Rise Guerilla Forces
The Bloc
#83 - 2017-06-08 13:24:19 UTC
Changed links and description in the OP. Changed version number to 1.1b. I hope in the following weeks I find the time for a few new features I got requests for.
Norio Nori
Ecoas Heavy Industries
SAMURAI SOUL'd OUT
#84 - 2017-06-22 12:58:32 UTC  |  Edited by: Norio Nori
Auto login does not seem to be working.
I think the reason is that the value of "[cookie_name] _ u" is always 1.

I tried to fix this.What do you think about this fix?

I am not very good at programming
I want to hear your opinion.

login.php

$user->set_login_key();
setcookie($this->config['cookie_name'].'_k',$user->cookie_data['k'],time()+31556926,$this->config['cookie_path'],$this->config['cookie_domain'],$this->config['cookie_secure']);
+setcookie($this->config['cookie_name'].'_u',$user->data['user_id'],time()+31556926,$this->config['cookie_path'],$this->config['cookie_domain'],$this->config['cookie_secure']);


It did not work. Sad
Makhar
Legion of 42
#85 - 2017-06-25 11:51:33 UTC
Thanks for this extension - very nice!

Anyway when assigning members to a group using SSO that we can make the group their default group?

_ I tried real-life once.  The graphics suck._

FlexiusVII
kekScale
Scourge.
#86 - 2017-07-05 10:59:21 UTC
Norio Nori wrote:
Auto login does not seem to be working.
I think the reason is that the value of "[cookie_name] _ u" is always 1.

I tried to fix this.What do you think about this fix?

I am not very good at programming
I want to hear your opinion.

login.php

$user->set_login_key();
setcookie($this->config['cookie_name'].'_k',$user->cookie_data['k'],time()+31556926,$this->config['cookie_path'],$this->config['cookie_domain'],$this->config['cookie_secure']);
+setcookie($this->config['cookie_name'].'_u',$user->data['user_id'],time()+31556926,$this->config['cookie_path'],$this->config['cookie_domain'],$this->config['cookie_secure']);


It did not work. Sad

What do you mean by saying it did not work, exactly? I've done the same thing (independently) and it's kinda fixed my issue (logging in from different IPs causing logout).

Practice makes perfect.

Norio Nori
Ecoas Heavy Industries
SAMURAI SOUL'd OUT
#87 - 2017-07-07 15:28:00 UTC
FlexiusVII wrote:

What do you mean by saying it did not work, exactly? I've done the same thing (independently) and it's kinda fixed my issue (logging in from different IPs causing logout).


The consistency of sid and cookie values in sessions table became illegal.
(An error occurs when trying to log out explicitly.)

In my environment, sessions table is periodically deleted by cron task.
(cron.task.core.tidy_sessions)

In pure phpBB, even if the value of sessions table disappears, the value left in sessions_keys table and
Auto login is possible using cookie_k and cookie_u left in the browser, but in SSO environment I felt that sessions table does not work well because there are additional columns.

However, since I am not familiar with programming, please let me know if there is a good idea!Big smile
Haradil Rakknarok
Albertross Mining Corp.
Off The Reservation.
#88 - 2017-07-09 22:30:38 UTC  |  Edited by: Haradil Rakknarok
I folow instruction step by step but if i login with admin he write:
{"error":"invalid_request","error_description":"The callback URI doesn't match the value stored for this client"}

Is this a problem with eve develop url?

OK i have clear this problem but next is after Login with admin char i get a error from phpbb; Error: Invalid auth state. and i cant log in
Haradil Rakknarok
Albertross Mining Corp.
Off The Reservation.
#89 - 2017-07-13 14:23:40 UTC
All says this tool is supported but no one help me. What is the ******* problem. Error: Invalid auth state.
Norio Nori
Ecoas Heavy Industries
SAMURAI SOUL'd OUT
#90 - 2017-07-15 09:04:06 UTC
Haradil Rakknarok wrote:

OK i have clear this problem but next is after Login with admin char i get a error from phpbb; Error: Invalid auth state. and i cant log in


if something goes wrong and you locked yourself out, access your database and find the key auth_method in your phpbb_config table and change it from 'evesso' to 'db'.

and purge your phpBB cache
https://www.phpbb.com/support/docs/en/3.0/kb/article/purging-the-phpbb-cache/

For now, you can log in with admin.
Snitch Ashor
Black Rise Guerilla Forces
The Bloc
#91 - 2017-07-19 14:39:34 UTC
Norio Nori wrote:
FlexiusVII wrote:

What do you mean by saying it did not work, exactly? I've done the same thing (independently) and it's kinda fixed my issue (logging in from different IPs causing logout).


The consistency of sid and cookie values in sessions table became illegal.
(An error occurs when trying to log out explicitly.)

In my environment, sessions table is periodically deleted by cron task.
(cron.task.core.tidy_sessions)

In pure phpBB, even if the value of sessions table disappears, the value left in sessions_keys table and
Auto login is possible using cookie_k and cookie_u left in the browser, but in SSO environment I felt that sessions table does not work well because there are additional columns.

However, since I am not familiar with programming, please let me know if there is a good idea!Big smile


Thanks that helped a lot, persistent logins are hopefully working in this version: https://bitbucket.org/snitchashor/php-ext-authevesso/get/490a9a6a8117.zip

please let me know. However after the session is cleared, you will have to authenticate for the admin login but within the board you should stay logged in. I'm pretending this is a security feature, but infact the admin state does not seem to be resored via cookie login since its part of the session and I guess theres nothing I can do about it.
Mapster Tacitus
Kriegsmarinewerft
Goonswarm Federation
#92 - 2017-07-22 15:14:07 UTC  |  Edited by: Mapster Tacitus
First of all: Thank you for this peace of software.

Installation and all went well.
Teamspeak is an issue now. When does the Script apply the groups ? The Server Query login seems to work since it pulls the ts3 server groups correctly from the server and i can assign them to corps/alliances in the extension tab.
With a fresh board user entering their unique id in their profile, the script seems to do nothing yet.

EDIT: i got one step further. once a user entered their unique ID and clicks send, HTTP Error 500, but the teamspeak server correctly assigns the group. after pushing F5 the profile site didnt saved the id in the field.
Snitch Ashor
Black Rise Guerilla Forces
The Bloc
#93 - 2017-07-22 19:32:31 UTC
Mapster Tacitus wrote:
First of all: Thank you for this peace of software.

Installation and all went well.
Teamspeak is an issue now. When does the Script apply the groups ? The Server Query login seems to work since it pulls the ts3 server groups correctly from the server and i can assign them to corps/alliances in the extension tab.
With a fresh board user entering their unique id in their profile, the script seems to do nothing yet.

EDIT: i got one step further. once a user entered their unique ID and clicks send, HTTP Error 500, but the teamspeak server correctly assigns the group. after pushing F5 the profile site didnt saved the id in the field.


TS groups are assigned at two points, first when the user enters the ID and afterwards every time the cron job runs and the groups would change. Any chance you can get me an apache log of that 500 error? Will try to reproduce it anyway.
Mapster Tacitus
Kriegsmarinewerft
Goonswarm Federation
#94 - 2017-07-23 14:26:52 UTC
Sure
23.07.2017 16:08:36 [client 2003:c9:2300::] PHP Fatal error:  Uncaught exception 'TeamSpeak3_Adapter_ServerQuery_Exception' with message 'duplicate entry' in /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery/Reply.php:319, referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] Stack trace:, referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #0 /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery/Reply.php(91): TeamSpeak3_Adapter_ServerQuery_Reply->fetchError(Object(TeamSpeak3_Helper_String)), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #1 /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery.php(141): TeamSpeak3_Adapter_ServerQuery_Reply->__construct(Array, 'servergroupaddc...', Object(TeamSpeak3_Node_Host), true), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #2 /ext/snitch/authevesso/libraries/TeamSpeak3/Node/Abstract.php(73): TeamSpeak3_Adapter_ServerQuery->request('servergroupaddc...', true), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #3 /ext/snitch/authevesso/libraries/TeamSpeak3/Node/Server.php(90): TeamSpeak3_Node_Abstract->request('servergroupaddc...', true), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #4 /mnt/web307/b2/25/542347 in /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery/Reply.php on line 319, referer: /ucp.php?i=178
Snitch Ashor
Black Rise Guerilla Forces
The Bloc
#95 - 2017-07-30 13:35:08 UTC
Mapster Tacitus wrote:
Sure
23.07.2017 16:08:36 [client 2003:c9:2300::] PHP Fatal error:  Uncaught exception 'TeamSpeak3_Adapter_ServerQuery_Exception' with message 'duplicate entry' in /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery/Reply.php:319, referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] Stack trace:, referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #0 /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery/Reply.php(91): TeamSpeak3_Adapter_ServerQuery_Reply->fetchError(Object(TeamSpeak3_Helper_String)), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #1 /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery.php(141): TeamSpeak3_Adapter_ServerQuery_Reply->__construct(Array, 'servergroupaddc...', Object(TeamSpeak3_Node_Host), true), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #2 /ext/snitch/authevesso/libraries/TeamSpeak3/Node/Abstract.php(73): TeamSpeak3_Adapter_ServerQuery->request('servergroupaddc...', true), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #3 /ext/snitch/authevesso/libraries/TeamSpeak3/Node/Server.php(90): TeamSpeak3_Node_Abstract->request('servergroupaddc...', true), referer: /ucp.php?i=178
23.07.2017 16:08:36 [client 2003:c9:2300::] #4 /mnt/web307/b2/25/542347 in /ext/snitch/authevesso/libraries/TeamSpeak3/Adapter/ServerQuery/Reply.php on line 319, referer: /ucp.php?i=178


Does that user already have groups on your ts server? I'm wondering if the mod tries to add a user that already exists, even though on my server that does not seem to be a problem...
Veritas Totient
Tai-Chi
Northern Coalition.
#96 - 2017-08-03 06:15:40 UTC  |  Edited by: Veritas Totient
Hi, I have added more scopes in my forums.
And I found that the cron task only checks the membership from ESIAPI which does not use the refresh token.
Is that a good idea remove the member from the group as long as someone revokes his refresh token?Cool
FibberGlass
Russian Space Community
Banderlogs Alliance
#97 - 2017-08-03 13:33:32 UTC
Tell me pls
What is the problem?


{"error":"invalid_request","error_description":"The callback URI doesn't match the value stored for this client"}


my conf:
http://imgur.com/a/5PnVV