These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

EVE Launcher for Linux

First post First post
Author
Rochtorr Umangiar
Royal Amarr Institute
Amarr Empire
#281 - 2016-08-04 11:24:18 UTC
Works beautifully on Fedora 24, plasma spin.
It's worth installing playonlinux to get all the libraries and more.


Here is a dmesg https://gist.github.com/incoherent-lime/6fd297b39bb7d4dda5465d0a63ce2ad0

I've had a tinker with the AppID for steam but alas I do not own EVE on steam, anyone else had any success here?
Kayaba Yuki
Limestone Pie and Co.
The Hivemind Federation Alliance
#282 - 2016-08-06 06:16:06 UTC  |  Edited by: Kayaba Yuki
Running on Mint 17.3 (Rosa) w/ KDE 4.13.2.
Had to download Wine via apt-get before client would start. Otherwise, runs beautifully! CCP Snorlax, you are truly a god among men!
Anne' T'neal
Viziam
Amarr Empire
#283 - 2016-08-06 14:37:51 UTC  |  Edited by: Anne' T'neal
Was running fine on Ubuntu 14.04 until the os crashed during an update patch. Now I can launch the launcher but the game client wont open. Never had any issues with the linux client, so I am a bit confused as to where the issue is.

Edit: False alarm. I guess I had to install Wine to get the required files and the EULA for the MS assets setup. All good again.

Thankyou to CCP Snorlax for your continued support of linux and allowing my laptop to play eve so that my wife wont kill me to use the desktop! o7
Christophe Merci
The Scope
Gallente Federation
#284 - 2016-08-07 14:48:34 UTC
I am trying to set up eve on an HP Pavilion dv7 laptop running 16.04 LTS Ubuntu. The fps under Windows 7 was poor, and I am hoping to squeeze a few more fps under this Linux OS. Ubuntu is the only OS now on this laptop.

I know very little about Linux, but have attempted to follow the guidance CCP Snorlax and others have posted here. I downloaded evelauncher-1043593.tar.gz, unpacked it in the Download folder, and ran evelauncher .sh script (in the evelauncher folder). The Eve launcher screen flashed, but nothing else would happen. Based on some of the comments, I decided to download WINE, though the Ubuntu Software Center, and ran the configuration process (I can now access the WINE configuration dialog box on the taskbar). I re-ran the evelauncher.sh script and the EVE launcher came back up, updated to the newer version (1056484). The launcher then closed.

What should I do to launch EVE at this point. I figured running the executable file in the evelauncher folder (evelauncher) would be the logical next step. Nothing seems to happen.

Thanks CCP Snorlax for your work!

o7

Kniht
#285 - 2016-08-09 15:42:29 UTC
Christophe Merci wrote:
I re-ran the evelauncher.sh script and the EVE launcher came back up, updated to the newer version (1056484). The launcher then closed.

What should I do to launch EVE at this point. I figured running the executable file in the evelauncher folder (evelauncher) would be the logical next step. Nothing seems to happen.

Open a terminal, cd to evelauncher directory, run ./evelauncher.sh. The output in the terminal may be useful.

The evelauncher.sh script sets up LD_LIBRARY_PATH and then runs ./evelauncher; this is all evelaucher.sh does. You should not run ./evelauncher directly as the variable is required to load the correct libraries. (There is an error in how LD_LIBRARY_PATH is set, where an empty entry, representing the CWD, is added when LD_LIBRARY_PATH is previously unset, but from your description, I doubt this affects you.)

o/ fly crazy

Yoggy NA
Ophiuchus Inc.
#286 - 2016-08-10 05:11:42 UTC
I was running Win version of the client manually under wine. Everything was working until the most recent patch; then the launcher decilned to open, started throwing certificate errors, and when I finally got into the game, IGB declined to work entirely.
Then I downloaded this, installed libgnutls, linked library, and magic happened! IGB started working, certificate errors vanished, and even FPS seems to have increased a bit. Awesome work, CCP Snorlax! Cool
Lonami Rainfeld
Caldari Provisions
Caldari State
#287 - 2016-08-11 13:41:21 UTC  |  Edited by: Lonami Rainfeld
This appears to be working perfectly on Arch Linux with an i5-3570k and a GTX 1070 with the proprietary drivers. I already had EVE working with a normal version of Wine because I didn't know this version existed, but this one works much better, and while I wasn't paying too much attention to CPU load before, this version seems to distribute the load across cores more evenly.

One thing I might test later is how this one deals with fullscreen. With the normal wine I had to play in fixed fullscreen because regular fullscreen would cause the game to freeze after alt-tabbing, and sometimes even when starting the game. Fixed fullscreen had no issues though, and that's what I like to use anyway.

Thanks CCP Snorlax, for pimping my game!

Edit: I noticed one thing that wasn't working. With vanilla wine, double-clicking in space made a blue target and line appear to show you the direction you were headed. That doesn't show up with this for some reason.

Edit2: Maybe I was just imagining it; the blue destination thing is back now.
Rounon Dax
Terra Nanotech
Sev3rance
#288 - 2016-08-11 20:32:31 UTC  |  Edited by: Rounon Dax
Since a couple of days now, I do have a weird "bug". I can't open any links at all any more. Neither from the launcher nor ingame. Can click on them, nothing happens at all, no browser is opening for me. Any ideas?

If I start EVE from my own local wine installation with the windows launcher, it all works.
Shiroe Kumamato
SoulPepper Expeditionary Force
#289 - 2016-08-12 16:54:10 UTC
Since the latest patch, gas clouds have disappeared for me. Otherwise, all seems well.
Rounon Dax
Terra Nanotech
Sev3rance
#290 - 2016-08-12 18:40:14 UTC
Rounon Dax wrote:
Since a couple of days now, I do have a weird "bug". I can't open any links at all any more. Neither from the launcher nor ingame. Can click on them, nothing happens at all, no browser is opening for me. Any ideas?

If I start EVE from my own local wine installation with the windows launcher, it all works.


Did some digging today, it seems to be a Qt bug.
When ever I try to open a link, I get the following message:
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Reinstalling the application may fix this problem.
/usr/bin/xdg-open: Zeile 565: 30559 Abgebrochen             kde-open${KDE_SESSION_VERSION} "$1"


xcb is definitely installed, as I mentioned before, when I start EVE from the windows launcher using my own installed wine, all works fine, using the linux launcher, I get this behaviour.

I also noticed that the linux luncher comes with some libs and plugins for Qt 5.6.0, while on my system Qt 5.6.1 is installed. Maybe that already is the issue, a simple version mismatch?
Rounon Dax
Terra Nanotech
Sev3rance
#291 - 2016-08-12 19:07:30 UTC
Rochtorr Umangiar wrote:

I've had a tinker with the AppID for steam but alas I do not own EVE on steam, anyone else had any success here?

8500 is the steam ID
Gislin D'ahl
Perkone
Caldari State
#292 - 2016-08-12 20:10:37 UTC
This is running well in my XFCE desktop on gentoo. Thank you for being a linux advocate.
Excoecaria Agallocha
Plantae Malum
#293 - 2016-08-13 02:06:33 UTC
When I first started looking at EVE on Linux It was a huge disappointment to find so little information. I had been told by some of the veteran members of Providence "Linux? Yeah there used to be some people running EVE on Linux, well a couple of years ago, before the first goon war and before sound mind, when you had to warp uphill both ways to gates......".

For any Debian users out there I just did a clean install of debian 8.5.0 kde, and this process worked for me.

1. Do the Linux install process. I used the GUI and just went with the defaults.

2. Open a shell ( click the 'K' | All Applications | System | Terminal and use wget/curl to download the CCP Snorlax eve launcher. By default you'll be in your home directory, while this doesn't feel as clean as a package that would instal to /usr/bin or /usr/local/bin just deal with it.

#you don't need to sudo this and its probably going to break things later if you do
wget https://binaries.eveonline.com/evelauncher-1043593.tar.gz
#it would be nice if there was a symlink to /evelauncher-current.tar.gz so a change of versions doesn't break scripts or instructions.

3. Since other posts that got EVE to work for different Linux distributions said to I installed the same stuff they did
sudo dpkg --add-architecture i386
#i dunno why they need to do this but a good guess is people who have posted issues with missing library files probably means a program wants 32 bit libs that don't get installed on a 64 bit setup by default.

sudo apt-get install libpng12-0:i386 libldap-2.4:i386
#libgnutls30:i386 was also listed in a post, but in debian this package doesn't exist, the closest is libgnutls28 but it has C and C++ specific packages. Not knowing which to use I left the package off completely.

4. I have an nvidia graphics card, so i have to install drivers from the non-free and the contrib repositories so I have to modify my apt sources.list. For the lazy you can cut and paste this one into the console. There was a prompt for me but you can safely ignore it.

sudo sed -i 's/main/main contrib non-free/g' /etc/apt/sources.list
sudo apt-get update
sudo apt-get install nvidia-driver
#this can take a little while
#previous command gave me a warning about missing firmware so I did this next one that probably doesn't apply to everyone
#sudo apt-get install firmware-linux-nonfree
sudo apt-get install nvidia-xconfig
sudo nvidia-xconfig
#i really didn't change anything in the nividia applet its just what the nvidia instructions said to do and I closed it after not finding anything interesting.

4. I rebooted my computer to load the nvidia drivers, the firmware modules and the updated xconfig. It might sound like a lot but one thing I've learned about windows and linux is that when you put a driver on its usually best to do a reboot. Just click the 'K' and

5. Re-open a shell.
tar -xvf evelauncher-1043593.tar.gz
cd evelauncher
./evelauncher.sh

6. Eve launcher is now running! At least it did for me at this point. :-)


The CCP Snorlax launcher is outstanding, great work!

At this rate I won't have to pay for the next Windows OS and can blow all that money on PLEX instead...
Christophe Merci
The Scope
Gallente Federation
#294 - 2016-08-13 12:15:03 UTC
Kniht wrote:
Christophe Merci wrote:
I re-ran the evelauncher.sh script and the EVE launcher came back up, updated to the newer version (1056484). The launcher then closed.

What should I do to launch EVE at this point. I figured running the executable file in the evelauncher folder (evelauncher) would be the logical next step. Nothing seems to happen.

Open a terminal, cd to evelauncher directory, run ./evelauncher.sh. The output in the terminal may be useful.

The evelauncher.sh script sets up LD_LIBRARY_PATH and then runs ./evelauncher; this is all evelaucher.sh does. You should not run ./evelauncher directly as the variable is required to load the correct libraries. (There is an error in how LD_LIBRARY_PATH is set, where an empty entry, representing the CWD, is added when LD_LIBRARY_PATH is previously unset, but from your description, I doubt this affects you.)


Thanks for the suggestion Kniht. Here is my output when running evelauncher.sh in a terminal:
~/Downloads/evelauncher$ ./evelauncher.sh
[0813/070403:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/chris/Downloads/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/chris/Downloads/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0813/070403:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
Segmentation fault (core dumped)

Any suggestions?
-Christophe
Elassus Herron
Akadeimia Keipouron SVK
Apocalypse Now.
#295 - 2016-08-14 10:06:24 UTC
Shiroe Kumamato wrote:
Since the latest patch, gas clouds have disappeared for me. Otherwise, all seems well.


According to Eve Updates, a recent release iterated the gas cloud assets using effects that depend on DX11. Since the Linux client is DX9 only, this may be why they disappeared (though, that entry said clouds would still render using the old model for DX9 clients).

But fear not. Another dev blog somewhere said they were phasing out DX9 entirely at some point soon, and I very much doubt they'd do so before having a solution in place for the Wine client (which both Mac and Linux users now use). I read some rumors from last year that CodeWeavers (who sell a Wine fork) was developing DX11 support, and that it should trickle down into Wine proper Soon™.
Yurica
Happyness Realization Party
#296 - 2016-08-14 12:00:20 UTC
Hello, after several hours of trying I still cannot start the game using ubuntu 16.04 LTS.

I launch steam and then run ./evelauncher.sh. This brings up the launcher but after a few seconds of inactivity it will just freeze the whole desktop.

Here are all the error messages I get at the moment:

Quote:
[0814/134508:ERROR:nss_util.cc(94)] Failed to create /home/kmi/.pki/nssdb directory.
[0814/134508:ERROR:resource_bundle.cc(691)] Failed to load /media/kmi/Data/eve/evelauncher/qtwebengine_resources.pak
Some features may not be available.
[0814/134508:ERROR:resource_bundle.cc(691)] Failed to load /media/kmi/Data/eve/evelauncher/qtwebengine_resources_100p.pak
Some features may not be available.
[0814/134508:ERROR:resource_bundle.cc(691)] Failed to load /media/kmi/Data/eve/evelauncher/qtwebengine_resources_200p.pak
Some features may not be available.
[0814/134508:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
Installed Qt WebEngine locales directory not found at location /media/kmi/Data/eve/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /media/kmi/Data/eve/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0814/134508:ERROR:nss_util.cc(94)] Failed to create /home/kmi/.pki/nssdb directory.
[0814/134508:ERROR:resource_bundle.cc(691)] Failed to load /media/kmi/Data/eve/evelauncher/qtwebengine_resources.pak
Some features may not be available.
[0814/134508:ERROR:resource_bundle.cc(691)] Failed to load /media/kmi/Data/eve/evelauncher/qtwebengine_resources_100p.pak
Some features may not be available.
[0814/134508:ERROR:resource_bundle.cc(691)] Failed to load /media/kmi/Data/eve/evelauncher/qtwebengine_resources_200p.pak
Some features may not be available.
[0814/134508:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.


what can I do now?
Gamingloser1
Pickle Rick Appreciation Society
#297 - 2016-08-14 21:00:44 UTC  |  Edited by: Gamingloser1
o/

Is anyone having issues with the price history graphs in the market? When I select the tab for price history the "data" is plotted graphically, however it is missing all numerical references to translate the data points. This is the case for every item in the market.

Any ideas?

Mint 17.2
CCP Snorlax
C C P
C C P Alliance
#298 - 2016-08-14 21:07:36 UTC
Gamingloser1 wrote:
o/

Is anyone having issues with the price history graphs in the market? When I select the tab for price history the "data" is plotted graphically, however it is missing all numerical references to translate the data points. This is the case for every item in the market.

Any ideas?

Mint 17.2

You are missing the Arial font. Are you using the Linux launcher? It should provide the font. If you are running your own Wine setup then you can use winetricks to get the font.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Kniht
#299 - 2016-08-16 09:37:46 UTC
Christophe Merci wrote:
Here is my output when running evelauncher.sh in a terminal:
~/Downloads/evelauncher$ ./evelauncher.sh
[0813/070403:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/chris/Downloads/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/chris/Downloads/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0813/070403:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
Segmentation fault (core dumped)

Everything up to the core dump you should be able to ignore. Unfortunately, someone else will have to help you figure out what causes the segfault or how to avoid it.

o/ fly crazy

Gamingloser1
Pickle Rick Appreciation Society
#300 - 2016-08-16 12:59:27 UTC
CCP Snorlax wrote:
Gamingloser1 wrote:
o/

Is anyone having issues with the price history graphs in the market? When I select the tab for price history the "data" is plotted graphically, however it is missing all numerical references to translate the data points. This is the case for every item in the market.

Any ideas?

Mint 17.2

You are missing the Arial font. Are you using the Linux launcher? It should provide the font. If you are running your own Wine setup then you can use winetricks to get the font.



I think I had wine installed but I used the linux laucher. I tried uninstalling wine and that didn't work. Should I remove the installer and try again?