These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
 

The new launcher and the web server issues on the 21st of May: FAQ and update thread

First post First post
Author
Par'Gellen
#521 - 2013-05-26 16:37:06 UTC
I'm getting another strange issue with the launcher today. If I leave it open and don't log in an account for a bit then when I tab out and try to log in it tells me it does not recognize my IP and makes me enter the name of a character on the account. I checked my IP and it did not change. The reason I'm sure it did not change is because I check my IP daily to make sure my little dinky webserver's DNS record is correct (I ain't shelling out what my ISP wants for a static IP). It's usually weeks to months between IP changes anyway but I still check it every day usually multiple times (it's my browser's homepage and I live on the Internet lol).

Anyway, to sum up, what's up with the launcher thinking my IP changed when it didn't?

"To err is human", but it shouldn't be the company motto...

Mag's
Azn Empire
#522 - 2013-05-26 16:39:11 UTC
CCP Atropos wrote:
Mag's wrote:
Is there some way to stop the launcher checking the client, every time I start it up?

The old system was start Eve, paste password, log in.

The new system is start launcher, type in username, Ctrl v password, wait for it to check the client, log in, press play. I tend to simply go and make myself a cuppa while it checks. Not fun.

If this is happening everytime you start the client then something isn't working correctly. Are you able to file a bug repoet and attach your logs; I'm hoping that they contain a hint of what might be wrong, allowing us to if not solve it, at least work out why it's happening and offer some idea of a solution.
Sorry but I simply don't have the time to sort that out for you. I don't even have time to play these days. I don't believe I'm the only one getting this so....

On another note, I honestly thought we'd seen the back of this CCP. You told us you had learned the lessons from not listening and that you wouldn't force things on us without talking to us first. But here we are yet again, back to the CQ and inventory situation.

The thing is, if you can't get the forums to work correctly after all this time, what faith should we have that the launcher with ever hold true?

Destination SkillQueue:- It's like assuming the Lions will ignore you in the Savannah, if you're small, fat and look helpless.

Seth Toralen
Deep Core Mining Inc.
Caldari State
#523 - 2013-05-26 16:56:37 UTC  |  Edited by: Seth Toralen
I am still having issues with the launcher's login process. All of my attempts to communicate this to CCP have gone unanswered. Let me try to explain to explain the problem again.

I get 324 Errors whenever I try to access a number of EVE's login pages. I can't login to community.eveonline, secure.eveonline, or login.eveonline. When I try to access those pages, Chrome returns: "Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data." This problem persists across all computers on my local network. I suspect that a secure connection is failing to be established between the login pages and my computer.

This affects the launcher since the launcher directly tries to connect to login.eveonline for login purposes. I experience the error through the launcher and this page: https://client.eveonline.com/launcherv3.

I have filed two bug reports on this issue. One specific to the launcher issue (158877), and one specific to the websites (158874). I only realized later that they are in fact, the same issue. I also have been active on multiple forum posts. CCP has not responded to any of my posts. Here is the latest one: https://forums.eveonline.com/default.aspx?g=posts&m=3082892#post3082892 I also filed multiple petitions. The latest one is: #3234285

Please respond to something. I can't access account management, API's, petitions, the launcher.... Once the login is migrated out of the client, I will be completely unable to access EVE (except for the forums oddly enough).
James Amril-Kesh
Viziam
Amarr Empire
#524 - 2013-05-26 16:59:51 UTC
Skex Relbore wrote:
The statement quoted in your reply is incompatible with the response I'm replying to, because the functionality I'm making use of and desire is the availability of the ExeFile.exe.

So even if you had something else that worked just as effectively, you would reject it outright?

Enjoying the rain today? ;)

Par'Gellen
#525 - 2013-05-26 17:11:57 UTC
James Amril-Kesh wrote:
Skex Relbore wrote:
The statement quoted in your reply is incompatible with the response I'm replying to, because the functionality I'm making use of and desire is the availability of the ExeFile.exe.

So even if you had something else that worked just as effectively, you would reject it outright?

That's what it looked like to me... Some people's kids.... *sigh*

"To err is human", but it shouldn't be the company motto...

El Burrito Bandito
The Scope
Gallente Federation
#526 - 2013-05-26 17:25:15 UTC  |  Edited by: El Burrito Bandito
This may have been answered already somewhere else, if so, I apologize :

I tried to load up eve today, the launcher started updating, so far, so good.. Then the status bar disappeared and nothing happened, now the launcher will not work, no new processes start when I double click the launcher icon.

I tried getting the eve.exe and same thing.

I tried using the built in repair utility, no change.

Eve is not installed on C: if that makes any difference.

Can someone please help, or point me to a thread with an answer??

El - B
Skex Relbore
GoonWaffe
Goonswarm Federation
#527 - 2013-05-26 18:25:50 UTC
James Amril-Kesh wrote:
Skex Relbore wrote:
The statement quoted in your reply is incompatible with the response I'm replying to, because the functionality I'm making use of and desire is the availability of the ExeFile.exe.

So even if you had something else that worked just as effectively, you would reject it outright?



Nothing involving the launcher would work just as effectively.

Let me be clear, the only time I use the launcher is to update my client. Other than that I don't touch it at all to access the game. I use ISboxer to manage my EVE clients, I right click on it select the character set I want to run and wait while it launches the EXEfile.exe with the appropriate clients with their relevant settings. I then enter their passwords and log in. If I were to actually sync my passwords I could even use the repeater functionality to reduce that to a single action but I prefer to maintain some additional security by using separate passwords.

This also means that to change characters on a given client I simply log off that instance and wait for it to restart to the login screen and change to the desired character.

The new launcher offers me nothing that I want and removes functionality that I use and value.

Of course the easy win/win answer would be to do whatever the hell they want with the launcher as long as they leave the exefile.exe functionality in place and everyone would be happy. The question is why this is not an acceptable solution, and no answer has been given.

It would be one thing if the new launcher was actually tied to some new functionality that I would find useful, but it isn't. It's just more bloatware being shoved down our throat for no discernible reason. What possible reason is there to change this? Why on earth would I want a single login in for a game that encourages and practically requires the use of multiple accounts? If they want us to be able to access services out of game then let us log into those services outside of the ******* game it's not that complicated to do.
Onion Ring
Royal Amarr Institute
Amarr Empire
#528 - 2013-05-26 18:38:02 UTC
Skex Relbore wrote:
I use ISboxer to manage my EVE clients


You are such a wise guy.

I appreciate having got to known you and your last words on the forums before you lifetime ban of all your accounts from EVE Online.

The discussion of the usability of the launcher is clearly above your understanding of compliance to CCP rules.
Oraac Ensor
#529 - 2013-05-26 19:22:08 UTC
James Amril-Kesh wrote:
Skex Relbore wrote:
The statement quoted in your reply is incompatible with the response I'm replying to, because the functionality I'm making use of and desire is the availability of the ExeFile.exe.

So even if you had something else that worked just as effectively, you would reject it outright?

CCP Atropos has already expressed the opinion that the current use players make of the ExeFile.exe makes no sense, so there would seem to be little chance of any sort of replacement for it, but nevertheless says that it will not be removed until an alternative is in place.

No great intellect is required to see an obvious conflict here.
Lord Haur
Star Frontiers
Brotherhood of Spacers
#530 - 2013-05-26 19:31:11 UTC
Onion Ring wrote:
Skex Relbore wrote:
I use ISboxer to manage my EVE clients


You are such a wise guy.

I appreciate having got to known you and your last words on the forums before you lifetime ban of all your accounts from EVE Online.

The discussion of the usability of the launcher is clearly above your understanding of compliance to CCP rules.

I'll point you to this GM post. While CCP doesn't endorse the use of ANY third-party programs, at this point in time the use of ISBoxer is not specifically against the EULA. This may change as a result of CCP changing their minds/the rules, or ISBoxer introducing additional functionality which breaks the EULA.

In an effort to appease the mods, please keep discussion of that specific topic to other threads (the thread the linked GM post is in, for example), or use a petition to address any further queries to the GMs.

Disclaimer: I am not CCP, so I have no hand in the official interpretation of the EULA.
Kblackjack54
Deep Core Mining Inc.
Caldari State
#531 - 2013-05-26 20:19:01 UTC
El Burrito Bandito wrote:
This may have been answered already somewhere else, if so, I apologize :

I tried to load up eve today, the launcher started updating, so far, so good.. Then the status bar disappeared and nothing happened, now the launcher will not work, no new processes start when I double click the launcher icon.

I tried getting the eve.exe and same thing.

I tried using the built in repair utility, no change.

Eve is not installed on C: if that makes any difference.

Can someone please help, or point me to a thread with an answer??

El - B


Open the launcher, (NEW), Then open the Launcher settings, EVE Client settings Tab and click the 'Clear cached client data' button, reboot eve and try the repair option if it does not update as required.

Should allow you too update the client, if above fails a second time clear cache data again and then try the Bin/ EVE.exe method to open a client, .

Jonuts
The Arrow Project
#532 - 2013-05-26 20:23:32 UTC
CCP Atropos wrote:

You can, yes. The old login method still exists for the moment, however with login moved into the EVE Launcher then the concept of the old login screen simply doesn't make sense.


Hate to break it to you, but you got that backwards. moving the log in to the launcher makes no sense, as this is a game practically built around alternate accounts. Change isn't a good thing when you break the old way to do something and the new way is inferior. Just saying. The launcher itself just feels outdated, and it's update feels like a step backwards.
Mara Rinn
Cosmic Goo Convertor
#533 - 2013-05-26 22:32:13 UTC
It wouldn't be the Summer expansion without CCP causing a ruckus Lol

I'm looking forward to the new launcher having the ability to coordinate the simultaneous launch of characters from all my accounts, along with the animated WebGL background with theme music.
MaRU2760 133
Unit 439
#534 - 2013-05-26 23:04:54 UTC
Mara Rinn wrote:
It wouldn't be the Summer expansion without CCP causing a ruckus Lol

I'm looking forward to the new launcher having the ability to coordinate the simultaneous launch of characters from all my accounts, along with the animated WebGL background with theme music.


You obviously have a more capable computer than I do. Grats. :)
Hagbard Solaris
Omega Eternal
#535 - 2013-05-26 23:36:18 UTC
Mara Rinn wrote:
It wouldn't be the Summer expansion without CCP causing a ruckus Lol

I'm looking forward to the new launcher having the ability to coordinate the simultaneous launch of characters from all my accounts, along with the animated WebGL background with theme music.


I'm looking forward to a new SpongeBob Squarepants themed launcher with live streaming of WoW gameplay so the new target demographic players won't feel like they are missing anything.

What if New Eden was a virtual prison and we're convicts in a prison pod somehwere?

Mara Rinn
Cosmic Goo Convertor
#536 - 2013-05-26 23:45:53 UTC
MaRU2760 133 wrote:
Mara Rinn wrote:
It wouldn't be the Summer expansion without CCP causing a ruckus Lol

I'm looking forward to the new launcher having the ability to coordinate the simultaneous launch of characters from all my accounts, along with the animated WebGL background with theme music.


You obviously have a more capable computer than I do. Grats. :)


My current computer would melt down if I left it on the login screen too long, but it seems to handle the WebGL ship viewer just fine.
Muul Udonii
THORN Syndicate
Northern Coalition.
#537 - 2013-05-27 00:10:23 UTC
I have had an issue trying to log in on my laptop; it's told me that there is a new build available, so I let it install, and it starts up the launcher, so I close it and run eve again, and it tells me that there is a new build available.

This cycle continues until I use the launcher to log in, then log out, close the launcher and log in without the launcher.

Can this be stopped, please? I will not use the launcher until it is finished, as it increases the time it takes me to start playing by about 5 minutes.
Skex Relbore
GoonWaffe
Goonswarm Federation
#538 - 2013-05-27 00:19:43 UTC
Onion Ring wrote:
Skex Relbore wrote:
I use ISboxer to manage my EVE clients


You are such a wise guy.

I appreciate having got to known you and your last words on the forums before you lifetime ban of all your accounts from EVE Online.

The discussion of the usability of the launcher is clearly above your understanding of compliance to CCP rules.


You are an idiot, there is absolutely nothing about using ISBoxer that is against the EULA, So no I won't be going anywhere soon. Now go back to your corner while the adults discuss things.
blazegryph
Corpy Hooves
#539 - 2013-05-27 00:38:14 UTC  |  Edited by: blazegryph
hmm...don't know if this goes here, but after yesterday's launcher update, my ingame keyboard support its gone.. i can type on the chats and all, but outside chat windows , ESC, ALt+N, ALT+G F10, F11...no keyboard shortcut works. Deinstaled and reinstaled a fresh client ... still no keyboard support ingame.... even going by the old login screen, i can't press enter to acept the username&pasword, must click on 'accept'

And as no keyboard shortcut works, i cannot launch the bugreport from ingame... i know there is an out-of-game bug report, but cant attach much usefull stuff..


..copied data info from /documents & settings/user/configuración local (local files)/datos de programa (program files)/CCP/ to the new generated /Configuración local/ ...it seems the language files cannot process the accentuated O (ó) and instead adds to the path name the ó ...as workaround should be fine but after checking didnt worked, deinstaled and reinstaled a fresh client ... still no keyboard shortcut support ingame.... ...and the repair tool gives an error when repairing... both before and after installing the client, saying this when used...

Traceback (most recent call last):
File "repairTool\progressPanel.pyc", line 82, in _TaskRun
File "repairTool\repairUI.pyc", line 97, in Start
File "repairTool\repairLogic.pyc", line 199, in Repair
File "repairTool\repairLogic.pyc", line 316, in Restore
File "checksum.pyc", line 291, in __init__
File "shelve.pyc", line 239, in open
File "shelve.pyc", line 223, in __init__
File "anydbm.pyc", line 83, in open
File "dbhash.pyc", line 18, in open
File "bsddb\__init__.pyc", line 364, in hashopen
DBNoSuchFileError: (2, 'No such file or directory')
Total Runtime: 0h00m00s

*****UPDATE:*****

Misteriously it got fixed next day i started up the computer again, so no issues running currently... i wonder what happened really... as the game had no keyboard support for like 3 days nonstop
Vaerah Vahrokha
Vahrokh Consulting
#540 - 2013-05-27 00:43:27 UTC
Mara Rinn wrote:
It wouldn't be the Summer expansion without CCP causing a ruckus Lol

I'm looking forward to the new launcher having the ability to coordinate the simultaneous launch of characters from all my accounts, along with the animated WebGL background with theme music.


Considering they could not even manage to keep the jukebox, I have some doubts about WebGL and theme music.