These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Information Portal

 
  • Topic is locked indefinitely.
 

EVE Launcher update on May 21, 2013

First post First post
Author
Kale Freeman
Garoun Investment Bank
Gallente Federation
#761 - 2013-05-21 17:23:01 UTC
Kale Freeman wrote:
Malcanis wrote:
Darkness Assasin wrote:
Launching the game from :C:\Program Files (x86)\CCP\EVE\bin\exefile.exe works for me.
That is after updating the launcher to the latest version.


Doing that trapped me in endless update cycles. Running Repair.exe then Launching the game from :C:\Program Files (x86)\CCP\EVE\bin\exefile.exe has me with a working connection.


Crap, I hope I dont get into endless update cycles. Just manually run the exefile program. It's busy downloading a 23MB patch. I'm amazed at the general incompetence


Hmm... that has finished and now I'm downloading a launcher update. Goddamn bandwidth.
thunXa
My Own One
#762 - 2013-05-21 17:23:05 UTC
Xia Kairui wrote:
Ok, has anyone found a solution yet? I've been through this threadnought and didn't find a workable solution.

I've tried for the last hours:

Run Launcher -> Offline
Run ExeFile.exe -> incompatible
Run Repair.EXE as admin -> Launcher starts, offline
Change Build number in COMMON.INI, run repair.exe as Admin -> DLing some stuff times out
Grabbing Chribba's files atm.

Any other possible solutions?



how to bypass errors:

create shortcut from repair.exe |||

right click on the shortcut and open properties |||

add this to your launch file/directory to the end of repair.exe |||

(1 empty space) --safemode || it will look like this directory/repair.exe --safemode ||

launch the shortcut, after repair go to eve/bin dir and launch exefile.exe


this worked for me and 4 other guys from corp.
its been confirmed that this only works with original install dir.. (not copy&paste files)
Steijn
Quay Industries
#763 - 2013-05-21 17:23:06 UTC
Jess Technite wrote:
After Chribba's patch the ExeFile throws this message:

Your Eve client installation may have modified, damaged or corrupt files. Please run repair.exe located in the EVE game directory or re-install the game client.
Bad manifest signature, timestamp "2012.03.06 16:22:04", expected "2009.02.25 10:35:34"


run repair.exe then start eve via the exe file in /bin
Synthmilk
The United Peoples of Synth
#764 - 2013-05-21 17:23:33 UTC
CCP Atropos wrote:
For those reporting connection errors, are you able to connect to https://client.eveonline.com/launcherv3 and http://client.eveonline.com/patches/win_launcherinfoTQ_inc.txt


I am getting the connection error and I am not able to connect to either of those addresses.
DrHeinz Doofenshmirtz
The Scope
#765 - 2013-05-21 17:23:57 UTC
Xia Kairui wrote:
Ok, has anyone found a solution yet? I've been through this threadnought and didn't find a workable solution.

I've tried for the last hours:

Run Launcher -> Offline
Run ExeFile.exe -> incompatible
Run Repair.EXE as admin -> Launcher starts, offline
Change Build number in COMMON.INI, run repair.exe as Admin -> DLing some stuff times out
Write a petition -> "Unspecified error, try later"
Grabbing Chribba's files atm.

Any other possible solutions?

CCP Atropos wrote:
For those reporting connection errors, are you able to connect to https://client.eveonline.com/launcherv3 and http://client.eveonline.com/patches/win_launcherinfoTQ_inc.txt


Once the pages loaded, now they time out; the LauncherV3 loads partially.

run evefile.exe after running the repair :D. going to the launcher after repairing doesn't help (obviously)
jiantsquidz
Stripers Of New Eden
#766 - 2013-05-21 17:24:04 UTC
Another break from eve detected. hopefully its fixed tomorow
Atena Dineji
Caldari Provisions
Caldari State
#767 - 2013-05-21 17:24:32 UTC  |  Edited by: Atena Dineji
Well, sometimes deployments fail when you have to deploy something to such a variety of clients.
Update failed on my side, too, but that doesn't change my mood. What does is if an non-essential update breaks everything.

Being responsible for IT Projects myself, the first thing i ask when something breaks or creates trouble in any way is:
Do we really need this thing?
In case of the launcher i'd say no. It's not essential. So why is there? Because it could provide some nice features. So, the second question to ask is:
How would it look like if it would be absolutely perfect - or at least as perfect as we can imagine?
The login-process for players with only one account, playing on tq is almost the same - with or without launcher. An SSO-System doesn't really improve that. To really improve that process you should look at players who have different accounts and play on Sisi as well. Eve is very special. So should the launcher be.
The best launcher i could imagine would be one that lets you manage your accounts and perhaps even the sisi installation on your system. Provide a guest login that doesn't change personalized settings. Save credentials of my accounts, remember my personal way to launch the game (it's a launcher, isn't it?). Like a login-like-last-time-button that launches Account A on screen 0 and a second client with Account B on screen 1, so i don't have to do this manually. That would be an innovative improvement that really stands out.
And of course, the usual stuff it should do: To verify or update the installation or - in special occasions - repair it, while showing me interessting news of the universe.
Thats what i would expect from an innovative company thinking about their vision the create something really unique.

But what you did with the launcher is just as casual as it could be. My guess is nobody in the Engineering-department really wanted to develop that thing and somebody just wrote it to the todo list because "other mmos have it too, so it must be kinda cool" while the management got a boner hearing the word "landing page", because it means more space for advertising.
And thats really what it looks like.

Seriously, if thats your best, your best won't do.

And for that abomination my installation completly fscked up? Thats something that ruins my mood.
Razuvious Darklighter
Brutor Tribe
Minmatar Republic
#768 - 2013-05-21 17:24:44 UTC
advii wrote:
Sir HyperChrist wrote:
Run

\program files\CCP\eve\bin\exefile.exe

if you want to skip the launcher in general, or if you want to play now that this update borked up the launcher :)


Thanks, this seems to work. I was about to unleash all my rage. EvilEvilEvilEvilEvilEvil


This doesn't even work for me. Tried it and all I get is "Incompatible Protocol". CCP fails yet again.

As has been stated several times already, "Y U BREAK LAUNCHER?!!"
Ginger Barbarella
#769 - 2013-05-21 17:24:47 UTC
Xia Kairui wrote:
Ok, has anyone found a solution yet? I've been through this threadnought and didn't find a workable solution.

I've tried for the last hours:

Run Launcher -> Offline
Run ExeFile.exe -> incompatible
Run Repair.EXE as admin -> Launcher starts, offline
Change Build number in COMMON.INI, run repair.exe as Admin -> DLing some stuff times out
Write a petition -> "Unspecified error, try later"
Grabbing Chribba's files atm.

Any other possible solutions?

CCP Atropos wrote:
For those reporting connection errors, are you able to connect to https://client.eveonline.com/launcherv3 and http://client.eveonline.com/patches/win_launcherinfoTQ_inc.txt


Once the pages loaded, now they time out; the LauncherV3 loads partially.


Run repair.exe as administrator with "-safemode" switch (per CCP) (especially if you've since tried the launcher after repair), run ExeFile.exe from ../bin folder.

"Blow it all on Quafe and strippers." --- Sorlac

Jonzac
Sebiestor Tribe
Minmatar Republic
#770 - 2013-05-21 17:25:36 UTC
Launcher unable to work for me. I get both links to work but VERY slowly. I ran repair and then ran exe file from EVE/bin and I'm in now.
Ustag
Lucidus Ordo
Pandemic Legion
#771 - 2013-05-21 17:26:13 UTC  |  Edited by: Ustag
guys stop repairing or doing anything with your client.

it's a randomic serverside problem, CCP has to fix it.

prolly it's too much load to a new service tied with the launcher, wich in turn returns error 503 most of the times.

go to eve folder/bin/ and launche exefile.exe till this thing gets solved (on your own risk).

oh, CCP wish u goodspeed in fixing this, but.. **** happens, ya know!

oh.. if exefile is not running fine, chribba knows:

Quote:
Chribba wrote:
Not claiming to have a fully working fix here - but it worked for me patching up my other computers so if anyone want to try go for it.

http://eve-files.com/temp/eve-update-20130521.zip (it's the files that got modified for me today, 50mb)

Copy and while launcher will still most likely fail, start the exefile.exe straight from the \bin folder.

On your own risk ofc but worked fine for me.

Else many suggested running repair.exe which seems to work in some cases.
KEREAPER
KNIGHT'S OF THE ROUND ROOM
#772 - 2013-05-21 17:26:18 UTC
If there ever was a valid reason for having a "test" server this could be it, OH! now I understand this is the test server. Directions to log in on the real server would be nice.
OldWolf69
Militaris Industries
Northern Coalition.
#773 - 2013-05-21 17:26:37 UTC
I love the fact players have solutions. But more i LOVE the fact CCP is Silention Stampa. Goddamn quiet. Expected reaction, btw.Lol
Mermalior
Jugis Modo Utopia
pwn-O-graphy
#774 - 2013-05-21 17:26:40 UTC
RadioBANITA wrote:
Quote:
Chribba wrote:
Not claiming to have a fully working fix here - but it worked for me patching up my other computers so if anyone want to try go for it.

http://eve-files.com/temp/eve-update-20130521.zip (it's the files that got modified for me today, 50mb)

Copy and while launcher will still most likely fail, start the exefile.exe straight from the \bin folder.

On your own risk ofc but worked fine for me.

Else many suggested running repair.exe which seems to work in some cases.


/c


Chribba, u rocks!! Your solution works just perfectly! Thank you man :))


MAN, YOU ARE GREAT!

Nothing helped, but your file worked perfectly
Doublewhopper
Temporary Assignment
#775 - 2013-05-21 17:26:45 UTC
With the launcher as of today i am unable to login.

If it works again someday i will not resubscribe my accounts until i can login without a webbrowser again.

This is effectively hindering multiboxing.
Bad Messenger
Rehabilitation Clinic
#776 - 2013-05-21 17:26:54 UTC
another CCP quality feature, keep going good work !
Chokichi Ozuwara
Perkone
Caldari State
#777 - 2013-05-21 17:26:59 UTC
Kale Freeman wrote:
I'm amazed at the general incompetence

You must be new around here.

Tears will be shed and pants will need to be changed all round.

Azriel X
#778 - 2013-05-21 17:27:04 UTC
Its OK ccp... I"ll forgive you, but at what cost mooohahahaha.

This calls for freebies and cool stuff to assuage the peoples' anger.
Admiral Manhattan
Caldari Provisions
Caldari State
#779 - 2013-05-21 17:27:07 UTC
Richouse Gallentry
Risk-Averse
PLEASE NOT VIOLENCE OUR BOATS






I believe the problem is with the content server.

When you run the launcher, it attempts to grab content... since the content server is currently having it's problems (extremely slow load for some, no load for most). Several different errors are being reported, like "Offline Mode", "My Launcher Just Took a Crapper!", and so on and so forth.

The easiest way to work around this issue for now is to skip the launcher and run "ExeFile.exe" which is found in:

Program Files/EVE/bin/
-or-
Program Files (x86)/EVE/bin/
-or-
**YourSpecificFolder**/EVE/bin/

It's likely when you run this file, you will get to your login screen, but still unable to login because your EVE Client hasn't properly updated since the patch.

To resolve this, navigate directly to your "repair.exe" file and run it. The repair file can be found in your Program Files/EVE/ directory. The repair tool should detect that your version of EVE is out of date and then update. Once updated, you'll still need to bypass the EVE Launcher because the content server is the core problem, and run the ExeFile.exe from the /EVE/bin/ directory.
KIller Wabbit
MEME Thoughts
#780 - 2013-05-21 17:27:32 UTC
Ginger Barbarella wrote:
Xia Kairui wrote:
Ok, has anyone found a solution yet? I've been through this threadnought and didn't find a workable solution.

I've tried for the last hours:

Run Launcher -> Offline
Run ExeFile.exe -> incompatible
Run Repair.EXE as admin -> Launcher starts, offline
Change Build number in COMMON.INI, run repair.exe as Admin -> DLing some stuff times out
Write a petition -> "Unspecified error, try later"
Grabbing Chribba's files atm.

Any other possible solutions?

CCP Atropos wrote:
For those reporting connection errors, are you able to connect to https://client.eveonline.com/launcherv3 and http://client.eveonline.com/patches/win_launcherinfoTQ_inc.txt


Once the pages loaded, now they time out; the LauncherV3 loads partially.


Run repair.exe as administrator with "-safemode" switch (per CCP) (especially if you've since tried the launcher after repair), run ExeFile.exe from ../bin folder.


That's "--safemode" I believe