These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

EVE Launcher for Linux

First post First post
Author
Sabrina Winslow
Galactic Board of Price Equalization
#621 - 2017-05-25 01:41:58 UTC
I tried the launcher again after work today aaaand... the launcher is working fine now.

interesting.
Ardes Atavuli
EVE University
Ivy League
#622 - 2017-05-25 20:01:01 UTC
On Debian sid, it is mostly working after installing steam and adding symlinks to ssl and crypto libs:
 
     sudo apt install steam
     cd /path/to/launcher
     ln -s libssl-compat.so.1.0.0 libssl.so.1.0.0
     ln -s libssl-compat.so.1.0.0 libssl.so
     ln -s libcrypto-compat.so.1.0.0 libcrypto.so.1.0.0
     ln -s libcrypto-compat.so.1.0.0 libcrypto.so


The native launcher just works with the installed wine and winetricks. However, the keyboard in not recognized in the actual eve client: so no typing in channel names to join chat, no searching for items in the regional market, no typing into chat windows. no keyboard shortcuts.

I looked around, and found some mention of XMODIFIERS

So I added

XMODIFIERS=""
export XMODIFIERS

into the eve launcher shell script, to no avail. Any idea what IO could try next?

Ardes
Roesjka
The Last Solution Inc
#623 - 2017-05-26 13:38:18 UTC  |  Edited by: Roesjka
Chupalav Al-Caucasus wrote:
Tried script above with no success:( Debian testing 64-bit - launcher still hangs with no errors. Any other solutions maybe?


I take it you did alter path/to/evelauncher to the actual path and have libssl1.0.2 (this will also install libcrypto.so.1.0.2 installed, you'll find it in the Stretch/testing repo?

Than it should work in Debian Stretch/testing.

Forgot to mention I am using MATE as a DE.

You'll find me in the Linux channel when I am online.

cheers.

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Elassus Herron
Akadeimia Keipouron SVK
Apocalypse Now.
#624 - 2017-05-28 09:37:44 UTC
Dumb question: is there a way to set where the launcher puts its wine binaries? I have a dedicated SSD for EVE where the launcher is installed, but there is also the directory ~/.eve, containing almost 9GB of files. I'd like to move this over to the EVE drive as well. Is there a way to do this?

Cheers,
wurstsalat
RedCounty
#625 - 2017-05-28 17:26:45 UTC  |  Edited by: wurstsalat
I can't make the launcher work on ubuntu 17.04.

https://pastebin.com/PwCH7iED

Here's part of the error log, it successfully downloads the first file it needs, then it starts downloading some part of wine and stops at 10%, just repeatedly spamming something failed and that I should look into the error log, the part in the pastebin is repeated until I stop the launcher. Can't copy paste the whole thing because it quickly balloons to several MB of logs.

I have wine staging installed, version 2.8. When starting the sh file throws this up:

[0528/191223:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/ubuntu/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/ubuntu/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0528/191223:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale

Am I doing something wrong?

Edit: figured it out, after configuring the launcher to use a custom wine version and adding a symbolic link to the .wine folder, the launcher downloaded everything, but now nothing happens when I click on play.
Arctos DeJure
0 GOLDEN TITANS 0
#626 - 2017-05-28 18:23:52 UTC
First of all i would like to say hello to all members here and developers.

This is my first post, I am new in the forum, and the game, although i had tried the trial version a couple of years ago.

I just used the EVE Launcher on a fresh Mint 18.1 install, it worked like a charm. There was some delay in the first run after install, but has been working great so far. A huge thank you and a hat tip to CCP Snorlax for giving this opportunity to all linux users.
Zerg Lurker Okanata
State War Academy
Caldari State
#627 - 2017-05-30 21:19:31 UTC
Trying to install client.

spieler@spieler-System-Product-Name:~/evelauncher$ chmod +x evelauncher.sh
spieler@spieler-System-Product-Name:~/evelauncher$ sh evelauncher.sh
/home/spieler/evelauncher/./evelauncher: 1: /home/spieler/evelauncher/./evelauncher: Syntax error: "(" unexpected


ubuntu 16.04

What's wrong?
Ardes Atavuli
EVE University
Ivy League
#628 - 2017-05-30 21:47:18 UTC
Zerg Lurker Okanata wrote:
Trying to install client.

spieler@spieler-System-Product-Name:~/evelauncher$ chmod +x evelauncher.sh
spieler@spieler-System-Product-Name:~/evelauncher$ sh evelauncher.sh
/home/spieler/evelauncher/./evelauncher: 1: /home/spieler/evelauncher/./evelauncher: Syntax error: "(" unexpected


ubuntu 16.04

What's wrong?


1. What is your /bin/sh linked to? (it could be dash, which is weird)
2. Does running bash ~/evelauncher.sh help there.
3. You could try "bash -x ~/evelauncher.sh" to see what is going on.

Ardes
Kuran Sincomil
Sofa Kingdom
#629 - 2017-05-30 21:50:49 UTC
I think your shell is not compatible with shell script . try to run explicitly pointing to /bin/bash:

/bin/bash ./evelauncher.sh
Zerg Lurker Okanata
State War Academy
Caldari State
#630 - 2017-05-31 06:56:27 UTC  |  Edited by: Zerg Lurker Okanata
spieler@spieler-System-Product-Name:~/evelauncher$ bash evelauncher.sh
evelauncher.sh: line 14: /home/spieler/evelauncher/./evelauncher: cannot execute binary file: wrong format
Kuran Sincomil
Sofa Kingdom
#631 - 2017-05-31 16:50:40 UTC
I think your Installed Linux is 32-bit version, so evelauncher is ELF64 format and could not be run on 32-bit system
Zerg Lurker Okanata
State War Academy
Caldari State
#632 - 2017-05-31 19:53:58 UTC
yes, but my hardware is 32-bit. how can i awoid this problem?

im new to unix-based systems. can i do anything with this?

____________
ubuntu-16.04.1 LTE i386
Kuran Sincomil
Sofa Kingdom
#633 - 2017-06-01 16:54:53 UTC
Since there no ELF32 binaries you have to use wine to run windows binary launcher instead of Linux Native, it works almost same.
Zerg Lurker Okanata
State War Academy
Caldari State
#634 - 2017-06-01 18:03:50 UTC
it doedent sork

Kuran Sincomil
Sofa Kingdom
#635 - 2017-06-01 22:06:46 UTC
run winecfg and set windows version to Windows XP emulation, when launcher runs make sure to set option to run game in DX9
Murdo Ranulfson
Star Tide Industries
Requiem Eternal
#636 - 2017-06-04 22:52:48 UTC
Issues running the latest launcher after an upgrade. Linux version is Linux Mint 18.1 Serena. Here is the output of the commands I am running to attempt to get it to run. Already verified I am running wine in windows xp mode via winecfg:
sivik@Saveak ~/Downloads/evelauncher $ ./evelauncher
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted
sivik@Saveak ~/Downloads/evelauncher $

sivik@Saveak ~/Downloads/evelauncher $ bash -x ./evelauncher.sh
++ basename ./evelauncher.sh
++ sed 's,.sh$,,'
+ appname=evelauncher
++ dirname ./evelauncher.sh
+ dirname=.
+ tmp=
+ '[' . '!=' / ']'
+ dirname=/home/sivik/Downloads/evelauncher/.
+ LD_LIBRARY_PATH=/home/sivik/Downloads/evelauncher/.:
+ export LD_LIBRARY_PATH
+ export QTDIR=/home/sivik/Downloads/evelauncher/.
+ QTDIR=/home/sivik/Downloads/evelauncher/.
+ export QT_PLUGIN_PATH=/home/sivik/Downloads/evelauncher/./plugins/platforms
+ QT_PLUGIN_PATH=/home/sivik/Downloads/evelauncher/./plugins/platforms
+ /home/sivik/Downloads/evelauncher/./evelauncher
[0604/175158:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/sivik/Downloads/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/sivik/Downloads/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0604/175158:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.

Running the evelauncher.sh loads a window called EVE Launcher - version 1146159 and it opens a window but the window is missing. Only the title bar exists.
Andevellicus de'Athar
Deep Core Mining Inc.
Caldari State
#637 - 2017-06-05 22:21:43 UTC
Same with me. I can only think that it's something to do with QT libs.
Dexxel Farcry
Taggart Transdimensional
Solyaris Chtonium
#638 - 2017-06-06 00:58:20 UTC  |  Edited by: Dexxel Farcry
Quote:
Bunch of stuff I just typed


It turns out that I'm an just an idiot.

I was trying to use evelauncher, instead of evelauncher.sh, back to my corner now.
Ragnar STS
Matari Machining
Bloody Hands of Matar.
#639 - 2017-06-09 04:58:54 UTC
Just FYI....fresh new install on a new laptop today.

Fresh Linux Mint 18.2 beta.
Launcher ran fine; wouldn't launch the client.
Fiddled with it for a couple hours, then installed PlayOnLinux.
Client worked immediately.

Definitely nice to have a new laptop with 1060 video and an 8 core I7. :)
Fran Spamordi
Sebiestor Tribe
Minmatar Republic
#640 - 2017-06-12 21:17:27 UTC
Ragnar STS wrote:
Just FYI....fresh new install on a new laptop today.

Fresh Linux Mint 18.2 beta.
Launcher ran fine; wouldn't launch the client.
Fiddled with it for a couple hours, then installed PlayOnLinux.
Client worked immediately.

Definitely nice to have a new laptop with 1060 video and an 8 core I7. :)


I can second the POL part of that, I had issues on Ubuntu 17.04 until I installed this. Works flawlessly after that. Props to Snorlax.