These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

EVE Launcher for Linux

First post First post
Author
Ralphydd
Aliastra
Gallente Federation
#641 - 2017-06-13 17:55:03 UTC
fixed window mode is great! no rerender on desktop switch. get better resolution bla bla bla.
oh yeah except the part where the mouse renders like an inch BELOW where it actually clicks (is).

how to fix? wine problem?

nothing better than try'n to click back to fullscreen for 2 minutes then click the apply button cuz the mouse render is F*%ked up......

yeah i know just hit esc to cancel the changes.
Ailatan
SQUAD V
Northern Coalition.
#642 - 2017-06-18 21:04:30 UTC  |  Edited by: Ailatan
I have updated to Debian 9 Stretch today and launcher is not working. No error messages in console, it just wait infinitely after typing: ./evelauncher.sh

Any ideas? Anybody have this problem too?
Ailatan
SQUAD V
Northern Coalition.
#643 - 2017-06-19 05:09:07 UTC
Ailatan wrote:
I have updated to Debian 9 Stretch today and launcher is not working. No error messages in console, it just wait infinitely after typing: ./evelauncher.sh

Any ideas? Anybody have this problem too?


Solved copying: libssl.so.1.0.2 and libcrypto.so.1.0.2 are in /usr/lib/x86_64linux-gnu/ into launcher folder and renaming them without version.
Joerano Virpio
Immortal defenders of humanity
#644 - 2017-06-19 16:40:26 UTC
Ailatan wrote:
I have updated to Debian 9 Stretch today and launcher is not working. No error messages in console, it just wait infinitely after typing: ./evelauncher.sh

Any ideas? Anybody have this problem too?


In ArchLinux have this problem too.
Problem in openssl package? upgraded in Arch to 1.1.0.f-1
Installing extra/openssl-1.0 and symlink /usr/lib/libssl.so.1.0.0 /usr/lib/libcrypto.so.1.0.0 to launcher directory solves this.
Calden Aivo
Brave Newbies Inc.
Brave Collective
#645 - 2017-06-20 05:23:44 UTC
Ailatan wrote:
Solved copying: libssl.so.1.0.2 and libcrypto.so.1.0.2 are in /usr/lib/x86_64linux-gnu/ into launcher folder and renaming them without version.


I have no idea how you figured it out, but the same worked for me. The launcher stopped working for me after upgrading to Fedora 26 and was brought back to life by copying the two files to the evelauncher directory. On Fedora (and probably other RH-related distros), they're in /usr/lib64/, by the way.
Furor Crendraven
Moucho Corporation
#646 - 2017-06-20 13:52:58 UTC
Does anyone knows how to limit FPS? as Present Interval doesn't seem to work. Thanks Smile
Ravow
Hell For French
Deep Space Alliance
#647 - 2017-06-20 15:36:24 UTC
Furor Crendraven wrote:
Does anyone knows how to limit FPS? as Present Interval doesn't seem to work. Thanks Smile


Well, it's broken on my side to.
I'm using it full screen at 4k res, Interval 1 set it to exactly 30 fps, with is not enough and with immediate, I get anything between 75 to 330 and it warm up the room... And something I see tearing as my screen is 60hz.

I say do like me until it's fixed, leave it at interval 1 for station spinning and stuff like hauling and mining but as so as you decide to hot drop on peoples or do some other pvp activities, put it to immediate. Anyway, if your in a fight with lot of stuff and your FPS go to like 58, with a working vsync it would drop to 30 so better to leave immediate for pvp.
Lucius Kalkoken
Ubiquitous Hurt
The WeHurt Initiative
#648 - 2017-06-20 18:50:34 UTC
Unfortunately vsync not working was introduced with wine 2.5. If you really need vsync you'll have to use a build from before that. Also if anyone is in a position to do a bisect between wine 2.4 and 2.5 to figure out which commit caused it that would be awesome.

There is no shame in not knowing, only in not wanting to know

Furor Crendraven
Moucho Corporation
#649 - 2017-06-20 19:01:55 UTC
Ravow wrote:
Furor Crendraven wrote:
Does anyone knows how to limit FPS? as Present Interval doesn't seem to work. Thanks Smile


Well, it's broken on my side to.
I'm using it full screen at 4k res, Interval 1 set it to exactly 30 fps, with is not enough and with immediate, I get anything between 75 to 330 and it warm up the room... And something I see tearing as my screen is 60hz.

I say do like me until it's fixed, leave it at interval 1 for station spinning and stuff like hauling and mining but as so as you decide to hot drop on peoples or do some other pvp activities, put it to immediate. Anyway, if your in a fight with lot of stuff and your FPS go to like 58, with a working vsync it would drop to 30 so better to leave immediate for pvp.


No matter what Interval I select I always get the same FPS, I thought that this happened to all Linux users.. so there is no other way to limit FPS?
Ravow
Hell For French
Deep Space Alliance
#650 - 2017-06-21 00:43:48 UTC
Furor Crendraven wrote:
Ravow wrote:
Furor Crendraven wrote:
Does anyone knows how to limit FPS? as Present Interval doesn't seem to work. Thanks Smile


Well, it's broken on my side to.
I'm using it full screen at 4k res, Interval 1 set it to exactly 30 fps, with is not enough and with immediate, I get anything between 75 to 330 and it warm up the room... And something I see tearing as my screen is 60hz.

I say do like me until it's fixed, leave it at interval 1 for station spinning and stuff like hauling and mining but as so as you decide to hot drop on peoples or do some other pvp activities, put it to immediate. Anyway, if your in a fight with lot of stuff and your FPS go to like 58, with a working vsync it would drop to 30 so better to leave immediate for pvp.


No matter what Interval I select I always get the same FPS, I thought that this happened to all Linux users.. so there is no other way to limit FPS?


If your using the normal Wine or Wine with CSMT (Like you have an Nvidia card for example), The bottleneck is the CPU and yes, I think the fps might be more stable (and lower). If your using an decent AMD card and the open source (Mesa) drivers with by the bay, perform now better even with native application again AMD BLOB, and have GALLIUM Nine enabled, the bottleneck become the GPU.

As for the limite, it might be possible to enable the vsync on the driver level. I have the problem with Wine 2.3. I might have a different problem as my vsync work but just set the wrong limit (30fps instead of 60)
Kalestrom Crendraven
Alcoholocaust.
Test Alliance Please Ignore
#651 - 2017-06-21 21:55:17 UTC
The SSL/crypto things get blown away every launcher update it seems :(

Also seconding, how did you figure that one out?
Furor Crendraven
Moucho Corporation
#652 - 2017-06-22 11:58:10 UTC
Ravow wrote:
Furor Crendraven wrote:
Ravow wrote:
Furor Crendraven wrote:
Does anyone knows how to limit FPS? as Present Interval doesn't seem to work. Thanks Smile


Well, it's broken on my side to.
I'm using it full screen at 4k res, Interval 1 set it to exactly 30 fps, with is not enough and with immediate, I get anything between 75 to 330 and it warm up the room... And something I see tearing as my screen is 60hz.

I say do like me until it's fixed, leave it at interval 1 for station spinning and stuff like hauling and mining but as so as you decide to hot drop on peoples or do some other pvp activities, put it to immediate. Anyway, if your in a fight with lot of stuff and your FPS go to like 58, with a working vsync it would drop to 30 so better to leave immediate for pvp.


No matter what Interval I select I always get the same FPS, I thought that this happened to all Linux users.. so there is no other way to limit FPS?


If your using the normal Wine or Wine with CSMT (Like you have an Nvidia card for example), The bottleneck is the CPU and yes, I think the fps might be more stable (and lower). If your using an decent AMD card and the open source (Mesa) drivers with by the bay, perform now better even with native application again AMD BLOB, and have GALLIUM Nine enabled, the bottleneck become the GPU.

As for the limite, it might be possible to enable the vsync on the driver level. I have the problem with Wine 2.3. I might have a different problem as my vsync work but just set the wrong limit (30fps instead of 60)


Yes my problem is about the limit, too much fps all the time, but I am using the default Wine provided by the launcher, I will do more tests with other Wine versions when vacations arrive. Thanks to all for the info, fly safe.
Pierre Desjardins
Caldari Provisions
Caldari State
#653 - 2017-06-26 13:25:04 UTC  |  Edited by: Pierre Desjardins
After today's launcher update, it just hangs after executing evelauncher.sh

*sigh*

EDIT: After updating Manjaro it seems to work.

wtf I love CCP now.
Nako Saisima
Caldari Provisions
Caldari State
#654 - 2017-06-26 14:38:41 UTC
Ailatan wrote:

Solved copying: libssl.so.1.0.2 and libcrypto.so.1.0.2 are in /usr/lib/x86_64linux-gnu/ into launcher folder and renaming them without version.


Many thanks. I needed to install Steam, too.
Roesjka
The Last Solution Inc
#655 - 2017-06-26 14:47:17 UTC  |  Edited by: Roesjka
Have a look at
https://forums.eveonline.com/default.aspx?g=posts&m=6943810#post6943810

I am now running wine-staging 2.9 (wine-staging 2.10 freezes on me when I am playing WoW with DX11).
and running EVEOnline with the tick remove for DX9.

Do note you have to set post-processing to High.
In CQ I see only a black head lol, but I hardly use CQ anyway.
Outside station you might encounter some flickering when looking into a bright sun/star.

You also might have to set the brightness in game higher.

Steam isn't needed for EVEOnline unless you have an subscription via Steam.
The warning you see abt Steam are just warnings nothing else.

Cheers.

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Sabrina Winslow
Galactic Board of Price Equalization
#656 - 2017-06-30 05:48:27 UTC
Launcher broke for me again with most recent update. When running evelauncher.sh, there is no output at all and it seems to just hang.

I've also tried getting it to run under PlayOnLinux which hasn't worked either.

I'll probably spend some time this weekend getting it to run under my own wine instead of the static launcher version. Let me know if anyone has any pointers in the meantime... time for bed.
Gabriel Locke
Aliastra
Gallente Federation
#657 - 2017-06-30 14:17:33 UTC
Just tried this for the first time on Debian. Launcher opened but wouldn't run the game. Installed PlayOnLinux and retried the launcher, everything worked perfectly.

Thanks CCP Snorlax!
Sabrina Winslow
Galactic Board of Price Equalization
#658 - 2017-07-01 01:57:07 UTC
So far I've been trying to get the game to install via PlayOnLinux.

I run Arch and was having an issue initially where the installer would show squares instead of text. I fixed this by following some advice on the Arch wiki, https://bbs.archlinux.org/viewtopic.php?pid=1701938#p1701938

Still having issues with the installer crashing, but it seems like a step in the right direction.
Sabrina Winslow
Galactic Board of Price Equalization
#659 - 2017-07-01 08:07:26 UTC
Posting from mobile.

Still no luck with PlayOnLinux. The game installs without issue but after trying to run it I get an error box indicating an issue with QTWebEngine.exe. Have tried a few different builds of PlayOnLinux and I'm curious how other users got it to work.

Has been almost a week since I've been able to sign-on... I may post some more detailed error logs soon.
Sabrina Winslow
Galactic Board of Price Equalization
#660 - 2017-07-02 01:41:37 UTC
Trying again on my laptop, also running Arch Linux.

Trying the Eve Launcher first before trying PlayOnLinux on this machine. I'm encountering the same issue I have on my desktop using the Eve Launcher.

After running sh -x evelauncher.sh, this is my output:


++ basename evelauncher.sh
++ sed 's,.sh$,,'
+ appname=evelauncher
++ dirname evelauncher.sh
+ dirname=.
+ tmp=
+ '[' . '!=' / ']'
+ dirname=/home/USER/evelauncher/.
+ LD_LIBRARY_PATH=/home/USER/evelauncher/.:
+ export LD_LIBRARY_PATH
+ export QTDIR=/home/USER/evelauncher/.
+ QTDIR=/home/USER/evelauncher/.
+ export QT_PLUGIN_PATH=/home/USER/evelauncher/./plugins
+ QT_PLUGIN_PATH=/home/USER/evelauncher/./plugins
+ /home/USER/evelauncher/./evelauncher


/home/USER/evelauncher is the directory for the evelauncher.

There is no further output- That is the full result of running evelauncher.sh and the process hangs until I kill it.