These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Ships & Modules

 
  • Topic is locked indefinitely.
 

pyfa 1.15.0 (Vanguard)

First post First post First post
Author
Keanu Reeves WthDreadlock
Sebiestor Tribe
Minmatar Republic
#941 - 2015-07-11 22:34:24 UTC
Pyfa isn't calculating missile range rigs stacking correctly. I don't think it has the stacking penalty.

I have a sniper fit that shows the range in Pyfa as 232km, but the actual all 5s range is 196km. Right now in-game and EFT ranges agree with each other with multiple guidance and missile range rigs but Pyfa shows too much range.
Kadesh Priestess
This Game Is Terrible
Warlords of the Deep
#942 - 2015-07-11 23:14:32 UTC
Missile flight time rigs indeed were not penalized. Fix will be available next build.
Caleb Seremshur
Naked Oiled Bodybuilders
Parasitic Legion.
#943 - 2015-07-12 08:56:25 UTC
Can't load or use MGC and MGE?
Hix Ra
Syndicate Enterprise
Test Alliance Please Ignore
#944 - 2015-07-12 15:47:46 UTC
I'm using Windows 7 64 and just updated from carnyx to the successive aegis releases for pyfa. I was testing to see how the new missile guidance computers and enhancers worked. However, when I go down to the Weapon Upgrades tree and click the "plus" to expand the tree, nothing is shown in the field where the modules show up. I click on the Missile Guidance Computer and Missile Guidance Enhancers (just like you would to see the modules in a group) and still nothing shows up.

I've deleted and downloaded the releases again to see if that could be an issue and it wasn't. I dont have any previous installs of pyfa, other than carnyx and aegis, as I recently re-installed my OS.

Is anyone else seeing this issue?

http://imgur.com/T7bTaVO
Mari Sinn
Balanced Industries
#945 - 2015-07-14 16:26:13 UTC  |  Edited by: Mari Sinn
Hix Ra wrote:
I'm using Windows 7 64 and just updated from carnyx to the successive aegis releases for pyfa. I was testing to see how the new missile guidance computers and enhancers worked. However, when I go down to the Weapon Upgrades tree and click the "plus" to expand the tree, nothing is shown in the field where the modules show up. I click on the Missile Guidance Computer and Missile Guidance Enhancers (just like you would to see the modules in a group) and still nothing shows up.

I've deleted and downloaded the releases again to see if that could be an issue and it wasn't. I dont have any previous installs of pyfa, other than carnyx and aegis, as I recently re-installed my OS.

Is anyone else seeing this issue?

http://imgur.com/T7bTaVO


I'm having the same issue.

My error log that I just found with the 1.13.3 client.

"2015-07-14 11:17:31,434 root INFO Starting pyfa
2015-07-14 11:17:58,296 service.fit DEBUG ==========recalc==========
2015-07-14 11:17:58,358 eos.saveddata.fit DEBUG Starting fit calculation on: 1 Orthrus PVE (Orthrus)
2015-07-14 11:17:59,295 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: early - 936.00ms (936.00ms elapsed)
2015-07-14 11:17:59,342 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: normal - 47.00ms (983.00ms elapsed)
2015-07-14 11:17:59,342 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: late - 0.00ms (983.00ms elapsed)
2015-07-14 11:17:59,342 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with fit calculation - 0.00ms (983.00ms elapsed)
2015-07-14 11:17:59,372 STDOUT INFO Not projected, getting projected fits
2015-07-14 11:17:59,372 service.fit DEBUG ==========recalc==========
2015-07-14 11:17:59,372 eos.saveddata.fit DEBUG Starting fit calculation on: 1 Orthrus PVE (Orthrus)
2015-07-14 11:17:59,388 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: early - 16.00ms (16.00ms elapsed)
2015-07-14 11:17:59,388 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: normal - 0.00ms (16.00ms elapsed)
2015-07-14 11:17:59,404 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: late - 15.00ms (31.00ms elapsed)
2015-07-14 11:17:59,404 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with fit calculation - 0.00ms (31.00ms elapsed)
2015-07-14 11:17:59,497 service.fit DEBUG ==========recalc==========
2015-07-14 11:17:59,513 eos.saveddata.fit DEBUG Starting fit calculation on: 1 Orthrus PVE (Orthrus)
2015-07-14 11:17:59,513 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: early - 0.00ms (0.00ms elapsed)
2015-07-14 11:17:59,545 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: normal - 32.00ms (32.00ms elapsed)
2015-07-14 11:17:59,545 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with runtime: late - 0.00ms (32.00ms elapsed)
2015-07-14 11:17:59,545 eos.saveddata.fit DEBUG Timer - Fit: 1, Orthrus PVE - Done with fit calculation - 0.00ms (32.00ms elapsed)
2015-07-14 11:18:10,246 STDOUT INFO Missing icon file: icon.png"
Sargon Matrix
Perkone
Caldari State
#946 - 2015-07-15 00:09:34 UTC
Kinda hard to fit Missile Guidance modules with the current release...Roll
xXxNIMRODxXx
Enlightened Industries
Goonswarm Federation
#947 - 2015-07-16 03:43:55 UTC  |  Edited by: xXxNIMRODxXx
http://i.imgur.com/JovJR8L.jpg

Not the first time that, when there are new modules in pyfa, something gets screwed..
It was like that also in the the beta release prior this "official" one, strange you didn't notice.

Please fix it if you can.

edit:
Mari Sinn wrote:
Shadrissa wrote:
Do you people not read the release notes? For the v1.13.1 release, which is included in the v1.13.2 description:

Quote:
Note: Missile Guidance Computers / Enhancers have an empty market group. This seems to be an issue with the EVE data, and will most likely be fixed with the next expansion. The modules are located in the Tracking Computers / Enhancers group (see #319)


And then it links you to the issue itself: https://github.com/DarkFenX/Pyfa/issues/319

Like, this is the whole purpose of release notes. I wonder how many people downloaded the recent beta release thinking it was a new version because they didn't read anything. It was CCP's problem with the market tree when they first released the expansion. pyfa simply scrapes the data the client provides.

Anyway, great program! Keep it up you guys!


Yes, I eventually found and read the release notes, and used them to add the missile guidance module to my build.



I am an idiot and i don't know how i missed this..
Shadrissa
Hedion University
Amarr Empire
#948 - 2015-07-16 05:05:27 UTC
Do you people not read the release notes? For the v1.13.1 release, which is included in the v1.13.2 description:

Quote:
Note: Missile Guidance Computers / Enhancers have an empty market group. This seems to be an issue with the EVE data, and will most likely be fixed with the next expansion. The modules are located in the Tracking Computers / Enhancers group (see #319)


And then it links you to the issue itself: https://github.com/DarkFenX/Pyfa/issues/319

Like, this is the whole purpose of release notes. I wonder how many people downloaded the recent beta release thinking it was a new version because they didn't read anything. It was CCP's problem with the market tree when they first released the expansion. pyfa simply scrapes the data the client provides.

Anyway, great program! Keep it up you guys!
Shadrissa
Hedion University
Amarr Empire
#949 - 2015-07-16 05:10:30 UTC
Scott Ormands wrote:
Is it possible to get ship mass added to the "Targeting & Misc" section?


Mass is already easily accessible. Hover over the align time; the tooltip include the mass. I think it's a recent addition within the last 6mo or so?
Arcos Vandymion
Ministry of War
Amarr Empire
#950 - 2015-07-16 10:39:15 UTC  |  Edited by: Arcos Vandymion
I can't seem to get the Tactical Mode to work - most noticeable on a T2 Beam Confessor fit with Aurora. Range should be, pi times thumb, around 50km - Focused Beam S, Aurora, no TE / TC / Locus; in sharpshooter mode ('bout 30 plus two thirds of 'bout 30 should come out at around 50-ish).
Mari Sinn
Balanced Industries
#951 - 2015-07-16 18:19:12 UTC  |  Edited by: Mari Sinn
Shadrissa wrote:
Do you people not read the release notes? For the v1.13.1 release, which is included in the v1.13.2 description:

Quote:
Note: Missile Guidance Computers / Enhancers have an empty market group. This seems to be an issue with the EVE data, and will most likely be fixed with the next expansion. The modules are located in the Tracking Computers / Enhancers group (see #319)


And then it links you to the issue itself: https://github.com/DarkFenX/Pyfa/issues/319

Like, this is the whole purpose of release notes. I wonder how many people downloaded the recent beta release thinking it was a new version because they didn't read anything. It was CCP's problem with the market tree when they first released the expansion. pyfa simply scrapes the data the client provides.

Anyway, great program! Keep it up you guys!


Yes, I eventually found and read the release notes, and used them to add the missile guidance module to my build.
Arcos Vandymion
Ministry of War
Amarr Empire
#952 - 2015-07-21 08:20:43 UTC  |  Edited by: Arcos Vandymion
Here's only some random things I found while messing around with

1.13.3

  • "Copy" fit seems broken (does nothing)
  • graphing seems broken (does nothing), get basically the same error as Torgeir below
  • "Back" behaves weirdly - it sends you to ship groups (to "Ship Groups" from say "Svipul") from a list of ship fittings if you just created a new fitting. However upon revisiting all the fits for a hull "Back" behaves as it should and sends you back to the market group (say to Tactical Destroyers when viewing Svipuls)
  • the tactical modes still don't do anything for the numbers



Traceback (most recent call last):
File "\pyfa\.\gui\mainFrame.py", line 703, in openGraphFrame
     self.graphFrame = GraphFrame(self)
File "\pyfa\.\gui\graphFrame.py", line 76, in __init__
     self.fitList.fitList.update(self.fits)
File "\pyfa\.\gui\display.py", line 298, in update
      self.refresh(stuff)
File "\pyfa\.\gui\display.py", line 250, in refresh
      newText = col.getText(st)
File "\pyfa\.\gui\builtinViewColumns\baseName.py", line 46, in getText
      return "%dx %s (%s)" % (stuff.getProjectionInfo(fitID).amount, stuff.name, stuff.ship.item.name)
AttributeError
:
'NoneType' object has no attribute 'amount'
Torgeir Hekard
I MYSELF AND ME
#953 - 2015-07-21 11:31:52 UTC
Damage graphs are broken in 1.13.3. That is, they don't open.

I'm getting this:

Traceback (most recent call last):
  File "/home/infine/pyfa-git/Pyfa/gui/mainFrame.py", line 703, in openGraphFrame
    self.graphFrame = GraphFrame(self)
  File "/home/infine/pyfa-git/Pyfa/gui/graphFrame.py", line 76, in __init__
    self.fitList.fitList.update(self.fits)
  File "/home/infine/pyfa-git/Pyfa/gui/display.py", line 298, in update
    self.refresh(stuff)
  File "/home/infine/pyfa-git/Pyfa/gui/display.py", line 250, in refresh
    newText = col.getText(st)
  File "/home/infine/pyfa-git/Pyfa/gui/builtinViewColumns/baseName.py", line 46, in getText
    return "%dx %s (%s)" % (stuff.getProjectionInfo(fitID).amount, stuff.name, stuff.ship.item.name)
AttributeError: 'NoneType' object has no attribute 'amount'
Sniper Smith
Center for Advanced Studies
Gallente Federation
#954 - 2015-07-23 07:24:29 UTC
First, love this program, it's awesome :)

Second, where are the fits saved? I ask because I recently replaced my HDD, and only copied the app folder. When I opened it up again on the fresh install, all my previously saved fits were gone. I still have the old HDD, so if I knew where they were I could copy over the db and keep moving forward without missing a beat :)

Thanks
Athos warrior
Doomheim
#955 - 2015-07-24 02:07:59 UTC  |  Edited by: Athos warrior
found my problem was the beta build vs the aegis build so far things appear to be working with the aegis build.
Toric Xeno
The Scope
Gallente Federation
#956 - 2015-07-27 06:45:13 UTC
PYFA for OSX does not seem to want to access the clipboard when importing fits. i verified EVE was copying the fit to the clipboard, but neither control v, command v, or the edit->from clipboard does anything. nothing to strange in the log, but ill try to post it anyway later tomorrow.
Saybre Ruenshield
The Scope
Gallente Federation
#957 - 2015-07-27 17:17:46 UTC
Is there anyway currently to import a fitting with modules in cargo to the game?
I've tried the copyboard and the .xml method both, and neither worked
Kara Anders
Spartan Vanguard
Test Alliance Please Ignore
#958 - 2015-08-01 03:10:58 UTC
Noted a rather large discrepancy between PYFA and In-game given stats. Notes about this:. Svipul in defensive mode. Build pictures below to show that they are the same equipment.





PYFA Game
EM 68% 78%
Therm 74% 60%
Kin 88% 81%
Exp 78% 66%


Ingame:
http://i1094.photobucket.com/albums/i457/BVickery74/2015.08.01.02.53.47_zpschukixvy.png

From PYFA
http://i1094.photobucket.com/albums/i457/BVickery74/Screenshot%201_zps1fksoiai.png
Arcos Vandymion
Ministry of War
Amarr Empire
#959 - 2015-08-02 10:01:44 UTC
Kara Anders wrote:
Noted a rather large discrepancy between PYFA and In-game given stats.


See above posts of mine - the modes don't do anything yet*. The general lack of any change in any number at all upon switching between the three modes; no change in range for sniper- and no change for speed in speed-mode.

I recon one could look up the description on how to create modules for PYFA (there was one floating around for the then unreleased Bastion), add a random slot for te tactical and work around this way; or wait for the fix... which might stillt ake a while as I can't see any issues for that on the github page.



*though I recon I haven't fully reinstalled and deleted the cache... might be a local thing... gonna check that later.
Warderbrad
Caldari Provisions
Caldari State
#960 - 2015-08-13 23:42:38 UTC
I keep having an issue where it automatically changes the character it is using from my imported character to the All 5 character. Is there a way to prevent this, or if not is there a way to remove the all 0 and all 5 characters so it has no other option but to use my character?