These forums have been archived and are now read-only.

The new forums are live and can be found at

Ships & Modules

  • Topic is locked indefinitely.

pyfa 1.15.0 (Vanguard)

First post First post First post
Soel Reit
The Scope
Gallente Federation
#981 - 2015-10-04 07:09:45 UTC
Kasimir Wulf wrote:
Soel Reit wrote:
First of all, thank you for this awesome program.
i found it more complete respect ETF.

That's said, can i suggest you a feature?
When you have your ship full equipped it would be nice to know the cap when only certain modules are active.
Right now it show the total cap amount (positive or negative, and it tell you the time left on the cap.)

I mean: i'm in a data site's ship with certain modules fitted --> i get ganked --> i'll shut down the data analyzer and turn on other modules to defend myself.

right now the program take in considerations the cap needed for all the modules. The only way around to know the real cap when i'm defendig myself is to unfit the modules that will be shut down (in this case the data analyzer).
A "right click" option --> "Shut down this module" would be a nice feature in my opinion.

Thanks for your hard work and sorry for my english.

Soel Reit

if you look at the module, see where the check mark is next to it? if you click that, it'll turn the module off. you can even offline rigs/passive modules without having to remove them from the fit. active modules you'll have to take off the fit for example MWD's to remove the cap penalty if you say offline it or burn it out.

thank you :) didn't noticed, my bad!
Hedion University
Amarr Empire
#982 - 2015-10-04 15:24:06 UTC
Just wanted to ask a question in regards to to projected effects of the program..

I just downloaded the program and hoping to switch from EFT but I have found a major issue.
When dropping a projected effect onto the ship like remote cap or remote armour I can not do this from the modules directly on the ship. I can however drag and drop the module from the market bar but if I do that I don't get the bonuses from skills and that cause incorrect information.

Am I doing something wrong or is this a bug.. Don't really know as this is the way I did it with EFT so that way I don't have to create 2 ships as complete copies to find out the result.

Loving the program so far though, awesome work...

Leto Anthar
Imperial Shipment
Amarr Empire
#983 - 2015-10-05 02:13:59 UTC  |  Edited by: Leto Anthar
Love this tool a lot! Sadly, when I recently tried to create a new character in pyfa, it does not allow me to click "Create" button or "Rename" button when renaming. Screenshot.
Clicking "OK" will result in pyfa window quickly disappearing and appearing (less than 1 second flicker) and creating a new character with a name "New Character" regardless of the name I typed in the Character Editor.

I'm using pyfa "1.15.0 Stable - Vanguard 1.0" on Windows 7 64-bit, tried reinstalling the tool and removing the .pyfa folder, didn't help. I think it's worth noting that my OS language is set to Russian, as I know Python sometimes has problems with Cyrillic character encoding on Windows.

Am I missing something? Last time I tried creating new characters in pyfa was several releases ago (on exactly the same PC & OS) and I'm sure it had no issues that time.

EDIT: Seems like all I needed to do was press Enter when cursor is in the name text field when in character creation window.
The Last Solution Inc
#984 - 2015-10-11 19:03:29 UTC
I am running Debian jessie amd64.

PyFA 1.11.1-wx3 works great for me, but when I try to run PyFA 1.15.0 I get the following error:

wxPython 2.8 not found; attempting to use newer version, expect errors
Traceback (most recent call last):
File "./", line 82, in -module-
import wx
ImportError: No module named wx

I know it is because wxPyhton 2.8 is not installed.
Besides installing 2.8, any workaround available?



Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Phoenix Geganius
State War Academy
Caldari State
#985 - 2015-10-16 19:41:57 UTC  |  Edited by: Phoenix Geganius
Hello, I have problem in Pyfa. Can`t set name for new character profile. It is "New character" always. Can`t rename.

UPD. Pressing "Enter" helped.
Oma Lorche
Stay Frosty.
A Band Apart.
#986 - 2015-10-19 16:02:57 UTC
Is that possible to have list of implants which stays with character so I dont have to look for them with every new fit?
Apart of that I love it. Better then EFT IMO.
Brutor Tribe
Minmatar Republic
#987 - 2015-10-22 19:05:32 UTC
Small feat request (unless I missed such option somewhere):

Ability to keep module stats window permanently open and more or less docked instead of floating, automatically reacting to any module highlighted (similarly as it is possible in EFT).

Jita Flipping Inc.: Kovl & Kuvl

#988 - 2015-10-22 21:01:48 UTC
How do you handle export/import in OS X?
Max Reborn
Dancing Pistols
LowSechnaya Sholupen
#989 - 2015-10-26 11:06:07 UTC
Pyfa on Mac OS X El Capitan crashes on start
Acidcop Shardani
Hoplite Brigade
#990 - 2015-10-26 20:26:55 UTC
Pyfa runs like a charm on OS X El Capitan on my trouble what so ever...
#991 - 2015-10-30 14:57:54 UTC
as citadels will be set up the same as ships are there any plans to include citadel fitting in pyfa?
Uranus Intruders
#992 - 2015-10-30 22:50:16 UTC
Pyfa don't run well in El Capitan OS X. Crash, and i can't fetch char, "urlerror SSL.....
Hectoor Kronksa
Republic University
Minmatar Republic
#993 - 2015-11-03 06:23:36 UTC
Hey all! I switched from EFT to Pyfa and so far I've been thrilled. However, recently I noticed some discrepancies between the Capacitor Throughput I was getting in Pyfa and what I would get in the Eve fitting tool itself. Pyfa would say I was stable, Eve would disagree and say I'd run out in 1:30. I poured over the description for the modules in both Eve and Pyfa and all were identical.

But then I realized Capacitor Throughput is in GJ/s (Giga Joules?) and the only power statistic for modules is in MW (megawatts?) Where is the consumption statistic for powered modules coming from? I found the Capacitor Total under the ship description in GJ and the time to recharge, but nowhere have I seen rate of consumption by modules.

It appears there may be a difference between how Pyfa and Eve are calculating this total. Thanks!

PS. My fitting was for a Cheetah for individual use (no boosters, no bonuses).
Dr Minx
#994 - 2015-11-03 14:17:08 UTC  |  Edited by: Dr Minx
just downloaded pyfa version Parallax - v1.16.0, i can not create a new character, the last stage of clicking "ok" once done all the api stuff does not work for me

ignore fixed it now
#995 - 2015-11-03 15:26:33 UTC  |  Edited by: Haffsol
Dr Minx wrote:
just downloaded pyfa version Parallax - v1.16.0, i can not create a new character, the last stage of clicking "ok" once done all the api stuff does not work for me

ignore fixed it now

edit: fixed mine too, I had a ghost instance of pyfa running in the background so things weren't updated on the active one P
Praetorian Mining Group
#996 - 2015-11-03 19:00:15 UTC
Whoever decided it was a good idea to assign "attributes editor" to CTRL+A needs to rethink that.

Typing an item in the market search bar, then pushing CTRL+A to select what has been typed and delete it, now opens up a window.

How can I fix this?

weeeeEEEEEEEEEE are never ever ever!

Hectoor Kronksa
Republic University
Minmatar Republic
#997 - 2015-11-03 19:55:37 UTC
Hectoor Kronksa wrote:

It appears there may be a difference between how Pyfa and Eve are calculating this total.

I am totally wrong. I misunderstood the differences between active and online.

Pyfa is fine. Maybe if there is a way to filter my ship modules by slots? Sometimes I have an empty Med slot and just can't decide what to fit there, and it would be great to limit my list to only that slot.

Someone please tell me this is already in Pyfa too and I just overlooked it. Thanks!

Atlantian Laboratories
#998 - 2015-11-03 20:28:44 UTC
few observations from the recent update.

Cant close character editor window at all. either by hitting ok or the X (two pcs have the same issue)

Can a confirm prompt be added to the character delete bit? with those two crosses so close together its quite easy for an absent minded click to delete a character


Jimmy Mallmann
Deep Core Mining Inc.
Caldari State
#999 - 2015-11-04 12:52:55 UTC
OSX Yosemite and El Capitain is not working
Kimimaro Yoga
School of Applied Knowledge
Caldari State
#1000 - 2015-11-04 13:09:46 UTC  |  Edited by: Kimimaro Yoga
Ugh, I don't have a github account, going to post two small issues here.
First is that version 1.16.0 wouldn't open for me, similar issue to Issue #395 on github. Only in my case the last few lines of Console look like this:
Nov  4 20:44:55 TheOctoBeast [0x0-0x144144].org.evefit.pya[5431]:   File "wx/_core_.pyc", line 10, in __load
Nov  4 20:44:55 TheOctoBeast [0x0-0x144144].org.evefit.pya[5431]: ImportError: dlopen(/Applications/, 2): Library not loaded: /System/Library/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
Nov  4 20:44:55 TheOctoBeast [0x0-0x144144].org.evefit.pya[5431]:   Referenced from: /Applications/
Nov  4 20:44:55 TheOctoBeast [0x0-0x144144].org.evefit.pya[5431]:   Reason: image not found
Nov  4 20:44:55 TheOctoBeast pyfa[5431]: pyfa Error

The bad new is that the library in question doesn't exist because /System/Library/Frameworks does not contain a folder named CoreGraphics.framework. Oops. The good news is that the problem went away once I downloaded the regular version of 1.16.1. And then, the more bad news is that the same error occurs when I tried 1.16.1 the wx3 version. Clearly wx3 has a problem with my OS.

Now with 16.1 I get a rather minor error in the console:
"pyfa[5738]: CFURLCreateWithString was passed this invalid URL string: '/System/Library/CoreServices/CommonCocoaPanels.bundle' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead."

Seems like that should be a straightforward fix. :)

Edit: Running 10.7.5 on an old Mac Pro.

Now recruiting: