These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
 

Update to the Launcher and the repair tool - Fix inside!

First post First post
Author
Arcana Mortis
Kybernauts
#601 - 2015-03-25 04:21:43 UTC
So last night I downloaded the update, and all was well. Got into the game etc etc...everything was just dandy!

Then I decided to relog, and all is decidedly NOT well. The launcher refuses to acknowledge that I am connected to the Internet. The client woks just fine if I use the .exe file in the bins folder (which tip I found here on this thread, thanks) but the launcher is dead in the water.

http://imgur.com/3joFaVf

Have a look at that - doesn't the irony just KILL you? Also, I've just gotten used to using the launcher and I would like it fixed now please.
Daddy Thundercock
Sebiestor Tribe
Minmatar Republic
#602 - 2015-03-25 04:29:26 UTC
I found a workaround for the stuck "downloading launcher update" issue some have been experiencing. It may (or may not) help with other issues too. Either way it's worth a shot should all else fail.

The downside is that it requires you have a test server install laying around, otherwise your boned.

You can see the details of what I did, etc, on this thread:

https://forums.eveonline.com/default.aspx?g=posts&m=5611477#post5611477

hope that it helps someone. Maybe the devs can use this information to fix this for those without test server installs, or just simply to make the launcher work as it should on a game we all pay monthly to pay....Roll
Kira Talfase
Dirty sexy money
#603 - 2015-03-25 09:02:14 UTC  |  Edited by: Kira Talfase
Post an official update when you're able to un-**** your launcher.

I've reinstalled windows after wiping my ssd, losing over 180gb of games and data, all for you. I've completely re-updated Win7, set my box up properly and now I get a running process with nothing happening.

Thanks, so much.


Time spent trying to get this working : 10 hours+
CCP Atropos
C C P
C C P Alliance
#604 - 2015-03-25 09:45:46 UTC
Arcana Mortis wrote:
So last night I downloaded the update, and all was well. Got into the game etc etc...everything was just dandy!

Then I decided to relog, and all is decidedly NOT well. The launcher refuses to acknowledge that I am connected to the Internet. The client woks just fine if I use the .exe file in the bins folder (which tip I found here on this thread, thanks) but the launcher is dead in the water.

http://imgur.com/3joFaVf

Have a look at that - doesn't the irony just KILL you? Also, I've just gotten used to using the launcher and I would like it fixed now please.

That's because you're continually starting the older EVE Launcher (2.2.859950) probably because you've pinned it to your task bar. That version has been half updated to the newer, download-on-demand capable version, and thus the certificates used to connect to the server have been moved and that connection can't be validated.

Try running eve.exe directly, and if that doesn't fail, reinstall just the EVE Launcher from here: http://cdn1.eveonline.com/EveOnlineLauncher/release/EVEOnlineLauncher_2_2_871481.exe
manijak
P.E.K
The Army of Mango Alliance
#605 - 2015-03-25 14:15:49 UTC
Kira Talfase wrote:
Post an official update when you're able to un-**** your launcher.

I've reinstalled windows after wiping my ssd, losing over 180gb of games and data, all for you. I've completely re-updated Win7, set my box up properly and now I get a running process with nothing happening.

Thanks, so much.


Time spent trying to get this working : 10 hours+



Iv got the same thing,only difrent is time spent on " fixing" game,and still wont work,after xxx times i did new instalation,and downloaded full game client again !
Vaneel Tremurn
Mechanical Basterds
#606 - 2015-03-25 17:38:49 UTC
Had the same issue, Un-Pinning the launcher and reinstalling it fixed the problem for me.

CCP, I'd suggest putting a link to the launcher reinstall somewhere in the launcher itself. Having to look in a 3 year old forum thread to find the solution to this morning's new problem is not exactly straight-forward.





Launcher can be reinstalled from

http://cdn1.eveonline.com/EveOnlineLauncher/release/EVEOnlineLauncher_2_2_871481.exe
Kira Talfase
Dirty sexy money
#607 - 2015-03-25 19:04:55 UTC  |  Edited by: Kira Talfase
Uninstalled and reinstalled directX and. Net framework along with video drivers, am able to log in now.


Hope it helps someone else.
Daddy Thundercock
Sebiestor Tribe
Minmatar Republic
#608 - 2015-03-25 23:27:31 UTC  |  Edited by: Daddy Thundercock
Kira Talfase wrote:
Im losing patience.

Does anyone have any suggestions to getting this game to run after a fresh install of windows AND the launcher / repair tool / etc.

I get the exefile running but nothing happens.... (shortened because the forums told me to do so) .......The launcher says my computer only supports Directx 9.0... but I sat there and watched it install Directx 11. I ran the installer KB and still the launcher says I don't have it? SO many problems, Im not sure this is all worth the time and effort. I'm losing patience.


nevermind, I just saw that you fixed it. Post mostly deleted.
Treyah
Sebiestor Tribe
Minmatar Republic
#609 - 2015-03-26 01:23:10 UTC
The broken patcher / connectivity issues are starting to grow old. Seriously, I don't want to sit down and work IT every dang patch...Evil
Kira Talfase
Dirty sexy money
#610 - 2015-03-27 02:27:31 UTC  |  Edited by: Kira Talfase
Treyah wrote:
The broken patcher / connectivity issues are starting to grow old. Seriously, I don't want to sit down and work IT every dang patch...Evil



Yea, Ive been dealing with it for 3 days now myself. I'm able to get in the game ONLY if I run the launcher as an administrator and every single time I relog I lose my entire overview/UI/shortcut settings. Everything.


If I run it normally I get this giant popup window that says "exception" with a long string on HTML that I'm not allowed to post here on the forums.


*** EDIT*** I have found the fix for the particular issue I was having above. I found the CCP folder within Program Data and went to Properties>Security>Edit> And set it to allow everything for "users". I can log in normally now, and the UI (etc) saves upon relogging. ***EDIT***

Pretty crazy that just by experimenting I was able to fix this.. I know ****-all about computers, but at least its working I guess. Hopefully its not a bad idea doing what I did.


However, still there is NO eve game registered in my programs lists under control panel, no EVE shown under start menu, Launcher for eve did not auto install to my desktop, and I had to dig around on my C drive to get a shortcut placed. I'm scared to run the repair tool because for the past 2 days, everytime I did.. it deleted the entire game and made me download the 7GB again, and again, and again.
Ellariona
B52 Bombers
#611 - 2015-03-29 17:56:20 UTC  |  Edited by: Ellariona
- nvm -
Damryn
Black Night Industries
BORE
#612 - 2015-04-02 07:02:39 UTC
I am still having the launcher freeze problem every time a new patch is sent out. Ever since the new downloader came out I have been having a lot of problems. I can get it to work by re downloading everything, "repair tool" etc, but it keeps happening. Evil
Nihilaus Vause
Stay Frosty.
A Band Apart.
#613 - 2015-04-14 17:50:04 UTC
Yup.
Every. Single. Time.

I just go play something else whilst I wait the hours or whatever it takes the launcher to work out what the hell is going on.

Treyah
Sebiestor Tribe
Minmatar Republic
#614 - 2015-04-15 01:00:07 UTC
CCP -- WHY DOES YOUR LAUNCHER ALWAYS, ALWAYS BREAK? Seriously ... 10 minutes stuck at 1.9%?

I 'know' I'm not the only one. #NoServiceFromFlorida!

Sand Gaara
Doomheim
#615 - 2015-04-15 19:25:53 UTC
Just came home and patched the client, press play and nothing happens. Updated the drivers, cleared the chache, ran repair tool - nothing. eve exe runs in process manager. any ideas?
Grandal Malabayn
EVE University
Ivy League
#616 - 2015-04-15 23:39:37 UTC
Same thing in south Georgia, I am thinking the ISPs are doing some kind of tragic shaping down here or one of the local EVE servers (Georgia Tech?) is unreliable.

Repair client is CRAWLING at 176 B /s... yes that is Bytes per second.

Treyah wrote:
CCP -- WHY DOES YOUR LAUNCHER ALWAYS, ALWAYS BREAK? Seriously ... 10 minutes stuck at 1.9%?

I 'know' I'm not the only one. #NoServiceFromFlorida!

Martzel Viteri
CCT Industrial Group
#617 - 2015-04-19 17:14:10 UTC  |  Edited by: Martzel Viteri
Just throwing my comment in for the head count. Same problems as all of the above.

Location: Alberta, Canada
ISP: Telus
Halets Thellere
The Scope
Gallente Federation
#618 - 2015-04-20 00:10:12 UTC
Grandal Malabayn wrote:
Same thing in south Georgia, I am thinking the ISPs are doing some kind of tragic shaping down here or one of the local EVE servers (Georgia Tech?) is unreliable.

Repair client is CRAWLING at 176 B /s... yes that is Bytes per second.

Treyah wrote:
CCP -- WHY DOES YOUR LAUNCHER ALWAYS, ALWAYS BREAK? Seriously ... 10 minutes stuck at 1.9%?

I 'know' I'm not the only one. #NoServiceFromFlorida!




Alabama here. If you have mediacom that might ("might") be it.
Terramort Suiadan
The Scope
Gallente Federation
#619 - 2015-04-20 19:31:21 UTC
Oregon here, also being royally screwed by EVE. Launcher won't work and takes forever to download the patch (as in, 8 hours). Before I could at least play a few hours by wiping an reinstalling, waiting for the patch, then playing. Now however the patch won't finish (got stuck at 90%) and I'm quite frustrated. I paid my sub the day before all this started happening, have lost about 12 hours of skill training, and am frankly feeling like starting EVE was a mistake.

Every work around I can think of has been stopped by you at CCP as if you want players to have huge headaches while trying to play your game - why did you remove manual patch support? At least then I could try to login more than once every EIGHT HOURS. Why does the repair tool patch to the PREVIOUS version of the launcher and force the update to download all over again? People tell me EVE is over 10 years old - I find this almost hard to believe with the level of incompetency going on.
Natasha Veritas
Doomheim
#620 - 2015-04-21 13:33:04 UTC
Feeling fooled Evil

Just download the fix and get trapped in a download from 7.5 GB, dear CCP, this is bullshit Twisted