These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Ships & Modules

 
  • Topic is locked indefinitely.
 

pyfa 1.15.0 (Vanguard)

First post First post First post
Author
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#421 - 2014-05-28 20:51:59 UTC
Aiwha wrote:
Do you plan a pre-release for Kronos data or will you be updating everything once Kronos releases?


Kadesh is currently working on Kronos release. Whether or not it is ready before Kronos releases I cannot say. The update process is long and annoying, requiring a bit of manual work. If it's not ready before, it should be available soon after.
Lothros Andastar
The Scope
Gallente Federation
#422 - 2014-06-01 15:33:57 UTC
More dumb demands requests.

Any chance of a setting to limit pyfa to 1 instance? I keep opening about 2319782139678312 instances of the thing. :3
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#423 - 2014-06-01 16:31:58 UTC
Lothros Andastar wrote:
More dumb demands requests.

Any chance of a setting to limit pyfa to 1 instance? I keep opening about 2319782139678312 instances of the thing. :3


How do you accomplish this? I think I may, every now and then, open 2 instances by accident, in which case I just close one. >_>
Rammix
TheMurk
#424 - 2014-06-01 17:24:53 UTC  |  Edited by: Rammix
Somehow the right side of the window (where the stats are) became more narrow for me, some numbers don't fit in.

OpenSUSE Leap 42.1, wine >1.9

Covert cyno in highsec: https://forums.eveonline.com/default.aspx?g=posts&t=296129&find=unread

Rammix
TheMurk
#425 - 2014-06-01 17:30:39 UTC
+ one request: please divide the high/med/low slot groups with a horizontal line or some empty space. Colouring them isn't so comfortable.

OpenSUSE Leap 42.1, wine >1.9

Covert cyno in highsec: https://forums.eveonline.com/default.aspx?g=posts&t=296129&find=unread

Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#426 - 2014-06-01 18:42:50 UTC
Rammix wrote:
Somehow the right side of the window (where the stats are) became more narrow for me, some numbers don't fit in.


Need more info with screenshot, along with OS information

About the rack separation, it's coming with the Kronos release
Admiral Gray Beard
Hedion University
Amarr Empire
#427 - 2014-06-01 22:17:58 UTC
When attempting to add charges to projectile weapons, I don't have any short range ammo available...

No Short Range Ammo Available
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#428 - 2014-06-01 22:48:48 UTC
Admiral Gray Beard wrote:
When attempting to add charges to projectile weapons, I don't have any short range ammo available...

No Short Range Ammo Available


It's available. It's under "Orbital EMP S"

Yes, this is a bug, and yes this has been fixed internally. Next release is with Kronos.
Kalliea Aeterna
Sebiestor Tribe
Minmatar Republic
#429 - 2014-06-03 08:45:56 UTC  |  Edited by: Kalliea Aeterna
I have a problem trying to load the ships tab. I first select the ship type (eg. Exhumers). It then shows me how many fits for each ship but when I select the ship type nothing happens.
It does not view the fit or anything. My ships tab is then broken and no longer responds to anything.
This started happening after I upgraded to 1.1.22 from 1.1.18.
Pyfa was installed to a different directory.
I have un-installed and re-installed without any success.
Rammix
TheMurk
#430 - 2014-06-03 10:35:40 UTC
Sable Blitzmann wrote:
Rammix wrote:
Somehow the right side of the window (where the stats are) became more narrow for me, some numbers don't fit in.


Need more info with screenshot, along with OS information

Screenshot with some random fitting: http://i.imgur.com/G9vqPx6.png (the right edge of the "Targeting & Misc" section).
OS: openSUSE 13.1 x64, kernel 3.11.10-11-desktop, KDE 4.11.5, DPI 114.


And, if it's not too time-consuming, please make the lower-left section (where we pick specific modules) remember its height. Usually it needs less space than the section above it.

OpenSUSE Leap 42.1, wine >1.9

Covert cyno in highsec: https://forums.eveonline.com/default.aspx?g=posts&t=296129&find=unread

Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#431 - 2014-06-03 14:42:52 UTC
Kalliea Aeterna wrote:
I have a problem trying to load the ships tab. I first select the ship type (eg. Exhumers). It then shows me how many fits for each ship but when I select the ship type nothing happens.
It does not view the fit or anything. My ships tab is then broken and no longer responds to anything.
This started happening after I upgraded to 1.1.22 from 1.1.18.
Pyfa was installed to a different directory.
I have un-installed and re-installed without any success.


This sounds like it could be database corruption. Please upload saveddata.db (in your ~/.pyfa/ directory) somewhere and send me the link to this file via eve mail so I can take a look.

Rammix wrote:
Sable Blitzmann wrote:
Rammix wrote:
Somehow the right side of the window (where the stats are) became more narrow for me, some numbers don't fit in.


Need more info with screenshot, along with OS information

Screenshot with some random fitting: http://i.imgur.com/G9vqPx6.png (the right edge of the "Targeting & Misc" section).
OS: openSUSE 13.1 x64, kernel 3.11.10-11-desktop, KDE 4.11.5, DPI 114.


And, if it's not too time-consuming, please make the lower-left section (where we pick specific modules) remember its height. Usually it needs less space than the section above it.


I was just talking to Kadesh about spacing on Linux platforms yesterday. It's difficult to figure out a best fit that works everywhere as linux can have many themes depending on distribution / gtk version. I'll take a look at it.
Lucius Regni
1Bitcoin
#432 - 2014-06-03 16:30:49 UTC
I'm looking forward to the Kronos release :)
Antillie Sa'Kan
Imperial Shipment
Amarr Empire
#433 - 2014-06-03 17:05:00 UTC
Lucius Regni wrote:
I'm looking forward to the Kronos release :)

As am I. EFT won't run under Wine for me.
Kadesh Priestess
This Game Is Terrible
Warlords of the Deep
#434 - 2014-06-03 20:24:05 UTC  |  Edited by: Kadesh Priestess
And update is here!

Thanks @blitzmann, he did most of the work for this release. Other contributors (including me) helped him, now it's one of the most feature-rich releases of the past year. Make sure to check release notes to not miss anything.

Also some groundwork started on stand-alone website (pyfa.net) by Evil Vile. If anyone is willing to help - please message me via EVE-mail.
Bienator II
madmen of the skies
#435 - 2014-06-03 21:51:29 UTC
great stuff!

however i think i found i bug since it seems that i can't update the skills of my char anymore. E.g medium drone op is set to not-injected and i can't change it via API update or even when i go over the char editor window. I press ok but it is not saved.

my workaround is to use the All 5 char preset.

how to fix eve: 1) remove ECM 2) rename dampeners to ECM 3) add new anti-drone ewar for caldari 4) give offgrid boosters ongrid combat value

Rammix
TheMurk
#436 - 2014-06-03 22:15:07 UTC
Quote:
Can import fit by copying from EVE Client's Fitting Window. See #91 and Wiki > Import / Export options

Heh. Wanted to make a script for myself to copy and parse fittings in such way to import, but was too lazy and totally forgot about it. But you realized the same thing in Pyfa. Thank you!! /me happily bows. Big smile

OpenSUSE Leap 42.1, wine >1.9

Covert cyno in highsec: https://forums.eveonline.com/default.aspx?g=posts&t=296129&find=unread

Kalliea Aeterna
Sebiestor Tribe
Minmatar Republic
#437 - 2014-06-04 00:07:55 UTC
Sable Blitzmann wrote:
Kalliea Aeterna wrote:
I have a problem trying to load the ships tab. I first select the ship type (eg. Exhumers). It then shows me how many fits for each ship but when I select the ship type nothing happens.
It does not view the fit or anything. My ships tab is then broken and no longer responds to anything.
This started happening after I upgraded to 1.1.22 from 1.1.18.
Pyfa was installed to a different directory.
I have un-installed and re-installed without any success.


This sounds like it could be database corruption. Please upload saveddata.db (in your ~/.pyfa/ directory) somewhere and send me the link to this file via eve mail so I can take a look.



Can I just delete this file to fix?

I don't care about losing my fits as they are mostly crap anyways.
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#438 - 2014-06-04 03:27:58 UTC
Kalliea Aeterna wrote:
Sable Blitzmann wrote:
Kalliea Aeterna wrote:
I have a problem trying to load the ships tab. I first select the ship type (eg. Exhumers). It then shows me how many fits for each ship but when I select the ship type nothing happens.
It does not view the fit or anything. My ships tab is then broken and no longer responds to anything.
This started happening after I upgraded to 1.1.22 from 1.1.18.
Pyfa was installed to a different directory.
I have un-installed and re-installed without any success.


This sounds like it could be database corruption. Please upload saveddata.db (in your ~/.pyfa/ directory) somewhere and send me the link to this file via eve mail so I can take a look.



Can I just delete this file to fix?

I don't care about losing my fits as they are mostly crap anyways.


If you don't care about losing your fits, characters, etc, go for it. Let me know if it starts to work after that. =)
Slvrsmth
Native Freshfood
Minmatar Republic
#439 - 2014-06-04 05:22:34 UTC  |  Edited by: Slvrsmth
1.2.0 doesn't seem to launch for me on Win 8.1 x64. The current window just flashes as if new application was launching, then nothing.

Tried upgrading previous installation, installing fresh (both with exe installer), and extracting the zip file into a new folder. Logs in .pyfa are both empty (tried deleting that folder too, no effect).

Event viewer has this to say:

Faulting application name: pyfa.exe, version: 0.0.0.0, time stamp: 0x49180193
Faulting module name: sqlalchemy.cresultproxy.pyd, version: 0.0.0.0, time stamp: 0x4e9b307d
Exception code: 0xc0000005
Fault offset: 0x000012aa
Faulting process id: 0x818
Faulting application start time: 0x01cf7fb3fcba7be5
Faulting application path: C:\Program Files (x86)\pyfa\pyfa.exe
Faulting module path: C:\Program Files (x86)\pyfa\sqlalchemy.cresultproxy.pyd
Report Id: 3a8ffbc0-eba7-11e3-8287-00235490d75c
Faulting package full name:
Faulting package-relative application ID:

Carebearium - find the best solar system for you!

Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#440 - 2014-06-04 05:54:01 UTC  |  Edited by: Sable Blitzmann
This is a known issue with current skeleton pyfa is built upon. We will hopefully get around to rebuilding the skeleton soon () next expansion perhaps). Please see here for a fix:

https://github.com/DarkFenX/Pyfa/wiki/APPCRASH-sqlalchemy-.pyd-files