These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Ships & Modules

 
  • Topic is locked indefinitely.
 

pyfa 1.15.0 (Vanguard)

First post First post First post
Author
Kalliea Aeterna
Sebiestor Tribe
Minmatar Republic
#441 - 2014-06-04 06:07:36 UTC
Sable Blitzmann wrote:
Kalliea Aeterna wrote:
Sable Blitzmann wrote:
Kalliea Aeterna wrote:
I have a problem trying to load the ships tab. I first select the ship type (eg. Exhumers). It then shows me how many fits for each ship but when I select the ship type nothing happens.
It does not view the fit or anything. My ships tab is then broken and no longer responds to anything.
This started happening after I upgraded to 1.1.22 from 1.1.18.
Pyfa was installed to a different directory.
I have un-installed and re-installed without any success.


This sounds like it could be database corruption. Please upload saveddata.db (in your ~/.pyfa/ directory) somewhere and send me the link to this file via eve mail so I can take a look.



Can I just delete this file to fix?

I don't care about losing my fits as they are mostly crap anyways.


If you don't care about losing your fits, characters, etc, go for it. Let me know if it starts to work after that. =)



Deleted all files and folders I could find related to pyfa and reinstalled the new release and everything is fine now.
My fits and characters are still there too which I am pleasantly surprised by.
Kadesh Priestess
the king asked me to guard the mountain
Silent Company
#442 - 2014-06-04 07:09:31 UTC
Bienator II wrote:
however i think i found i bug since it seems that i can't update the skills of my char anymore. E.g medium drone op is set to not-injected and i can't change it via API update or even when i go over the char editor window. I press ok but it is not saved.

my workaround is to use the All 5 char preset.
It was API issue on CCP side it seems. Yesterday i could reproduce it too, but now it works fine.
Ookami Hoshisenshi
Perkone
Caldari State
#443 - 2014-06-04 07:23:51 UTC
The last update gets listed as a virus by Panda antivirus...
Apparently it's a bug from Panda who doesn't like the W23/Exploit.gen for some reason:
http://support.pandasecurity.com/forum/viewtopic.php?t=2236&p=9198
Caleb Freeman
The Scope
Gallente Federation
#444 - 2014-06-04 07:59:17 UTC  |  Edited by: Caleb Freeman
Is there a way to submit found bugs, to make program better ? Like in game on my Corax I have 281.1 CPU grid in Pyfa it states 262.5 on all V. Also all my 7 charrs have problems importing skills, for example some of my 6 Year old charrs flying Dreds according to Pyfa don't have skills to fly destroyers. And on API screen it states that skills were fetched succesfully. Sorry If that is wrong place to write crap like mine, but I like Pyfa so much better than EFT especially I LOVE Yesterdays visual update and ability to copy fits from chat or killmails and It simply annoys me when I make Fit to have 99% of both grids used I build in game and I see over 10% CPU unused.
EDIT Just checked API seems to work fine Today.
Kadesh Priestess
the king asked me to guard the mountain
Silent Company
#445 - 2014-06-04 08:15:26 UTC
Ookami Hoshisenshi wrote:
The last update gets listed as a virus by Panda antivirus...
Apparently it's a bug from Panda who doesn't like the W23/Exploit.gen for some reason:
http://support.pandasecurity.com/forum/viewtopic.php?t=2236&p=9198
It is not detected as virus on virustotal, even by panda. I don't have it installed on my PC so i'm afraid i can't really help.
Kadesh Priestess
the king asked me to guard the mountain
Silent Company
#446 - 2014-06-04 08:16:54 UTC
Caleb Freeman wrote:
Is there a way to submit found bugs, to make program better ? Like in game on my Corax I have 281.1 CPU grid in Pyfa it states 262.5 on all V.
https://github.com/DarkFenX/Pyfa/issues/new
Please paste whole fitting and implants used.

And yes, it could be consequence of yesterday's EVE API bugs.
Caleb Freeman
The Scope
Gallente Federation
#447 - 2014-06-04 08:38:59 UTC
Kadesh Priestess wrote:
Caleb Freeman wrote:
Is there a way to submit found bugs, to make program better ? Like in game on my Corax I have 281.1 CPU grid in Pyfa it states 262.5 on all V.
https://github.com/DarkFenX/Pyfa/issues/new
Please paste whole fitting and implants used.

And yes, it could be consequence of yesterday's EVE API bugs.

Ok Ignore me. I'm simply ********. I had couple of coraxes in station and I jumped to one of old ones (used when I hadn't perfect fitting skills) and it was already rigged with Procesor overclocking unit and since I used just 2 rigs in new build it mounted them without errors. Still I bookmarked address for errors just in case.
Maeltstome
Academy of the Unseen Arts
#448 - 2014-06-04 21:39:34 UTC
Still the best fitting tool available.
Amari Ormand
Strix Ridens
#449 - 2014-06-05 05:58:04 UTC
With the Kronos Patch i ran into an interesting bug that caused all skills needed to build up as you tried to fit things in the same start up of the program. Photo of Problem
Kadesh Priestess
the king asked me to guard the mountain
Silent Company
#450 - 2014-06-05 15:04:20 UTC
Amari Ormand wrote:
With the Kronos Patch i ran into an interesting bug that caused all skills needed to build up as you tried to fit things in the same start up of the program. Photo of Problem
This is known issue: https://github.com/DarkFenX/Pyfa/issues/118
Neutral Jita Hauler
Doomheim
#451 - 2014-06-06 04:28:22 UTC
Getting numerous crashes with this release when adding / removing modules in quick succession after about ~5 minutes of use. Previous version never a single crash, win7 x64.
Archie Zekemann
A Good Name is better than Riches
#452 - 2014-06-06 09:05:25 UTC
Logging in just to say "thank you" for adding visual separators for high, mid, low and rig slots.
Makes things much easier and clearer to read than before.
Aureus Ahishatsu
Deadspace Knights
#453 - 2014-06-06 15:06:49 UTC
Kadesh Priestess wrote:
Amari Ormand wrote:
With the Kronos Patch i ran into an interesting bug that caused all skills needed to build up as you tried to fit things in the same start up of the program. Photo of Problem
This is known issue: https://github.com/DarkFenX/Pyfa/issues/118


I had a similar issue. While fitting out a cruor I put a web on that i did not have the skill for. Rather. than just listing needing the skill for the t2 web it listed EVERYSKILL for EVERY mod on the ship. This makes it rather difficult sometimes to figure out which mod you don't have the skill for if you don't catch that as you add it.
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#454 - 2014-06-06 21:34:18 UTC
Aureus Ahishatsu wrote:
Kadesh Priestess wrote:
Amari Ormand wrote:
With the Kronos Patch i ran into an interesting bug that caused all skills needed to build up as you tried to fit things in the same start up of the program. Photo of Problem
This is known issue: https://github.com/DarkFenX/Pyfa/issues/118


I had a similar issue. While fitting out a cruor I put a web on that i did not have the skill for. Rather. than just listing needing the skill for the t2 web it listed EVERYSKILL for EVERY mod on the ship. This makes it rather difficult sometimes to figure out which mod you don't have the skill for if you don't catch that as you add it.


You can still enable the "tree" view in the preferences. So if you have a few modules that you don't have skills for, but only want to know of a certain module, enable that.

The reason we switched to the "compact" skill list of showing the skills needed (listing the skills once, and the minimum level needed to fit everything currently on the ship) was because the current version of wxPython doesn't display large tooltips well. But that is still an option

Also, the bug with the compact skills should be fixed. Those interested should apply this patch: https://github.com/DarkFenX/Pyfa/commit/dea6ced052ba54fa3f8170276e977b0f406b8665
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#455 - 2014-06-06 21:39:06 UTC
Neutral Jita Hauler wrote:
Getting numerous crashes with this release when adding / removing modules in quick succession after about ~5 minutes of use. Previous version never a single crash, win7 x64.


This is pretty vague, however I'm not sure how you can provide more detail without running pyfa through a python interpreter. If that's possible for you, please do so (mail me in game if you need help with it).

Otherwise, please check the ~/.pyfa directory and provide any logs that you may see there. Pyfa has crap logging support, but there's always the possibility that it dumped the error there. If not, I'll try to reproduce issue.
Jason Pareka
Project Sanctuary
#456 - 2014-06-07 00:25:33 UTC
I can't change damage types i could at first but now when i r-click the resists it no longer does anything
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#457 - 2014-06-07 01:03:18 UTC
Jason Pareka wrote:
I can't change damage types i could at first but now when i r-click the resists it no longer does anything


I cannot reproduce. More info is needed (windows? mac? version? etc)
Oxide Ammar
#458 - 2014-06-07 07:54:21 UTC
Neutral Jita Hauler wrote:
Getting numerous crashes with this release when adding / removing modules in quick succession after about ~5 minutes of use. Previous version never a single crash, win7 x64.


Getting also crashes, especially when I add drones to my fit.

Lady Areola Fappington:  Solo PVP isn't dead!  You just need to make sure you have your booster, remote rep, cyno, and emergency Falcon alts logged in and ready before you do any solo PVPing.

Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#459 - 2014-06-07 17:07:43 UTC
Oxide Ammar wrote:
Neutral Jita Hauler wrote:
Getting numerous crashes with this release when adding / removing modules in quick succession after about ~5 minutes of use. Previous version never a single crash, win7 x64.


Getting also crashes, especially when I add drones to my fit.


For those getting crashes, please provide a bit more detail, such as the fit that you were working one when it crashed, the module or drone your were trying to add, exactly what happens (does it lock up, does it just not add correctly, does the program close?).

Please also backup your ~/.pyfa directory and then delete it. This will reset your user information - perhaps it's an issue with your fit database.

Alternatively, I started to provide nightly builds of pyfa here:

http://blitzmann.it.cx/pyfa-nightly/

It would be extremely helpful if you can try to pinpoint the build where the issue starts. I know it's difficult, especially for seemingly random crashes, but it's usually not random. We just need to know the reproduction steps or about where the problem was added...
Rammix
TheMurk
#460 - 2014-06-07 23:49:05 UTC
Is there some way to quickly export fits to html one by one? If no, should be.

OpenSUSE Leap 42.1, wine >1.9

Covert cyno in highsec: https://forums.eveonline.com/default.aspx?g=posts&t=296129&find=unread