These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

phpBB 3.x API Registration Mod v6+

Author
Cyerus
Eternal Strife
#981 - 2013-12-15 21:58:52 UTC
ILLADEN wrote:
If the faction warfare config is enabled, and a neutral tries to register with no militia, a bad request is returned from the API server, gets displayed and interuppts the registration. I have tried to write some error handling but failed.

Quote:
$handle = curl_init($result);
curl_setopt($handle, CURLOPT_RETURNTRANSFER, TRUE);


$response = curl_exec($handle);


$httpCode = curl_getinfo($handle, CURLINFO_HTTP_CODE);
if($httpCode == 400) {
$devilbug == 1;
}
curl_close($handle);

if ($devilbug == 1){
$foundFactionWarfare = true;
$charArray["forumGroups"][$config['eveapi_fw_m_group']] = $config['eveapi_fw_m_default'];
$charArray["TSGroups"][] = $config['eveapi_fw_m_tsgroup'];
}


or

Quote:
else
{
$foundFactionWarfare = true;
$charArray["forumGroups"][34] = $config['eveapi_fw_m_default'];
$charArray["TSGroups"][] = 150;
}

Forgot to update the Faction Warfare part of the code, should be fixed in 6.3.0.


Snitch Ashor wrote:
Hi,

I have one small request. We would like to use the fitting display in conjunction with a spoiler bbcode. In principal this works however whenever the fitting contains special chars such as an apostrophe these get converted to the html entities like &...; by the bbcode and the fitting fisplay will not work anymore. Anyone has an idea how to solve this?

Cheers,
Snitch

I think it has to do with the way the spoiler code works. It's probably changing its contents to be proper HTMl code instead of text, causing these issues. I suggest to search for a better solution (or rather a better working spoiler code script).


Gizmo Tinker wrote:
hey guys
want to be able to check characters api's for account expiry and remove them from the forum when they unsub (to workin with the current cron job)

is it possible?

Currently not possible, but I'll think about adding such functionality in the future. Is tricky though, as it would require yet another API permission to be activated on the API credentials.
Cyerus
Eternal Strife
#982 - 2013-12-15 22:07:09 UTC
Sugar Von MurdererTits wrote:
I have a small problem with changing the style from Prosilver to subsilver2. It's not a major issue as I can still use the forum, but I have a subsilver2 based style I want to install use and currently cannot.

I did a fresh install of phpBB 3.0.11 and am using the EVE_API_6.2.4_for_phpBB_3.x

When I go to apply the style changes on the automod tab, I have one error:

Quote:

styles/subsilver2/template/overall_footer.html

...


Find

< body

In-Line Find

< body

The In-Line Find specified by the MOD could not be found. The Find specified by the MOD could not be found

(added some spaces to avoid html).

If I force the style update, none of the Eve api changes are applied anyway.

Any ideas?

Fixed in 6.3.0. Code snippit should be part of overall_header, not overall_footer.


ISuper wrote:
2 Cyerus:
Hi!
Could you add to the admin panel an option to choose eve API mask to accept registration. For example my alliance need only the full API keys and i have to edit files each update.
Thank you very much for your work Big smile

Ahh yeah, the feature I keep forgetting. Won't make it in 6.3.0, but I'll try to push it into 6.3.1. If not, evemail me about it haha!


Go0fBall wrote:
Anyone know if this is compatible with phpBB 3.0.12 which was released earlier today? Don't want to take the plunge and fubar my forums lol o7.

Version 6.3.0 should be fully compatible with phpBB 3.0.12.


Protoburger wrote:
Is it possible to set a Forum Group based on the titles in EVE ?

Currently not possible, but might be implemented in the future.
Cyerus
Eternal Strife
#983 - 2013-12-15 22:18:17 UTC
Gizmo Tinker wrote:
hey

Having the HTTP Error 403 with a number of my members API Keys, Has CCP fixed the issue or is there a fix currently out there?

have read though this post and havnt found any answers.

Thanks in Advance


Should be fixed in 6.3.0, as CCP restored some parts of the functionality. With PeterPowers help (he updated his PHEAL class) we now have the API errors codes back.


Eliza Taree wrote:
hi, I have managed to get this great mod installed on the forum and its working great.

Only problem I have encountered is when someone leaves corps they are never removed for the group (not default group).

I have seen some posts talking about cron jobs, will this remove people who leave corp, if so how do i go about setting this up?

thanks

You can either choose to run it manually, or let an actual cronjob handle the script. By going to forum.com/eveapi_cron.php you'll runt he script manually, or use "wget forum.com/eveapi_cron.php" as a cronjob line should make the script run automatically. I suggest to only run it once per hour, as else you'll just receive cached replies from the API server.

For a bigger guide on cronjob I suggest to use google, as other people are far more skilled in explaining what an actual cronjob is, and what it does.


Aterion Vaert wrote:
"This character isn't permitted to have an account on this forum."

Who faced such problem?

With the settings you have set,t his character isn't allowed access. Manually verifiy all the entities you have set to determine where the problem is at.


Kashada Kumato wrote:
TeamSpeak error: 111 -> Connection refused is still all the info i am given as far as i can tell from lack of log info and that message is the stop is happening before it gets to the server, but i have tried this with our teamspeak3.com hosted server and one i host off of a local computer for testing with.

neither one works and gives the same error, i signed up with tsviewer.com using the same info and it can use query commands to get the server info.

I will get round to capturing a screenshot next time i am fiddling with it, but so far nothing i try is working. i have the latest version of PHPBB and the latest release of API MOD

Let me know by evemail if you are still having issues.


Gizmo Tinker wrote:
im receiving this error when i try to post

QL ERROR [ postgres ]

ERROR: permission denied for sequence phpbb_exacttopics_seq []

SQL

INSERT INTO phpbb_exacttopics (topic_poster, topic_time, topic_last_view_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (2, 1385200659, 1385200659, 39, 0, 1, 'Python 2.7.6', 'Gizmo Tinker', '00FFFF', 0, 0, 0)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/postgres.php
LINE: 211
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1983
CALL: dbal_postgres->sql_query()

FILE: [ROOT]/posting.php
LINE: 1142
CALL: submit_post()

ive been told its mod related and this is the only mod i have installed can anyone help me?

Cheers

The table phpbb_exacttopics isn't part of my mod nor vanilla phpBB. It is MOD related, but not mine. Perhaps some leftover table from any other mod?

If possible, try to set up a clean forum as that will undoubtly fix your issue.
Cyerus
Eternal Strife
#984 - 2013-12-15 22:27:45 UTC
LordPsylex wrote:
Any chance youll make this for Vbulletin 4.x.x?

Yes and no. I'm working on a system that would allow API integration in a few different forum systems, but it won't be the same as this current mod. A valid legal license of vBulletin would help though, as I'd rather not work on an illegal copy.


1SF5X wrote:
I get the confirmation that MOD is uploaded and when i return to AutoMOD there is nothing to install, no errors etc...
Screenshot: http://my.jetscreenshot.com/21608/20131128-uxhs-167kb.jpg

I tried to repeat it and it gave me error: http://my.jetscreenshot.com/21608/20131128-1a7u-50kb.jpg

Im using EVE_API_6.2.4_for_phpBB_3.x version

Any ideas?

Update AutoMOD to the latest version.


novellus wrote:
Got everything working. Great mod! Awesome work.

I do have a question!

Under groups, "Enable integration of this TeamSpeak 3 group when an user is part of this forumgroup." -- It doesn't seem to work, regardless of whether or not the group is immune. No TS group is ever assigned. All other TS functions seem to work.

Am I doing something wrong? Has anybody else gotten forum groups to translate over to teamspeak groups? This would be extremely helpful!

Thanks!

This feature should be fully operational in version 6.3.0.


Third Descendant wrote:
I'd like to thank you for this great mod - almost everything is working perfectly and it's definitely making my life easier managing our forums.

Now I do have one issue, it's that after a toon registers (clicks register on the registration screen), he/she gets a blank 500-internal system error. The toon does register however.

I believe this is related to the downloading of the avatar, because users get the same error when they use the 'UCP -> change avatar -> download avatar' option. Might be these errors are related to a server-based setting? CHMOD for example?

I could really use some assistance getting rid of this little hiccup. Thanks in advance!

Our forums can be found at http://forum.tardis-unlocked.com/

Let me know by evemail if you are still having this issue.


Yugo Reventlov wrote:
You are probably missing the files eveapi_fitting.css and eveapi_fitting.js in your /styles/stylename/template folder. You should be able to copy those from the default template.

Bad Yugo, only need to update the style with the modifications (AutoMOD can do that for you quite easily). ACP -> AutoMOD -> "EVE API mod by Cyerus", click Details -> Scroll to bottom, select correct inheritance template and apply changes. Don't forget to Clear Cache after.


Cyerus
Eternal Strife
#985 - 2013-12-15 22:34:22 UTC
Dieter Rams wrote:
I can't seem to reset the passwords of users as admin, I get "Warning - Forbidden". The only thing that works is them clicking "forgot password" and receiving a new one, but then they're stuck with it: nobody can change their password.

No idea what would cause this. I suggest to start over and try again,a s you probably missed a step.




I've got a beta of version 6.3.0 ready to be tested, but as usual I'm all out of testers.
So, I'm looking for a few testers willing to set up a test forum and verify everything is working as it should.

I'm not responsible for any data loss if you do want to use this beta version on your public forum, as I warned you against it.

Feel free to send me an evemail if you are interested and willing to test it, as well as being on TeamSpeak to help me debug issues if you come across any.
Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#986 - 2013-12-16 10:24:22 UTC
Cyerus wrote:


Yugo Reventlov wrote:
You are probably missing the files eveapi_fitting.css and eveapi_fitting.js in your /styles/stylename/template folder. You should be able to copy those from the default template.

Bad Yugo, only need to update the style with the modifications (AutoMOD can do that for you quite easily). ACP -> AutoMOD -> "EVE API mod by Cyerus", click Details -> Scroll to bottom, select correct inheritance template and apply changes. Don't forget to Clear Cache after.




I know I'm bad, but I'm also lazy and after doing what you just mentioned here 5x (and not getting it to work), I decided to go the other way round ;)

Granted, I was using phpBB 3.0.12, maybe that's why it didn't work for me...
Manic Velocity
Kurtzman Media Syndication LLC
#987 - 2013-12-17 16:33:02 UTC  |  Edited by: Manic Velocity
EDIT: Disregard. Got it working.

"The most punchable face in New Eden."

Be excellent to each other.

Twitter | Twitch | YouTube

Lady Toxic
Chaotic Holdings
#988 - 2013-12-19 08:28:20 UTC  |  Edited by: Lady Toxic
Hy

I try to install your MOD , but when i try it with a fresh phpBB (version 3.0.11 or 3.0.12) i will get this error when i start the installation

[phpBB Debug] PHP Warning: in file [ROOT]/umil/umil.php on line 3054: strpos(): Empty delimiter

can you help me please with this ?

and looks like it is a autoMOD error , but , yeah ... need some help

this is the line 3054
Quote:
if ((strpos($table_name, $table_prefix) === 0) && (strlen($table_name) > strlen($table_prefix)))
Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#989 - 2013-12-19 10:35:15 UTC
Lady Toxic wrote:
Hy

I try to install your MOD , but when i try it with a fresh phpBB (version 3.0.11 or 3.0.12) i will get this error when i start the installation

[phpBB Debug] PHP Warning: in file [ROOT]/umil/umil.php on line 3054: strpos(): Empty delimiter

can you help me please with this ?

and looks like it is a autoMOD error , but , yeah ... need some help

this is the line 3054
Quote:
if ((strpos($table_name, $table_prefix) === 0) && (strlen($table_name) > strlen($table_prefix)))


This must mean your table_prefix is empty, I'm not sure if that really is a problem. But to get it out of the way, install the forum database with a table prefix.
Third Descendant
Hedion University
Amarr Empire
#990 - 2013-12-22 15:22:03 UTC
Cyerus wrote:
Third Descendant wrote:
I'd like to thank you for this great mod - almost everything is working perfectly and it's definitely making my life easier managing our forums.

Now I do have one issue, it's that after a toon registers (clicks register on the registration screen), he/she gets a blank 500-internal system error. The toon does register however.

I believe this is related to the downloading of the avatar, because users get the same error when they use the 'UCP -> change avatar -> download avatar' option. Might be these errors are related to a server-based setting? CHMOD for example?

I could really use some assistance getting rid of this little hiccup. Thanks in advance!

Our forums can be found at http://forum.tardis-unlocked.com/

Let me know by evemail if you are still having this issue.


I did mail you. You then came searching for me (since I haven't been logging in that much recently).

The issue was caused by me not following the steps in the installation video properly (I skipped stuff), which caused stuff to break. I'm an idiot, I admit it. Admitting it is half the battle, right?

Anyway, my advice - if you have issues with this mod, try watching the installation video again (this time don't skip parts) and follow it to the letter.

You spend quite some time helping me out, and therefore I am ever so grateful. Thanks a bunch, you're awesome!

- 7th
bandRK Numon
W-Space Squad
#991 - 2013-12-25 16:00:49 UTC  |  Edited by: bandRK Numon
Hi all.
Firstly I want to thank Cyerus for his mod.
And I have a questions about mod use. In case of pitot which was registered on the forum left the corporation (or kick from the corporation), he will automatically deleted from forum rules and login in the forum will be impossible?
Thanks a lot
Meridian Mi
Native Freshfood
Minmatar Republic
#992 - 2013-12-25 20:36:28 UTC  |  Edited by: Meridian Mi
Hi,

i tried to update from 6.2.1 to 6.2.4

Used automod (uploaded it and used it), then i should go to "yourdomain/install/ and i get the seperate install page from your mod (is this still necessary after i installed it via automod?). I get the info that my currently installed version is 6.2.1 and the mod version is 6.2.4. i use the standard settings, press submit and then yes. But i only get a blank page after this. Even deinstalled and deleted old version (currently installed none) and after i press submit and then yes i get again those blank screen(Firefox, IE say's HTTP 500 error). Migrated board from my server to webspace.Any ideas?
Dave Leadland
GoonWaffe
Goonswarm Federation
#993 - 2013-12-29 14:20:17 UTC  |  Edited by: Dave Leadland
Great product. I used your previous versions year or two ago and had no issues at all.
However I started to reuse your system recently and have ran now one issue related on TeamSpeak 3 management.

When I try to save TS3 UID it will not save, I read in here from some post it is an connection issue.

Eveapi_check
Quote:
Required - You must have your TeamSpeak UID set in your profile in order to verify if the TeamSpeak integration is working correctly.

Username: Xxxxx Xxxxx
UID: Unknown
Error code: 111
Error message: Connection refused


Eveapi_cron
Quote:
Starting
EVE API MOD -> version 6.2.4
TeamSpeak 3 Framework -> version 1.1.18
PHEAL -> version 0.1.6
TeamSpeak error: 111 -> Connection refused
Quiting the cronjob, as no connection to the TeamSpeak 3 server could be made while TeamSpeak 3 Integration is enabled.
12-29-2013 14:16:19 --- Finished!

I have no problems logging in on Query via Telnet.

edited: Also I asked my TS provider to white list my server IP, and added UID manually via MySQL for now, but still connection gets refused. However I am renting Virtual TS3, not sure if it does play the role in this case.

Maybe you have previous clients with this same problems and you could direct me right direction. What to do or what to ask from our Virtual TS3 server hoster.
Plain213
Macabre Votum
Northern Coalition.
#994 - 2013-12-30 17:55:02 UTC
Hi Cyerus,

Recently installed this Mod with and currently trying to configure ts3. Looking at your config video i beliebe i have done so correctly.

After registering a new toon, I then try and create a ts3 account, details are entered and I get confirmation that the profile has been updated. BUT not usergroup is assigned on ts3.

Help...

Plain
Cyerus
Eternal Strife
#995 - 2014-01-01 22:30:00 UTC
bandRK Numon wrote:
Hi all.
Firstly I want to thank Cyerus for his mod.
And I have a questions about mod use. In case of pitot which was registered on the forum left the corporation (or kick from the corporation), he will automatically deleted from forum rules and login in the forum will be impossible?
Thanks a lot

No, you'll have to run the forum.com/eveapi_cron.php script in order to update/disable those accounts.

Meridian Mi wrote:
Hi,

i tried to update from 6.2.1 to 6.2.4

Used automod (uploaded it and used it), then i should go to "yourdomain/install/ and i get the seperate install page from your mod (is this still necessary after i installed it via automod?). I get the info that my currently installed version is 6.2.1 and the mod version is 6.2.4. i use the standard settings, press submit and then yes. But i only get a blank page after this. Even deinstalled and deleted old version (currently installed none) and after i press submit and then yes i get again those blank screen(Firefox, IE say's HTTP 500 error). Migrated board from my server to webspace.Any ideas?

Try to start of with a fresh install and see if that helps, as migrating boards from one webhost to the other could be causing issues like this.

Dave Leadland wrote:
Great product. I used your previous versions year or two ago and had no issues at all.
However I started to reuse your system recently and have ran now one issue related on TeamSpeak 3 management.

When I try to save TS3 UID it will not save, I read in here from some post it is an connection issue.

Eveapi_check
--- CUT ---

Eveapi_cron
--- CUT ---
I have no problems logging in on Query via Telnet.

edited: Also I asked my TS provider to white list my server IP, and added UID manually via MySQL for now, but still connection gets refused. However I am renting Virtual TS3, not sure if it does play the role in this case.

Maybe you have previous clients with this same problems and you could direct me right direction. What to do or what to ask from our Virtual TS3 server hoster.

If you are absolutely sure your webhost IP is whitelisted by your TeamSpeak 3 provider, it'll probably have to do with a wrong username/password combination. Or perhaps your webhost is blocking outgoing connections? Check the forum.com/eveapi_check.php to be sure all dependencies are available.

Plain213 wrote:
Hi Cyerus,

Recently installed this Mod with and currently trying to configure ts3. Looking at your config video i beliebe i have done so correctly.

After registering a new toon, I then try and create a ts3 account, details are entered and I get confirmation that the profile has been updated. BUT not usergroup is assigned on ts3.

Help...

Plain

In 6.2.4 and below any TeamSpeak error is suppressed, meaning that if something goes wrong you don't see it happening. To give you a small indication as to why it doesn't work, you'll have to check forum.com/eveapi_check.php while being logged in as an admin to verify the connection is set up correctly.

In 6.3.0 TS errors will be shown instead of suppressing them.
Cyerus
Eternal Strife
#996 - 2014-01-01 22:58:49 UTC  |  Edited by: Cyerus
Happy New Year! CoolLol
Hereby I'm releasing version 6.3.0


  • NOTE! Remember to update your Special Group permissions in each of the Group settings screen, as the main Special Group checks from the EVE API General tab are now removed!
  • Fix for Subsilver2 based templates; body belongs in overall_header, not in overall_footer
  • Faction Warfare integration should now work without errors again
  • Updated PHEAL to support the new way the EVE API handles its errors. It will return XML as body with HTTP statuscode on errors, after which PHEAL filters the errors and sends them back as PhealAPIException (in short: Back to semi-old method).
  • Updated the database to Rubicon 1.0.4.
  • Jabber authentication is now based on forum groups and EVE entities.
  • TeamSpeak groups are now able to be set by forum groups.
  • Improved TeamSpeak error handling. Users should now be able to see why their TS UID is not being saved.
  • Return of the Quick Reply on Prosilver themes.
  • Customizeble AccessMask using the ACP (new module).
  • Fix for 'TeamSpeak3 class not found' fatal error, which happened under certain rare configurations.
  • Updated TeamSpeak3 PHP Framework to 1.1.23 from 1.1.18. (Requires TeamSpeak3 Server 3.0.9 or newer.)


Version 6.3.0 requires phpBB 3.0.12.
In order to update from phpBB 3.0.11 from phpBB 3.0.12 while using my mod, please follow the following small guide.

  1. Upload the root/install folder from the 6.2.4 package to the root of your forum.
  2. Browse to forum.com/install and select to Uninstall.
  3. Once uninstalled, delete the install folder from your forum.
  4. Uninstall the 6.2.4 mod from AutoMOD using the ACP.
  5. Once uninstalled, delete the 6.2.4 package from AutoMOD.
  6. Clear forum cache!
  7. You can now upgrade your forum to 3.0.12, default phpBB upgrade procedure applies.
  8. Once phpBB 3.0.12 is installed, delete the install folder from your forum.
  9. Upload and install version 6.3.0 of the mod.
  10. Once installed, browse to forum.com/install and select Install to install the database part of the mod.
  11. Clear forum cache!
  12. Go to the new AccessMask module and set the requested AccessMask.
  13. Go to each Forum group (Users and Groups - Manage Groups) and set the correct Immunity, TeamSpeak and Jabber permissions to each group.
  14. Once done, clear the forum cache again, as you can't do that enough!

If you'd like to have a bit more insight in this process, please watch the 6.2.0 Installation and Configuration video on Youtube as that video should explain a very similar process. The link to the Youtube videos can be found in the second post of this topic.

Please be aware that increasing the required AccessMask for users can cause users to have their accounts disabled, as their currently configured AccessMask might not match your newly set AccessMask. To be on the safe side only select the bare minimum required, which is Public - CharacterInfo (and Public - FacWarStats if you use the Faction Warfare integration). You have been warned!

Download can be found in the first post of this topic as usual.
Let me know if you come across any issues.
Dieter Rams
Deep Core Mining Inc.
Caldari State
#997 - 2014-01-03 05:08:25 UTC
Great update, thank you so very much for your excellent work!
Selfless Cynic
Swamphole Inc.
#998 - 2014-01-05 00:07:45 UTC
I used this in my previous alliance but for some reason while following your outdated video guide I am getting stuck.
Could you please work on releasing a written guide that's up to date.

My main issue is that for some reason I can't manage to get the API fields to come up. I think Ive had everything but after going over the video multiple times I really don't know wtf I missed.
Dianne Saber
Saberick Interest and Development
Goonswarm Federation
#999 - 2014-01-08 18:57:48 UTC
So far we are loving your mod. The functionality is great! We migrated from SMF to phpBB due to some issues and staff turnover. One function we really did like from Temar's Eve API mod was the ability to store multiple APIs on one forum account in order to be able to track alts. Is this something that could be added?
Go0fBall
Perkone
Caldari State
#1000 - 2014-01-09 10:37:14 UTC
Cyerus, as always thank you very much for keeping this project going, and for your recent flawless update. I have a question I am hoping someone can help with. I have ejabberd working just fine, but I am curious how one goes about sending out broadcast messages. I can use Pidgin and the ADHOC commands to send out announcements, but I know there is an announce/broadcast system which ejabberd uses internally, I am just not sure how to go about setting it up.

If someone would be so kind as to walk me through getting that working, I'd greatly appreciate it. Thanks in advance Smile