These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

phpBB 3.x API Registration Mod v6+

Author
Cyerus
Eternal Strife
#961 - 2013-11-24 16:12:51 UTC  |  Edited by: Cyerus
Alizar Civire wrote:
Is this author still active at all? I've made a few changes to the item list in the mysql database however it sure would be nice if the mysql database would be updated by the author. Assuming it was created using an API -> MySQL program or data dump. If we could figure out where he got the database or how he created it, I would love to recreate it for Rubi and get it uploaded.

Also interesting thing that could be added would be linking player names in forum posts.


Whether I'm active or not should not influence whether you ask a question or not, but I'm currently enjoying a few weeks off, actually playing the game for a change rather than developing the mod for it.
And yes, I'm still developing and maintaining the mod.
Third Descendant
Hedion University
Amarr Empire
#962 - 2013-11-24 16:43:55 UTC
Cyerus wrote:
Alizar Civire wrote:
Is this author still active at all? I've made a few changes to the item list in the mysql database however it sure would be nice if the mysql database would be updated by the author. Assuming it was created using an API -> MySQL program or data dump. If we could figure out where he got the database or how he created it, I would love to recreate it for Rubi and get it uploaded.

Also interesting thing that could be added would be linking player names in forum posts.


Whether I'm active or not should not influence whether you ask a question of not, but I'm currently enjoying a few weeks off, actually playing the game for a change rather than developing the mod for it.
And yes, I'm still developing and maintaining the mod.


In that case, enjoy your weeks off!

I shall be looking forward to the update making the mod work with Rubicon!
LordPsylex
Shadow State
Goonswarm Federation
#963 - 2013-11-24 23:51:56 UTC
Any chance youll make this for Vbulletin 4.x.x?
Wafou Ka'Djo
Yellow Box Ltd.
#964 - 2013-11-25 02:09:17 UTC
LordPsylex wrote:
Any chance youll make this for Vbulletin 4.x.x?


phpBB is completely a different script from vBulletin. I wish and I hope someone will release a vB 4/5 API registration hack but I'm waiting it looooong way , I think we'll never see one.


Back in topic, thanks Cyerus for your hard work mantaining and releasing new version of your module. Take your time, I hope to see 'soon' a new version of your module with a lot of new features ;)

Thanks again :)
Alizar Civire
Arcadia Wars Training
#965 - 2013-11-25 04:04:16 UTC
Cyerus wrote:
Alizar Civire wrote:
Is this author still active at all? I've made a few changes to the item list in the mysql database however it sure would be nice if the mysql database would be updated by the author. Assuming it was created using an API -> MySQL or data dump. If we could figure out where he got the database or how he created it, I would love to recreate it for Rubi and get it uploaded.

Also interesting thing that could be added would be linking player names in forum posts.


Whether I'm active or not should not influence whether you ask a question or not, but I'm currently enjoying a few weeks off, actually playing the game for a change rather than developing the mod for it.
And yes, I'm still developing and maintaining the mod.


Thank you very much for your reply, I can fully understand you taking a break. Have fun, and happy holidays to you. If you should get the chance to sit down and have a small discussion with me, I'd love to pass on some ideas to you that we're given to my by my very large group of Fleet Commanders. If you'd like just eve mail me. Thanks :)
Go0fBall
Perkone
Caldari State
#966 - 2013-11-25 10:50:59 UTC
Cyerus wrote:
Alizar Civire wrote:
Is this author still active at all? I've made a few changes to the item list in the mysql database however it sure would be nice if the mysql database would be updated by the author. Assuming it was created using an API -> MySQL program or data dump. If we could figure out where he got the database or how he created it, I would love to recreate it for Rubi and get it uploaded.

Also interesting thing that could be added would be linking player names in forum posts.


Whether I'm active or not should not influence whether you ask a question or not, but I'm currently enjoying a few weeks off, actually playing the game for a change rather than developing the mod for it.
And yes, I'm still developing and maintaining the mod.


Thanks for the update Cyerus, I know many of us look forward to and await the update. Enjoy your game time Big smile .
fenya33 drobshest
Sebiestor Tribe
Minmatar Republic
#967 - 2013-11-27 15:05:13 UTC  |  Edited by: fenya33 drobshest
thank you for your work
Abraham Nalelmir
Viziam
Amarr Empire
#968 - 2013-11-27 22:55:22 UTC  |  Edited by: Abraham Nalelmir
EDIT- I am testing the mod now and hope it will be working with rubicon, thanks for the nice work Smile

In Go.. ECM I trust

1SF5X
Kullervo Holdings
#969 - 2013-11-28 19:49:21 UTC
I get the confirmation that MOD is uploaded and when i return to AutoMOD there is nothing to install, no errors etc...
Screenshot: http://my.jetscreenshot.com/21608/20131128-uxhs-167kb.jpg

I tried to repeat it and it gave me error: http://my.jetscreenshot.com/21608/20131128-1a7u-50kb.jpg

Im using EVE_API_6.2.4_for_phpBB_3.x version

Any ideas?
Abraham Nalelmir
Viziam
Amarr Empire
#970 - 2013-11-28 19:54:58 UTC
Feedback after installing the MOD:

phpBB version: 3.0.12, Installed the following mods:
AutoMOD-1.0.2
UMIL-1.0.5
EVE_API_6.2.4_for_phpBB_3.x

Everything went smooth and OK, I was able to link my character so easy, and items, systems and fitting features are all working fine, of course the items of Rubicon are missing, but whatever Smile

The help videos you had on Youtube are just awesome!

In Go.. ECM I trust

novellus
The Special Snowflakes
#971 - 2013-11-29 10:38:57 UTC  |  Edited by: novellus
Got everything working. Great mod! Awesome work.

I do have a question!

Under groups, "Enable integration of this TeamSpeak 3 group when an user is part of this forumgroup." -- It doesn't seem to work, regardless of whether or not the group is immune. No TS group is ever assigned. All other TS functions seem to work.

Am I doing something wrong? Has anybody else gotten forum groups to translate over to teamspeak groups? This would be extremely helpful!

Thanks!
Third Descendant
Hedion University
Amarr Empire
#972 - 2013-11-30 01:46:24 UTC  |  Edited by: Third Descendant
I'd like to thank you for this great mod - almost everything is working perfectly and it's definitely making my life easier managing our forums.

Now I do have one issue, it's that after a toon registers (clicks register on the registration screen), he/she gets a blank 500-internal system error. The toon does register however.

I believe this is related to the downloading of the avatar, because users get the same error when they use the 'UCP -> change avatar -> download avatar' option. Might be these errors are related to a server-based setting? CHMOD for example?

I could really use some assistance getting rid of this little hiccup. Thanks in advance!

Our forums can be found at http://forum.tardis-unlocked.com/
Juchi Ju
Mindstar Technology
Goonswarm Federation
#973 - 2013-12-01 11:35:07 UTC

I have problem with the evefitting, im getting the fitting screen and all the mods below it. Screnshot

I have looked the logs and i cant find anything what could cause it.

Any tips?

Thanks for advance
Heimdall Midgard
The Scope
Gallente Federation
#974 - 2013-12-01 15:09:28 UTC  |  Edited by: Heimdall Midgard
Juchi Ju wrote:

I have problem with the evefitting, im getting the fitting screen and all the mods below it. Screnshot

I have looked the logs and i cant find anything what could cause it.

Any tips?

Thanks for advance



Clean Cache of the Templates, Icons etc.


novellus wrote:
Got everything working. Great mod! Awesome work.

I do have a question!

Under groups, "Enable integration of this TeamSpeak 3 group when an user is part of this forumgroup." -- It doesn't seem to work, regardless of whether or not the group is immune. No TS group is ever assigned. All other TS functions seem to work.

Am I doing something wrong? Has anybody else gotten forum groups to translate over to teamspeak groups? This would be extremely helpful!

Thanks!



Got the same Problem here. Corp Assigments Work pretty well. But i cant assign TS3 Rights per Groups...
novellus
The Special Snowflakes
#975 - 2013-12-01 23:42:40 UTC
Heimdall Midgard wrote:


novellus wrote:
Got everything working. Great mod! Awesome work.

I do have a question!

Under groups, "Enable integration of this TeamSpeak 3 group when an user is part of this forumgroup." -- It doesn't seem to work, regardless of whether or not the group is immune. No TS group is ever assigned. All other TS functions seem to work.

Am I doing something wrong? Has anybody else gotten forum groups to translate over to teamspeak groups? This would be extremely helpful!

Thanks!



Got the same Problem here. Corp Assigments Work pretty well. But i cant assign TS3 Rights per Groups...

Good to see I'm not crazy and alone!
Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#976 - 2013-12-02 11:19:02 UTC
Juchi Ju wrote:

I have problem with the evefitting, im getting the fitting screen and all the mods below it. Screnshot

I have looked the logs and i cant find anything what could cause it.

Any tips?

Thanks for advance

You are probably missing the files eveapi_fitting.css and eveapi_fitting.js in your /styles/stylename/template folder. You should be able to copy those from the default template.
Dieter Rams
Deep Core Mining Inc.
Caldari State
#977 - 2013-12-03 03:50:34 UTC
I can't seem to reset the passwords of users as admin, I get "Warning - Forbidden". The only thing that works is them clicking "forgot password" and receiving a new one, but then they're stuck with it: nobody can change their password.
Heimdall Midgard
The Scope
Gallente Federation
#978 - 2013-12-13 13:28:43 UTC
novellus wrote:
Heimdall Midgard wrote:


novellus wrote:
Got everything working. Great mod! Awesome work.

I do have a question!

Under groups, "Enable integration of this TeamSpeak 3 group when an user is part of this forumgroup." -- It doesn't seem to work, regardless of whether or not the group is immune. No TS group is ever assigned. All other TS functions seem to work.

Am I doing something wrong? Has anybody else gotten forum groups to translate over to teamspeak groups? This would be extremely helpful!

Thanks!



Got the same Problem here. Corp Assigments Work pretty well. But i cant assign TS3 Rights per Groups...

Good to see I'm not crazy and alone!



You solved the problem?
novellus
The Special Snowflakes
#979 - 2013-12-13 22:39:55 UTC
Heimdall Midgard wrote:
novellus wrote:
Heimdall Midgard wrote:


novellus wrote:
Got everything working. Great mod! Awesome work.

I do have a question!

Under groups, "Enable integration of this TeamSpeak 3 group when an user is part of this forumgroup." -- It doesn't seem to work, regardless of whether or not the group is immune. No TS group is ever assigned. All other TS functions seem to work.

Am I doing something wrong? Has anybody else gotten forum groups to translate over to teamspeak groups? This would be extremely helpful!

Thanks!



Got the same Problem here. Corp Assigments Work pretty well. But i cant assign TS3 Rights per Groups...

Good to see I'm not crazy and alone!



You solved the problem?

Nope, I've tried several different installations. TS3 corp/alliance permissions work great. But for some reason, teamspeak permissions are never assigned per group. I'm at my wit's end and am just waiting to hear back from either the developer or someone who found a fix.
Cyerus
Eternal Strife
#980 - 2013-12-15 21:48:28 UTC  |  Edited by: Cyerus
Durp Vader wrote:
Mmm, when I upload version 6.2.4, I get following error:

The directory structure of the uploaded MOD archive is unrecognized. Check if the zip archive you uploaded is corrupt or missing any files/directories, or contact the MOD Author.

Updating AutoMOD should fix this issue.


Durp Vader wrote:
Juno Libertas wrote:
I am still having problem saving Teamspeak UIDs through ACP and UCP anyone have any hints?


I can't update the Teamspeak 3 user group of my groups on the board.

EDIT: Actually, none of the EVE API settings in the usergroups seem to work. I can't enable Jabber, nor can I add that group to a Teamspeak group. Anyone else got this issue? :)
EDIT2: I manually updated the database with the correct group, and the group got correctly displayed in the EVE API settings for that group. However, the users were not automatically moved in that group eve though all settings on my end should be correct.

This functionality hasn't been fully integrated yet. The fields you see there are placeholders only. In version 6.3.0 this will function correctly and as expected.


Durp Vader wrote:
Well after some digging through the scripts it looked like a permission error, but for some reason people on the teamspeak server are still not getting the correct permissions. Instead, they have their permissions removed.

If permissions are removed by the script but not added, it will more than likely have to do with the settings you have set.


StuofBeef wrote:
is there any sort of walk through on how to integrate with ejabberd? I saw on one of your tutorials you went into ejabberd_side.php but you didn't explain any more other than that. basically I want my forum users to get automatically registered for ejabberd. In testing at the moment i get the following error after entering the server address and a known username/password for the server

"Could not connect to Jabber server.

Error: open_socket() - No connection could be made because the target machine actively refused it.

Error: connect() #2"

I am only testing internally at the moment though with ejabberd running on a dedicated linux box but I can connect to the service fine using pidgin on my desktop showing that firewall isn't the problem.

Other than this minor issue, great work you are doing Cyerus

ejabberd integration is tricky to set up. I'll see if I can create a guide for it, but since there are so many linux variants, I can't guarantee it will be 100% accurate on your setup. Contact me by ingame mail if you need some extra help, as your problems are likely to be the problems others are having, giving me insight on what I should give extra attention in the future guide.