These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Information Portal

 
  • Topic is locked indefinitely.
 

EVE Launcher update on May 21, 2013

First post First post
Author
Tara Tyrael
Quantum Anomaly Corporation
#1881 - 2013-05-22 00:04:06 UTC
may I ask how many people actually tested this before it went live?

I will gladly do testing for you, you don't need to pay me that much either, because to the end user it sure as hell looks like you DID NOT even try to run this before you sent it out.

True, you have been working for 10 years, and EVE is a great game, but man, this happens almost every patch. Patch day topic has 5 workarounds already for stuff, how did you manage to miss it all?
Anonymouse Reporter01
Doomheim
#1882 - 2013-05-22 00:04:07 UTC
Anonymouse Reporter01 wrote:
Shanerous Lorenthien wrote:
Problems with the new launcher when I got home today.
Symptoms:
4) Takes about 20 minutes to validate install. (


I wish it was a speedy 20 minute validation as at the 25 minute mark I'm still at:

(1/4): VALIDATING CLIENT : 50.4%

I only have one account with 3 Alts so nothing fancy. Luckily I started a 14 day skill train yesterday and should be good for June.


At 59 minute mark the Client was validated and I've clicked the button to launch client. Left hand side of Launcher has cleared and the Gerbils in the processor appear to be sleeping on the job as CPU usage has flatlined. Three minutes later CPU activity is jumping up and down like a slow motion yo-yo.
CCP Atropos
C C P
C C P Alliance
#1883 - 2013-05-22 00:05:33 UTC  |  Edited by: CCP Atropos
Regarding missing EVE settings: this is a bug in the initial installer of the new update that people had to upgrade from the old Launcher to the new one. The installer automatically starts the EVE Launcher after the update, but does so with what's known as a short Windows path. A short path is in the style of EVE-ON~1 or PROGRA~1. In this instance, the working directory in this short format is inherited by the EVE client which then tries to make a unique folder name based upon the directory it thinks it is in, and the server it is connecting to. This is the unique location that your settings are stored in.

Note, this folder still exists.

To work around the issue, you simply need to restart the EVE Launcher and any clients that it started. The new instance of the EVE Launcher will not have this short path, and so what would have been an (incorrect) path of c_builds_eve-on~1_tranquility is correctly interpreted as c_builds_eve-online_tranquility.

I'm currently working on a fix for this installer, when not answering forum threads, and I'm hoping to get it out as soon as I can.
SGT FUNYOUN
Elysian Space Navy - 1st Fleet
#1884 - 2013-05-22 00:09:18 UTC
Large Collidable Object wrote:
I like the new launcher - the hour it took to make the legal 100+ account miners to make a macro logging all their accounts in, they probably felt as pissed off about the game as I do the remaining 8759 hours about them.

That was worth it - thank you L'Oréal....


ok, Dude...

I can understand punishing botters.
I can NOT understand punishing someone who PAYS and actually PLAYS more than one account.

And unless they are profiting off of it somehow, I don't see ANYONE playing 100+ accounts by themselves just to mine, and DEFINITELY not off of 1 machine.

I know players who have 20+ accounts, and they have machines that can play up to about 8 at a time.

But whining about a PLAYER who actually SITS at their computer and PLAYS 8+ accounts at once... is just whiny.

You being happy that someone who PAYS to actually PLAY this game with multiple accounts is having trouble... is just petulant.

This is a service product.

We are the customers.

We demand service.

And you being happy that a LARGE majority of the community that has purchased this product is having trouble using it...

Dude.

Botters, are no-go; we can ALL agree on that. But bashing on someone for actually PLAYING their 20 accounts when they PAY for them...

...is just lame.
45thtiger 0109
Already Replaced.
#1885 - 2013-05-22 00:09:28 UTC  |  Edited by: 45thtiger 0109
Knowing CCP will fix the issue.

I also has the same problem and on the 3rd try it worked.

We should all know when something new comes out it will have bugs it dose not matter what it is.

Technology has bugs in it and we should live with it.

Its apart of day to day living and CCP are only human someone or something might have cause this problem.

We should not complain about little things.

We should be happy with what CCP are doing and making EVE Online Stable instead of whining and carrying on about something that can be fixed.

People lets all grow up we all know that CCP are doing there best and lets be happy Big smile

BTW it now works fine for me as CCP has fixed the problem.

See people CCP did fix the problem and it might be slow from the start when the launcher is checking the eve files on you HD and it all depends on how fast your system is.

And oh the days of the Boot.ini well i was lucky again i did not have any issues. EvilLol

**You Have to take the good with the bad and the bad with the good.

Welcome to EvE OnLiNe**

Anyura
Smart Industries
Intaki-Business Logistics Union
#1886 - 2013-05-22 00:09:28 UTC  |  Edited by: Anyura
I'd still like answer as to whether Odyssey will have a login theme like Apocrypha, Trinity and so on.
CCP Atropos
C C P
C C P Alliance
#1887 - 2013-05-22 00:09:46 UTC
Regarding the slow startup time of the new EVE Launcher: the first time the new EVE Launcher starts up, it needs to determine the state of your client installation. This requires it to analyse every file in your installation. This will take some time, since the EVE client is somewhere around 12Gb in size. However, after this point, the checksums will be saved in the Launcher's cache folder. Clearing out the Launcher's cache folder will obviously delete this file, requiring you to re-analyse your installation.

If people are finding that they need to spend a lengthy amount of time analysing their installation every time they start up, I would beg them to file a bug reporting, and provide the logs that their Launcher is generating, and saving into it's cache folder.
CCP Atropos
C C P
C C P Alliance
#1888 - 2013-05-22 00:12:00 UTC
Regarding the two processes that the EVE Launcher starts: the EVE Launcher has a bootstrapping application that loads a versioned EVE Launcher. When one of these closes, the other one should close too, however we've seen in a few instances one of them waits whilst it writes out pending buffers to disk.

If launcher.exe processes are regularly hanging on shutdown, as above, I would beg for people to file a bug report and attach logs of the problem.
DRGaius Baltar
Perkone
Caldari State
#1889 - 2013-05-22 00:13:31 UTC
New launcher is **** and its horribly for multiboxers!!!! i have 6 accounts and have trouble launching the 5th account???
Zeronic
Black Scorpion Society
The Watchmen.
#1890 - 2013-05-22 00:13:52 UTC  |  Edited by: Zeronic
CCP Atropos wrote:
Regarding the slow startup time of the new EVE Launcher: the first time the new EVE Launcher starts up, it needs to determine the state of your client installation. This requires it to analyse every file in your installation. This will take some time, since the EVE client is somewhere around 12Gb in size. However, after this point, the checksums will be saved in the Launcher's cache folder. Clearing out the Launcher's cache folder will obviously delete this file, requiring you to re-analyse your installation.

If people are finding that they need to spend a lengthy amount of time analysing their installation every time they start up, I would beg them to file a bug reporting, and provide the logs that their Launcher is generating, and saving into it's cache folder.



Why was the even released when all the forum threads about it said it wan't READY?, further more it not Multi Account Friendly at all. Lucky for me I can still directly launch the EveFile.exe. This is almost making me what to cancel my accounts.
Sturmwolke
#1891 - 2013-05-22 00:15:04 UTC  |  Edited by: Sturmwolke
CCP Atropos wrote:

The new login functionality that we deployed today is designed to start changing the way users log into the EVE Universe; whilst it is often true that one shouldn't change something if it isn't broken, such a cliché doesn't allow for changing priorities. Our goal was that by rolling out the new login method, and supporting the single sign on service, we could lay the groundwork to start moving people away from the messy multiboxing setups that have traditionally never been supported by us as a company, and towards something that makes more sense for CCP and the services we provide.

To expand on this point, there are a number of exotic setups for multiboxing involving either multiple physical installs of the game, hybrid symlinks, junctions, soft links, hard links, partial copies and more. And in almost every single case people multi box for one reason: to be able to have individual setups for their settings, or to hasten the login flow. The deployment today, as difficult and bad as it was (for which I apologise) was to deploy the single sign on service, through which we can start to work on these issues. My hope is that in the end, you will be able to log into the EVE Launcher once, which downloads your settings from the cloud, with all of your accounts linked, via either a single EVE master account or via some other OAuth provider, and be able to select characters and switch between them at the click of a single button.

I suspected you guys going into this direction as much. The problem, you dropped the ball.
An AFTER THE FACT explanation for an IMPORTANT matter to highlight or bring into discussion (for the general audience) .... which SHOULD have its own devblog ..... I mean wtf??!

Whatever happpened to setting expectations?
All this flak was your own making, which could've been avoided or tempered down.

P.S And no, those other blogs, including the SSO blogs didn't touch on this directly in detail.
Patrick Baboli
Mad Science Union Local 42
#1892 - 2013-05-22 00:16:28 UTC  |  Edited by: Patrick Baboli
I use multiple toons every day, the new launcher takes longer to verify client status, and disapeers on launching EDIT: never mind, i'm an idiot, i found the don't auto-close button :END EDIT. i am disaponted by the lack of the old launchers ease of use for multiple toons, note it did do the no connection error, and is now working. the sso widow disapeered and when i relaunched it it took the same amount of time to check. can you make it so it will you know, not disapeer or so you can launch multaple acounts at once?

edit: after launching eve for reals it verifies it fine. but no longer lets me drag and drop a .gif for it to play :( i know it wasn't meant for that, but could you add something to let players make it their own? and image you save locally for it to display or something? so i can play with it, i like to make everything my own in some fashion. besides, the eve .gifs you'd get lol :)
CCP Atropos
C C P
C C P Alliance
#1893 - 2013-05-22 00:16:55 UTC  |  Edited by: CCP Atropos
Regarding usernames not being remembered by the login dialog: I ran across an issue earlier today where if I entered a new username whilst the dropdown dialog was open, with another name highlighted, when I tabbed on to the password field, the highlighted name in the dropdown took priority. I filed this as a defect and I'm hopeful that we can push out a fix for it as soon as possible.

Any other usability issues or defects with the username/password input I would like to hear about. If they're defects, a bug report would be best, but I'm happy to have a dialog about the design and intent of the site.
SGT FUNYOUN
Elysian Space Navy - 1st Fleet
#1894 - 2013-05-22 00:17:38 UTC
45thtiger 0109 wrote:
Knowing CCP will fix the issue.

I also has the same problem and on the 3rd try it worked.

We should all know when something new comes out it will have bugs it dose not matter what it is.

Technology has bugs in it and we should live with it.

Its apart of day to day living and CCP are only human someone or something might have cause this problem.

We should not complain about little things.

We should be happy with what CCP are doing and making EVE Online Stable instead of whining and carrying on about something that can be fixed.

People lets all grow up we all know that CCP are doing there best and lets be happy Big smile





Nope... I'd rather be a flaming whiny crybaby. CryCryCryCryCryCry

JK PTwisted
David Zahavi
Doomheim
#1895 - 2013-05-22 00:18:52 UTC  |  Edited by: David Zahavi
I can't believe such a buggy and borked launcher was launched....

Fix your **** before you release it please.


Now for the reason I'm posting....


I can't currently log on the game...

On my mac version I got errors all day (at work), and now that I'm home and got a new launcher, spent 20 min validating logged in had no settings.....

Restarted the game and launcher per above.... spent another 20 minutes validating...., hit play.... and the play button disappeared once I pushed it, but no EVE game client loaded...

Reloaded the launcher and now its validating again.

What is it validating?


How do you launch buggy stuff like this?
Gelatine
EverBroke Geeks
#1896 - 2013-05-22 00:20:06 UTC
I assume that this was actually necessary for some reason, but from my perspective it benefits me about as much as a real money auction house did in Diablo3: ie not benefit at all.

I don't like advertising spam and turning the launcher into a marketing mechanism is a massive turn off. I don't like having to be patient waiting just to log into a game I've paid to play. I don't want to watch EVE TV because I'm capable of making my own. I don't like that the EULA is now something I have to hunt for after a one shot read though in a tiny window. Look at the thing - it's a mess and nowhere near as adept at providing important information as the old launcher.

From a users perspective the old "keep it simple" approach was the most sensible and acceptable barrier to gameplay. New launcher is a much bigger barrier to gameplay - a bad move in my opinion.

Sorry I've nothing positive to say after what you guys have been through getting the thing to work.
Ruziel
Twilight Military Industrial Complex
#1897 - 2013-05-22 00:20:30 UTC
Thanks for this steaming pile that makes it a gigantic pain in the ass to change accounts while playing. Roll
Jonuts
The Arrow Project
#1898 - 2013-05-22 00:20:30 UTC
Your new launcher is bad, and you should feel bad.
Valeria Crossroads
Terra Incognita
#1899 - 2013-05-22 00:20:37 UTC
The launcher only remembers the last 7 accounts. I have way more than that. I really hope you guys do not expect me to type the account names over and over again. Ugh
AusTerror
Blue Capricorn Mining Corporation
#1900 - 2013-05-22 00:23:27 UTC
I was going to write a long post about problems and try to provide useful data.

But now I'll just say: I had problems just like everyone else in this thread.