These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

phpBB 3.x API Registration Mod v6+

Author
Cyerus
Eternal Strife
#641 - 2013-02-01 19:13:45 UTC
Andy Tibs wrote:
I have upgraded our forum to 6.2 of the mod and when I run the eveapi_check.php I am getting one that says is not found/installed.

Quote:
PHP extension Zip is enabled: No


Not quite sure where to enable/install this from. Any help would be great!

You can ignore that extension. Yesterday I noticed I made a mistake, as that extension isn't needed for my mod nor AutoMOD or vanilla phpBB.
Andy Tibs
Ministry of War
#642 - 2013-02-01 19:37:15 UTC
Cyerus wrote:
Andy Tibs wrote:
I have upgraded our forum to 6.2 of the mod and when I run the eveapi_check.php I am getting one that says is not found/installed.

Quote:
PHP extension Zip is enabled: No


Not quite sure where to enable/install this from. Any help would be great!

You can ignore that extension. Yesterday I noticed I made a mistake, as that extension isn't needed for my mod nor AutoMOD or vanilla phpBB.



Ok, Thanks!
Suleiman Shouaa
The Tuskers
The Tuskers Co.
#643 - 2013-02-02 01:27:04 UTC
I've updated from 6.1 to 6.2 but it seems that users' api data is no longer linked to their forum account. There is a MySQL table with what appears to be their API details in it, but in the admin control panel vcode/key is blank. How do I fix this*
Cyerus
Eternal Strife
#644 - 2013-02-02 03:17:05 UTC
Suleiman Shouaa wrote:
I've updated from 6.1 to 6.2 but it seems that users' api data is no longer linked to their forum account. There is a MySQL table with what appears to be their API details in it, but in the admin control panel vcode/key is blank. How do I fix this*

Did you run the install/index.php script to update the database part to 6.2.0?

If so and it still isn't working, you'll have to place back the backup you made and try the upgrade process again.
ISuper
State War Academy
Caldari State
#645 - 2013-02-03 14:58:26 UTC  |  Edited by: ISuper
Hi, finally i installed 6.2.0, i have some problems. My theme based on prosilver and it seems that second one is broken.

1. When i try to run eveapi_cron.php i get an error:

General Error
template->_tpl_load_file(): File ./styles/prosilver/template/breadcrumbs.html does not exist or is empty
https://www.dropbox.com/s/66cov7wku9fmizr/error2.png


2. In the registration page i have double evepi id and eveapi code lines.
https://www.dropbox.com/s/jpl7jnvieqi6ing/error1.png
On the eveapi_update.php page the same thing.


3. eveitems and evefits doesn't work.


If i switch to subsilver2 theme 1,2 working correctly (about 3 i am not shure how it must work).

Could you help me please? I want to save my current theme, but i need to fix it.


p.s. also will be great to have a small instructions for ejabberd installation, after some tries i got it. (i used beta jabber version before)
Wafou Ka'Djo
Yellow Box Ltd.
#646 - 2013-02-03 22:12:20 UTC
Awesome work! I just wanna ask if it's very difficult to customize phpBB with your mod to act like this:

Instead showing a normal phpBB 'register' I'd like to have a customized 'register' page that asks everything like the normal page apart the username. Instead of a username it asks UserID and vCode, fetch the characters and then asks which one is the main and it'd be the phpBB username.

Thanks in advance for your answers.
Cyerus
Eternal Strife
#647 - 2013-02-04 12:22:44 UTC  |  Edited by: Cyerus
ISuper wrote:
Hi, finally i installed 6.2.0, i have some problems. My theme based on prosilver and it seems that second one is broken.

1. When i try to run eveapi_cron.php i get an error:

General Error
template->_tpl_load_file(): File ./styles/prosilver/template/breadcrumbs.html does not exist or is empty
https://www.dropbox.com/s/66cov7wku9fmizr/error2.png


2. In the registration page i have double evepi id and eveapi code lines.
https://www.dropbox.com/s/jpl7jnvieqi6ing/error1.png
On the eveapi_update.php page the same thing.


3. eveitems and evefits doesn't work.


If i switch to subsilver2 theme 1,2 working correctly (about 3 i am not shure how it must work).

Could you help me please? I want to save my current theme, but i need to fix it.


p.s. also will be great to have a small instructions for ejabberd installation, after some tries i got it. (i used beta jabber version before)

Error 1:
File doesn't exist; So upload the original Prosilver files from the phpBB package.

Error 2:
You did something funky where the mod installed twice, probably because you used pre-edited files to start with, resulting in dual API fields.
Uninstall the mod from that template, delete the template and reupload a clean normal version of it. When installing the mod now, you should only see those fields once.

Error 3:
There are multiple causes that would result in this error. Try watching the video again to see which part you forgot to do yourself.


Wafou Ka'Djo wrote:
Awesome work! I just wanna ask if it's very difficult to customize phpBB with your mod to act like this:

Instead showing a normal phpBB 'register' I'd like to have a customized 'register' page that asks everything like the normal page apart the username. Instead of a username it asks UserID and vCode, fetch the characters and then asks which one is the main and it'd be the phpBB username.

Thanks in advance for your answers.

The user already needs to type the exact Charactername as forum username in order for the API check to correctly verifiy the user.
ISuper
State War Academy
Caldari State
#648 - 2013-02-04 13:31:04 UTC
Cyerus wrote:
ISuper wrote:
Hi, finally i installed 6.2.0, i have some problems. My theme based on prosilver and it seems that second one is broken.

1. When i try to run eveapi_cron.php i get an error:

General Error
template->_tpl_load_file(): File ./styles/prosilver/template/breadcrumbs.html does not exist or is empty
https://www.dropbox.com/s/66cov7wku9fmizr/error2.png


2. In the registration page i have double evepi id and eveapi code lines.
https://www.dropbox.com/s/jpl7jnvieqi6ing/error1.png
On the eveapi_update.php page the same thing.


3. eveitems and evefits doesn't work.


If i switch to subsilver2 theme 1,2 working correctly (about 3 i am not shure how it must work).

Could you help me please? I want to save my current theme, but i need to fix it.


p.s. also will be great to have a small instructions for ejabberd installation, after some tries i got it. (i used beta jabber version before)

Error 1:
File doesn't exist; So upload the original Prosilver files from the phpBB package.

Error 2:
You did something funky where the mod installed twice, probably because you used pre-edited files to start with, resulting in dual API fields.
Uninstall the mod from that template, delete the template and reupload a clean normal version of it. When installing the mod now, you should only see those fields once.

Error 3:
There are multiple causes that would result in this error. Try watching the video again to see which part you forgot to do yourself.


Wafou Ka'Djo wrote:
Awesome work! I just wanna ask if it's very difficult to customize phpBB with your mod to act like this:

Instead showing a normal phpBB 'register' I'd like to have a customized 'register' page that asks everything like the normal page apart the username. Instead of a username it asks UserID and vCode, fetch the characters and then asks which one is the main and it'd be the phpBB username.

Thanks in advance for your answers.

The user already needs to type the exact Charactername as forum username in order for the API check to correctly verifiy the user.



1. There is no breadcrumbs.html in official template, that file exist only im prosilver2.
2. How to uninstall the mod from template? Do i have to reinstall totally eveapi mod? (fu**ing hell)
3. . There are many problems when you are updating the mod and your video didn't help.
Aron Fox
Tranquillian Imperial Navy
#649 - 2013-02-04 22:13:04 UTC
http://s15.postimage.org/yzzuflh5n/eve_phpbb_mof_bug.png
this issue is appearing when using ProNight style, everything else seams to be working fine so far
Cyerus
Eternal Strife
#650 - 2013-02-05 00:00:36 UTC  |  Edited by: Cyerus
ISuper wrote:
1. There is no breadcrumbs.html in official template, that file exist only im prosilver2.
2. How to uninstall the mod from template? Do i have to reinstall totally eveapi mod? (fu**ing hell)
3. . There are many problems when you are updating the mod and your video didn't help.
It's pretty simple to update from 6.1.2 to 6.2.0.

The errors you are getting are from a wrong installation. You did something wrong, which messes up the whole forum.
The videos are easy to understand (and do expect a bit of knowledge) and guide your through the process step-by-step.
I haven't made a video on updating from 6.1.2 to 6.2.0 as the steps are basicly the same as a new installation, only you can now skip a lot of them.

You did something funky with your installation (probably manual file edition), resulting in corruption of the styles.
To try to clean this up, follow these steps;

  1. Backup, backup, backup, BACKUP!
  2. Uninstall the mod from AutoMOD (when the uninstallation gives errors on the styles, click on Force Uninstall)
  3. Delete the all the styles from your forums using FTP (contained inside the styles folder)
  4. Reupload the styles from the clean vanilla phpBB package (Prosilver and Subsilver2)
  5. Clear cache in the ACP
  6. Install the mod using AutoMOD (should give no errors on styles)
  7. Clear cache again


This will hopefully fix all of your errors.


Aron Fox wrote:
http://s15.postimage.org/yzzuflh5n/eve_phpbb_mof_bug.png
this issue is appearing when using ProNight style, everything else seams to be working fine so far

You forgot to apply the changes to the template you are using.
I suggest you to watch the 6.2.0 Installation and Configuration video (link can be found in the first post of this topic), as it explains in detail on how to automaticly edit the changes to the style of your choosing.
ISuper
State War Academy
Caldari State
#651 - 2013-02-05 03:28:55 UTC  |  Edited by: ISuper
Cyerus wrote:
ISuper wrote:
1. There is no breadcrumbs.html in official template, that file exist only im prosilver2.
2. How to uninstall the mod from template? Do i have to reinstall totally eveapi mod? (fu**ing hell)
3. . There are many problems when you are updating the mod and your video didn't help.
It's pretty simple to update from 6.1.2 to 6.2.0.

The errors you are getting are from a wrong installation. You did something wrong, which messes up the whole forum.
The videos are easy to understand (and do expect a bit of knowledge) and guide your through the process step-by-step.
I haven't made a video on updating from 6.1.2 to 6.2.0 as the steps are basicly the same as a new installation, only you can now skip a lot of them.

You did something funky with your installation (probably manual file edition), resulting in corruption of the styles.
To try to clean this up, follow these steps;

  1. Backup, backup, backup, BACKUP!
  2. Uninstall the mod from AutoMOD (when the uninstallation gives errors on the styles, click on Force Uninstall)
  3. Delete the all the styles from your forums using FTP (contained inside the styles folder)
  4. Reupload the styles from the clean vanilla phpBB package (Prosilver and Subsilver2)
  5. Clear cache in the ACP
  6. Install the mod using AutoMOD (should give no errors on styles)
  7. Clear cache again


This will hopefully fix all of your errors.


Aron Fox wrote:
http://s15.postimage.org/yzzuflh5n/eve_phpbb_mof_bug.png
this issue is appearing when using ProNight style, everything else seams to be working fine so far

You forgot to apply the changes to the template you are using.
I suggest you to watch the 6.2.0 Installation and Configuration video (link can be found in the first post of this topic), as it explains in detail on how to automaticly edit the changes to the style of your choosing.


Finally i fixed problem with a styles, thank you very much. It seems that i have summed errors from previous updates. Automod working really buggy and usually can't install/uninstall w/o force mode.
Aron Fox
Tranquillian Imperial Navy
#652 - 2013-02-05 06:56:00 UTC  |  Edited by: Aron Fox
Cyerus wrote:
ISuper wrote:
1. There is no breadcrumbs.html in official template, that file exist only im prosilver2.
2. How to uninstall the mod from template? Do i have to reinstall totally eveapi mod? (fu**ing hell)
3. . There are many problems when you are updating the mod and your video didn't help.
It's pretty simple to update from 6.1.2 to 6.2.0.

The errors you are getting are from a wrong installation. You did something wrong, which messes up the whole forum.
The videos are easy to understand (and do expect a bit of knowledge) and guide your through the process step-by-step.
I haven't made a video on updating from 6.1.2 to 6.2.0 as the steps are basicly the same as a new installation, only you can now skip a lot of them.

You did something funky with your installation (probably manual file edition), resulting in corruption of the styles.
To try to clean this up, follow these steps;

  1. Backup, backup, backup, BACKUP!
  2. Uninstall the mod from AutoMOD (when the uninstallation gives errors on the styles, click on Force Uninstall)
  3. Delete the all the styles from your forums using FTP (contained inside the styles folder)
  4. Reupload the styles from the clean vanilla phpBB package (Prosilver and Subsilver2)
  5. Clear cache in the ACP
  6. Install the mod using AutoMOD (should give no errors on styles)
  7. Clear cache again


This will hopefully fix all of your errors.


Aron Fox wrote:
http://s15.postimage.org/yzzuflh5n/eve_phpbb_mof_bug.png
this issue is appearing when using ProNight style, everything else seams to be working fine so far

You forgot to apply the changes to the template you are using.
I suggest you to watch the 6.2.0 Installation and Configuration video (link can be found in the first post of this topic), as it explains in detail on how to automaticly edit the changes to the style of your choosing.


nope cant be that i didnt follow your directions, i did exactly as you did in your video. even did it twice before i even posted this.

once it all is installed i upload the style, install the style, make check which deafult style its based of. open the details of the EVE api mod select to apply the changes to the style, purge the cach and refres the new style.
ISuper
State War Academy
Caldari State
#653 - 2013-02-05 13:39:54 UTC  |  Edited by: ISuper
Dex Thiesant wrote:
Dex Thiesant wrote:
Hey,

Great tool, I managed to get everything running fairly quick. The only issue I seem to be having is with the evefit bbcode.

This is what I'm seeing: http://imgur.com/tvUw2rt

I tested it in Chrome Version 24.0.1312.52 m as well as the IGB and I get the same result. I'm also using the latest version of your mod which is 6.1.2 .

Any thoughts?

Thanks,

Dex



Please disregard. I was using a custom theme that didn't inherit from pro-silver. I just had to add your css file and it worked like a charm. Again, beautiful work.

Dex


I have the same problem, my theme is based on prosilver, what do i have to do?

https://www.dropbox.com/s/9x0itwhx95mcxgk/evefit_error.png
Aron Fox
Tranquillian Imperial Navy
#654 - 2013-02-07 21:37:28 UTC  |  Edited by: Aron Fox
the cronjob still dont add people to both allience and corp groups. it only adds membership for the corps unless allience group is set to deafult.
Ashantia Makarov
Black Rising Shadow
#655 - 2013-02-07 23:00:17 UTC
iv installed the mod on a fresh forum

i still have an issue with the Fitting Posting

it shows me the fit:

[Rupture, Gate Camp]

1600mm Reinforced Steel Plates I
Damage Control II
Reactor Control Unit II
Energized Adaptive Nano Membrane II
Gyrostabilizer II

Experimental 10MN Microwarpdrive I
Sensor Booster II
Warp Scrambler II
Stasis Webifier II

425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II

Medium Ancillary Current Router I
Medium Trimark Armor Pump I
Medium Trimark Armor Pump I

Like This:

http://i.imgur.com/g2kJEQE.png

any help available?
Cyerus
Eternal Strife
#656 - 2013-02-07 23:22:13 UTC  |  Edited by: Cyerus
ISuper wrote:
Finally i fixed problem with a styles, thank you very much. It seems that i have summed errors from previous updates. Automod working really buggy and usually can't install/uninstall w/o force mode.

That's not AutoMOD being buggy, but rather the style you are using being rather weird by moving away from the default template to much. AutoMOD only consists of simple Find-and-Replace code, where in your style it's unable to find certain parts.


Ashantia Makarov wrote:
iv installed the mod on a fresh forum

i still have an issue with the Fitting Posting

it shows me the fit:

[Rupture, Gate Camp]

1600mm Reinforced Steel Plates I
Damage Control II
Reactor Control Unit II
Energized Adaptive Nano Membrane II
Gyrostabilizer II

Experimental 10MN Microwarpdrive I
Sensor Booster II
Warp Scrambler II
Stasis Webifier II

425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II

Medium Ancillary Current Router I
Medium Trimark Armor Pump I
Medium Trimark Armor Pump I

Like This:

http://i.imgur.com/g2kJEQE.png

any help available?

Remove the empty line between [Rupture, Gate Camp] and 1600mm Reinforced Steel Plates I.




Hereby I'm releasing version 6.2.1


  • NOTE! Remember to update your Special Group permissions in each of the Group settings screen, as the main Special Group checks from the EVE API General tab will be removed shortly!
  • Fixed the problem where the path to eveapi_fitting.css was wrong, resulting in a glitchy Fitting panel. Mainly my mistake, but also a bit of stupidity by phpBB involved, as they don't support css file inheritance. Used a workaround to fix it by placing the css file in the template directory (instead of theme), where inheritance is allowed and working.
  • Removed the PHP extension Zip from eveapi_check.php as it is not needed (but added something else, muahahaha!)
  • Removed the link to eveapi_update.php from the AdminCP login screen (mainly a Prosilver-based problem).
  • Finally fixed the annoying Default group-bug that has been hunting me for over a year now..! I was using array_unique() ont he forumGroups array that ws already unique, resulting in the loss of forumGroups.


Default installation/upgrade instruction apply.

Download can be found in the first post of this topic as usual.
Let me know if you come across any other issues.

Last but not least; Thoughts?
Aron Fox
Tranquillian Imperial Navy
#657 - 2013-02-07 23:24:10 UTC  |  Edited by: Aron Fox
Ashantia Makarov wrote:
iv installed the mod on a fresh forum

i still have an issue with the Fitting Posting

it shows me the fit:

[Rupture, Gate Camp]

1600mm Reinforced Steel Plates I
Damage Control II
Reactor Control Unit II
Energized Adaptive Nano Membrane II
Gyrostabilizer II

Experimental 10MN Microwarpdrive I
Sensor Booster II
Warp Scrambler II
Stasis Webifier II

425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II

Medium Ancillary Current Router I
Medium Trimark Armor Pump I
Medium Trimark Armor Pump I

Like This:

http://i.imgur.com/g2kJEQE.png

any help available?


are you using PYFA? because when I export fits with EFT format with PYFA and submit it i get the same problem. just remove the line brake directly after [Rupture, Gate Camp]. Its little tedious to do so but it works.

example:
[Rupture, Gate Camp]
1600mm Reinforced Steel Plates I
Damage Control II
Reactor Control Unit II
Energized Adaptive Nano Membrane II
Gyrostabilizer II

Experimental 10MN Microwarpdrive I
Sensor Booster II
Warp Scrambler II
Stasis Webifier II

425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II
425mm AutoCannon II

Medium Ancillary Current Router I
Medium Trimark Armor Pump I
Medium Trimark Armor Pump I
Aron Fox
Tranquillian Imperial Navy
#658 - 2013-02-07 23:34:25 UTC
Cyerus are you planning on removing the corp/allience/standing/faction date form the config table? If you havent considerd that I think you could easy remove "Amount of 'Special' forumgroups shown below." as you could gather all the needed details in a separate table making updating, and uninstalling the mod proably alot easier.
Cyerus
Eternal Strife
#659 - 2013-02-07 23:43:30 UTC  |  Edited by: Cyerus
Aron Fox wrote:
Cyerus are you planning on removing the corp/allience/standing/faction date form the config table? If you havent considerd that I think you could easy remove "Amount of 'Special' forumgroups shown below." as you could gather all the needed details in a separate table making updating, and uninstalling the mod proably alot easier.

I have thought about doing that, but it takes a lot more work (and time). Currently I'm using phpBB's own build in system to save my data, each based on their own tables. It might make the automated (un)installation a bit more technical, but I think I those problems have been solved, as I haven't had any problems with my (un)installation lately.

In the end a seperate solution might be best, but for now I'll stick with phpBB's functionality.
Aron Fox
Tranquillian Imperial Navy
#660 - 2013-02-07 23:43:44 UTC
When i am trying to upload the 6.2.1 archive with AUTOMod i get this message

Quote:
The directory structure of the uploaded MOD archive is unrecognized. Check if the zip archive you uploaded is corrupt or missing any files/directories, or contact the MOD Author.