These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

POS Tracker - FGV - 5.2.1

Author
Vogue
Pandemic Horde Inc.
Pandemic Horde
#121 - 2012-07-20 12:09:41 UTC
As I am a one man indy corp I have installed POS Tracker FGV 5.2.0 on my Windows 7 OS using IIS 7.5, PHP 5.3.15, MySQL 5.5.25a. I have performed the installation fine but I can't login as 'Admin' or 'admin' with a password I know I set. And I am on my 2nd fresh installation. I can't think what could be the problem. I tried a trick of copying the pos3_user 'pass' field encrypted text to a md5 decrypted but the text was invalid format. And conversely I tried creating a md5 password and inserting that into the Admin user 'pass' field.

I can't think what could be causing this problem. If I knew a way of converting a text password to the encrypted format pos3_user table --> pass field uses I could work around the issue that way..?
Vogue
Pandemic Horde Inc.
Pandemic Horde
#122 - 2012-07-20 14:07:03 UTC  |  Edited by: Vogue
I got it all working by getting a freebie linux - php\mysql web hosting deal Bear
Kildres Thellere
Absolutely Certain
#123 - 2012-07-25 05:49:38 UTC
Getting error when I try to register users.

Could not create user;Incorrect integer value: '' for column 'alliance_id' at row 1

Have tried several API keys and the site is trusted in the IGB. Not sure that matters for this issue.

v5.2.1
MySQL 5.5.25a
PHP 5.3.15
Curl 7.26
Vogue
Pandemic Horde Inc.
Pandemic Horde
#124 - 2012-07-25 06:13:10 UTC
Kildres Thellere wrote:
Getting error when I try to register users.

Could not create user;Incorrect integer value: '' for column 'alliance_id' at row 1

Have tried several API keys and the site is trusted in the IGB. Not sure that matters for this issue.

v5.2.1
MySQL 5.5.25a
PHP 5.3.15
Curl 7.26


I had this issue. I resolved it by creating a corp specific API key on my CEO char.
Kildres Thellere
Absolutely Certain
#125 - 2012-07-25 15:25:16 UTC  |  Edited by: Kildres Thellere
Vogue wrote:
Kildres Thellere wrote:
Getting error when I try to register users.

Could not create user;Incorrect integer value: '' for column 'alliance_id' at row 1

Have tried several API keys and the site is trusted in the IGB. Not sure that matters for this issue.

v5.2.1
MySQL 5.5.25a
PHP 5.3.15
Curl 7.26


I had this issue. I resolved it by creating a corp specific API key on my CEO char.



And that was my first thought as well. I did try that and even created a new one just to make sure. I Actually ahve two different toons that are CEO's. One in an alliance and one that is not and they both do the same thing.

I was able to manually add a user to the DB and log into it. This seems to work ok but I still cannot add a POS or pull down Corp/Alliance updates.
Kildres Thellere
Absolutely Certain
#126 - 2012-07-25 19:03:14 UTC
Kildres Thellere wrote:
Vogue wrote:
Kildres Thellere wrote:
Getting error when I try to register users.

Could not create user;Incorrect integer value: '' for column 'alliance_id' at row 1

Have tried several API keys and the site is trusted in the IGB. Not sure that matters for this issue.

v5.2.1
MySQL 5.5.25a
PHP 5.3.15
Curl 7.26


I had this issue. I resolved it by creating a corp specific API key on my CEO char.



And that was my first thought as well. I did try that and even created a new one just to make sure. I Actually ahve two different toons that are CEO's. One in an alliance and one that is not and they both do the same thing.

I was able to manually add a user to the DB and log into it. This seems to work ok but I still cannot add a POS or pull down Corp/Alliance updates.



Reinstalled the whole thing and got the same issue. Edited the register.php and set the alliance_id to 0 when it creates the new user account and it completes fine now. Not sure what that will do down the line but it got me past this issue.
Clism
Soul Takers
Pen Is Out
#127 - 2012-09-05 01:31:01 UTC
Hi, we're using your pos tracker, and it helps me a lot so far just to see my fuel levels on our many pos's.

I'm tryin to set it up now so I can see the silo levels and I'm just a tad slow I guess as I'm having a problem.

Mind if I ask?
It's a pretty simple question. On the View Pos page when I chose Edit, I add one harvester and one silo.

Then I have these choices. Adding the material type is easy. But then "input/output", not sure about that.
I can easily show the silo as connected to the harvester, but then "linked to" ?

So in this case below my harvester is #13 and the silo is #14.

I assume the Silo is input as the material goes into the silo?
The "linked to" would that be referring to the moon harvester, which would then be linked to Silo 14?


Harvesters/Reactors Arrays

Module Material
Moon Harvesting Array 13

Silo Arrays

Silo Material Input/Output Required/Produced Available Online FULL Connected to: Linked to:
Silo 14 Mercury Output 100 (0.8m3) EMPTY No Moon Harvester Silo 14

Is this correct? If not what should my inputs be please?
I have a feeling I need the "idiots guide" to this please?
Thanks
Clism
Clism
Soul Takers
Pen Is Out
#128 - 2012-09-11 20:05:38 UTC
Well, sorry about asking a noob question, but I'm still unable to get my silos to work and show their contents.
Anyone care to help?
Thanks

Clism wrote:
Hi, we're using your pos tracker, and it helps me a lot so far just to see my fuel levels on our many pos's.

I'm tryin to set it up now so I can see the silo levels and I'm just a tad slow I guess as I'm having a problem.

Mind if I ask?
It's a pretty simple question. On the View Pos page when I chose Edit, I add one harvester and one silo.

Then I have these choices. Adding the material type is easy. But then "input/output", not sure about that.
I can easily show the silo as connected to the harvester, but then "linked to" ?

So in this case below my harvester is #13 and the silo is #14.

I assume the Silo is input as the material goes into the silo?
The "linked to" would that be referring to the moon harvester, which would then be linked to Silo 14?


Harvesters/Reactors Arrays

Module Material
Moon Harvesting Array 13

Silo Arrays

Silo Material Input/Output Required/Produced Available Online FULL Connected to: Linked to:
Silo 14 Mercury Output 100 (0.8m3) EMPTY No Moon Harvester Silo 14

Is this correct? If not what should my inputs be please?
I have a feeling I need the "idiots guide" to this please?
Thanks
Clism

True Sight
Deep Freeze Industries
#129 - 2012-09-12 01:48:45 UTC
The API doesn't give silo information.

If you set a Silo as a Technetium Input, then every hour the POS tracker will decrease the amount by 100, if you set it as a Technetium Output, then it will increase the amount by 100.

Once you have set up your POS, you need to go to the "Production" tab at the top, then enter the amounts in each silo. This window will then display to you when a POS is running out of/silo filling up.

Each time someone in your corp empties/fills a silo, they need to login to the POS manager and manually update the silo volumes.
Dimitrie
Free-Space-Ranger
Northern Coalition.
#130 - 2012-09-12 06:54:57 UTC
There is a way to track the silos. I have written my own tool to manage them.
Silo tool
Johnathan Roark
Quantum Industries
#131 - 2012-09-16 07:14:36 UTC
Dimitrie wrote:
There is a way to track the silos. I have written my own tool to manage them.
Silo tool



There is a way, but it gets messy if you have multiple pos in the same system.

EVEVERIFY - A recruiting API Verification and Audit Tool

Also try out Yapeal for your php api needs

Dimitrie
Free-Space-Ranger
Northern Coalition.
#132 - 2012-09-16 12:44:33 UTC
Since the location api that goes well
Frozen Guardian
The Scope
Gallente Federation
#133 - 2012-10-03 19:08:27 UTC
Just a quick message just to let you guys know to the status of the project (since I've been meaning to) as I don't wish to keep ya out of the loop.

I'd hate to say it but the project is pretty much on hold for updates at this point until an unknown amount of time. Along those lines I am partly through complete conversion for the API to handle everything but I doubt it'll get finished any time soon since there's still a lot of work to be done and I'm off exploring other adventures outside of EVE. Perhaps in a year from now I'll start it back up and finish it. I'd say feel free to keep posting bugs and other various suggestions here or on the project page as I may get to it eventually :P

Best of luck to ya all and fly safe :)
Kismeteer
Bat Country
Pandemic Horde
#134 - 2012-10-08 14:52:07 UTC
Frozen Guardian wrote:
Just a quick message just to let you guys know to the status of the project (since I've been meaning to) as I don't wish to keep ya out of the loop.


Thanks for the update man. We have a very functional product right now, still.
epsilonion
CLOVEN SKY
#135 - 2012-10-13 17:33:32 UTC
Hi,

I seem to be having problems pulling from the api..

the cron job works fine ( I don't get a email telling me otherwise) but it does not update the database and when entering the app it says the api is out of date even after the time that the cron job has completed..

any ideas?

[u]Boom you went BOOM!![/u]

Uncle Jessy
Society For Creation and Utilization of Wormholes
#136 - 2012-10-25 10:49:04 UTC
Brilliant working lovely, is there a way of having it monitor the moon harvesters automatically? using the APi not manually changing the amounts when silos are emptied?

Thank you for this tool Big smile
Luna Pollard
Sunken Bros Inc.
#137 - 2012-11-04 10:44:49 UTC
i uploaded all files to server and

"Database initialisation failed"

error pops up when i go to the url
Kismeteer
Bat Country
Pandemic Horde
#138 - 2012-11-15 15:10:32 UTC
Luna Pollard wrote:
i uploaded all files to server and

"Database initialisation failed"

error pops up when i go to the url


Did you make sure that the application has the right information to write to your database?
Entaran
Assisted Recovery Solutions
#139 - 2012-12-15 07:38:02 UTC  |  Edited by: Entaran
Hey Guys,

Just trying to set this up for my altcorp, having issues with cronjobs and can't find any documentation that is actually relevant to my problems in any of the old threads all the way back to 2.x

Basically, I'm looking for a list of files I need to modify to make them work and the executable in the cronjob...

do I run poscron.sh, posmail.sh, postrackercron.sh, or do i run the cron_updatepos.php, cron_updatesov.php etc

Also, what lines do I have to modify inside these files?

atm I'm getting a return like it's trying to execute the commented section of the file

Quote:
/home/account/public_html/dir/pos/cron_updatepos.php: line 1: ?php: No such file
or directory
/home/account/public_html/dir/pos/cron_updatepos.php: line 2: /bin: is a directory
/home/account/public_html/dir/pos/cron_updatepos.php: line 3: access-logs:
command not found
/home/account/public_html/dir/pos/cron_updatepos.php: line 4: access-logs:
command not found


This is from running poscron.sh from shell and having it dump the results in an email.

cPanel Version 11.34.0 (build 11)
Apache version 2.2.22
PHP version 5.3.16
MySQL version 5.5.25-cll
Entaran
Assisted Recovery Solutions
#140 - 2012-12-16 04:50:04 UTC
CRON ISSUES

Longwinded reply to the above post, for future reference for everyone who experiences this problem given FG has stopped support of this product and future users may require support until someone else picks up development.

This is a straightforward process and you can copy paste it. I have broken it down into steps which you can follow (fairly idiot proofed)

Do not use notepad.exe w/windows as it appends all sorts of weird invisible characters. Use nano in linux, or get a program like notepad2.exe or notepad++.exe (google).

Step 1:
Navigate to the directory on your webhost - usually /public_html/pos/ -> May vary depending on where you put it or host.

Step 2: (Optional)
Delete the following files:
poscron.sh
posmail.sh
postrackercron.sh

Step 3:
Create a new file called
posupdate.sh
Contents in quote box - Your directory structure on line 2 may differ depending on where you installed it. On a Cpanel host it will be something like /home/accountname/public_html/path. For dedicated hosts it may be /srv/www or /var/www and so forth.
Quote:

#!/bin/sh
cd /public_html/pos
php5 cron_updatepos.php
php5 cron_updatejobs.php
php5 cron_mail.php


Step 4:
Create a new file called
posupdateallisov.sh
Contents in quote box - Your directory structure on line 2 may differ depending on where you installed it. On a Cpanel host it will be something like /home/accountname/public_html/path. For dedicated hosts it may be /srv/www or /var/www and so forth.
Quote:

#!/bin/sh
cd /public_html/pos
php5 cron_updateallianceinfo.php
php5 cron_updatesov.php


Step 5:
Goto your Cron setup and enter your cronjobs

posupdate.sh can be run every 6 hours as per CCP api limitations.
posupdateallisov.sh can be run every hour although there is little need to run it more than weekly. Mine runs weekly.

Path for a cronjob in Cpanel is /home/accountname/public_html/path/posupdate.sh
If you are doing it on a dedicated host, use google to work out how to run cron jobs as I'm a terrible scrub who uses an easy solution.


I hope this post helps some people. It has resolved my issues and a couple of other points.