These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Client crashes on Ubuntu 11.10

First post
Author
kakmonstret
Domain Mining and Trading Corp
#41 - 2012-04-24 21:29:25 UTC
One guy in the Linux ingame channel reports that it dosen't crasch with folowing:

Suri Abrams > Two GTX 570s in SLI with 295.4 drivers and the most recent wine you can get on Arch.

Not sure what if anything what it means seems alot of you got the same driver version.
NegatedVoid
Native Freshfood
Minmatar Republic
#42 - 2012-04-24 21:44:55 UTC
I've made a Wine bug report as I start looking into this.

http://bugs.winehq.org/show_bug.cgi?id=30515

Please post any relevant details, but don't just chatter / 'me too' / spam, etc.
NegatedVoid
Native Freshfood
Minmatar Republic
#43 - 2012-04-24 21:50:55 UTC
kakmonstret wrote:
One guy in the Linux ingame channel reports that it dosen't crasch with folowing:

Suri Abrams > Two GTX 570s in SLI with 295.4 drivers and the most recent wine you can get on Arch.

Not sure what if anything what it means seems alot of you got the same driver version.


See if you can have him run wine --version?

Also, ask him if he has overrides in winecfg for msvcr80, msvcr90, and/or msvcr100 and what they're set to.
POS Trader
Merchants of Lore
#44 - 2012-04-24 21:50:58 UTC
Calebus Phobeus wrote:
@Laurent: It crashs with 295.40 for the tengu here. Just getting the loading animation and then the client freezes (not the computer). Tornado is working fine here. Loading, seems to be fine and rotating it... works nicely.
//edit: Legion and Proteus also crashs here.
//edit2: Could it be, that its working with the Tornado here as I checked it yesterday and its still in cash, while I never checked the other T3 ships? Maybe that the reason, why it seems to be somewhat random which T3 are crashing the client?



Tornado is NOT a T3 ship. Tornado is a TIER 3 Battlecruiser.

Anyway, I was very happy about increased FPS on my client so I wanted to test it out. So I undocked in Jita - first time in weeks UghUghUgh
Katrina Bekers
A Blessed Bean
Pandemic Horde
#45 - 2012-04-24 22:26:26 UTC
Confirming the issue.

Kubuntu 11.10 64-bit.
WINE 1.4.0
Nvidia drivers 280.13
GTX 560 Ti

As workaround, I suggest everyone to open the map (so that models are not actually displayed) and dock/undock/fly to safety.

<< THE RABBLE BRIGADE >>

Maquis196
Deep Core Mining Inc.
Caldari State
#46 - 2012-04-24 23:06:53 UTC
Confirming bug as well (we all know it's a bug just want to help build up numbers so CCP know it's a big problem).

Also, there's nothing wrong with dozens of people confirming bug with winehq as well, or at least until somewhere there actually confirms the bug, enough activity on the bug report by a lot of people might see movement. The problem does appear to be UI related and I think there was work there for Inferno.

We know it's not a windows issue, so either wine or eve is broken, hopefully it's a quick fix, I live up north and avoiding T3s is hard!

Cheers,
Maq
Spoofeydoo
Eternity INC.
Goonswarm Federation
#47 - 2012-04-24 23:14:14 UTC
Katrina Bekers wrote:


As workaround, I suggest everyone to open the map (so that models are not actually displayed) and dock/undock/fly to safety.


I had the map open, I flew to a gate where a Tengu was and crashed.

I have a fruit cup and I'm not afraid to use it.

NegatedVoid
Native Freshfood
Minmatar Republic
#48 - 2012-04-24 23:58:58 UTC
Maquis196 wrote:

Also, there's nothing wrong with dozens of people confirming bug with winehq as well, or at least until somewhere there actually confirms the bug, enough activity on the bug report by a lot of people might see movement. The problem does appear to be UI related and I think there was work there for Inferno.

We know it's not a windows issue, so either wine or eve is broken, hopefully it's a quick fix, I live up north and avoiding T3s is hard!

Cheers,
Maq


Please don't spam the winehq people. Work on Wine is done on a volunteer basis - a bunch of people complaining just will irritate someone, not motivate them to be helpful. I'm a Wine developer (on unrelated parts).

But do post any additional logs, different systems/architectures/versions of whatever. That is useful information!
PotH34d
Capital Investment Fund
#49 - 2012-04-25 00:52:06 UTC  |  Edited by: PotH34d
See what I found in the huge log generated by using this line
WINEDEBUG=+file wine explorer /desktop=EVE2,1440x900 "C:\Program Files\CCP\EVE\bin\ExeFile.exe" > log.txt 2>&

Quote:
fixme:d3d:resource_check_usage Unhandled usage flags 0x8
fixme:d3d:resource_check_usage Unhandled usage flags 0x8
fixme:d3d:resource_check_usage Unhandled usage flags 0x8
fixme:d3d:resource_check_usage Unhandled usage flags 0x8
fixme:d3d:resource_check_usage Unhandled usage flags 0x8
trace:file:CreateFileW L"C:\\Program Files\\CCP\\EVE\\lib\\carbonlib.ccp" GENERIC_READ FILE_SHARE_READ FILE_SHARE_WRITE creation 3 attributes 0x8
trace:file:RtlDosPathNameToNtPathName_U (L"C:\\Program Files\\CCP\\EVE\\lib\\carbonlib.ccp",0x339e0c,(nil),(nil)
trace:file:RtlGetFullPathName_U (L"C:\\Program Files\\CCP\\EVE\\lib\\carbonlib.ccp" 520 0x339b50 (nil)
trace:file:wine_nt_to_unix_file_name L"\\??\\C:\\Program Files\\CCP\\EVE\\lib\\carbonlib.ccp" -> "/home/name/.wine/dosdevices/c:/Program Files/CCP/EVE/lib/carbonlib.ccp
trace:file:CreateFileW returning 0x8c
trace:file:ReadFile 0x8c8 0x2c1c5fb0 512 0x339eb0 (nil
trace:file:ReadFile 0x8c8 0x2c1c5fb0 512 0x339eac (nil
trace:file:ReadFile 0x8c8 0x2c1c61cc 3272 0x339f04 (nil
trace:file:RtlGetFullPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\//ships/" 520 0x33a8d8 (nil)
trace:file:GetFileAttributesExW L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\" 0 0x33a9d
trace:file:RtlDosPathNameToNtPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\",0x33a998,(nil),(nil)
trace:file:RtlGetFullPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\" 520 0x33a6e8 (nil)
trace:file:wine_nt_to_unix_file_name L"\\??\\C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\" -> "/home/name/.wine/dosdevices/c:/users/name/Local Settings/Application Data/CCP/EVE/c_program_files_ccp_eve_tranquility/cache/ships/
trace:file:RtlGetFullPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\//ships/29984_29972_30048_30088_30122_30143.black" 520 0x33a8d8 (nil)
trace:file:RtlGetFullPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\//ships/29984_29972_30048_30088_30122_30143.gr2" 520 0x33a8d8 (nil)
trace:file:RtlGetFullPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\//ships/29984_29972_30048_30088_30122_30143.lock" 520 0x33a8d8 (nil)
trace:file:GetFileAttributesExW L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\29984_29972_30048_30088_30122_30143.black" 0 0x33a9d
trace:file:RtlDosPathNameToNtPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\29984_29972_30048_30088_30122_30143.black",0x33a998,(nil),(nil)
trace:file:RtlGetFullPathName_U (L"C:\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\29984_29972_30048_30088_30122_30143.black" 520 0x33a6e8 (nil)
trace:file:wine_nt_to_unix_file_name L"\\users\\name\\Local Settings\\Application Data\\CCP\\EVE\\c_program_files_ccp_eve_tranquility\\cache\\ships\\29984_29972_30048_30088_30122_30143.black" not found in /home/name/.wine/dosdevices/c:/users/name/Local Settings/Application Data/CCP/EVE/c_program_files_ccp_eve_tranquility/cache/ship
fixme:msvcrt:MSVCRT__wsopen_s : pmode 0x01ff ignored



It seems that one '\\??\\C:' is missing?! Hopefully this is something interesting and useful, not really sure because I'm newbie in this. The .black file is available in the mentioned directory btw.
NegatedVoid
Native Freshfood
Minmatar Republic
#50 - 2012-04-25 01:01:40 UTC
Okay, here it is, hilarious workaround time. This renders t3s invisible. And probably does evil stuff to your game.

Also, totally send me isk.

You'll need to locate your eve cache folder and adjust this from my settings.

Open a console, and input this:

while true; do rm -r ~/.wine/drive_c/users/murph/Local\ Settings/Application\ Data/CCP/EVE/c_program_files_ccp_eve_tranquility/cache/ships/*; done

This will start a continual loop that is deleting the generated ships cache (only t3s are generated, i think).

Now, in a second console, go start eve your usual way.
NegatedVoid
Native Freshfood
Minmatar Republic
#51 - 2012-04-25 01:16:02 UTC
If you do that, be warned that flying a t3 is really weird. The camera can't do a "look at" on your own ship. So you can look at other stuff, but then can't reset the camera. Not the end of the world though.,
Buzzy Warstl
Native Freshfood
Minmatar Republic
#52 - 2012-04-25 02:25:32 UTC
NegatedVoid wrote:
If you do that, be warned that flying a t3 is really weird. The camera can't do a "look at" on your own ship. So you can look at other stuff, but then can't reset the camera. Not the end of the world though.,

Oh, that is a gross hack. Tengu verry much


For my sanity I added 2>/dev/null at the end of the rm command.

http://www.mud.co.uk/richard/hcds.htm Richard Bartle: Players who suit MUDs

Palovana
Inner Fire Inc.
#53 - 2012-04-25 02:55:12 UTC  |  Edited by: Palovana
NegatedVoid wrote:
Okay, here it is, hilarious workaround time. This renders t3s invisible. And probably does evil stuff to your game.

Also, totally send me isk.

You'll need to locate your eve cache folder and adjust this from my settings.

Open a console, and input this:

while true; do rm -r ~/.wine/drive_c/users/murph/Local\ Settings/Application\ Data/CCP/EVE/c_program_files_ccp_eve_tranquility/cache/ships/*; done

This will start a continual loop that is deleting the generated ships cache (only t3s are generated, i think).

Now, in a second console, go start eve your usual way.


That is quite an ugly thing to have running, but it seems to work.

I tried just setting that dir unwriteable, but upon previewing the Tengu, the game locked up (it didn't crash) for over a minute.

When restoring the original write permissions to the cache/ships dir the game unfroze (and then crashed as it would normally when previewing a Tengu).

I ran the rm loop and Preview of Tengu and other Tech III Cruisers (Legion, Proteus, Loki) didn't cause a crash - the little "loading" circular animation just played endlessly.

Undocking and flying around the grid didn't seem to cause any issues either, including flying right up to a (now-invisible, only the bracket is displayed) Tengu.

EDIT: I wound up doing this:

  • cd ~/.wine/drive_c/users/$USER/Local\ Settings/Application\ Data/CCP/EVE/c_program_files_ccp_eve_tranquility/cache/ships/ # this command may wrap lines in a browser
  • while true; do rm *; done 2>/dev/null # Be extra sure you're in the correct directory or this will nuke your game install or worse
Suttin Inkura
Caldari Provisions
Caldari State
#54 - 2012-04-25 03:03:53 UTC
NegatedVoid wrote:
Okay, here it is, hilarious workaround time. This renders t3s invisible. And probably does evil stuff to your game.

Also, totally send me isk.

You'll need to locate your eve cache folder and adjust this from my settings.

Open a console, and input this:

while true; do rm -r ~/.wine/drive_c/users/murph/Local\ Settings/Application\ Data/CCP/EVE/c_program_files_ccp_eve_tranquility/cache/ships/*; done

This will start a continual loop that is deleting the generated ships cache (only t3s are generated, i think).

Now, in a second console, go start eve your usual way.


While disgusting, it does work.
Lairel Dallocort
Hot Lobster
#55 - 2012-04-25 03:58:26 UTC
The while loop did not work for me. As soon as I jumped onto grid on my home station I crash no matter what.
NegatedVoid
Native Freshfood
Minmatar Republic
#56 - 2012-04-25 04:08:31 UTC
Make sure you've got the right directory for your cache. Some distros put it in other places or something.

"find ~ | grep /cache/ships" should point you in the right direction, might be slow tho.
Lairel Dallocort
Hot Lobster
#57 - 2012-04-25 04:26:43 UTC
NegatedVoid wrote:
Make sure you've got the right directory for your cache. Some distros put it in other places or something.

"find ~ | grep /cache/ships" should point you in the right direction, might be slow tho.


Nah, it's correct.

I have been pouring over logs and I noticed this line that may or may not have been present prior to this patch:

Quote:
err:winediag:shader_generate_glsl_declarations The hardware does not support enough uniform components to run this shader, it may not render correctly.


Does anyone else have this? I searched on the Google and found multiple threads about wine + some game + new patch for said game breaking the game and this was present in all of them. Also, for many of these threads this error was new as of that new patch. If the thread did not mention a patch, it simply stated that "all of a sudden" their game started crashing. Could it be that CCP used a d3d command with the new patch that is not yet supported in wine? I know my hardware supports this, and enough other people are having the problem to likely rule out hardware/drivers being old.
NegatedVoid
Native Freshfood
Minmatar Republic
#58 - 2012-04-25 04:31:10 UTC
You could try doing winetricks glsl-disable and running without glsl.
Lairel Dallocort
Hot Lobster
#59 - 2012-04-25 04:33:32 UTC
NegatedVoid wrote:
You could try doing winetricks glsl-disable and running without glsl.


The client does not run with GLSL disabled for me.
DJ Rubbie
W-Space IT Department
Test Alliance Please Ignore
#60 - 2012-04-25 04:48:27 UTC
Interestingly enough, I have no problems when using the tengu itself, but when I get on grid with another tech 3 cruiser or switch subsystems on the tengu, the crash is triggered.