These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
 

Alternative way of patching

First post First post First post
Author
Rehax
Viziam
Amarr Empire
#81 - 2012-04-25 17:10:35 UTC
In thinking
Elistea
BLUE Regiment.
#82 - 2012-04-25 17:16:12 UTC  |  Edited by: Elistea
Wow how incompetent must one be to **** up every single patch in last 12 months to level that half ppl are not able to log in.
Brilliant job CCP as usual
Not to mention 3 morons who actualy LIKED this original topic - which wouldn't be here if CCP done it's job properly for once in it's history.
Raluvhimba
Ministry of War
Amarr Empire
#83 - 2012-04-25 18:27:28 UTC
Currently the Launcher downloads Win patch for OS X ! Got it solved manually !
Yaar Podshipnik
Signal Cartel
EvE-Scout Enclave
#84 - 2012-04-25 18:39:32 UTC
Client totally broken, manual patch doesn't help, repair doesn't help. Full reinstall pending.

Never had problems with the old system.
Mex Detis
Grumpy Space Hermits
Hiigaran Protectorate
#85 - 2012-04-25 19:01:20 UTC  |  Edited by: Mex Detis
Full reinstall necessary for a minor patch. Launcher is garbage - not only corrupted my Eve client install, it corrupted itself as well. Repair tool did a wonderful job listing how many blocks were missing from a huge number of files, and then erroring out every attempt to fix those problems. Though it was fun watching the Newtonian approximation method the repair tool seemed to apply to each subsequent pass.

At one point there was this glorious idea of actually testing the patch process within CCP before foisting this crap on to the user base. It would appear that maybe this idea should be brought up again, and possibly even staffed and implemented.

It might be even smarter to take this glorious reality changing idea of testing patches and link it to a bludgeoning every time a patch fails. I for one look forward to YouTube videos of developers being run through a gauntlet of club wielding users whenever they screw things up this bad.

UPDATE:

Full reinstall gets to "Register with Games Explorer" and then... APPCRASH.
Problem signature:
Problem Event Name: APPCRASH
Application Name: EVE_Online_Installer_364755.exe
Application Version: 9.9.0.37075
Application Timestamp: 4e807c58
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7601.17651
Fault Module Timestamp: 4e211319
Exception Code: c0000005
Exception Offset: 0002feb8
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

What an amazing piece of crap we've all paid for.
Bruce Blacky
Blacky Invention Research Development YinYang
#86 - 2012-04-25 19:53:38 UTC  |  Edited by: Bruce Blacky
Lliana Tadaruwa wrote:
Xiou sheyn wrote:
As a MAC client I feel like we are always second seat. Even when I submit a petition they always refer me to a Windows solution even after posting in the petition that I have a MAC client. It is very frustrating. All month I've played just a hand full of times, my research que has been empty for days now and I'm being charged for time I'm not able to play. As much as I enjoy the game I am a very dissatisfied customer right now!



Being on Linux, I wish we had a seat, considering there are more wine players than mac players.


I second that.
Being on Linux (Ubuntu) since i started playing EVE (actually that it was available for Linux was one strong reason for me to start in the first place)
I have to upgrade 10 clients which takes anything between 1 hour and 3 hours depending on the volume.
I have to switch libraries form built-in, native to native, build-in every time the launcher needs to run and back when the update is done.

And since the patch yesterday my clients crash again for no reason.


above all to the side...i still love this game

cheers
Bruce Blacky

P.S.: i might run again for CSM, just to give CCP a sign how many WINE (=Linux) pilots there are
Raluvhimba
Ministry of War
Amarr Empire
#87 - 2012-04-25 20:36:24 UTC
Yaar Podshipnik wrote:
Client totally broken, manual patch doesn't help, repair doesn't help. Full reinstall pending.

Never had problems with the old system.


Same here ! Full download & reinstall pending.
Horanda
Pickled Frogs
#88 - 2012-04-25 21:33:37 UTC
Downloaded correct Win patch file, ran launcher, and it started trying to re-download the patch.
Noticed that new patch was not named the same, so took the '_win' off the end of the filename and ran launcher again.
Patch installed quickly and game started.
Rammix
TheMurk
#89 - 2012-04-25 22:08:36 UTC  |  Edited by: Rammix
Tenris Anis wrote:
Lliana Tadaruwa wrote:
Xiou sheyn wrote:
As a MAC client I feel like we are always second seat. Even when I submit a petition they always refer me to a Windows solution even after posting in the petition that I have a MAC client. It is very frustrating. All month I've played just a hand full of times, my research que has been empty for days now and I'm being charged for time I'm not able to play. As much as I enjoy the game I am a very dissatisfied customer right now!



Being on linux, I wish we had a seat, considering there are more wine players than mac players.


At least last time I heard some numbers, there actually really more mac players than wine players, and by large. Less than a 1% of the playerbase was using linux WHILE linux was supported. Though feel free to correct me with current numbers.

How to count when even "native" linux client wasn't native but used Cedega or something like that. Linux users had to use windows client, not a native one.

Someone has already suggested in this forum to add a checkbox into Eve client to let linux users actually show themselves and be counted properly.

p.s. No one wants native linux client made from scratch. We just need all coming patches to be -- officially -- properly tested on WINE. That would have some benefits for windows users too: less bugged for WINE is also more stable for windows.
Why not to create some constant connections with WINE developers community.

OpenSUSE Leap 42.1, wine >1.9

Covert cyno in highsec: https://forums.eveonline.com/default.aspx?g=posts&t=296129&find=unread

Kaasumi
Wormholers Btw.
#90 - 2012-04-26 01:00:23 UTC
hi, before yesterdays patch I had downloaded the payload files with serial "360229".

I then downloaded the zip from this thread to patch from 360229 to the latest patch.

note this is fresh install on my old desktop. on my laptop it works fine.



Starts off with "(1/7 Downloading index: initializing...)"

And about 30 seconds later it changes that heading to "cantresolveurl"

Suggests I should run the repair tool, but when I do so it brings about an error box saying "repair.exe.log" will give more info. I cont find that log at the path it says it should be.



any help will be appreciated
Karrion NightStalker
Deep Space Rats
#91 - 2012-04-26 01:17:30 UTC
Didn't bother reading this whole thread, however.. yes i too had a problem with the download/patch some sort of failure with a message about it retrying with admin priviledges or something along those lines... I just used the repair tool from the launcher screen, it dowloaded the files and did the update to my client.
Jodge Nelprin
Astrology Majors
#92 - 2012-04-26 01:33:36 UTC  |  Edited by: Jodge Nelprin
Yeah... why the HELL would you make it so i HAVE TO USE THE LAUNCHER to patch? the ENTIRE POINT of this alt-method was so i DIDN'T HAVE TO USE THE LAUNCHER, because i CAN'T! I get this stupid bullshit message that i have ALWAYS gotten using the launcher:

Traceback (most recent call last)
File "launcher.py", line 42, in
File "lib\initialization.pyc", line 137, in StartLaunche
File "lib\initialization.pyc", line 69, in InitInf
File "lib\info.pyc", line 141, in Setu
File "lib\info.pyc", line 133, in Ge
File "lib\info.pyc", line 120, in GetLauncherInfoFun
File "lib\info.pyc", line 108, in GetLauncherInf
File "lib\info.pyc", line 93, in GetInfoFromUr
File "lib\info.pyc", line 29, in ParseInf
File "yaml\__init__.pyc", line 69, in loa
File "yaml\loader.pyc", line 34, in __init_
File "yaml\reader.pyc", line 79, in __init_
File "yaml\reader.pyc", line 135, in determine_encodin
File "yaml\reader.pyc", line 165, in updat
ReaderError: 'utf8' codec can't decode byte #x8b: invalid start byt
in "", position
Locals by frame, innermost last
Frame in launcher.py at line 54
NoInternetError =
ServerUnreachableException =

[the error goes on, but it's too long to post]
Francisco Bizzaro
#93 - 2012-04-26 07:03:26 UTC
Horanda wrote:
Downloaded correct Win patch file, ran launcher, and it started trying to re-download the patch.
Noticed that new patch was not named the same, so took the '_win' off the end of the filename and ran launcher again.
Patch installed quickly and game started.

Thanks for this suggestion. Unfortunately it didn't work for me - could you post the full name of your re-named patch file so I can compare against what I'm doing?
BANE LINX
Caldari Provisions
Caldari State
#94 - 2012-04-26 11:31:12 UTC
People, this situation is actually very simple: we are being trolled by CCP, so they could measure just much bs they could get away with; and unfortunately, they can get away with quite a bit.

Alternative patching methods? Are you serious? If we end up pretty much manually patching the game, then what the hell is the point of utilizing that fail-Launcher? The only thing it succeeded at doing was pissing me off for the past few days. GM's, I know it's not your fault, but can you guys at least update the patch link ASAP?
Shadow Evlos
ShadowMoon Corporation
#95 - 2012-04-26 12:11:32 UTC
Rehax wrote:
http://content.eveonline.com/EveOnlineLauncher/launcherInstaller/launcher_installer_TQ_131.exe


It works!!!! Thank you.

BTW, may I get a new "repair.exe", mine is broken.
Fossor Wintersky
Ordinus Ursorum Cautorum
#96 - 2012-04-26 12:14:14 UTC
Quote:

Exception during UpdaterModule.Update
Traceback (most recent call last):
File "lib\update.pyc", line 634, in Update
File "lib\update.pyc", line 688, in _Update
File "lib\update.pyc", line 413, in Run
File "zsync\zsync.pyc", line 1205, in CreatePatch
File "zsync\zsync.pyc", line 953, in GetFilesToRepair
File "checksum.pyc", line 357, in GetSum
File "checksum.pyc", line 199, in ChecksumFile
File "checksum.pyc", line 210, in ChecksumFileObject
File "core_utils.pyc", line 241, in ReadToCallback
IOError: [Errno 13] Permission denied
Locals by frame, innermost last:
Frame __bootstrap in threading.pyc at line 503:


alternative method? Lolwut? Sure?

New patch is 365866, and there are NO any link to file with NEW patch!

/me casts Summon GM. <___<
Shadow Evlos
ShadowMoon Corporation
#97 - 2012-04-26 12:19:43 UTC
Ling Sinsen wrote:
Rehax wrote:
http://content.eveonline.com/EveOnlineLauncher/launcherInstaller/launcher_installer_TQ_131.exe

Thank you!Smile
Somehow, my exeFile.exe in \bin is corrupted too.
How could I fix that? Sad


Same issue!
Shadow Evlos
ShadowMoon Corporation
#98 - 2012-04-26 12:20:56 UTC
Shadow Evlos wrote:
Ling Sinsen wrote:
Rehax wrote:
http://content.eveonline.com/EveOnlineLauncher/launcherInstaller/launcher_installer_TQ_131.exe

Thank you!Smile
Somehow, my exeFile.exe in \bin is corrupted too.
How could I fix that? Sad


Same issue!


This issue happened after I ran the newest repair.exe.
missevil mrevil
Deep Core Mining Inc.
Caldari State
#99 - 2012-04-26 12:42:11 UTC
could someone please put new patch up... the launcher still doesnt work... thank you.
Amsterdam Conversations
Doomheim
#100 - 2012-04-26 12:47:31 UTC
Launcher as always couldn't run by itself, because of asking for administrator privileges. So had to run it manually, at which point it always crashed at around step 3/7... It just closed and said nothing.

Repair tool worked though.

This updating process is horrible.