These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Science & Industry

 
  • Topic is locked indefinitely.
 

EVE Planetary Planner - Redesigned Beta version available

First post
Author
yutsaku
Garoun Investment Bank
Gallente Federation
#161 - 2017-02-07 16:15:07 UTC  |  Edited by: yutsaku
i try cleaning net framwork and reinstal it :)

ok no change same issue
yutsaku
Garoun Investment Bank
Gallente Federation
#162 - 2017-02-07 16:27:54 UTC
yutsaku wrote:
same issue here

Signature du problème :
Nom d’événement de problème: CLR20r3
Signature du problème 01: EVEPlanetaryPlanner.exe
Signature du problème 02: 8.0.0.0
Signature du problème 03: 58988586
Signature du problème 04: PresentationFramework
Signature du problème 05: 4.6.1055.0
Signature du problème 06: 563c1d45
Signature du problème 07: 5b2
Signature du problème 08: 1c
Signature du problème 09: System.Windows.Markup.XamlParse
Version du système: 6.1.7601.2.1.0.256.48
Identificateur de paramètres régionaux: 1036
Information supplémentaire n° 1: 0a9e
Information supplémentaire n° 2: 0a9e372d3b4ad19135b953a78882e789
Information supplémentaire n° 3: 0a9e
Information supplémentaire n° 4: 0a9e372d3b4ad19135b953a78882e789


some change with it :

Signature du problème :
Nom d’événement de problème: CLR20r3
Signature du problème 01: eveplanetaryplanner.exe
Signature du problème 02: 8.0.0.5
Signature du problème 03: 5899ed38
Signature du problème 04: PresentationFramework
Signature du problème 05: 4.0.30319.17929
Signature du problème 06: 4ffa7956
Signature du problème 07: 2cb
Signature du problème 08: 1c
Signature du problème 09: System.Windows.Markup.XamlParse
Version du système: 6.1.7601.2.1.0.256.48
Identificateur de paramètres régionaux: 1036
Information supplémentaire n° 1: 168e
Information supplémentaire n° 2: 168e376f4ee287e9709de3c54acb4a00
Information supplémentaire n° 3: 8d58
Information supplémentaire n° 4: 8d582b6850f919d8f3c56a8661936bac

Ideki
E.A.D Alliance
#163 - 2017-02-07 16:32:21 UTC
Ok, another version to try.
Sorry to impose that on you, but for some reason here it is working perfectly for me Sad

I also fixed an issue saving the type of command center.
yutsaku
Garoun Investment Bank
Gallente Federation
#164 - 2017-02-07 16:38:32 UTC  |  Edited by: yutsaku
same ... but the launcher are not 8.0.0.6

afk for 1h
Don Silesius
Deep Core Mining Inc.
Caldari State
#165 - 2017-02-07 16:42:57 UTC
8.0.0.6:

Failed to load.
'Set property 'EVEPlanetaryPlanner.Border.BlocksSize' threw an exception.' Line number '97' and line position '13'.
at System.Windows.Markup.XamlReader.RewrapException(Exception e, IXamlLineInfo lineInfo, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
at EVEPlanetaryPlanner.MainWindow.InitializeComponent()
at EVEPlanetaryPlanner.MainWindow..ctor()
Ideki
E.A.D Alliance
#166 - 2017-02-07 16:43:20 UTC
yutsaku wrote:
same ... but the launcher are not 8.0.0.6


?
It should be 8.0.0.6.

The auto updater did not work ?
yutsaku
Garoun Investment Bank
Gallente Federation
#167 - 2017-02-07 16:44:16 UTC
no not work i download all files from your web site
Don Silesius
Deep Core Mining Inc.
Caldari State
#168 - 2017-02-07 16:45:23 UTC
Ideki wrote:
yutsaku wrote:
same ... but the launcher are not 8.0.0.6


?
It should be 8.0.0.6.

The auto updater did not work ?


What do you mean about the auto-updater? I just redownload it manually every time I try a new version? It crashes before it can start so I’m not sure how it could launch any kind of auto-updating?
Ideki
E.A.D Alliance
#169 - 2017-02-07 16:48:34 UTC
Don Silesius wrote:
Ideki wrote:
yutsaku wrote:
same ... but the launcher are not 8.0.0.6


?
It should be 8.0.0.6.

The auto updater did not work ?


What do you mean about the auto-updater? I just redownload it manually every time I try a new version? It crashes before it can start so I’m not sure how it could launch any kind of auto-updating?



Ah it is possible the auto-updater does not even have time to kick-in

In the current (working) version, there is an auto-updater mechanism that check for the latest version and ask you if you want to download it if you do not have the latest.
I also implemented it in the Alpha.
But I am guessing the crash happens before the code even reaches that part.

This is so frustrating.
If I could at least reproduce it here... X
yutsaku
Garoun Investment Bank
Gallente Federation
#170 - 2017-02-07 16:49:32 UTC
no not work i download all files from your web site, i see on web site 8.0.0.6 (alpha) but there files downloaded are 8.0.0.5 launcher
Ideki
E.A.D Alliance
#171 - 2017-02-07 16:50:46 UTC  |  Edited by: Ideki
k. let me re-upload it again in case I messed up that.
Because I am going crazy now...

EDIT: Upload done, can you try again ?
Don Silesius
Deep Core Mining Inc.
Caldari State
#172 - 2017-02-07 16:54:57 UTC  |  Edited by: Don Silesius
Still:

Failed to load.
Exception has been thrown by the target of an invocation.
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.Activator.CreateInstance[T]()
at EVEPlanetaryPlanner.MainWindow..ctor()

I don’t see how to confirm on my side that I have the 8.0.0.6 files though (I just re-downloaded everything).

Edit. Nevermind: right-clicking and checking the details confirmed that I have 8.0.0.6.
Ideki
E.A.D Alliance
#173 - 2017-02-07 17:02:38 UTC
Don Silesius wrote:
Still:

Failed to load.
Exception has been thrown by the target of an invocation.
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.Activator.CreateInstance[T]()
at EVEPlanetaryPlanner.MainWindow..ctor()

I don’t see how to confirm on my side that I have the 8.0.0.6 files though (I just re-downloaded everything).

Edit. Nevermind: right-clicking and checking the details confirmed that I have 8.0.0.6.


Well at least the message changed, so maybe I am on the right path.
I finish my lunch and will do some more changes to try.
Give me ~20 minutes.
Ideki
E.A.D Alliance
#174 - 2017-02-07 17:05:36 UTC
oh bingo!!
I got the exception to show for me.
Not an actual solution, but at least now I can start to trace it back and figure out what is wrong!!
yutsaku
Garoun Investment Bank
Gallente Federation
#175 - 2017-02-07 17:34:02 UTC
Ideki wrote:
oh bingo!!
I got the exception to show for me.
Not an actual solution, but at least now I can start to trace it back and figure out what is wrong!!



héhé you have take the great price off brainstorming :D
Ideki
E.A.D Alliance
#176 - 2017-02-07 17:54:37 UTC
I have to go to work now, and I am not close to a solution yet.
I think I understand a bit what is the issue, and it might take me some time to fix it properly.
In short, WPF does not work the way I would expect it, and it looks I am going to have to modify some controls to make it behave properly.
I am not looking forward to it, but it's not like I have a choice...

So please be patient I will try to fix that asap.
Ideki
E.A.D Alliance
#177 - 2017-02-08 02:47:18 UTC
Let's try again.
I uploaded 8.0.0.7 with another potential fix for the BlocksSize issue.
Let me know how it goes. (cross fingers)
Don Silesius
Deep Core Mining Inc.
Caldari State
#178 - 2017-02-08 03:08:29 UTC
Ideki wrote:
Let's try again.
I uploaded 8.0.0.7 with another potential fix for the BlocksSize issue.
Let me know how it goes. (cross fingers)


Not working, but the message is different, so I guess that is some evolution?

Failed to load.
'Set property 'EVEPlanetaryPlanner.Border.BlocksSize' threw an exception.' Line number '97' and line position '13'.
at System.Windows.Markup.XamlReader.RewrapException(Exception e, IXamlLineInfo lineInfo, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
at EVEPlanetaryPlanner.MainWindow.InitializeComponent()
at EVEPlanetaryPlanner.MainWindow..ctor()

Thank you so much for working on this.
Ideki
E.A.D Alliance
#179 - 2017-02-08 03:31:10 UTC
Which version of Windows are you using ?
I am starting to wonder if it is not a Windows issue.
Some part of the error message raise that issue when searched on google...
Or do you have custom English settings ?

From what I have read, it looks like if I include one more library to the project it might work.
So there goes 8.0.0.8 for you to try.
Don Silesius
Deep Core Mining Inc.
Caldari State
#180 - 2017-02-08 03:38:26 UTC  |  Edited by: Don Silesius
Ideki wrote:
Which version of Windows are you using ?
I am starting to wonder if it is not a Windows issue.
Some part of the error message raise that issue when searched on google...
Or do you have custom English settings ?

From what I have read, it looks like if I include one more library to the project it might work.
So there goes 8.0.0.8 for you to try.


I’m using Windows 7 Professional. In English, yes, but may have some custom regional settings as I work a lot in another language. Not too sure about those language settings, but I could check for more specific stuff if it helps.

As for the new version, well first there is this message now on launch :

Unexpected token 'M8,5,7.5 l6.5,-6.5 h120 l0,8' encountered at position '8'.
at MS.Internal.AbbreviatedGeometryParser.ThrowBadToken()
at MS.Internal.AbbreviatedGeometryParser.ReadNumber(Boolean allowComma)
at MS.Internal.AbbreviatedGeometryParser.ReadPoint(Char cmd, Boolean allowcomma)
at MS.Internal.AbbreviatedGeometryParser.ParseToGeometryContext(StreamGeometryContext context, String pathString, Int32 startIndex)
at MS.Internal.Parsers.ParseStringToStreamGeometryContext(StreamGeometryContext context, String pathString, IFormatProvider formatProvider, FillRule& fillRule)
at MS.Internal.Parsers.ParseGeometry(String pathString, IFormatProvider formatProvider)
at EVEPlanetaryPlanner.Border.UpdatePaths()
at EVEPlanetaryPlanner.Border.set_BlocksSizeFromCallback(String value)
at EVEPlanetaryPlanner.Border.BlocksSizeChangedCallback(DependencyObject obj, DependencyPropertyChangedEventArgs e)

After that, the auto-updater does its thing now. It offered a new version, and to download some files (the xml files I think?). And then two windows with this message appeared:

Failed to switch element.
Cannot perform this operation while dispatcher processing is suspended.

When I click on "close", it crashes.

Edit. By the way, I’ll unfortunately have to leave for a couple of hours now. Sorry I can’t do more testing right away, but I’ll check when I’m back to see if there is something new to test.