These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

EVE Planetary Planner - Redesigned Beta version available

First post
Author
Ideki
E.A.D Alliance
#101 - 2017-01-27 14:34:23 UTC
There we go.

You want the Alpha version?
Yeah!!!

Well good news for you, the EVE Planetary Planner has his own domain now.
So go take a look

The News page is not working properly at the moment because I am fixing the script for it.
But I am guessing that's not why you would go there anyway. Big smile

So have fun and be gentle with the Alpha.
She is shy and fragile. Blink
Kiddoomer
The Red Sequence
#102 - 2017-01-27 17:20:03 UTC
Awesome you're still working on this Big smile a great tool for me to planify my factory planets.

But when I tried to launch the alpha, I got this message : "
Error

Failed to load.

The property Set ' EvePlanetaryPlanner.Border.BlockSSize ' raised an exception.
"

Seems to be just a upper case letter instead of a lower case one.

In the name of Jirai 'Fatal' Laitanen : “Some capsuleers claim that ECM is 'dishonorable' and 'unfair'. Jam those ones first, and kill them last.”

Ideki
E.A.D Alliance
#103 - 2017-01-27 18:12:22 UTC
Kiddoomer wrote:
Awesome you're still working on this Big smile a great tool for me to planify my factory planets.

But when I tried to launch the alpha, I got this message : "
Error

Failed to load.

The property Set ' EvePlanetaryPlanner.Border.BlockSSize ' raised an exception.
"

Seems to be just a upper case letter instead of a lower case one.


Thanks for trying the Alpha Big smile

Ok, I'll look at it tonight.

Meanwhile I figured out the issue with the News and started to upload older news.
Might take me a few days to get them all back.
Entdeckerin Diana
GottesLegion
#104 - 2017-01-31 20:34:47 UTC
Ich habe auch den Fehler

Failed to load.
Beim Festlegen der Eigenschaft "EVEPlanetaryPlanner.Border.BlocksSize2" wurde eine Ausnahme ausgelöst.
Ideki
E.A.D Alliance
#105 - 2017-02-05 13:52:21 UTC
Entdeckerin Diana wrote:
Ich habe auch den Fehler

Failed to load.
Beim Festlegen der Eigenschaft "EVEPlanetaryPlanner.Border.BlocksSize2" wurde eine Ausnahme ausgelöst.


Again ?
Damn, I thought I had it fixed by now.
K, I'll take a look again.
I just can't figure out why it does that because I cannot even reproduce it on my machine :(
Entdeckerin Diana
GottesLegion
#106 - 2017-02-05 19:22:10 UTC
Ideki wrote:
Entdeckerin Diana wrote:
Ich habe auch den Fehler

Failed to load.
Beim Festlegen der Eigenschaft "EVEPlanetaryPlanner.Border.BlocksSize2" wurde eine Ausnahme ausgelöst.


Again ?
Damn, I thought I had it fixed by now.
K, I'll take a look again.
I just can't figure out why it does that because I cannot even reproduce it on my machine :(



Der Fehler ist auf die Grafig Einstellungen zurück zuführen.
In der Program Datei die Border Einstellungen für das Fenster endern.
Da die Grafigkarten die darstellung des Fensters anders behandeln.
Ideki
E.A.D Alliance
#107 - 2017-02-06 01:36:45 UTC
Entdeckerin Diana wrote:
Ideki wrote:
Entdeckerin Diana wrote:
Ich habe auch den Fehler

Failed to load.
Beim Festlegen der Eigenschaft "EVEPlanetaryPlanner.Border.BlocksSize2" wurde eine Ausnahme ausgelöst.


Again ?
Damn, I thought I had it fixed by now.
K, I'll take a look again.
I just can't figure out why it does that because I cannot even reproduce it on my machine :(



Der Fehler ist auf die Grafig Einstellungen zurück zuführen.
In der Program Datei die Border Einstellungen für das Fenster endern.
Da die Grafigkarten die darstellung des Fensters anders behandeln.


Forgive me, but I do not speak German, could you please post that in English ?
Or someone else translate ?
Serhey Kvaich
Uncharted spectrum
#108 - 2017-02-06 13:29:27 UTC  |  Edited by: Serhey Kvaich
Alpha ver. error((( windows 10x64

Failed to load.
The property Set ' EvePlanetaryPlanner.Border.BlockSSize ' raised an exception.
Ideki
E.A.D Alliance
#109 - 2017-02-06 14:24:52 UTC
I have uploaded a new version with what I hope will fix that issue.

Please download it, try it and tell me if it fixed the issue this time.

Note: for now the auto update is disabled for the Alpha version, so each time you will have to download manually.
I plan to add support for it soon, but got more urgent issues to work on.
Serhey Kvaich
Uncharted spectrum
#110 - 2017-02-06 19:44:18 UTC
Ideki wrote:
I have uploaded a new version with what I hope will fix that issue.

Please download it, try it and tell me if it fixed the issue this time.

Note: for now the auto update is disabled for the Alpha version, so each time you will have to download manually.
I plan to add support for it soon, but got more urgent issues to work on.

Hi. Sorry not solved the problem
Entdeckerin Diana
GottesLegion
#111 - 2017-02-07 04:53:05 UTC
Ok

Failed to load.
Beim Festlegen der Eigenschaft "EVEPlanetaryPlanner.Border.BlocksSize2" wurde eine Ausnahme ausgelöst.


Failed to load.
Beim Festlegen der Eigenschaft "EVEPlanetaryPlanner.Border.BlocksSize" wurde eine Ausnahme ausgelöst.


Schon besser

Wie gesagt das Fenster muss anders aufgebaut werden dann kommt der Fehler auch nicht mehr.

Danke für deine Arveit weiter so.
Ideki
E.A.D Alliance
#112 - 2017-02-07 14:13:20 UTC
I have uploaded a new version of the Alpha that will hopefully resolved the problem with the BlockSize
 
I also added autoupdate support for the Alpha so you do not have to go download it manually each time.
You can get the new version here.
Serhey Kvaich
Uncharted spectrum
#113 - 2017-02-07 14:48:49 UTC
Ideki wrote:
I have uploaded a new version of the Alpha that will hopefully resolved the problem with the BlockSize
 
I also added autoupdate support for the Alpha so you do not have to go download it manually each time.
You can get the new version here.

(((

Failed to load.
"Setting properties" EVE Planetary Planner.Border.Block Size "has caused an exception.": The line number "97" and the position in the string "13".
Ideki
E.A.D Alliance
#114 - 2017-02-07 16:33:40 UTC
Thanks for the report, I just uploaded a new version that might fix the issue.
For some reason I do not have it happening on my system.
So I am very grateful that you help me debug this issue.

I also fixed an issue with saving the routes and the command center type.
Serhey Kvaich
Uncharted spectrum
#115 - 2017-02-07 19:12:23 UTC
Ideki wrote:
Thanks for the report, I just uploaded a new version that might fix the issue.
For some reason I do not have it happening on my system.
So I am very grateful that you help me debug this issue.

I also fixed an issue with saving the routes and the command center type.


Failed to load.
The destination call generated an exception.
in System.RuntimeTypeHandle.CreateInstance (RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean & canBeCached, RuntimeMethodHandleInternal & ctor, Boolean & bNeedSecurityCheck)
in System.RuntimeType.CreateInstanceSlow (Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark & stackMark)
in System.Activator.CreateInstance [T] ()
in EVEPlanetaryPlanner.MainWindow..ctor ()
Ideki
E.A.D Alliance
#116 - 2017-02-07 19:57:28 UTC
Serhey Kvaich wrote:
Ideki wrote:
Thanks for the report, I just uploaded a new version that might fix the issue.
For some reason I do not have it happening on my system.
So I am very grateful that you help me debug this issue.

I also fixed an issue with saving the routes and the command center type.


Failed to load.
The destination call generated an exception.
in System.RuntimeTypeHandle.CreateInstance (RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean & canBeCached, RuntimeMethodHandleInternal & ctor, Boolean & bNeedSecurityCheck)
in System.RuntimeType.CreateInstanceSlow (Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark & stackMark)
in System.Activator.CreateInstance [T] ()
in EVEPlanetaryPlanner.MainWindow..ctor ()


Yeah I am having troubles with wpf.
I do not even understand why the tool is working on my computer, or even my wife's computer, but nowhere else...
It will take me some time to figure it out, but I will get to it, I have some leads already.

Sorry for the delay. What?
Entdeckerin Diana
GottesLegion
#117 - 2017-02-07 20:25:20 UTC
Soory me Englich not Good.

Error -->

{"Zeilennummer \"94\" und Zeilenposition \"10\" von \"Durch den Aufruf des Konstruktors für Typ \"EVEPlanetaryPlanner.Border\", der den angegebenen Bindungseinschränkungen entspricht, wurde eine Ausnahme ausgelöst.\"."}


Problembehandlung bei Ausnahmen: System.Windows.Markup.XamlParseException

https://msdn.microsoft.com/query/dev11.query?appId=Dev11IDEF1&l=DE-DE&k=k(EHWMXamlParse)&rd=true

Ideki
E.A.D Alliance
#118 - 2017-02-08 15:23:32 UTC
Version 8.0.0.10 is up

I finally fixed the problem with the BlockSize.
I have also fixed the following issues:

  • Added support to force a reorder of the structures on a planet
  • Fixed an issue with adding a route on a planet that would show the wrong 'from' planet
  • Fixed support for the Alpha autoupdate that kept triggering at load time
  • Fixed an issue with an infinite UI update loop
  • Fixed an issue with initial position of planets and controls
  • Fixed an issue with scrollbars not showing when they should

 
Known issues:

  • Tool crash when accessing the Notifications tab
  • Exception shown when trying to add a planet


Remember that this is an Alpha version, so except bugs and crash.
Entdeckerin Diana
GottesLegion
#119 - 2017-02-08 19:55:36 UTC
Super Job

Knuddel
Nuran DeSiad
Garoun Investment Bank
Gallente Federation
#120 - 2017-02-09 12:10:46 UTC
Back after 4 years silence, yay !
Tried the new Alpha version yesterday. It started up fine already. However, after clicking around a bit it exited without any warning or error. Haven't looked.further, will try to do so the coming days.