These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

After Update launcher freezes

Author
Corra Raifen
Republic Military School
Minmatar Republic
#1 - 2017-05-29 20:06:32 UTC
Hello guys,

I'm running Archlinux 4.11.2-1 x64 and the game ran perfect.
Yesterday I saw there was a newer launcher as I have here at the forum and downloaded it.

After extracting and replacing the old nothing happened. (Seemd like.)
I started it from the shell, and after I press return nothing more as a new line seems to happen. (Even no error output or something like.)
I tried it under VBox with Ubuntu Mate and it worked.
I also tried with strace and saw that it stops working. But I haven't enough know how to understand why.

Furthermore: Where do you document the needed dependencies?

Strace output on my Arch: (I can't insert from beginning, because that's more than 5,000 characters)
At last comes "detached". At this point I pressed Ctrl + C after some minutes. This means the last output before I killed it was wait4(-1,

dup2(3, 255)                            = 255
close(3)                                = 0
fcntl(255, F_SETFD, FD_CLOEXEC)         = 0
fcntl(255, F_GETFL)                     = 0x8000 (flags O_RDONLY|O_LARGEFILE)
fstat(255, {st_mode=S_IFREG|0555, st_size=312, ...}) = 0
lseek(255, 0, SEEK_CUR)                 = 0
read(255, "#!/bin/sh\nappname=`basename \"$0\""..., 312) = 312
pipe([3, 4])                            = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [INT CHLD], [], 8) = 0
lseek(255, -262, SEEK_CUR)              = 50
clone(child_stack=NULL, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7faad91cbe10) = 1856
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigaction(SIGCHLD, {sa_handler=0x443a00, sa_mask=[], sa_flags=SA_RESTORER|SA_RESTART, sa_restorer=0x7faad8834a90}, {sa_handler=0x443a00, sa_mask=[], sa_flags=SA_RESTORER|SA_RESTART, sa_restorer=0x7faad8834a90}, 8) = 0
close(4)                                = 0
read(3, "evelauncher\n", 128)           = 12
read(3, "", 128)                        = 0
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=1856, si_uid=30584, si_status=0, si_utime=0, si_stime=0} ---
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], WNOHANG, NULL) = 1856
wait4(-1, 0x7ffe642c8d50, WNOHANG, NULL) = -1 ECHILD (No child processes)
rt_sigreturn({mask=[]})                 = 0
close(3)                                = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGINT, {sa_handler=0x4404c0, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, {sa_handler=SIG_DFL, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, 8) = 0
rt_sigaction(SIGINT, {sa_handler=SIG_DFL, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, {sa_handler=0x4404c0, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
read(255, "\ndirname=`dirname \"$0\"`\ntmp=\"${d"..., 312) = 262
pipe([3, 4])                            = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [INT CHLD], [], 8) = 0
lseek(255, -238, SEEK_CUR)              = 74
clone(child_stack=NULL, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7faad91cbe10) = 1859
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigaction(SIGCHLD, {sa_handler=0x443a00, sa_mask=[], sa_flags=SA_RESTORER|SA_RESTART, sa_restorer=0x7faad8834a90}, {sa_handler=0x443a00, sa_mask=[], sa_flags=SA_RESTORER|SA_RESTART, sa_restorer=0x7faad8834a90}, 8) = 0
close(4)                                = 0
read(3, "./.evelauncher\n", 128)        = 15
read(3, "", 128)                        = 0
close(3)                                = 0
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=1859, si_uid=30584, si_status=0, si_utime=0, si_stime=0} ---
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], WNOHANG, NULL) = 1859
wait4(-1, 0x7ffe642c8d90, WNOHANG, NULL) = -1 ECHILD (No child processes)
rt_sigreturn({mask=[]})                 = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGINT, {sa_handler=0x4404c0, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, {sa_handler=SIG_DFL, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, 8) = 0
rt_sigaction(SIGINT, {sa_handler=SIG_DFL, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, {sa_handler=0x4404c0, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
read(255, "tmp=\"${dirname#?}\"\n\nif [ \"${dirn"..., 312) = 238
rt_sigprocmask(SIG_BLOCK, [INT CHLD], [], 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [INT CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [INT CHLD], NULL, 8) = 0
clone(child_stack=NULL, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7faad91cbe10) = 1860
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGINT, {sa_handler=0x4404c0, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, {sa_handler=SIG_DFL, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7faad8834a90}, 8) = 0
wait4(-1, strace: Process 1855 detached
Corra Raifen
Republic Military School
Minmatar Republic
#2 - 2017-06-03 14:56:10 UTC
As far as I can find out is anything with the web gui, because if I symlink my Qt5 libraries and replace the EVE Qt5 libraries, it tries to work. But not before I disable the web gui (option -d ) it runs. But at file 8 of 9 it stucks and can't be found/downloaded.

Any ideas?
Andevellicus Truk
Deep Core Mining Inc.
Caldari State
#3 - 2017-06-05 22:19:37 UTC
Exact same thing happened to me. I have a suspicion that it has to do with the QT libraries, but no real idea how to fix it....