These forums have been archived and are now read-only.

The new forums are live and can be found at


  • Topic is locked indefinitely.

DX11 with Dev Version

Ragnar STS
Arcane Odyssey
Electus Matari
#1 - 2017-05-02 23:09:03 UTC
Ok. So the other day I had some horrible horrible instability and crashing. I cleared the cache, and then used the settings in the launcher to bump up to 'dev versions' wine. This fixed my instability. I Selected ccp-master dev branch and wine version currently is sitting at wine-2.6-ccp-master-27.

I still need to run it with DX9 turned on though. Are some of you getting DX11 working with this particular build or are you rolling your own?

Video driver version is nvidia-375.39 if it happens to make any sort of difference.
Ragnar STS
Arcane Odyssey
Electus Matari
#2 - 2017-05-12 03:42:23 UTC
Alright, so I'm guessing after a week of no reply, that nobody is getting dx11 to work on the supplied version of wine 2.6.

I've tried a few things and not gotten anywhere it seems.
Roughly 60% of the way through the log I see a little red error stating:

(info) Found video adapter output "\\.\DISPLAY1"
(error) No valid display adapter found
(info) Terminating process by request - returning 12

Yet the log doesn't end there, it continues trucking along just fine it seems. Near the end of the logs before it actually ceases to excecute it says a lot of:

(info)"fixme:d3d:wine3d3_check_device_multisample_type multisample_type17 not handled yet."
(info)"fixme:d3d:wine3d3_check_device_multisample_type multisample_type18 not handled yet."
(info)"fixme:d3d:wine3d3_check_device_multisample_type multisample_type19 not handled yet."

up through number 32.

It finally dumps out with handful of (info)....not error...:
"fixme:dxgi:dxgi_output_GetDisplayModeList iface 0x1b2fa0, format DXGI_FORMAT_B8G8R8A8_UNORM, flags 0, mode_count 0x339370, desc (nil) partial stub!"
"fixme:dxgi:dxgi_output_GetDisplayModeList iface 0x1b2fa0, format DXGI_FORMAT_B8G8R8A8_UNORM, flags 0, mode_count 0x339370, desc 0x2482b58 partial stub!"
"A traceback has been generated. It has been logged in the log server as stacktrace #1\r"
"C:\\tq\\code.ccp\\certifi\\core.pyj:53: DeprecatedBundleWarning: The weak security bundle is being deprecated.\r"
"Terminating process by request - returning 12"
Process 23510 finished with exit code 12

I'm not much of a troubleshooter when it comes to DirectX or wine. I have a very strong urge to run winecfg and click around in it though, but can't seem to figure out how to run the included version of wine's winecfg. The game runs beautifully on dx9, just seems to puke out on dx11 and all I seem to get is a crappy message about a display suddenly not being found when it finds it fine with 9, and errors that I imagine go away if people with other builds have it working.

Anybody have any thoughts?
The Last Solution Inc
#3 - 2017-05-17 17:47:06 UTC
Which distro do you use?

See for some ideas


Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Ragnar STS
Arcane Odyssey
Electus Matari
#4 - 2017-06-07 01:53:11 UTC
I think you misunderstand the point. The point is to find out if dx11 works on the 'stock' supplied by the launcher, or dev version wine supplied by CCP...just like on the mac clients.

I was asking with the intent of figuring out if it all worked on dx11 without mucking about building wine-staging / custom wine.

It doesn't work. Which is sort of implied by the fact that you made a long post finding the way to custom build a working one. If it worked out of the box only the best masochists would bother building their own each tiny little wine/nvidia/kernel revision to try and squeeze .2% framerate increases out. :) Most of us don't care that much about a couple percent.
guigui lechat
the no fock given
#5 - 2017-06-14 13:16:06 UTC
I had crashes on wine… I think 2.7 and since then have stayed on dx9.
The kind of crash that actually crashes my computer. Like, for no reason, my comp freezes. with or without the staging options.

I think ill give it another try since I just updated to wine 2.10 and graphic drivers update.
Ragnar STS
Arcane Odyssey
Electus Matari
#6 - 2017-07-12 03:50:32 UTC
Tested dev supplied ccp-master 'latest' and confirmed wine 2.10 today.

On my desktop it got nowhere at all.

On my freaky awesome new laptop it had trouble with the networking connection and the exefile wouldn't connect. Odd. Rolled back to 2.7 and no change.

Maybe next month.
Ragnar STS
Arcane Odyssey
Electus Matari
#7 - 2017-07-12 04:10:51 UTC  |  Edited by: Ragnar STS

Fixed my shizzles.

Ok - Mint Linux here,

Eve Launcher set to DX11 and working - settings button and 'Run clients with DX9' -- Unchecked.
Used Dev versions -- checked
Dev branch -- ccp-master
Wine version -- Latest.

Tweaks done to make it work (not dx11 related....but seems to make it work after July2017 update):

WINEPREFIX=~/.eve/wineenv/ ~/.eve/wine/bin/winecfg

sudo apt-get install libnss-mdns:i386

This fixes the network resolution error on the windows/wine game.

After that the game launched but showed all black - no ship, no background, no nothing except all the menus. I change. I pulled up the video settings and turned everything low...didn't help. I then hit the 'Reset graphics settings'.

Holy crap it is more beautiful. :) Winning!

Laptop seems pretty hot, but no noticeable difference in framerate. Only noticeable problem is no transparency in the menus and windows.
Ragnar STS
Arcane Odyssey
Electus Matari
#8 - 2017-07-12 04:20:04 UTC
It actually appears that previous efforts at combating artifacting ( turning off post processing ) is what causes the graphics blackout. All the other settings can be edited to fit your preferences, but post processing NEEDS to be at least set to low.

High is actually kind of irritating around a star....low is less obnoxious.
Ragnar STS
Arcane Odyssey
Electus Matari
#9 - 2017-07-12 04:34:22 UTC I can't go back to dx9. Planets didn't look right on my networking connection for eve is borked on dx9.

#10 - 2017-07-12 21:40:29 UTC  |  Edited by: Merkwurkdigliebe
The thing I love most about EVE? Its so damned educational!

Try adding the 4 from mdns4 in /etc/nsswitch.conf maybe?

Mine is:

hosts:          files mdns4_minimal [NOTFOUND=return] dns
networks:       files
netgroup:       nis

I have libnss-mdns for x64 but not i386
I have libavahi-client3:i386 and x64, which also provides multicast

Apparently they are part of desktop and xfce task... Id have picked up the i386 versions with the apt-get upgrade after adding i386 support.

$ apt-cache rdepends --no-suggests --no-conflicts --no-breaks --no-replaces --no-enhances --installed --recurse libnss-mdns
Reverse Depends:
Reverse Depends:
#11 - 2017-07-12 22:56:11 UTC
Ah hah!

So you got me curious so I tried and got DX11 working with no trouble at all (except yours, heh)

Instead of latest I used

dev branch: ccp-master
wine: wine-2.10-ccp-master-29

Then let it do it's downloads, added DX11 native in winecfg using your command, and restarted. Works fine for me but I have older hardware and all medium settings.

The graphics at medium seem slightly crisper somehow and I had no problem looking at Amarr V. That said they also seemed slightly laggier, I have read elsewhere that the debug will slow things down so I checked my logs and sure enough a lot of 'fixme' lines which are the big slow down.. I'm going to try adding -all after I reboot. Apparently when I closed eve something didn't kill the window properly. I closed it and the xfce top panel became inaccessible I want to reboot so I test the debug switch in a clean state. Heres an idea of the working errors:

wine    error    "err:d3d:wined3d_guess_card Unrecognized renderer \"GeForce GT 740/PCIe/SSE2\", falling back to default."
wine    error    "err:winsock:interface_bind Failed to bind to interface, receiving broadcast packets will not work on socket 0630."
2017-07-12T15:28:41.535Z        wine    debug   "fixme:heap:RtlSetHeapInformation 0x490000 0 0x32fce4 4 stub"
2017-07-12T15:28:41.548Z        wine    debug   "fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub"
2017-07-12T15:28:44.815Z        wine    debug   "fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0xa3ea28c 1 C) semi-stub"
2017-07-12T15:28:44.815Z        wine    debug   "fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0xa3ea08c 1 C) semi-stub"
2017-07-12T15:28:44.825Z        wine    debug   "fixme:heap:RtlSetHeapInformation 0x490000 0 0x328274 4 stub"
2017-07-12T15:28:45.413Z        wine    debug   "fixme:win:EnumDisplayDevicesW ((null),0,0x328868,0x00000000), stub!"
2017-07-12T15:28:45.475Z        wine    debug   "fixme:win:EnumDisplayDevicesW ((null),0,0x328868,0x00000000), stub!"
2017-07-12T15:28:45.549Z        wine    debug   "fixme:win:EnumDisplayDevicesW ((null),0,0x328618,0x00000000), stub!"
2017-07-12T15:28:45.554Z        wine    debug   "fixme:dxgi:dxgi_check_feature_level_support Ignoring adapter type."
2017-07-12T15:28:45.554Z        wine    debug   "fixme:dxgi:dxgi_device_init Ignoring adapter type."
2017-07-12T15:28:45.563Z        wine    debug   "fixme:d3d11:device_parent_create_swapchain_texture device_parent 0x1385ac, container_parent 0x13f798, wined3d_d$
2017-07-12T15:28:45.564Z        wine    debug   "fixme:d3d11:device_parent_create_swapchain_texture Implement DXGI<->wined3d usage conversion."
2017-07-12T15:28:45.594Z        wine    debug   "fixme:win:EnumDisplayDevicesW ((null),0,0x3284f8,0x00000000), stub!"
2017-07-12T15:28:45.594Z        wine    debug   "fixme:win:EnumDisplayDevicesW ((null),1,0x3284f8,0x00000000), stub!"
2017-07-12T15:28:45.660Z        wine    debug   "fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x3282fc 1 C) semi-stub"
2017-07-12T15:28:45.678Z        wine    debug   "fixme:reg:GetActiveProcessorGroupCount semi-stub, always returning 1"
2017-07-12T15:28:45.736Z        wine    debug   "fixme:win:EnumDisplayDevicesW ((null),0,0x3274c8,0x00000000), stub!"
2017-07-12T15:28:45.741Z        wine    debug   "fixme:dxgi:dxgi_check_feature_level_support Ignoring adapter type."
2017-07-12T15:28:45.742Z        wine    debug   "fixme:dxgi:dxgi_device_init Ignoring adapter type."
2017-07-12T15:28:45.744Z        wine    debug   "fixme:d3d11:device_parent_create_swapchain_texture device_parent 0x14edc4, container_parent 0x14e7c8, wined3d_d$
2017-07-12T15:28:45.745Z        wine    debug   "fixme:d3d11:device_parent_create_swapchain_texture Implement DXGI<->wined3d usage conversion."
2017-07-12T15:28:45.755Z        wine    debug   "fixme:d3d11:d3d11_device_CheckFormatSupport iface 0x14ed98, format 0, format_support 0x327c60 partial-stub!"

#12 - 2017-07-12 23:18:56 UTC  |  Edited by: Merkwurkdigliebe
It may well be less laggy too. I declare DX11 to be slightly better then DX9 on my hardware for the 5 minutes I played :)

AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
NVIDIA Corporation GK107 [GeForce GT 740] (rev a1)
4 gigs ram

Interestingly the tab out behavior seems to work more like you'd expect it to. When I tabbed out to write this it went into a smaller windowed mode and I had to use alt enter twice to get it to full window then fullscreen.. It wasn't doing a very stable job of switching before so thats cool, but apparently when in fullscreen it doesn't close properly.

Really impressed how far both the launcher and wine have come.

P.S. Do you have Use system configuration for proxy checked? I do.
Ragnar STS
Arcane Odyssey
Electus Matari
#13 - 2017-07-13 00:11:50 UTC  |  Edited by: Ragnar STS
Well bugger. Today DX11 fired right up and I didn't make any changes from last night when I decided to sleep instead of continuing to troubleshoot how I broke it.

I am using system proxy. considering there isn't any option to set anything else if you uncheck it...well just seems like a broken option. :)

I have heard of issues with dx11 and transparency still with wine. So I am still generally just happy it is somewhat working. Only a deal breaker on the windows. Didn't realize how much I depend on that little bit of transparency. The planets look borked...but that is ok. :)

As of today....Latest is 2.10 fix you're using the same wine. Manually selecting it just forces it to not autoupdate later on.
Ragnar STS
Arcane Odyssey
Electus Matari
#14 - 2017-07-13 02:18:43 UTC I tried DX11 on the desktop. Performance is similar to DX9, and transparency in the boxes works fine. My desktop rig is rather similar to yours with an old Phenom X3 cpu and using a nvidia 750 ti video card. My laptop has a much newer nvidia 1060 in it, which apparently isn't quite as capable right now.

Same loads, same binary driver blob. Interesting. Not quite as concerned about overheating on my desktop. Planets are slightly less wonky. I think the sun seems to flicker a bit on both machines though. Will be fun to continue testing at least. Kind of exciting that wine is doing a much better job than it was even a couple months ago.
Debian Severasse
The Scope
Gallente Federation
#15 - 2017-07-15 17:19:38 UTC
OK---I'm in also......Using ccp-master & latest as the wine version. My rig is a bit stronger---i7 3.7g & 16g ram-SLI nVidia 960GTX with 4g of ram each. Running everything on high in EVE settings--Dammmm, it looks great...bit of bloom, but all-in-all nicer than DX9. Don't think that I'll be going back to DX9 anytime soon......

Any idea on the black windows? I've made them as small as possible, but you're right---I didn't know how much I relied on the sides.....Not as bad as if my screen space was smaller (I'm a LG 32in ultra-wide), even so---seeing from the sides is very important ....

"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :) Linux User# 395230

Ragnar STS
Arcane Odyssey
Electus Matari
#16 - 2017-07-17 20:01:21 UTC
Borked my thing today and it wouldn't load. Purely my fault. I might have typed something about clean and purge into a terminal. It may or may not have removed libldap:i386....

Fixed with:

sudo apt-get install libldap-2.4.2:i386

Obviously your mileage my vary depending on your chosen package manager. Just stop deleting old stuff like 32 bit libraries. Lol
Ragnar STS
Arcane Odyssey
Electus Matari
#17 - 2017-07-20 01:54:49 UTC
I have noticed some severe artifacting during hacking minigame. All kinds of goofy hacking symbols popping up all over. This only occurs when shader quality is set to high. Shader to medium seems to resolve it.