These forums have been archived and are now read-only.

The new forums are live and can be found at

Issues, Workarounds & Localization

  • Topic is locked indefinitely.

Windows 7: launcher won't launch, repair tool won't repair

Mara Rinn
Cosmic Goo Convertor
#1 - 2017-02-24 09:45:37 UTC  |  Edited by: Mara Rinn
My long suffering other half is using Windows 7 (being the source of said suffering) and has encountered an error with the launcher:

Your EVE client installation may have modified, damaged or corrupt files.
Verification failed:
'C:\ProgramData\CCP\EVE\SharedCache\tq\bin\_trinity_dx11_deploy.dll', crc:6e3b3aea, expected:e78fa1ec

When we try running the repair tool we get this:

Traceback (most recent call last):
  File "", line 372, in module
  File "updateSelf.pyc", line 85, in UpdateSelf_nt
  File "updateSelf.pyc", line 15, in ReadUpdateInfo
  File "repairTool\repairTools.pyc", line 234, in GetRepairInfo
  File "repairTool\repairTools.pyc", line 146, in SafeUrlOpen
TypeError: __init__() takes exactly 6 arguments (2 given)

I've seen other attempts at fixing this issue start with a statement of the problem, but then no followup in the last year or so.

We tried turning it off and back on again (literally: shut down Windows, start computer back up). And now the launcher appears to be actually working, the blue bar progresses across the bottom of the window indicating that stuff is supposedly being downloaded, then we get the "damaged or corrupt files" warning again.

We have:

  • Turned it off and back on again
  • Tried running the repair tool (but that's ancient and doesn't work)
  • Turned off anti-virus, rebooted, opened the launcher again

Amazing stuff these modern operating systems :D

Any suggestions on where to go from here?