These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Skill Discussions

 
  • Topic is locked indefinitely.
 

EVEMon - The Open Source Character Planner - The Ashilta Era

First post
Author
Tonto Auri
Vhero' Multipurpose Corp
#121 - 2017-05-24 17:18:06 UTC
What about scheduler crashes?

Two most common elements in the universe are hydrogen and stupidity. -- Harlan Ellison

Samuelus8728
Galactic Corp
#122 - 2017-05-26 08:50:07 UTC
Anyone else having a problem retrieving multiple acc's?
Arya Elf-Bron
Mouth Trumpet Cavalry.
Mouth Trumpet Cavalry
#123 - 2017-05-26 22:19:16 UTC
So, when I export the after plan character to look at it in pyfa, because of the recent bug with detecting whether the account is alpha or omega that character shows up as alpha. Unfortunately, even though the character has many of the necessary skills trained, they do not show up as trained in pyfa because of this. Any way around this? Thanks!
Ashilta
Escalated.
Project Gungnir.
#124 - 2017-05-27 09:40:52 UTC  |  Edited by: Ashilta
Hey folks,

Apologies I've not been around so very much. I lost my job at the start of the year and it took me two months to find a new role; as such, pretty much every waking hour was spent looking at job boards, speaking to recruitment agencies and honing my CV time and time again. I'm now gainfully employed again, but it's taken me some time to settle in. To top it all off, I get married in three days, so it's been a really busy few months.

To address some concerns in the briefest of forms:

  • There are some ongoing concerns relating to querying account status. Long story short, as part of my work to migrate from the old XML API to ESI, it's becoming apparently we're going to lose the ability to query this directly from ESI. CCP views whether or not an account is an Alpha or an Omega as information that does not need to be queries; it is deemed not to relate to the character or to things within the EVE universe and so it won't be information readily available to us.
  • Instead, I've got to come up with some way of "determining" whether or not a character is an omega or alpha character. This will undoubtedly be less accurate than if we could query the information directly, but I'm currently thinking over the options to try to make this as accurate as possible.
  • Again, as part of the migration to ESI, I've run into some problems making the appropriate SSO requests. For EVEMon to work with its' current functionality, the number of scopes required is causing problems with the SSO process, specifically that when the redirection occurs to the login page, the original query string is retained in a new query string, and it's so long that it' generating errors. CCP Bartender has kindly opened an issue with the appropriate team, and we await their resolution.
  • Until the SSO problem is addressed, I'm stuck between a rock and a hard place. I can either implement a process by which you, as the user, would be required to authenticate each character, multiple times, to obtain multiple tokens for multiple scopes, or I can sit and wait. I've roughly calculated that I'd need three tokens, meaning that if you have three accounts, you've got to authenticate with SSO 27 times to have all characters tracked fully in EVEMon. Considering that I've seen reports of people managing 50+ characters in EVEMon, this seems unacceptable to me.
  • The Citadel crashing issue has been mitigated against through a contribution by DefectiveNu - you have my thanks.


I'm aiming to get a release of the binaries and the latest SDE out over the weekend, after which I'll be jetting off to a sunny place for my honeymoon. I'll have a chat with CCP Bartender again soon and see if we can get some traction on the SSO issue to finally the API situation.

TL;DR - I've been busy, there are SSO problems, DefectiveNu deserves your recognition.

Speak soon!
Ashilta

28/May UPDATE: There's something amiss with the data import tool, in that it doesn't recognise some of the more recently introduced ships as displayable and so they don't appear in the ship browser... I'm (probably) going to have to forget about the release until i get back from Honeymoon... Sorry all!
Vixen Vix
Hack the Planets
B.E.N.E.V.O.L.E.N.C.E
#125 - 2017-05-29 10:48:19 UTC
Ashilta wrote:

TL;DR - I've been busy, there are SSO problems, DefectiveNu deserves your recognition.

Speak soon!
Ashilta

28/May UPDATE: There's something amiss with the data import tool, in that it doesn't recognise some of the more recently introduced ships as displayable and so they don't appear in the ship browser... I'm (probably) going to have to forget about the release until i get back from Honeymoon... Sorry all!
Hey mate! Good to see you again and hear that you are well :) I was following your refactoring. Keep up the good work.

I think the credits for citadel fix should go to Henry Lajoie (HTL2001).
https://github.com/HTL2001/evemon/commit/6f8e185fb5ae9a20fd0fac48f6f63c103b0b0690 he made change on github earlier. DefectiveNu made PR.

PS.
For the impatiens I'll post my binary in the usual place (see my previous posts).
Samuelus8728
Galactic Corp
#126 - 2017-05-29 17:59:18 UTC
Am I the Only one suffering this?

is it possible that having an alpha and omega acc in evemon is breaking it for me?
I constantly get error querying blah di blah from server but only for the omega acc (2nd one added)

I deleted and recreated my api keys for both 2 days ago which fixed that the alpha wouldn't query either before.
Then i had the previous error of only the alpha and not the omega querying successfully.

And since then they're both not retrieving again.
Vixen Vix
Hack the Planets
B.E.N.E.V.O.L.E.N.C.E
#127 - 2017-05-30 10:39:50 UTC
Samuelus8728 wrote:

I constantly get error querying blah di blah from server but only for the omega acc (2nd one added)

I deleted and recreated my api keys for both 2 days ago which fixed that the alpha wouldn't query either before.
Then i had the previous error of only the alpha and not the omega querying successfully.

And since then they're both not retrieving again.
Hi! You should learn to report malfunctions. Software errors in particular.


  1. What EVEMon version do you use?
  2. What "constantly" means? Do you restart constantly EVEMon every 5 minutes or is it running for 2 hours?
  3. "blah di blah" is not an error. Write exactly what error says. Make a screenshot.
  4. Clear EVEMon cache File->Clear Cache


Connection errors are related to internet connection. Either CCP API is unresponsive or you have internet problems. Seems you have the later.
Ellysea
Alcoholocaust.
Test Alliance Please Ignore
#128 - 2017-06-04 02:40:13 UTC
Color keys for plan are not functioning properly?

I have skills already in my queue which Evemon reads properly. However, when I load a plan, it doesn't recognize which of these skills are already in my queue (ie. those should be colored blue).
Tonto Auri
Vhero' Multipurpose Corp
#129 - 2017-06-04 09:27:13 UTC
Ellysea wrote:
Color keys for plan are not functioning properly?

WJFFM

Two most common elements in the universe are hydrogen and stupidity. -- Harlan Ellison

Ellysea
Alcoholocaust.
Test Alliance Please Ignore
#130 - 2017-06-05 02:45:06 UTC
Tonto Auri wrote:
Ellysea wrote:
Color keys for plan are not functioning properly?

WJFFM


Strange. Will re-install Evemon and see if that helps.

Thanks.
Rhom Achensa
Ascendance
Goonswarm Federation
#131 - 2017-06-05 17:54:36 UTC
Hi, I think Ashilta addressed this in their most recent post a week ago, but I wanted to make sure I'm correct. I'm an Alpha at the moment and my skill planner shows every skill, even ones that aren't available to me.
Does anyone know of a workaround where I could maybe manually set my account status? Thanks!
Zirqel Vinqel
Aliastra
Gallente Federation
#132 - 2017-06-07 16:46:33 UTC  |  Edited by: Zirqel Vinqel
Any info on how to run it in Linux?
EVE runs fine, but EVEmon asks .net, installed bunch of them, still crashes.
Ubuntu 16.10

-edit:
I fiddled little bit more and got program to start and give error report.
https://pastebin.com/bZ2N0xXQ
Luscius Uta
#133 - 2017-06-09 09:28:57 UTC
I have a feature suggestion:

Give us a prompt to delete a skill plan if all skills in it are completed. The check could run either when EVEMon starts or when you open the character with such skill plan.

Workarounds are not bugfixes.

Virginia McElhone
No Life Industries LLC
#134 - 2017-06-17 15:39:18 UTC  |  Edited by: Virginia McElhone
Eve Mon is killing my internet connection for a solid 5 minutes now every time I start the program.

The only error I get is " An Error occurred while querying the server status " Which I suspect is just because I have no internet connection.

I've tried nuking and reinstalling a couple of times now with no success.

Any ideas on a fix or work around as I've been using evemon for a lot of years and don't want to change , but the whole killing my router everytime it starts is getting old.

Any help appreciated.


* Made new limited Apis that only have Skill and wallet stuff and am having 0 problems now. So maybe it was the corp industry jobs or the corp Apis . I don't know and don't really have the time to trouble shoot it myself. But it works for what I need it for and I don't need to look for anything else :)
chez1962
KarmaFleet
Goonswarm Federation
#135 - 2017-06-21 16:45:34 UTC  |  Edited by: chez1962
Hi guys,

EVEMon dont update the account status anymore?

I have version 3.0.3 off EVEMon

Any suggestions?

regards
chez

Dying is not scary, It's almost like we've been prepering for it our whole live's. But it was very sad. I didn't want to go. I love my life. I no longer try to be right. I choose to be happy.

Zirqel Vinqel
Aliastra
Gallente Federation
#136 - 2017-06-25 04:08:29 UTC
Please make Evemon work on Linux.
Cyber God
Spartan Vanguard
Test Alliance Please Ignore
#137 - 2017-07-05 21:29:17 UTC
Are we any closer to a full update of the program yet?
Marcus Tedric
Zebra Corp
Goonswarm Federation
#138 - 2017-07-18 14:21:22 UTC
As of dt today - no longer shows the effects of Implants on Attributes or SP/hr.

Times to complete seem accurate mind you.

Don't soil your panties, you guys made a good point, we'll look at the numbers again. - CCP Ytterbium

Brazero
#139 - 2017-07-19 14:35:07 UTC
Marcus Tedric wrote:
As of dt today - no longer shows the effects of Implants on Attributes or SP/hr.

Times to complete seem accurate mind you.


Yes I have that same problem, and I thought for a moment CCP did yet another stealth nerf Shocked
Multavious
Nightmare Vine
#140 - 2017-07-19 20:46:22 UTC
Marcus Tedric wrote:
As of dt today - no longer shows the effects of Implants on Attributes or SP/hr.

Times to complete seem accurate mind you.


I am having this issue as well. Using EVEMon's API tester for the "CharacterSheet" method, I see that the API is no longer returning the implant "typeName" values for implant slots 1-4 (they are empty strings). This is true for me for all characters across 2 different accounts.

Other implant slots seem to be working though, it's just slots 1-4.