These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Launcher

 
  • Topic is locked indefinitely.
Previous page12
 

EVE Launcher version 1097946

First post
Author
Xuzi
Pator Tech School
Minmatar Republic
#21 - 2016-11-27 11:20:59 UTC
CCP Snorlax wrote:

In the latest beta version of the launcher I've actually removed the Reset button and moved that functionality into the Verify process. I've also fixed one issue that might explain why the launcher gets into this state, and I'm adding more logging and trying to improve error handling.


I know that for me personally the most likely reason I got into this state was because I'm usually downloading these smaller patches over dial-up which results in a lot of interrupted file transfers that have to be restarted, but often are timed out and won't restart again without another laucher start. Often it will try and work with files it hasn't fully downloaded which results in it trying to work with a "corrupt" file.

I noticed in one of the other threads where someone had this same issue, they had closed the launcher mid patch.
https://forums.eveonline.com/default.aspx?g=posts&t=501542&find=unread

I often lament when watching loglite (which I now always have up when patching) is how poorly the launcher performs at downloading files compared to most download managers you find in modern web browsers or browser add-ons. On the other hand it has definitely improved significantly at this task since its earlier incarnations.

If you can make it more robust over poor/slower connections, it might smooth things out for these sorts of edge cases.
Raynor Oskold
Sebiestor Tribe
Minmatar Republic
#22 - 2016-11-28 03:05:15 UTC  |  Edited by: Raynor Oskold
CCP Snorlax wrote:
Xuzi wrote:
I managed to fix the problem I posted above. The launcher is skipping the "Downloader for Tranquility" step and not downloading files that are missing/corrupt.

First my suggested fix for players, second a full accounting of everything I did and what I observed, for the devs.

Open the launcher, under the E menu, select shared cache.
On the shared cache interface, verify the cache integrity (I had already done this and doesn't fix anything on its own, but you want to make sure you've done this first), it takes some time. Then push the button for 'reset last known build information'.
Fully close the launcher and restart it. This time it should see the files its missing and download them the way it should and fix your problems.

What I noticed in the loglite entries was that the launcher was trying to copy files that didn't' exist, which didn't make sense since it was telling me it was fully patched. So what I tried to do was to copy and rename the file it was looking for from my sisi folder, back into the shared cache, so it had something to find and copy. This worked and revealed the next file it was missing. I had two missing files. Doing this for both allowed the launcher to copy the files it wanted into the tq folder and start the client at which point the client saw these two files as corrupt/modified for obvious reasons. So, I verified the cache again to get rid of them and tried the 'reset last known build information' button which I figured might make the launcher do some sort of recheck of some sort. What I noticed in the loglite logs from before and after this was that before the launcher was skipping the "Downloader for Tranquility" step, but afterwards it did execute that step which allowed it to download the missing files.

Hope this helps some folks.

Thanks for this, this is quite useful.

In the latest beta version of the launcher I've actually removed the Reset button and moved that functionality into the Verify process. I've also fixed one issue that might explain why the launcher gets into this state, and I'm adding more logging and trying to improve error handling.


Hey Snorlax, I've been battling this particular bug that Xuzi mentioned all weekend, I've tried literally EVERYTHING I can think of to fix it, you can see the particular error I was getting in the thread I made, I also opened a support ticket on it, although it being the weekend I had little hope of help before Monday.

Some comments/questions I have on this are: First and foremost, regarding the functionality you mentioned in the new beta launcher, I did switch to the beta launcher just to see if anything was different, and while I was rather ecstatic that the beta launcher actually acknowleged the missing files, it gave me an error "missing files cannot be copied while clients are running". Which is insanely frustrating considering that there are no clients running, that's the entire problem in the first place. So while it's a step in the right direction, its definitely got some bugs.

Second, I'm sure Xuzi's solution will work, and in fact its one of the first things I tried, however I'm in the same boat she is, I download my patches on a terribly slow connection, and when I tried to reset it downloaded a 48mb patch, but then for some reason a 900mb patch behind it, that was not feasible on the connection I was running, so I cancelled it. I instead opted to replace the entire Eve directory with my friend's working up to date one.

Third, the "verify cache" button has never been clickable for me, instead there's some red text next to it "some indices are missing" can you comment on what might be causing this. What I did find was a file named "rescache" in EVE/Sharedcache/tq, however running this file brought up 0 corrupted files and 0 missing files.

and finally, I have my friend's working version of both launcher and client, he's been playing the entire weekend, and we've interchanged our EVE directories several times after patches with no issues. However in this particular case my PC won't recognize that his files are up to date even when I delete the entire EVE directory and replace it with his, so there must be some file stuck somewhere that is telling the launcher it needs to extract this ghostfile regardless of the state of the launcher/sharedcache, I've tried purging both the CCP folders in the programdata folder and the user/appdata/local folders to no effect, what is causing the launcher to retain this piece of memory?
CCP Snorlax
C C P
C C P Alliance
#23 - 2016-11-28 09:15:58 UTC
Raynor Oskold wrote:

...

Third, the "verify cache" button has never been clickable for me, instead there's some red text next to it "some indices are missing" can you comment on what might be causing this. What I did find was a file named "rescache" in EVE/Sharedcache/tq, however running this file brought up 0 corrupted files and 0 missing files.

...

The Verify can't do its job until it has downloaded all relevant indices. If you have the test servers enabled, by default Singularity and Duality - then Verify isn't available until those have finished downloading as well. You can disable them in the Settings if you don't care about logging into test servers. This will make the Verify accessible earlier.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

CCP Snorlax
C C P
C C P Alliance
#24 - 2016-11-28 09:22:10 UTC
Raynor Oskold wrote:

...
Some comments/questions I have on this are: First and foremost, regarding the functionality you mentioned in the new beta launcher, I did switch to the beta launcher just to see if anything was different, and while I was rather ecstatic that the beta launcher actually acknowleged the missing files, it gave me an error "missing files cannot be copied while clients are running". Which is insanely frustrating considering that there are no clients running, that's the entire problem in the first place. So while it's a step in the right direction, its definitely got some bugs.
...

I'm curious to see your logs. Could you file a bug report, attaching the launcher logs? You'll find them in %LOCALAPPDATA%\CCP\EVE\Launcher.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Raynor Oskold
Sebiestor Tribe
Minmatar Republic
#25 - 2016-11-28 17:44:11 UTC
CCP Snorlax wrote:
Raynor Oskold wrote:

...
Some comments/questions I have on this are: First and foremost, regarding the functionality you mentioned in the new beta launcher, I did switch to the beta launcher just to see if anything was different, and while I was rather ecstatic that the beta launcher actually acknowleged the missing files, it gave me an error "missing files cannot be copied while clients are running". Which is insanely frustrating considering that there are no clients running, that's the entire problem in the first place. So while it's a step in the right direction, its definitely got some bugs.
...

I'm curious to see your logs. Could you file a bug report, attaching the launcher logs? You'll find them in %LOCALAPPDATA%\CCP\EVE\Launcher.


Unfortunately with the Launcher only saving the last 5 logs those from the beta are long overwritten, I have since switched back to the release launcher and opened/closed the launcher many times. On the bright side I did fix the issue with Xuzi's method, resetting the launcher version thingus.
CCP Snorlax
C C P
C C P Alliance
#26 - 2016-11-28 18:23:59 UTC
Raynor Oskold wrote:
CCP Snorlax wrote:
Raynor Oskold wrote:

...
Some comments/questions I have on this are: First and foremost, regarding the functionality you mentioned in the new beta launcher, I did switch to the beta launcher just to see if anything was different, and while I was rather ecstatic that the beta launcher actually acknowleged the missing files, it gave me an error "missing files cannot be copied while clients are running". Which is insanely frustrating considering that there are no clients running, that's the entire problem in the first place. So while it's a step in the right direction, its definitely got some bugs.
...

I'm curious to see your logs. Could you file a bug report, attaching the launcher logs? You'll find them in %LOCALAPPDATA%\CCP\EVE\Launcher.


Unfortunately with the Launcher only saving the last 5 logs those from the beta are long overwritten, I have since switched back to the release launcher and opened/closed the launcher many times. On the bright side I did fix the issue with Xuzi's method, resetting the launcher version thingus.

Oh, well.

If you do give the beta version another go at some point in the future, please file a bug report attaching logs if you encounter any issues.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Eric de'Locke
Rapid Withdrawal
Pen Is Out
#27 - 2016-11-30 02:52:43 UTC
Launcher doesn't remember which client is logged in when closed to system tray on Windows 7.
CCP Snorlax
C C P
C C P Alliance
#28 - 2016-11-30 10:14:28 UTC
Eric de'Locke wrote:
Launcher doesn't remember which client is logged in when closed to system tray on Windows 7.

I thought I'd fixed that - I'll take another look.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Previous page12