These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

EVE-O Preview v3.0.0 (multi-client preview / switcher)

Author
Phrynohyas Tig-Rah
SoT
DarkSide.
#101 - 2017-01-07 15:53:42 UTC
Faylee Freir wrote:
I'm having an issue getting the keybinds to work. I followed the example in the readme, but I'm not sure if I've set it up correctly.

},
    "ClientHotkey": {
    "EVE - Character One": "1",
    "EVE - Character Two": "2",
    "EVE - Character Three": "3",
    "EVE - Character Four": "4",
    "EVE - Character Five": "5",
    "EVE - Character Six": "6"
}


Any help would be greatly appreciated!


I would stronly recomment to avoid setting hotkeys to alphanumeric keys w/o modifiers. Otherwise these hotkeys will conflict with chat windows ets.

IOW you cannot do


    "EVE - Character One": "1",


but you can do (just double-checked that it works ;-) )


    "EVE - Character One": "Alt+1",



    "EVE - Character One": "Control+1",



    "EVE - Character One": "Shift+1",
Faylee Freir
Brutor Tribe
Minmatar Republic
#102 - 2017-01-08 11:55:35 UTC
Phrynohyas Tig-Rah wrote:
Faylee Freir wrote:
I'm having an issue getting the keybinds to work. I followed the example in the readme, but I'm not sure if I've set it up correctly.

},
    "ClientHotkey": {
    "EVE - Character One": "1",
    "EVE - Character Two": "2",
    "EVE - Character Three": "3",
    "EVE - Character Four": "4",
    "EVE - Character Five": "5",
    "EVE - Character Six": "6"
}


Any help would be greatly appreciated!


I would stronly recomment to avoid setting hotkeys to alphanumeric keys w/o modifiers. Otherwise these hotkeys will conflict with chat windows ets.

IOW you cannot do


    "EVE - Character One": "1",


but you can do (just double-checked that it works ;-) )


    "EVE - Character One": "Alt+1",



    "EVE - Character One": "Control+1",



    "EVE - Character One": "Shift+1",

Ok I will try that. Is the formatting for that alright, or did I mess something up?
Phrynohyas Tig-Rah
SoT
DarkSide.
#103 - 2017-01-08 14:54:04 UTC
Yes, the formatting itself was OK
William Hazard
Literally The Worst Community
#104 - 2017-01-19 14:49:22 UTC
Hello,

I'm using it occasionnaly but I have a weird issue with your tool.

It works pretty well all the time BUT with one of mine account.

When Eve-o preview is launched before Eve, the game starts and works as expected until the character seletion screen. With 2 toons it'll continue working properly but with the third one the game will change its definition to something very small (like 150*80 pxl) and relocate the window out of my screen.

The issue always happens with the same account and only with this character, not the other two. Thats really weird.

If i stop eve-o preview, launch eve, select this toon, then launch eve-o preview again, it'll be ok and work.
Phrynohyas Tig-Rah
SoT
DarkSide.
#105 - 2017-01-19 18:28:48 UTC
Hello

That's weird. Could you send me your config file (see the starting post to find out how to do this)? If I'll manage to reproduce tihs locally I'll be able to fix it.


Thanks in advance
Grookshank
The Scope
Gallente Federation
#106 - 2017-01-21 09:33:30 UTC
William Hazard wrote:
Hello,

I'm using it occasionnaly but I have a weird issue with your tool.

It works pretty well all the time BUT with one of mine account.

When Eve-o preview is launched before Eve, the game starts and works as expected until the character seletion screen. With 2 toons it'll continue working properly but with the third one the game will change its definition to something very small (like 150*80 pxl) and relocate the window out of my screen.

The issue always happens with the same account and only with this character, not the other two. Thats really weird.

If i stop eve-o preview, launch eve, select this toon, then launch eve-o preview again, it'll be ok and work.

I have this too. You can fix it by setting max and min window sizes to the size you want the preview; e.g.:

  "ThumbnailSize": "320, 180",
  "ThumbnailMaximumSize": "320, 180",
  "ThumbnailMinimumSize": "320, 180",
William Hazard
Literally The Worst Community
#107 - 2017-01-22 19:17:40 UTC
Yeah after both or your message I looked at the conf file and the issue was here, crazy value were there. I fixed it and it fixed the issue.

Ty !

I still wonder how these value became written there.
Phrynohyas Tig-Rah
SoT
DarkSide.
#108 - 2017-02-04 10:57:53 UTC
Bragging time!
EVE-O Preview 2.2.0 total downloads count jumped over 1k this week.

I started a new active development phase. A lot of new features are plaaned and there's a very cool conribution from Ligraph waiting to be merged into the tool.

Share your stories how EVE-O Preview helps you in your everyday EVE life (via eve-mail). The most entertaining ones will be added to the 'Testimonials' section of documentaion (with or without your nicknames - I'll ask you to approve the text before publishing it)

PS ISK donations are highly welcome. I soo want these new Garmur/Orthus and Serpentis SKINs Big smile
R-0-B-0-C-O-P
Deep Core Mining Inc.
Caldari State
#109 - 2017-02-16 00:16:47 UTC
Howdy!

Awesome program, just trying to figure out how to use it properly. I'm trying to get hotkeys setup, and I was wondering if there was anyway to bind more than one character to the same key.

Example:

I have 3 accounts "X, Y, & Z". I have two characters on account "X" so my config will look like this:

Quote:
"ClientHotkey": {
"EVE - R-0-B-0-C-O-P": "Shift+1",
"EVE - Account Y Character": "Shift+2",
"EVE - Account Z Character": "Shift+3"
}


Is there anyway to add a second character with the keybing "Shift+1" in the event I'm on another character on that account and not actually on R-0-B-0-C-O-P?

Thanks a ton!
Phrynohyas Tig-Rah
SoT
DarkSide.
#110 - 2017-02-17 14:54:28 UTC
Quote:

Is there anyway to add a second character with the keybing "Shift+1" in the event I'm on another character on that account and not actually on R-0-B-0-C-O-P?


You can assign the same keybinding to several chars at once. Just bear in mind that if you'll login them all at once it won't be possible to predict which one of them will be the one that will be activated with this keybinding.

Such config will be entirely valid:


"ClientHotkey": {
  "EVE - R-0-B-0-C-O-P": "Shift+1",
  "EVE - Other Account X Character": "Shift+1",
  "EVE - Account Y Character": "Shift+2",
  "EVE - Account Z Character": "Shift+3"
}


---

Some technical details re how it works:
When a char is logged it EOP creates a preview window for it. Then it looks the hotkey bindings and if there is one it tries to assign this keyinding to the preview window (NOT to the actual EVE Online client. Sending keystrokes directly to EVE client would be.. not wise Blink ).

When a player presses one of the keybinings and there is a preview window listening for this keybinding then EOP acts like one have clicked that preview window (ie activates the corresponding EVE client). Then that particular keypress is swallowed by EOP (so it won't be possible f.e. to press F1 and simultaneously switch to the DPS char and activate its guns).

Moozh Vozmozhno
Lazerhawks
L A Z E R H A W K S
#111 - 2017-03-07 20:48:21 UTC
Is there a way to permanently disable the thumbnails?
Phrynohyas Tig-Rah
SoT
DarkSide.
#112 - 2017-03-07 22:00:09 UTC
Moozh Vozmozhno wrote:
Is there a way to permanently disable the thumbnails?

You mean to disable the thumbnail view for one particular client? Unfortunately no, this setting i not persisted (yet)
Stalex BigNoise
Sniggerdly
Pandemic Legion
#113 - 2017-03-22 21:15:01 UTC
Is any chance we can have preview windows bigger than 640x400? On my 40' screen (3840 x 2160) , thumbnails 640x400 is just barely visible :-(
Phrynohyas Tig-Rah
SoT
DarkSide.
#114 - 2017-03-23 12:12:39 UTC
Hello


Stalex BigNoise wrote:
Is any chance we can have preview windows bigger than 640x400? On my 40' screen (3840 x 2160) , thumbnails 640x400 is just barely visible :-(


Sure. Close EOP. Open the "EVE-O Preview.json" file with Notepad (it is located next to the .exe file)
Then find there line

  "ThumbnailMaximumSize": "640, 400",


This is the max size restriction. Change it to, say,

  "ThumbnailMaximumSize": "1920, 1080",


and start EOP again.

Regards
Stalex BigNoise
Sniggerdly
Pandemic Legion
#115 - 2017-03-24 07:59:14 UTC
Phrynohyas Tig-Rah wrote:
Hello

and start EOP again.

Regards


Thanks m8, good jump supporting this project
Elias Ristolainen
The Terrifying League Of Dog Fort
Freight Train Diplomacy
#116 - 2017-04-03 17:46:09 UTC  |  Edited by: Elias Ristolainen
Okay so I don't know what happened but as of today it's broken for me. I've been using this program for about 2 months now with no issues and just today it doesn't work properly anymore. Basically when I launch EVE O Preview with my clients the thumbnails pop up but when I arrange them and then click on them they disappear and I have to reset the client to get them to come back up. I have no idea what causes it because it's inconsistent but generally interacting with the thumbnails causes them to vanish for me now making the app pretty much unusable.

Any idea how to fix this because this really is a useful program and would hate to have to abandon it.

EDIT: Okay so it seems that for some reason the thumbnails now go behind the client windows once they are selected, so it works fine as long as I don't have them overlapping with any of my clients. Still it wasn't like this before and I have no idea how to fix it cause I'd rather not have to resize my client windows to make this work again.

EDIT 2: Okay so all of the sudden it's back to normal, I made it run as admin always just to be safe but it appears to be associated with having previews hide when EVE isn't active and frames not showing enabled. If I ever turn off frames is makes the previews go behind the client assuming I have Hide Previews when EVE isn't active enabled. Not sure if that helps but there ya go.
Phrynohyas Tig-Rah
SoT
DarkSide.
#117 - 2017-04-04 08:56:36 UTC
Elias Ristolainen wrote:


...

EDIT: Okay so it seems that for some reason the thumbnails now go behind the client windows once they are selected, so it works fine as long as I don't have them overlapping with any of my clients. Still it wasn't like this before and I have no idea how to fix it cause I'd rather not have to resize my client windows to make this work again.

EDIT 2: Okay so all of the sudden it's back to normal, I made it run as admin always just to be safe but it appears to be associated with having previews hide when EVE isn't active and frames not showing enabled. If I ever turn off frames is makes the previews go behind the client assuming I have Hide Previews when EVE isn't active enabled. Not sure if that helps but there ya go.


Hello

Do you run your EVE clients in windowed mode?

In need to repro this locally to investigate wth happens there (you're not the first one who reports this). Could you also send me your config file via EVE mail (just remove the part with your char's names)?

Well, in the worst case I'll just have to draw invisible frames around preview windows to help them stay on top, but I really need to find out first what happened (this could be some Win update, GPU drivers upate or glitch etc)
Jeriod
Aliastra
Gallente Federation
#118 - 2017-04-04 19:55:15 UTC
Is it possible to create a setup like this with EVE-O?
https://www.youtube.com/watch?v=XRoTF06GWSk

I'd like to be able to control everything like this.
Is this considered a violation?
Phrynohyas Tig-Rah
SoT
DarkSide.
#119 - 2017-04-08 17:34:01 UTC
Jeriod wrote:
Is it possible to create a setup like this with EVE-O?
https://www.youtube.com/watch?v=XRoTF06GWSk

I'd like to be able to control everything like this.
Is this considered a violation?


EVE-O is not needed for that. These are just EVE clients in window mode with properly arranged windows. Actually take a look at comments under this video - Crossing Zebras have a nice guide for this kind of ratting.
Sir Deathal
Imperium Cartel.
Fraternity.
#120 - 2017-04-08 21:56:25 UTC  |  Edited by: Sir Deathal
NVM, UI fixed it !


Fly safe