These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

EVE Launcher for Linux

First post First post
Author
Godric Arji
Doomheim
#481 - 2017-01-01 19:04:41 UTC
Just installed Eve on a fresh install of Manjaro Linux Distro....Worked like a charm thanks to some instructions by Xintara's forum post and a few other google searches....Pretty straight foward even for a linux newbie like me.

@CCP Snorlax, Please keep this going mate. Greatly appreciate the work you have done so far.
Comrade Jorker Arbosa
Sebiestor Tribe
Minmatar Republic
#482 - 2017-01-01 20:24:36 UTC
Hey, I'm getting this output when trying to launch the evelauncher

evelauncher$ sh evelauncher.shGtk-Message: Failed to load module "canberra-gtk-module"


I played it fine for some time about 5 months ago but now I've gone back to it recently as Eve has gone free to play and I cannot start it :(

I'm running Debian testing, nvidia 760. Anything else you want to know let me know.
Seregrorn
Deep Core Mining Inc.
Caldari State
#483 - 2017-01-02 14:35:31 UTC
Yeah! At last! Dear Snorlax, you brought me back to this beautiful game. I can't imagine how much effort is needed to do this port.

Thanks for the hard work!
Leo Musana
The Wowbaggers
#484 - 2017-01-03 00:01:33 UTC
Thank you VERY MUCH!
And a happy new year :D
Vincent Eneticum
Deep Core Mining Inc.
Caldari State
#485 - 2017-01-03 00:51:14 UTC
Comrade Jorker Arbosa wrote:
Hey, I'm getting this output when trying to launch the evelauncher

evelauncher$ sh evelauncher.shGtk-Message: Failed to load module "canberra-gtk-module"


I played it fine for some time about 5 months ago but now I've gone back to it recently as Eve has gone free to play and I cannot start it :(

I'm running Debian testing, nvidia 760. Anything else you want to know let me know.



i got the same issue, my laptop and desktop, both Debian Stretch 64bit. At some point i fixed the above mentioned error, it is unrelated. running the evelauncher.sh produces nothing, no console output, no error, no window.
Calin Roman
Doomheim
#486 - 2017-01-03 11:48:40 UTC  |  Edited by: Calin Roman
Vincent Eneticum wrote:
[quote=Comrade Jorker Arbosa]Hey, I'm getting this output when trying to launch the evelauncher

evelauncher$ sh evelauncher.shGtk-Message: Failed to load module "canberra-gtk-module"


sudo apt-get install libcanberra-gtk-module


But my problem is

Exefile STARTUP
"err:d3d:wined3d_guess_card Unrecognized renderer \"AMD Radeon R7 250 Series \", falling back to default."
"err:d3d:wined3d_guess_card Unrecognized renderer \"AMD Radeon R7 250 Series \", falling back to default."
"err:d3d:wined3d_guess_card Unrecognized renderer \"AMD Radeon R7 250 Series \", falling back to default."
"err:d3d:wined3d_guess_card Unrecognized renderer \"AMD Radeon R7 250 Series \", falling back to default."
C:\tq\code.ccp\certifi\core.pyj:53: DeprecatedBundleWarning: The weak security bundle is being deprecated.
EVE Client version 14.11 build 1108313 started 01/03/2017 13:39:58
"err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available."
"err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution."
"err:d3d:wined3d_guess_card Unrecognized renderer \"AMD Radeon R7 250 Series \", falling back to default."
No valid display adapter found


PrtScn: http://postimg.org/image/mgq8x5fd3/

i-m using latest dev wine on debian jessie gnome 3,14,1
Diktatus Iynexz
Sebiestor Tribe
Minmatar Republic
#487 - 2017-01-05 22:02:41 UTC
Just wanted to add another success story here, launcher's working great on Ubuntu 16.04. Was significantly easier than trying to get everything working thru PlayOnLinux. I'm not sure if running the script is the correct way to start the launcher every time (Linux noob here lul) but if so it's working for me. Lol
Godric Arji
Doomheim
#488 - 2017-01-06 19:26:02 UTC
Went back to a brand new fresh install of pure Arch Linux. Followed the instructions exactly and was able to launch as soon as i got it going. Again I want to say how appreciated this is CCP Snorlax and hope that you will continue to do this for us.

Btw, very new to linux so for me to get this working is a huge accomplishment.
Dynast
Room for Improvement
Good Sax
#489 - 2017-01-06 22:41:38 UTC
Following the directions in the original post, worked on first try on Linux Mint 18.0, has functioned reliably without incident for a few hours of various PvE tasks, mostly market and mining Thank you for putting in the time to make this work.
Equilibrium404
New Holland.
#490 - 2017-01-07 09:33:22 UTC
Works for me. <3 CCP
Vandermast Svetgard
Ubeslutte Industries
#491 - 2017-01-08 04:12:27 UTC
Works beautifully on Ubuntu-Mate 16.04LTS Big smile

Thank you so very much for this!!!

Cheers,
-VS
Krel Aifolin
Russian Crime Syndicate
#492 - 2017-01-08 12:00:54 UTC
Works great! Thank you very much! I tryed with playonlinux and it doesn't work. And now works with your package!
Linux x64 amd radeon r5m240 A8-6410(notebook). Debian 8.6 Jessie.

Now I no need launch windows for game! Very very very good job! Good game at good OS.

Russian Crime Syndicate - Corporation of bribetakers, killers, scums, liars. thieves. We trade weapons and drugs. Human trafficking is our main business. Good business for bad people. Still wanna be one of us?

Leroy Diehard
The Scope
Gallente Federation
#493 - 2017-01-11 09:17:02 UTC
Worked great on Ubuntu 16.04. Performance is better than Windows 7 on this hardware.

Thanks for your work.
Spelunker vanBorsten
Pator Tech School
Minmatar Republic
#494 - 2017-01-11 19:54:01 UTC
hello and thanks for this! i just installed the package on a dell xps with ubuntu 16.10 and eve is running out of the box.
made me happy Big smile
Ohne Dich
Doomheim
#495 - 2017-01-13 12:57:52 UTC
Hi. Ubuntu 16.10 amd64 and nvidia does not start.
Solution
sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libc6:i386

If there is no sound
sudo apt-get install libpulse0:i386

Thank you
Farrez
Moo corporation
#496 - 2017-01-14 11:53:49 UTC
Good job, works a treat. Thanks
SoundKonducta
Van Diemen's Demise
Northern Coalition.
#497 - 2017-01-15 05:28:17 UTC
Diktatus Iynexz wrote:
Just wanted to add another success story here, launcher's working great on Ubuntu 16.04. Was significantly easier than trying to get everything working thru PlayOnLinux. I'm not sure if running the script is the correct way to start the launcher every time (Linux noob here lul) but if so it's working for me. Lol



Thought this would help you. http://xmodulo.com/create-desktop-shortcut-launcher-linux.html
Armand Bozsik
Federal Navy Academy
Gallente Federation
#498 - 2017-01-15 13:31:45 UTC
Hello,

First of all I am sorry for the crosspost.
I have such a noobish question I think, but please forgive me :D

OS: Ubuntu 16.04 LTS x64
VGA: nVidia GTX960 4GB

So I have downloaded EVELauncher from first post, extracted to
/home/bozsikarnand/Games/EVE
then started it with
bash evelauncher.sh
and it gives the error as follows:

Installed Qt WebEngine locales directory not found at location /home/bozsikarmand/Games/EVE/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/bozsikarmand/Games/EVE/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0115/130835:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.


Steam is installed on my system. Once I was able to fix this problem, but I do not remember how. Now the client starts, I can login without a problem, then when I would like to press the play button the blue line loads in the launcher, and nothing happens.

Video illustration of my problem: YouTube

Do I need something else to make it work?

Thanks for your help!

Armand
Mictlantecuhtli Angmar
Republic University
Minmatar Republic
#499 - 2017-01-18 19:46:08 UTC
In my eve online launcher directory, I created a simbolic link to my steam.pid and it solved the problem. I hope this would help you.

cd /home/myuser/games/eveonline
ln -s ~/.steam/steam.pid steam_appid.txt
Xaeon Mileghere
The Scope
Gallente Federation
#500 - 2017-01-21 10:21:30 UTC  |  Edited by: Xaeon Mileghere
Mictlantecuhtli Angmar wrote:
In my eve online launcher directory, I created a simbolic link to my steam.pid and it solved the problem. I hope this would help you.

cd /home/myuser/games/eveonline
ln -s ~/.steam/steam.pid steam_appid.txt


Tried that but still having the same issue as in the video above. Anything that I can do about it?



Installed Qt WebEngine locales directory not found at location /home/bozsikarmand/Games/EVE/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/bozsikarmand/Games/EVE/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0115/130835:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale


so with installing Steam i got and doing that simbolic link I got rid of:


[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.