These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

EVE Launcher for Linux

First post First post
Author
Ima Wreckyou
The Conference Elite
Safety.
#441 - 2016-12-01 20:35:35 UTC
CCP Snorlax wrote:
http://binaries.eveonline.com/evelauncher_linux_release.json tells you what the current release is of the launcher - you could use that to determine the url for the latest release.

There are similar urls for beta and dev versions.

Exactly what I was looking for. Thanks a lot!
Jibril Olerie
Aliastra
Gallente Federation
#442 - 2016-12-03 03:03:56 UTC
Does anyone else have this same problem? When I play EVE in Linux using this launcher, I can't watch streaming video in my web browsers (Firefox and Chromium). The content that doesn't play is HTML5 videos (ie. Twitch, Youtube). As soon as I close out of EVE, I can go back to watching video streams without restarting the web browser.
Kay Cold
Center for Advanced Studies
Gallente Federation
#443 - 2016-12-03 10:33:32 UTC
Jibril Olerie wrote:
Does anyone else have this same problem? When I play EVE in Linux using this launcher, I can't watch streaming video in my web browsers (Firefox and Chromium). The content that doesn't play is HTML5 videos (ie. Twitch, Youtube). As soon as I close out of EVE, I can go back to watching video streams without restarting the web browser.

Im just guessing here, but it seems that your video card has very little video memory left after launching eve. What gfx card do you have? How much video memory? What browser? What environment (gnome, kde, unity)?
Dutch RAF
LIONS LEGION
#444 - 2016-12-04 13:53:59 UTC  |  Edited by: Dutch RAF
The following steps worked for me on Linux Mint 18 (Sarah) - no custom drivers:
1.Installled Wine - from SoftwareManager
2. Installed Playonlinux - from SoftwareManager
3. Installed Steam - from SoftwareManager
4.Download and extract the launcher to home.
5.Run the shell script sh ./evelauncher.sh - with sudo su in bash prompt
6.Launcher pop up and start downloading files automatically.
7.Client ready and Play!

very good indeed!!!
Thanx Snorlax. Keep up the good work.
Mankou Guyver
Breizh Corp
#445 - 2016-12-04 19:19:48 UTC
Hi !

I've got a problem with the launcher.
When I launch it, it appears but stay « white ». It's impossible to login.
You can see my problem on the pic here : http://www.hostingpics.net/viewer.php?id=420609Capturedu20161202133922.png
Does someone has a solution ?

Thanks !
BalanceVoice
The Gateless Gates
#446 - 2016-12-04 20:51:28 UTC  |  Edited by: BalanceVoice
There seems to be a problem, the launcher's settings are not being saved at all. Launcher versions, wine versions, launch settings, any change is lost when the client closes. I could have sworn it was saving at one point- I had turned on hardware rendering from the full settings menu, and testing shows I now can't turn it off- but I have no idea what's going on here. Logs show nothing, same old warnings about locales and steam API.

Bug or misaligned feature? I don't want to have to set the wine version to the CCP dev version every time I open the launcher, and the constant attempts to downgrade back to release versions of the launcher is also annoying.

EDIT: Apparently I found where the config is stored (it was in .config, wadaya know), apparently the file is read-only because it belongs to root.
Zerzzes Markarian
McCloud and Markarian Trade and Logistics Corp.
#447 - 2016-12-07 09:17:44 UTC  |  Edited by: Zerzzes Markarian
The launcher got an update today, and now I get a

Segmentation fault (core dumped)

everytime I start it. It comes up, then tries to read extra files for the shared cache, and then I get the segmentation fault.

Edit: I managed to get it to run by hitting the 'Close' button on the small window where it said it would look for new files.
Robin D'Ohara
Federal Navy Academy
Gallente Federation
#448 - 2016-12-08 18:31:04 UTC
hello i have a problem,
when i start the launcher by "evelauncher.sh" like usualy, nothing happend.

i'm on linux mint 17 cinnamon 64 bit
JDubYa Ahishatsu
Perkone
Caldari State
#449 - 2016-12-08 20:24:34 UTC  |  Edited by: JDubYa Ahishatsu
Hi everyone,

I am having issues getting the launcher to run. I am using 64 bit Cent 7 and I get the launcher to come up but it crashes soon after and says: line 14: 25473 Segmentation fault (core dumped) "$dirname/$appname" "$@"

Line 14 in the start script is "$dirname/$appname" "$@" im guessing it has a problem with that and what its pointing to?

anyone have any ideas I can try?

Thanks

edit:
This is what I get in the core file:
[root@jbot evelauncher]# gdb core core.25574
GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-80.el7
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
core: No such file or directory.
[New LWP 25574]
[New LWP 25577]
[New LWP 25578]
[New LWP 25575]
[New LWP 25580]
[New LWP 25576]
[New LWP 25581]
[New LWP 25585]
[New LWP 25582]
[New LWP 25596]
[New LWP 25583]
[New LWP 25603]
[New LWP 25584]
[New LWP 25689]
[New LWP 25586]
[New LWP 25587]
[New LWP 25588]
[New LWP 25590]
[New LWP 25591]
[New LWP 25594]
[New LWP 25595]
[New LWP 25597]
[New LWP 25601]
[New LWP 25602]
[New LWP 25604]
[New LWP 25610]
[New LWP 25626]
[New LWP 25660]
[New LWP 25593]
[New LWP 25589]
[New LWP 25592]
Missing separate debuginfo for the main executable file
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/5a/6a62cb617a77f82262f7de89e9fea6c79145c9
Core was generated by `/home/jdub/Desktop/EVE/evelauncher/./evelauncher'.
Program terminated with signal 11, Segmentation fault.
#0 0x00007fba93d82af3 in ?? ()
(gdb) bt
#0 0x00007fba93d82af3 in ?? ()
#1 0x0000000000008b18 in ?? ()
#2 0x0000000000000000 in ?? ()
(gdb)
Dave Hariere
Zee Ankh
#450 - 2016-12-08 21:37:06 UTC
Hi,

Many thanks installed using your loader no issues folloed instructions on first page...

I am currently using opensuse Tumbleweed 64bit..
I did try and get wine to run from opensuse repos but this did the trick..

many thanks

Fly Dangerous

dave.
Roesjka
The Last Solution Inc
#451 - 2016-12-08 22:15:06 UTC
CCP Snorlax,

After the last update wasn't able to start eve anymore with my already installed wine-staging.
Something abt. "wine client error:0: version mismatch 513/524."
Managed to solve it by renaming ~/.eve/wine/bin/wineserver to ~/.eve/wine/bin/wineserver.old
and SharedCache/wine/bin/wineserver to SharedCache/wine/bin/wineserver.old.

Any idea what caused the mismatch? Before the last update it was running fine.

Desktop Asrock 990FX Extreme4, AMD FX-8320, 16GB ram,
2x AMD HD7870 Crossfire, Debian jessie 64bits (multiarch), wine-staging 1.9.23~jessie

Cheers

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Zerzzes Markarian
McCloud and Markarian Trade and Logistics Corp.
#452 - 2016-12-09 09:24:38 UTC
Zerzzes Markarian wrote:
The launcher got an update today, and now I get a

Segmentation fault (core dumped)

everytime I start it. It comes up, then tries to read extra files for the shared cache, and then I get the segmentation fault.

Edit: I managed to get it to run by hitting the 'Close' button on the small window where it said it would look for new files.



Now I get again this:

QXcbWindow: Unhandled client message: "_GTK_LOAD_ICONTHEMES"
Segmentation fault (core dumped)


I can start the launcher, and even start the clients from it, but after some time, the launcher crashes (but the clients still run).
Zweinhander Frenzy
Viziam
Amarr Empire
#453 - 2016-12-09 13:44:42 UTC
I got a problem with the .sh file.

I'm not a heavy linux user. I got a notebook with Linux Mint on it.

1st time I got a syntax error ( unexpected, and worked around with bash ./evelauncher.sh. But then this error came up

./evelauncher.sh: line 14: /home/mint/Downloads/evelauncher/./evelauncher: cannot execute binary file: Exec format error


No ideia what to do to fix this.

Tried installing Eve from the stratch on PlayonLinux but always a Qt error somepoint.

Any clues?

o/
Laticia Valr'eth
University of Caille
Gallente Federation
#454 - 2016-12-09 22:22:42 UTC  |  Edited by: Laticia Valr'eth
I'm just using 1 wine prefix, running per wine-staging 1.9.23 (have regular and staging per /opt/wine-staging/bin/ dual-installed)

i figured how to make the launcher show up again, untested if the game runs at all yet!
EDIT: game runs again!!

in winecfg I set these processes to run in winXP :

eve.exe (regular gamefolder)
evelauncher.exe (found in the launcher subfolder)
QtWebEngineProcess.exe (found also in the launcher subfolder)

hope that helps for peeps with the regular windows client running over wine .. not the inofficial linux launcher posted on page 1

OT: I know eve online isn't quite supported for running on linux .. but I really would appreciate to continue playing .. since WINE 2.0rc1 is out as devel version and they kept on working on dx11 and the shader stuff
Roesjka
The Last Solution Inc
#455 - 2016-12-10 11:26:55 UTC
Ok to summarize steps to be taken when on Debian testing/stretch and using wine-staging,
might also be helpful for ppl with other distro's.

Check if you have still installed libssl1.0.2, normally libssl1.0.2_1.0.2j-4 should still be installed,
otherwise reinstall it from Debian testing/stretch or your distro's repo..

Make a symlinks in the evelauncher directory:
ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2 libssl.so
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2 libcrypto.so

In case you are running into the wineserver mismatch versions rename SharedCache/wine/bin/wineserver to wineserver.org or just remove it.

I can now launch and run EVE with my custom wine-staging 1.9.23 but might also help with other wine versions.

Thx guys for giving me the pointers to get it working again.

Winecfg: Windows 7, overrides: *d3d10 disabled, *d3d11 disabled.

Cheers

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Robin D'Ohara
Federal Navy Academy
Gallente Federation
#456 - 2016-12-10 12:03:22 UTC  |  Edited by: Robin D'Ohara
I am a beginner (we can say a f*****g noob) in the use of linux environment.
How and where do i check if i still have libssl1.0.2

Linux Mint 17 Cinnamon 64-bit
Wine 1.6.2

EDIT : seems i found where, but i don't have libssl1.0.2 just have a libssl1.0.0
is it good or not ?

EDIT 2 : i'm not sure of my "where"

EDIT 3 : i've found some libssl but none are where you say, and seems to be a different version of your, so i don't know what to do
Kasarch
Techno Hive
Valkyrie Alliance
#457 - 2016-12-11 16:12:50 UTC
Does this launcher write some logs?
I cannot get eve working. I can run launcher and login, but eve does not starting.
Dropzone
Crotchety Old Farts
#458 - 2016-12-12 15:30:28 UTC  |  Edited by: Dropzone
I ran into an issue that after the Launcher Patched, I was unable to get the game to launch past the launcher. I deleted the Eve game and downloaded it again. Patched and same issue. Then I went and found the .eve and .Eve folders. Deleted these and the main folder again with no luck. After 4 tries, I did a search in my /home directory and found another folder in Cache. I deleted everything and tried the patch process again. The game launched. I am not sure what or why this happened.

I only provide this info for others just in case someone else has had this issue.

Thank you
Dropzone

System Specs below
Linux Mint 17.3
Sager Gaming Notebook
Intel I7 5850
Dual AMD 8900M
32GB RAM
Zuril Nair
Jagged Rock Guild
#459 - 2016-12-13 00:43:24 UTC
Hey, just wanted to give a big "THANK YOU!" for this effort. I only use Windows for games, but now I can hop into my favorite game without a reboot.

Kudos!
Ariolo
Pator Tech School
Minmatar Republic
#460 - 2016-12-13 07:06:35 UTC  |  Edited by: Ariolo
Jibril Olerie wrote:
Does anyone else have this same problem? When I play EVE in Linux using this launcher, I can't watch streaming video in my web browsers (Firefox and Chromium). The content that doesn't play is HTML5 videos (ie. Twitch, Youtube). As soon as I close out of EVE, I can go back to watching video streams without restarting the web browser.

I have the same issue running UberStudent Heraclitus (fork of Ubuntu 14.04 LTS). My system only has onboard and HDMI audio; I'm using PulseAudio. The first time I ran with the Linux Launcher I already had YouTube running and EVE had no audio output. With EVE running first, no audio output form any other sources, whether Rythmbox playing local files, YouTube, or the Spotify linux client; I also tested VLC with ALSA instead of PulseAudio, does not work.