These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

Wine support for Mac

First post First post
Author
Het Silenius
The Scope
Gallente Federation
#81 - 2016-03-10 15:47:26 UTC
I haven't been able to get it to work on 10.9.5. I do currently have EVE installed via WineBottler, though. Would that cause a conflict?
CCP Snorlax
C C P
C C P Alliance
#82 - 2016-03-10 16:56:30 UTC
Het Silenius wrote:
I haven't been able to get it to work on 10.9.5. I do currently have EVE installed via WineBottler, though. Would that cause a conflict?

It shouldn't. I'd be curious to see your launcher logs. Can you dig them up and put in a Dropbox (or Google Drive) and send me the link in EVE Mail?

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Het Silenius
The Scope
Gallente Federation
#83 - 2016-03-10 17:27:11 UTC
CCP Snorlax wrote:

It shouldn't. I'd be curious to see your launcher logs. Can you dig them up and put in a Dropbox (or Google Drive) and send me the link in EVE Mail?


EVE Mail sent, thanks.
Amarisen Gream
Pleasant Peninsula Productions
Order of Allied Knights
#84 - 2016-03-10 19:31:57 UTC
Empress Sarum wrote:
Amarisen Gream wrote:
Some tid bits.

Under Wine - screen resolution isn't very consistent.

My iMac and External monitor are both native 1920x1080. I play in window mode which means I run 1920 x 1030. Under the wine version. It seems that it starts up in like 1920 x 1038/1060 and like any other compensation of 1920x10**.


So its happening to you swell, well it's good to know I'm not the only one, I wonder if there is a fix, or way yo lock the resolution so it doesn't slightly change each time you launch the client.



Just realized you posted before me about the same issue.

I'm cheering for the Mac team at CCP to find a fix.

Also, any word on the Command key change?

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Chromartix
Doomheim
#85 - 2016-03-10 21:09:40 UTC
Thank you CCPeople! BiaB plus WINE support makes playing on my late 2012 Mac Mini fantastically awesome.
Lauresh Thellere
The Scope
Gallente Federation
#86 - 2016-03-11 09:15:59 UTC
Empress Sarum wrote:
For those of you that got it working, does the client change window size on each launch? (If you are running in windowed mode).

Mine keeps growing by a few pixels each time I load a client, just wondering if anyone else is having this issue, or if its some strange byproduct of having had playonmac installed, and running eve via wine with that before using CCP's new wine method.

Quote:
One thing I have noticed, I am playing in windowed mode, with a set resolution (1344x840), each time I reboot the client the resolution grows by a few pixels. For example if I set my windowed size to the above resolution, the next time i start that client it has moved up to 1352x855. And will continue to grow in small increments until I have to reset it manually to where I want it. I tested it with a custom resolution by resizing the window, and the same behaviour, it grows by a few pixels per restart.


Wine has always done that for me even before CCP introduced the Wine wrapper. I'm not sure why but it's kind of annoying as I keep comms on the side next to the client :P
Invisusira
Escalated.
Project Gungnir.
#87 - 2016-03-12 01:03:14 UTC  |  Edited by: Invisusira
Got a client booting now, but I can't change the resolution - there's only one option, and it spans across both my monitors, which is not at all what I want.

It's very unstable, and took about 10 attempts to boot after downloading the latest stuff.

Logging in and attempting to change graphics settings instantly crashes the client.
Sunrise Aigele
Pemberley Enterprises
#88 - 2016-03-12 06:55:06 UTC  |  Edited by: Sunrise Aigele
I decided to load Captain's Quarters while running Project Discovery, to which I am hopelessly addicted. Invariably, after perhaps ten to fifteen minutes of normal function, Project Discovery will become unable to load slides, and LogLite will fill up with over 300 messages per minute, all of them saying, "[f]ailed to set RenderTarget to slot 0." It is occasionally interspersed with the error, "[f]failed to get a valid ballpark in time after trying 30 times." (CQ has a ballpark?! Where?! Big smile) After a couple of minutes of this, the client becomes unresponsive, and I have to force quit to terminate it. Then, invariably, I get the message that "There was an error writing a file to disk."

I have worked around this by loading the hangar instead.

(Note: I do not have to be running Project Discovery to get the RenderTarget error. That is merely what I was doing when I noticed it.)
CCP Snorlax
C C P
C C P Alliance
#89 - 2016-03-12 12:14:26 UTC
Sunrise Aigele wrote:
I decided to load Captain's Quarters while running Project Discovery, to which I am hopelessly addicted. Invariably, after perhaps ten to fifteen minutes of normal function, Project Discovery will become unable to load slides, and LogLite will fill up with over 300 messages per minute, all of them saying, "[f]ailed to set RenderTarget to slot 0." It is occasionally interspersed with the error, "[f]failed to get a valid ballpark in time after trying 30 times." (CQ has a ballpark?! Where?! Big smile) After a couple of minutes of this, the client becomes unresponsive, and I have to force quit to terminate it. Then, invariably, I get the message that "There was an error writing a file to disk."

I have worked around this by loading the hangar instead.

(Note: I do not have to be running Project Discovery to get the RenderTarget error. That is merely what I was doing when I noticed it.)

I'll see if we can reproduce this in the office. I've been in CQ without errors, but it may depend on settings and/or the OS X version and hardware used. I'd appreciate if you could file a bug report, give me your system details and attach a saved log from LogLite.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Sunrise Aigele
Pemberley Enterprises
#90 - 2016-03-13 03:08:20 UTC
CCP Snorlax wrote:
Sunrise Aigele wrote:
I decided to load Captain's Quarters while running Project Discovery, to which I am hopelessly addicted. Invariably, after perhaps ten to fifteen minutes of normal function, Project Discovery will become unable to load slides, and LogLite will fill up with over 300 messages per minute, all of them saying, "[f]ailed to set RenderTarget to slot 0." It is occasionally interspersed with the error, "[f]failed to get a valid ballpark in time after trying 30 times." (CQ has a ballpark?! Where?! Big smile) After a couple of minutes of this, the client becomes unresponsive, and I have to force quit to terminate it. Then, invariably, I get the message that "There was an error writing a file to disk."

I have worked around this by loading the hangar instead.

(Note: I do not have to be running Project Discovery to get the RenderTarget error. That is merely what I was doing when I noticed it.)

I'll see if we can reproduce this in the office. I've been in CQ without errors, but it may depend on settings and/or the OS X version and hardware used. I'd appreciate if you could file a bug report, give me your system details and attach a saved log from LogLite.


I cleared my log because it was pinwheeling. It had hundreds of thousands of lines! That will make it easier to isolate the problem and bug report it.

Look for one soon. I am on 10.11.3, the latest version of OS X.
Vincent Athena
Photosynth
#91 - 2016-03-13 05:04:41 UTC
Now that its working for me, Here are some issues Ive found.

Command Q does not quit the game. Instead, it tries to quit XQuartz. Control Q does nothing.

In the market interface, the price history plot has no scale values shown.

I'm using a MacBook Pro, with a trackpad. When I do a two finger scroll on my hangar window, the window jumps to the contents of the ship hangar, or the contents of a station container. To see this, put many items in your hangar, so a scroll is needed to navigate them all.

Know a Frozen fan? Check this out

Frozen fanfiction

Sunrise Aigele
Pemberley Enterprises
#92 - 2016-03-13 05:18:09 UTC  |  Edited by: Sunrise Aigele
Is there an upper limit on the attachment size for a support ticket? I ask because when the bug I'm reporting logs more than 5 errors per second, and I play for 20 minutes to wait for a freeze, it becomes unwieldy. It is over 27MB in size.

I have narrowed it down to three issues, for which there will be two tickets filed as soon as I sort out the logs. I may simply start over tomorrow or the next day and not wait so long!):

1) CQ in windowed mode crashes either before it loads or as soon as I move the camera;

2) Project Discovery's slide display pane goes black as soon as I try to use command-shift-4 to take a screenshot of the slide;

2) CQ in full screen mode runs smoothly, but crashes as soon as I use command-shift-4 to take a partial screenshot,but at least I get the screen shot.
Amarisen Gream
Pleasant Peninsula Productions
Order of Allied Knights
#93 - 2016-03-13 06:21:45 UTC
Vincent Athena wrote:
Now that its working for me, Here are some issues Ive found.

Command Q does not quit the game. Instead, it tries to quit XQuartz. Control Q does nothing.

In the market interface, the price history plot has no scale values shown.

I'm using a MacBook Pro, with a trackpad. When I do a two finger scroll on my hangar window, the window jumps to the contents of the ship hangar, or the contents of a station container. To see this, put many items in your hangar, so a scroll is needed to navigate them all.


Wine treats the command key as the "alt" key. So normally hot keys don't work.

Just think and try to train yourself for now that EVE is Native Windows and only window hotkey work.

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Amarisen Gream
Pleasant Peninsula Productions
Order of Allied Knights
#94 - 2016-03-13 06:24:55 UTC
Sunrise Aigele wrote:
Is there an upper limit on the attachment size for a support ticket? I ask because when the bug I'm reporting logs more than 5 errors per second, and I play for 20 minutes to wait for a freeze, it becomes unwieldy. It is over 27MB in size.

I have narrowed it down to three issues, for which there will be two tickets filed as soon as I sort out the logs. I may simply start over tomorrow or the next day and not wait so long!):

1) CQ in windowed mode crashes either before it loads or as soon as I move the camera;

2) Project Discovery's slide display pane goes black as soon as I try to use command-shift-4 to take a screenshot of the slide;

2) CQ in full screen mode runs smoothly, but crashes as soon as I use command-shift-4 to take a partial screenshot,but at least I get the screen shot.



For uploading files to CCPs bug report - just compress the file first. Had to do that the other day.
If you don't know how to compress the file - right-click and compress.

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Vincent Athena
Photosynth
#95 - 2016-03-13 16:46:29 UTC  |  Edited by: Vincent Athena
Amarisen Gream wrote:
Vincent Athena wrote:
Now that its working for me, Here are some issues Ive found.

Command Q does not quit the game. Instead, it tries to quit XQuartz. Control Q does nothing.

In the market interface, the price history plot has no scale values shown.

I'm using a MacBook Pro, with a trackpad. When I do a two finger scroll on my hangar window, the window jumps to the contents of the ship hangar, or the contents of a station container. To see this, put many items in your hangar, so a scroll is needed to navigate them all.


Wine treats the command key as the "alt" key. So normally hot keys don't work.

Just think and try to train yourself for now that EVE is Native Windows and only window hotkey work.

Except control Q does nothing. There is no hot key, not even a windows native hot key, to quit the client.
Edit: I found I could change the shortcut for quit so control Q quits the current client without quitting Xquartz.

Know a Frozen fan? Check this out

Frozen fanfiction

Bleyddyn apRhys
Ravens of Morrighan
#96 - 2016-03-13 17:24:58 UTC  |  Edited by: Bleyddyn apRhys
I switched to Wine to test it and didn't encounter any problems except that my settings weren't transferred over. I couldn't find any directions on how to transfer my settings so I switched back to Cider. Unfortunately, all of my old settings are now gone in Cider, too. Resetting window locations would be annoying, but I really, really don't want to have to rebuild all of my keybindings.

Any suggestions on how I can get my settings back?

Edited: Never mind, I figured it out.

I copied everything from (because the date/time stamps were from February):

~/Library/Application\ Support/EVE\ Online/p_drive/Local\ Settings/Application\ Data/CCP/EVE/c_program_files_ccp_eve_tranquility/settings

to:

~/Library/Application\ Support/EVE\ Online/p_drive/Local\ Settings/Application\ Data/CCP/EVE/c_tq_tranquility/settings_Default

NOT TO (the location that makes more sense):

~/Library/Application\ Support/EVE\ Online/p_drive/Local\ Settings/Application\ Data/CCP/EVE/c_tq_tranquility/settings_EVE_Online
Amarisen Gream
Pleasant Peninsula Productions
Order of Allied Knights
#97 - 2016-03-14 03:54:45 UTC
Bleyddyn apRhys wrote:
I switched to Wine to test it and didn't encounter any problems except that my settings weren't transferred over. I couldn't find any directions on how to transfer my settings so I switched back to Cider. Unfortunately, all of my old settings are now gone in Cider, too. Resetting window locations would be annoying, but I really, really don't want to have to rebuild all of my keybindings.

Any suggestions on how I can get my settings back?

Edited: Never mind, I figured it out.

I copied everything from (because the date/time stamps were from February):

~/Library/Application\ Support/EVE\ Online/p_drive/Local\ Settings/Application\ Data/CCP/EVE/c_program_files_ccp_eve_tranquility/settings

to:

~/Library/Application\ Support/EVE\ Online/p_drive/Local\ Settings/Application\ Data/CCP/EVE/c_tq_tranquility/settings_Default

NOT TO (the location that makes more sense):

~/Library/Application\ Support/EVE\ Online/p_drive/Local\ Settings/Application\ Data/CCP/EVE/c_tq_tranquility/settings_EVE_Online


The Wine version puts a folder in you documents folder (I think) but on like page two of this thread someone provides the location for your settings.

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Planeten Schreck
Green Screen
#98 - 2016-03-14 15:29:15 UTC
Hi,

Mac 10.9.5, amd 5780 GPU.

Tryed to use wine but not workling:

Switch Setting to wine, downloads stuff. Quit Launcher, restart Launcher. start client produces a square and after a short time a triangle again.

even installed x11 pack on max.

Tryed to submit bug report but the wegsite is not working at the moment:

2016-03-14T16:22:18.379Z default debug ("WINEDLLOVERRIDES=mscoree,mshtml=", "TMPDIR=/var/folders/86/wyygdbrs45z10kkfnvc_r16r0000gn/T/", "HOME=/Users/rolfrosenbaum", "PATH=/usr/bin:/bin:/usr/sbin:/sbin", "LOGNAME=rolfrosenbaum", "__CF_USER_TEXT_ENCODING=0x1F5:0:3", "WINEPREFIX=/Users/rolfrosenbaum/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache//wineenv", "WINEDEBUG=", "SHELL=/bin/bash", "SSH_AUTH_SOCK=/tmp/launch-jtRRc5/Listeners", "Apple_PubSub_Socket_Render=/tmp/launch-KrkGSh/Render", "__CHECKFIX1436934=1", "USER=rolfrosenbaum")
2016-03-14T16:22:20.901Z wine error "err:module:load_builtin_dll failed to load .so lib for builtin L\"winemac.drv\": dlopen(/Users/rolfrosenbaum/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wine/lib/wine/winemac.drv.so, 258): Symbol not found: _OSAtomicDecrement32Barrier"
2016-03-14T16:22:20.901Z default debug " Referenced from: /Users/rolfrosenbaum/Librar"
2016-03-14T16:22:20.901Z default debug ""
2016-03-14T16:22:20.912Z wine error "err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found"
2016-03-14T16:22:20.912Z default debug ""
2016-03-14T16:22:21.257Z wine debug "fixme:heap:RtlSetHeapInformation 0x490000 0 0x32fb74 4 stub"
2016-03-14T16:22:21.257Z default debug ""
2016-03-14T16:22:21.271Z wine debug "fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub"
2016-03-14T16:22:21.271Z default debug ""
2016-03-14T16:22:24.622Z wine debug "fixme:heap:RtlSetHeapInformation 0x490000 0 0x328154 4 stub"
2016-03-14T16:22:24.622Z default debug ""
2016-03-14T16:22:27.135Z wine error "err:setupapi:do_file_copyW Unsupported style(s) 0x144"
2016-03-14T16:22:27.135Z default debug ""
2016-03-14T16:22:27.295Z wine debug "fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x328960 1 C) semi-stub"
2016-03-14T16:22:27.295Z wine debug "fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x328678 1 C) semi-stub"
2016-03-14T16:22:27.295Z default debug ""
2016-03-14T16:22:27.295Z default debug "Network layer using: CarbonIO\r"
2016-03-14T16:22:27.295Z default debug "Executing DirectXRedist.exe ...\r"
2016-03-14T16:22:27.296Z default debug "Starting up Trinity through _trinity_stub_deploy ...\r"
2016-03-14T16:22:27.296Z default debug ""
2016-03-14T16:22:27.296Z default debug "A traceback has been generated. It has been logged in the log server as stacktrace #1\r"
2016-03-14T16:22:27.296Z default debug "Terminating process by request - returning 0"
2016-03-14T16:22:27.303Z default debug Process 2372 finished with exit code 0



Amarisen Gream
Pleasant Peninsula Productions
Order of Allied Knights
#99 - 2016-03-14 16:15:24 UTC
Has anyone had problems resizing the EVE window?

I know I reported issues with Wine and screen resolution.
I noticed i have the option when i mouse over the edge of EVE to resize it. I have not had any issues. Just wondering if anyone saw this? And if it has worked or not worked

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Ronald Sotken
Violence is the Answer
Wormhole Society
#100 - 2016-03-14 17:19:53 UTC  |  Edited by: Ronald Sotken
Since switching to the wine wrapper I've noticed that sometimes when warping/jumping into a system, the video that is displayed on the billboards will play in full screen. I haven't been able to determine the trigger for this, but it seems to occur when commencing warp, or alt+clicking in space.
I have found no way to remove it without restarting the client.

See the following to get an idea of what I'm talking about,
http://imgur.com/a/NGf94

And here is the screenshots of the billboards displaying the same images,
http://imgur.com/a/wSK2Z

I'm playing on a 2012 macbook pro using the wine wrapper.

Seems someone else on page 4 is having this issue as well.

Quote:

#65
- 2016-03-09 15:54:13 UTC |

Hello,

While warping to a gate my entire screen is suddenly filled with some video news that cannot be closed.


Any advice on a workaround/fix would be greatly appreciated.