These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

Wine support for Mac

First post First post
Author
Azeta
Aliastra
Gallente Federation
#41 - 2016-03-08 14:06:41 UTC
I would just like to voice my support for this direction, and a thank you to CCP for giving us this option. I tried this out last night and it worked brilliantly. I know there are still problems for some people but at least there is an open source option (submitting a bug report to the WINE community) for resolution notwithstanding support from our favorite game developer.

Thank you thank you thank you! If this still works post March release I'll be re-subbing my alts. Frankly we need to somehow tell all the mac people who have left about this new option so they can at least try it out!

My observations: Everything is faster. Everything I tried worked perfectly (although I just realized I did not try Windowed mode). I had graphics on max settings and it was much faster and more responsive than cider on medium. I wouldn't have thought this would be the case, but there it is. I'm on a Mac Pro (2013) with OS X 10.11.3.
Ronald Sotken
Redpimp's WhoreEmporium
#42 - 2016-03-08 15:51:25 UTC
Dragosta DinTei wrote:
Ronald Sotken wrote:


/Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wineenv/drive_c/users/yourName/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE


Hope that helps some people out.


Just one fix: this part: ".../drive_c/users/rob/Local Settings/..." where it says "rob" it's your mac username, or "yourName" as Ronald says at the beggining "/Users/yourName/..."

Didn't catch the second username in that string. Either way, I think the launcher needs to download and install the wine wrapper for the client in order for the subdirectories wineenv/drive_c/users/rob/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE to be created.

If the launcher won't do anything with the wine wrapper, it could be an issue of your system not working properly with wine.

This is a printout of running system_profiler SPSoftwareDataType in bash (with some user details omitted)
System Software Overview:

System Version: OS X 10.10.5 (14F1509)
Kernel Version: Darwin 14.5.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled

Hope it can help. Smile


Apoq Surrat
Amarritus Patriotus
#43 - 2016-03-08 17:45:42 UTC
I just tried this on my Mac Pro 2012, Nvidia GTX 680 with latest Nvidia Web Driver, running El Capitan 10.11.3.

The new launcher works fine with Cider, but when i switch it to Wine, it copies files, then says its ready, but will not start the game. When I click to play, the play symbol next to my name turns to a square, my name turns green along with the line under it. It then just sits there for about 45 seconds, then changes back to normal as if I never clicked anything.

MacPro (mid 2012) dual 6-core Xeon 3.06ghz, 64GB ECC Ram, PCIe-SSD, 2x SSHD, BD, SD, Nvidia Titan Xp. Running macOS Sierra 10.12.4.

Azeta
Aliastra
Gallente Federation
#44 - 2016-03-08 18:10:13 UTC
Apoq Surrat wrote:
I just tried this on my Mac Pro 2012, Nvidia GTX 680 with latest Nvidia Web Driver, running El Capitan 10.11.3.

The new launcher works fine with Cider, but when i switch it to Wine, it copies files, then says its ready, but will not start the game. When I click to play, the play symbol next to my name turns to a square, my name turns green along with the line under it. It then just sits there for about 45 seconds, then changes back to normal as if I never clicked anything.


Did you re-start the launcher? This was listed as a known issue on the first post in this thread. I did so after the wine files were copied and it started right up.
Xerxes Fehrnah
The Fallout Shelter
#45 - 2016-03-08 18:42:06 UTC
CCP,

From the bottom of my heart, thank you. This has bothered me for two years. I have been fighting with wine, unix command line, winetricks, and everything else under the sun to make Eve work on my Mac with some quality level approaching the Windows client.

This experience is completely superior. I have a working copy of wine, which ironically I finally got working again after weeks of tinkering just yesterday.

I clicked the button, it downloaded files, I moved my hud around, imported my overview, and now it is flying. The experience was seamless and easy.

A master stroke. You doubled the quality of the Mac experience and brought us back into your house in one shot.

I love you for this. Thank you.

-Xerxes
Invisusira
Escalated.
Project Gungnir.
#46 - 2016-03-08 18:44:26 UTC
Azeta wrote:
Apoq Surrat wrote:
I just tried this on my Mac Pro 2012, Nvidia GTX 680 with latest Nvidia Web Driver, running El Capitan 10.11.3.

The new launcher works fine with Cider, but when i switch it to Wine, it copies files, then says its ready, but will not start the game. When I click to play, the play symbol next to my name turns to a square, my name turns green along with the line under it. It then just sits there for about 45 seconds, then changes back to normal as if I never clicked anything.


Did you re-start the launcher? This was listed as a known issue on the first post in this thread. I did so after the wine files were copied and it started right up.

It's a known issue, but not a solved one. Rebooting the client/launcher/computer does nothing to solve it.
Vincent Athena
Photosynth
Just let it happen
#47 - 2016-03-08 19:23:38 UTC
Invisusira wrote:
Azeta wrote:
Apoq Surrat wrote:
I just tried this on my Mac Pro 2012, Nvidia GTX 680 with latest Nvidia Web Driver, running El Capitan 10.11.3.

The new launcher works fine with Cider, but when i switch it to Wine, it copies files, then says its ready, but will not start the game. When I click to play, the play symbol next to my name turns to a square, my name turns green along with the line under it. It then just sits there for about 45 seconds, then changes back to normal as if I never clicked anything.


Did you re-start the launcher? This was listed as a known issue on the first post in this thread. I did so after the wine files were copied and it started right up.

It's a known issue, but not a solved one. Rebooting the client/launcher/computer does nothing to solve it.

He is the first one to report having it with 10.11. CCP Snorlax has been able to reproduce the issue, and is working on it. (We have been eve mailing each other).
Just now I noted Wine 1.8 showed up in the list in the preferences, three versions (two in the Dev version list). I tried them all. None worked for me.

Know a Frozen fan? Check this out

Frozen fanfiction

Invisusira
Escalated.
Project Gungnir.
#48 - 2016-03-08 19:58:37 UTC
Vincent Athena wrote:
CCP Snorlax has been able to reproduce the issue, and is working on it. (We have been eve mailing each other).

\o/ woot!
CCP Snorlax
C C P
C C P Alliance
#49 - 2016-03-08 20:02:37 UTC
Vincent Athena wrote:
Invisusira wrote:
Azeta wrote:
Apoq Surrat wrote:
I just tried this on my Mac Pro 2012, Nvidia GTX 680 with latest Nvidia Web Driver, running El Capitan 10.11.3.

The new launcher works fine with Cider, but when i switch it to Wine, it copies files, then says its ready, but will not start the game. When I click to play, the play symbol next to my name turns to a square, my name turns green along with the line under it. It then just sits there for about 45 seconds, then changes back to normal as if I never clicked anything.


Did you re-start the launcher? This was listed as a known issue on the first post in this thread. I did so after the wine files were copied and it started right up.

It's a known issue, but not a solved one. Rebooting the client/launcher/computer does nothing to solve it.

He is the first one to report having it with 10.11. CCP Snorlax has been able to reproduce the issue, and is working on it. (We have been eve mailing each other).
Just now I noted Wine 1.8 showed up in the list in the preferences, three versions (two in the Dev version list). I tried them all. None worked for me.

This is taking a bit longer than I hoped, but should be sorted tomorrow. For some reason I'm expected to have a life outside of work as well...

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Vincent Athena
Photosynth
Just let it happen
#50 - 2016-03-08 20:08:33 UTC
CCP Snorlax wrote:

This is taking a bit longer than I hoped, but should be sorted tomorrow. For some reason I'm expected to have a life outside of work as well...

I'll give you that as soon as I see a picture of you swimming in a hot spring while wearing a merman tail.

Know a Frozen fan? Check this out

Frozen fanfiction

Invisusira
Escalated.
Project Gungnir.
#51 - 2016-03-08 21:29:37 UTC
CCP Snorlax wrote:
This is taking a bit longer than I hoped, but should be sorted tomorrow. For some reason I'm expected to have a life outside of work as well...

I'm just thrilled to see Mac support turned around this quickly! +1 for merman tail pic!
Rowells
Blackwater USA Inc.
Pandemic Horde
#52 - 2016-03-09 01:09:57 UTC
anyone else experiencing issues with the cider client after using the wine version? I'm seeing cpu resources go through the roof and cant even get to selection screen.
Danny TronIcs
Fano Plane Logistics
#53 - 2016-03-09 03:32:05 UTC
THANK YOU!

So far it is working very well on 2013 MacPro with Dual AMD FirePro and an iMac with Intel Graphics.

Really appreciate this kind of work!

Empress Sarum
Imperial Academy
Amarr Empire
#54 - 2016-03-09 04:38:10 UTC
Thank you so much CCP!

I no longer have to fiddle around with wine and PlayonMac etc, to get a "close to windows" eve online client feel. Just followed your instructions and away it went, amazing! Much smoother then my cider client experiences so far.

One thing I have noticed, I am playing in windowed mode, with a set resolution (1344x840), each time I reboot the client the resolution grows by a few pixels. For example if I set my windowed size to the above resolution, the next time i start that client it has moved up to 1352x855. And will continue to grow in small increments until I have to reset it manually to where I want it. I tested it with a custom resolution by resizing the window, and the same behaviour, it grows by a few pixels per restart.

Running on:

OSX 10.11.2
MacBookPro Mid 2015
Geforce GT 650m
16gb Ram

I have resolution scaling to 90%, I'm not sure if that would impact this or not. It did this same behaviour when running the windows install via wine and PlayonMac. The cider wrapper keeps the resolution the same.

Any ideas on this?

Many thanks!! <3
Amarisen Gream
Pleasant Peninsula Productions
Digital Vendetta
#55 - 2016-03-09 07:51:25 UTC  |  Edited by: Amarisen Gream
CCP Snorlax and the other Mac support team - WHY THE HECK IS THIS NOT IN THE NEWS.

BUTA, more importantly thank you guys so much, I look forward to getting home in a few hours and switching over.

I will be back with more love soon

p.s. You all deserve a bonus.

p.p.s. And I am not sorry for the caps. If this had been in the news I would have been all over this like a fat kid on cake. Like a dog on a bone. Like... You get the picture.


Raging - stuck at work with 5 hours to gooooooioooooooooooo

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Mr Veda
Aliastra
Gallente Federation
#56 - 2016-03-09 09:05:00 UTC
Firstly, many thanks for moving the client to wine. I'm sure it will be a huge improvement :)

Having a similar issue as many in the thread. Pressing the play button causes nothing to happen. After some time, the button goes back to a square. I also get this message from time to time:

There was an error writing a file to disk (see log for details).

If there are EVE clients running they might prevent updating files.

This could be also be caused by incorrect file permissions. Do you want me to try to fix permissions for the shared cache folder? (/Users/Madasa/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/)


EVE LogLite also shows no activity

OS 10.11.3
Mac Pro (Early 2008)
2 x 2.8 GHz Quad-Core Intel Xeon
10 GB 800 MHz DDR2 FB-DIMM
ATI Radeon HD 5770 1024 MB

Tried to file a bug report yesterday with my logs but there was an error on the website

dehino 'smin yathā dehe kaumāraḿ yauvanaḿ jarātathā dehāntara-prāptir dhīras tatra na muhyati

Amarisen Gream
Pleasant Peninsula Productions
Digital Vendetta
#57 - 2016-03-09 11:11:18 UTC
CCP - would it be possible to add a auto upload of logs via loglite? Don't know if this is a good idea or not, but I would not mind sending all my logs to you each time I played if it meant the client got better.
I asked this in the launcher thread, and felt it was also good to post here as this is the feedback for the wine version.

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Verite Rendition
F.R.E.E. Explorer
#58 - 2016-03-09 12:00:05 UTC
Snorlax, etc: kudos to you guys. After NVIDIA purchased the Cider team and tech, it was obvious that Cider as a product was nearing its end, and honestly I expected you guys to pull the plug on Mac support as a result. I'm not sure what you had to do to sell CCP management on spending resources to distribute and support WINE directly, but thank you for not giving up on the Mac.
Amarisen Gream
Pleasant Peninsula Productions
Digital Vendetta
#59 - 2016-03-09 13:44:00 UTC  |  Edited by: Amarisen Gream
anyone figure out how to copy over settings?

edit: After the Wine Wrapped upgrade. My EVE Online Application has vanished from my Application folder. where is the wine version hidden.????

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Amarisen Gream
Pleasant Peninsula Productions
Digital Vendetta
#60 - 2016-03-09 14:09:16 UTC
Ronald Sotken wrote:
This is great. Already noticed some much better functionality, such as multi locking with ctrl + mouse click drag not causing the client to lag out. Undocking is much cleaner too, and before I was having unhandled memory exceptions. I'll submit a report if it happens again.

But anyway, if any one was wondering, I was able to migrate the old settings profile from the cider wrapper to the wine wrapper by copying the settings sub directory from the following location

/Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE

to this location

/Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wineenv/drive_c/users/rob/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE


Hope that helps some people out.



<<<< This needs to be added up to the top by a blue.

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs