These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

Delay after jumping gates

Author
CS12
Doomheim
#1 - 2016-02-10 15:01:14 UTC
Hi,

Been playing on the same laptop for some time, with the exception of taking ages to load up space after leaving the station everything worked ok.

I haven't played much recently but between Oct/Nov and now, I get a real problem after jumping gates that makes the game unplayable. Basically, after i jump a gate into a new system, i can have a delay of upto 45 seconds when my ship is either not in space or it is in space but won't respond to any commands. The second version (ship in space but won't respond to commands) is very frustrating as you dont know if its a "normal" jump or not.

This doesn't happen on every jump, i'd say it happens every 3-5 jumps. It makes the game unplayable as travel in highsec is very slow and in low/null you are a sttting duck.

In-system, everything is fine and works well.

I see some other comments in other threads that people are having a similar issue. Are you aware of this and would you like more information?

Mac specs:

OSX 10.10.2
2.13 Ghz Core 2
4GB Ram
Geeforce 320M 256 MB

Reinstalled client today and issue persists.

As i say everything worked fine until some of the recent patches (i couldn't say exactly when this issue developed but now i cant really play).

PS. Thanks for fixing the issue with the market hanging when opened.
Hunter Ace
Fuctifino
#2 - 2016-02-10 15:30:15 UTC
Having the exact same issue.

I've filed a bug report twice with no reply and the support ticket I submitted basically ended with "file a bug report"

It's super frustrating.

iMac, 10.9.5, 3.06 Core 2 Duo, 8 gig of ram, ATI Radeon HD 4670 256 MB
Alan Mathison
The Gold Angels
Sixth Empire
#3 - 2016-02-13 23:19:06 UTC
Folks:

I'll mention this as well. I used both Mac and Linux and this only happens on Mac.

iMac 24" Early 2008
3.06GHz Intel Core 2 Duo
4GB RAM
GeForce 8800 GS 512MB

-- Alan Mathison, Explorer & Industrialist, Star Tide Industries

Azamat Baganatow
Adversity.
Psychotic Tendencies.
#4 - 2016-02-14 19:22:10 UTC
Yeah i have the same thing and it starting to **** me off

Sometimes i have to wait a full 45-55 seconds till i can warp or do anything after jumping thru the gates

Id like this Fixed please
CS12
Doomheim
#5 - 2016-02-16 04:44:51 UTC
Hi,

Been playing a bit more this week.

Delay on jumping gates (approx. every 3 - 5 gates) still happening, I can't detect any pattern to it - it seems random. I have 2 clients online at the same time, sometimes both clients jump fine, sometimes one jumps fine and one locks up. I still get the delay even if I use one client.

This makes it impossible to play in my normal style - where I wouldn't think twice about a 30 jump round trip.

I've been in wormholes a lot more as a result of this and I don't get any delay after jumping a wormhole. Everything is fine and works quickly even with two clients. This applies to jumps from wormhole space into normal space as well as to other wormholes. So I get the situation where I can jump normally from a wormhole into a system but I get a delay jumping from another system into the same system!

For everyone else who's been having the same issue, I can now tell if its a "normal" jump or a "delayed" jump by hitting Dscan. Dscan won't respond until the ship is controllable. This can take upto 60 seconds in bad cases.

Please tell us how we can provide more info to get this fixed. Thanks.
Meita Way
GoonWaffe
Goonswarm Federation
#6 - 2016-02-21 07:27:18 UTC
I've been having the exact same issue the last couple of days, mac only, my PC on the same connection is just fine. The delay is about 45 seconds each time it happens - *nothing* else at all is slow.
Hunter Ace
Fuctifino
#7 - 2016-02-22 20:09:31 UTC
It's been exactly 5 weeks since I submitted a bug report on this and I still have not had a reply.
Azamat Baganatow
Adversity.
Psychotic Tendencies.
#8 - 2016-02-22 23:03:55 UTC
I will be unsubbing from the game since i see that the graphics for CCP is more important to them then actually game play to them
this is disgusting and unacceptable
Hunter Ace
Fuctifino
#9 - 2016-02-23 05:43:33 UTC
Just partitioned my drive, installed windows and DL'd the client and guess what? It works perfectly.

So much for it being my connection...
Lizzie Lefthand Marstolt
Aperture Interstellar Innovations
#10 - 2016-02-27 10:21:02 UTC
I have the exactly same issue. Couldn't figure out any way to get rid of it. Finally switched to wine version of EVE, works alot better: https://forums.eveonline.com/default.aspx?g=posts&t=464631&find=unread
Brokk Witgenstein
Sebiestor Tribe
Minmatar Republic
#11 - 2016-02-28 16:24:46 UTC
BUMP!!!!

Following the announcement my WinXP (Bootcamp Partition) is end-of-line as far as CCP is concerned, I'm trying to revert to MacOS. I used to play on MacOS before, until November last year when I started having severe troubles jumping a gate (either closing my socket or recovering after 30 sec - a full minute).

I see things have slightly improved, but:

* docking, the market, industry: they're still horribly laggy to say the least.
* more importantly: I'm still having trouble jumping gates!!

A dev once told me to hit ctrl-option-shift-M and check if there were any outstanding calls. Matter of fact, there was one:

"Remote Object Call: CmdStargateJump". It remained open for 1:15 (minutes), followed by a GetTime call, then another one. The in-game Network Status showed outgoing packets and yes, my connection was fine. The socket closed around 16:13 EvE time, like two minutes after failing to jump.

When I logged back in, however, I found myself at the other side of the stargate so the session change did in fact happen server-side.


How do I proceed? What do you want me to do / try / send / compile / log in order to fix the Mac Client because in four months or so this will be my ONLY Client, apparently. And it's already been bugged for four months like this, so we might need to start moving on this one. Any takers?
Carn Uta
State War Academy
Caldari State
#12 - 2016-02-29 20:25:12 UTC
Exactly the same random delay issue when gate jumping, plus the ever-present black screen on leaving station that only killing the client and reloading cures. Both issues leave us floating randomly in space waiting to be popped :(
Brokk Witgenstein
Sebiestor Tribe
Minmatar Republic
#13 - 2016-03-02 20:33:16 UTC
I found this.


20:20:59 client::General notice 0039 PAT: Wrap: Exit _MakeShipActive returning res= None seq_id= 39
20:20:59 blue::TaskletTimer warning !! timeslice {"time": 268, "order": 1, "inframe": 268, "stack_1": "'machoNet::HandleMessage::NotifySessionChange_ProcessSessionChange::invCache^MakeShipActive'"}
20:20:59 svc::michelle notice Adding ballpark 30002529
20:21:00 blue::TaskletTimer warning !! timeslice {"time": 304, "order": 1, "inframe": 0, "stack_2": "'machoNet::HandleMessage^machoNet::HandleMessage::NotifySessionChange_OnSessionChanged::svc.michelle'", "stack_1": "'machoNet::_GetTransports'"}
20:21:00 svc::gameui notice GameUI::OnSessionChanged, Heading for inflight True (Session: (sid:5129445570330094269, clientID:0, mutating:0, contextOnly:False, locationid:30002529, corprole:0x20004080000L, userid:11554987, languageID:EN, role:0x6000000000000000L, charid:94673215, address:78.23.93.135:42394, userType:30, sessionType:5, regionid:10000030, constellationid:20000370, allianceid:99005675, corpid:98378220, shipid:1019858446405, solarsystemid:30002529, solarsystemid2:30002529, hqID:60012874, baseID:60012196, rolesAtAll:0x20000000000L, rolesAtHQ:0x5680000L, rolesAtBase:0x5680000L, rolesAtOther:0x4080000L, genderID:True, bloodlineID:14, raceID:2, corpAccountKey:1000)) {'solarsystemid2': (30002530, 30002529), 'solarsystemid': (30002530, 30002529), 'locationid': (30002530, 30002529)}
20:21:01 svc::michelle notice Done adding ballpark 30002529
20:21:02 svc::michelle notice SetState called. Spamming DoBallClear 30002529
20:21:03 blue::TaskletTimer warning !! timeslice {"time": 226, "order": 1, "inframe": 0, "stack_4": "'BeOS::System'", "stack_3": "'Destiny::Tick'", "stack_2": "'Destiny::DoPreTick'", "stack_1": "'Destiny::DoPreTick::SendEvent_DoBallClear::gameui'"}
20:21:03 requests::packages.urllib3.connectionpool notice Starting new HTTP connection (1): 52.17.152.179
20:21:28 eve::client.script.environment.jumpt warning Failed to report jump time statistic
20:21:29 svc::FxSequencer warning FxSequencer::AddTrigger: ship not in ballpark. Trigger ignored



^^^ Please note the TWENTY-FIVE second delay between the session change and the client "unfreezing". During this time, we can see our gatecloak timer counting down, there's remote calls stacking up (like GetInventory, GetMultipleCorpEx and so on) but it all boils down to: the client is waiting for "something" and it ain't getting it. Could be a threadsync issue, could be a supposedly asynchronous call behaving like a blocking call under MacOS ..... I don't know.

I can only hope any of this helps you guys out.

I'm also seeing a LOT of failures and warnings; such as



20:20:33 svc::billboard error Failed to get news headlines from: http://www.eveonline.com/mb/news-headlines.asp?s=tranquility&language_id=EN, Retrying in 1 minute
20:20:45 spaceObject::Billboard warning [ 9001210240000000372 ] Failed to set DiffuseMap billboard texture (BlueWrapper: trinity.TriTextureParameter (384F1AA0)) to cache:/Temp/headlines.dds

or

20:20:06 client::General warning (Local: GetLocationsLocal - Multi: GetMultiLocationsEx) - Prime() called for 128 items from michelle.py(454) in Dispatcher
20:20:06 blue::TaskletTimer warning !! timeslice {"time": 205, "order": 1, "inframe": 0, "next": 'Marshal::Save', "stack_2": "'StartService::ServiceStartRun::michelle^michelle:ballDispatcher'", "stack_1": "'machoNet::MachoTransport::Write'"}
20:20:13 eve::client.script.environment.jumpt warning Failed to report jump time statistic
20:20:14 spaceObject::PlayerShip warning [ 1019858446405 ] model is None, cannot play audio.
Leora Risalo
Insomnis Group
#14 - 2016-03-08 00:21:19 UTC  |  Edited by: Leora Risalo
-
Thoregon Aubaris
Very Drunken Eve Flying Instructors
Brotherhood Of Silent Space
#15 - 2016-03-12 11:16:21 UTC
Same Problem here. Today I did a supply run to highsec - 50 jumps - the average time it took to load the grid was about 20sec. I'm sad to say this but i will stop playing, it is NOT FUNNY anymore when you don't know if you can keep up with your fleet in null, lowsec or highsec - especially in times of war (wh's are working fine btw). For small groups -like my corp/alliance- everybody is important, you can not afford to lose even 15 seconds on a gate waiting. There are so many problems for us mac-users, i can live with most of them but eve without pvp is, as mentioned above, NOT FUNNY.
CS12
Doomheim
#16 - 2016-05-03 11:22:54 UTC
As of the citadel release this seems to have been fixed. Thanks.