These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Launcher

 
  • Topic is locked indefinitely.
 

Launcher constantly having to "copy files"

First post
Author
Sithlord Revan
Sebiestor Tribe
Minmatar Republic
#1 - 2016-02-07 17:33:49 UTC  |  Edited by: Sithlord Revan
Every time I open the EVE launcher, it spends anywhere from 2-5 minutes copying files -- even on non-patch days.

It's very frustrating because the old patcher never used to do this and if I just launch eveexe.exe to open the client manually, I don't have to wait for whatever the launcher has to "copy", if I just want to play asap.

Worse still is that whatever the launcher is doing makes my hard drive read/write like crazy and I can't imagine why it needs to do this every day or even multiple times a day.

It will happen the first time I open eve on a fresh reboot, and it will also happen if I close the launcher for a few hours then open it again. It will not happen if I close and reopen the launcher immediately after it has already done it in the last hour or so.

My launcher logfile is here: redacted d/t sensitive info

As you can see I basically started patching at 1220hrs and my play button was activated at 1222 when I opened the log viewer.. There is no reason I should have to wait close to 2 minutes for the patcher to be ready on a non-patch day when I play EVE every day... something is broken.

Any idea what the problem is or how I can fix it? Thanks.
CCP Snorlax
C C P
C C P Alliance
#2 - 2016-02-08 11:51:44 UTC
I am investigating this issue.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Sturmwolke
#3 - 2016-02-08 11:52:19 UTC  |  Edited by: Sturmwolke
OP you might want to redact your login usernames from that link. It's sensitive data that hackers would love to get their hands on.
CCP in their infinite wisdom logged it in plain view in the new launcher logs. If someone wanted to harvest login usernames from alliance members for example, all they have to do is mine the launcher logs with a datalogger.
Eric Slayer
Kissmydonkey Corporation
#4 - 2016-02-23 14:36:47 UTC
Hi Spacerats,

Yes I have run into this problem with Windows 10. There is a easy work around when launcher does the update, just say no to update. Go to your shortcut to and right click on it. Select "Run as Admin" when it ask say Yes. This appears not a problem with Eve Launcher but with windows security instead. Hope this help.

Remember in Space nobody can hear you scream, but you can pop them like a zit.

Fly safe
CCP Snorlax
C C P
C C P Alliance
#5 - 2016-02-23 17:09:57 UTC
Sturmwolke wrote:
OP you might want to redact your login usernames from that link. It's sensitive data that hackers would love to get their hands on.
CCP in their infinite wisdom logged it in plain view in the new launcher logs. If someone wanted to harvest login usernames from alliance members for example, all they have to do is mine the launcher logs with a datalogger.

Those logs are on your local machine, if someone is mining them you have bigger problems...

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Sturmwolke
#6 - 2016-02-24 00:24:07 UTC
CCP Snorlax wrote:
Those logs are on your local machine, if someone is mining them you have bigger problems...

Security that relies on dependencies is just as bad as security that relies on obscurity. With your reasoning, then there's literally no reason whatsoever to encrypt the SSO tokens. Yet it's encrypted.
Be that a machine is compromised, there is no reason whatsoever to wrap it into nice little presents with ribbons and hand them out without care. Do your part and secure what you can.

This will not be the first and last case where a player posts their entire logfile onto the internet in full public view.
You've basically created a security hole in which the information can be obtained innocently through social engineering.
Somethingski
Bunnyhop and Bears
#7 - 2016-03-06 12:07:52 UTC
Same here but at mine it starts the copying at 80%