These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

[V2x] SeAT: EVE API Tool And Corporation Manager

Author
Greygal
Redemption Road
Affirmative.
#41 - 2016-03-21 08:29:01 UTC  |  Edited by: Greygal
Have installed on a DigitalOcean Centos7 droplet, and so far it seems to be working well. I had to install using the step-by-step installation instructions, as the single-command install broke around the mariadb section.

The only hiccups I had when installing were trying to run the mysql_secure_installation script; I had to set a path environment for it. I did it using the following commands:

Quote:
cd $HOME
cat .bashrc
export PATH="$PATH:/usr/local/mysql/bin/"
source .bashrc


Makhar wrote:
Having an issue with no corporations showing on the Corporations screen. I have added a corporation API with full access. The queue has been working on "Corporation Eve Processing: ContractsItems" for over 24 hours now. Am I missing a step to get the corporations list populated? Characters list is working just fine.


I am having this same problem, it is not processing the corporation API keys properly. I have tried clearing the cache as recommended above, and the job shows as Processing: ContractsItems for over three hours since clearing cache.

Suggestions?

Also, is there a way to change the required API key mask?

Thanks for the fantastic amount of work you have done on this!

GG

What you do for yourself dies with you, what you do for others is immortal.

Free weekly public roams & monthly NewBro new player roams!

Visit Redemption Road or join mailing list REDEMPTION ROAMS for information

qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#42 - 2016-04-29 19:37:54 UTC
Pushed out a ton of updates and bugfixes today! Feel free to run the upgrade script!
http://seat-docs.readthedocs.io/en/latest/#one-line-upgrader

As a heads up (and the reason for this post), you will now be *required* to set a valid admin email in the SeAT settings so that CCP can contact you in case your server makes their XML API cry.

Happy upgrades!

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#43 - 2016-05-05 19:42:18 UTC
Ubuntu 16.04 installer is now ready: http://seat-docs.readthedocs.io/en/latest/

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

Regnar Avastum
#44 - 2016-05-07 01:27:20 UTC
Hi,

I'm trying (slowly and badly) to install your app and I hit a snag:
- https://i.gyazo.com/f0fadb0927b1333f7fba5478e765b666.png
- https://i.gyazo.com/edc016583bf7610af2a24903ac019570.png

Any ideas would be appreciated, thanks!
qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#45 - 2016-05-07 06:10:10 UTC
Regnar Avastum wrote:
Hi,

I'm trying (slowly and badly) to install your app and I hit a snag:
- https://i.gyazo.com/f0fadb0927b1333f7fba5478e765b666.png


This looks like your php cURL install cant find a local CA bundle to validate an SSL cert with (www.fuzzwork.co.uk in this case). I have no idea how that works on Windows though.



On many unix type machines, this dependency can be solved by installing the php-intl package.

Regnar Avastum wrote:

Any ideas would be appreciated, thanks!


To be honest, I have never tested SeAT natively on Windows. My current plan for this was once the new Docker betas for Windows and Mac are out, an official SeAT image will be built so that that can just be pulled, installed and run.

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

Klorrak
Entropy of Annihilation
#46 - 2016-05-08 08:43:24 UTC
So, thank you so much for the 16.04 installer. But i have a really quick question. Is there any ETA for a PHPBB3/teamspeak auth to be put in? It's the only thing that is really stopping me from fully using SeAT. I believe with just those two modules you will take the EvE community by storm. Especially with your outstanding customer support! Hope you get back to me soon.

-Klorrak
qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#47 - 2016-05-08 08:55:08 UTC
Klorrak wrote:
So, thank you so much for the 16.04 installer. But i have a really quick question. Is there any ETA for a PHPBB3/teamspeak auth to be put in? It's the only thing that is really stopping me from fully using SeAT. I believe with just those two modules you will take the EvE community by storm. Especially with your outstanding customer support! Hope you get back to me soon.

-Klorrak


Unfortunately no ETA atm, but, its definitely getting closer to the top of the list. FWIW, I have started to think about how to best do this a lot more lately :P

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

Cyno Butthead
Porksword Freight Services
#48 - 2016-05-10 20:42:36 UTC
I noticed in an earlier version that you can see the contents inside a container, not on the latest version it's not possible anymore.
qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#49 - 2016-05-14 07:23:23 UTC
EVE SSO Support just landed! Upgrade to the latest packages and read the admin guide here:
http://seat-docs.readthedocs.io/en/latest/admin_guides/sso/

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

Acen Dread
Avalanche.
Fraternity.
#50 - 2016-05-20 11:43:19 UTC  |  Edited by: Acen Dread
Hi, i am currently trying to install Seat but it keeps throwing
PHP Fatal error:  require(): Failed opening required '/var/www/seat/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /va
  r/www/seat/bootstrap/autoload.php on line 17

halfway into executing
composer create-project eveseat/seat seat --keep-vcs --prefer-source --no-dev
.
I already did try
apt-get install php-pear
but it had no effect.
Does anyone have an idea how to fix/workaround that?


EDIT: I am trying to install on an ubuntu 14.04 Server. And I already had the old beta version of seat installed until i realize there was a new one.

EDIT: Ok, i'm stupid. I tried it again and followed the instructions and it worked... Probably
qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#51 - 2016-05-21 16:37:57 UTC
Acen Dread wrote:
Hi, i am currently trying to install Seat but it keeps throwing

[snip]



If you still need help, join Slack and ask in the #support channel http://seat-docs.readthedocs.io/en/latest/contact/#slack

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

Domminique Francon
Federal Defense Union
Gallente Federation
#52 - 2016-05-25 05:03:57 UTC
Hitting a small snag and can't figure this out.
Got SeAT installed on in my home dir (with the correct permissions etc').
When I go to http://my.site/seat/index.php, the site loads fine.
When I go to http://my.site/seat, it redirects me to http://my.site/seat/home to a not found page and complains:
The requested URL /home/user/seat/public/index.php was not found on this server

I imagine this is some apache shenanigans, but I can't figure it out.
apache conf
Hilianna
Exploration Frontier inc
Tactical-Retreat
#53 - 2016-05-30 21:01:50 UTC
hello,

Is that possible to install this tool via FTP from WinSCP or Filezilla ?
Hikryon
De perdidos al rio
#54 - 2016-06-06 01:27:12 UTC
Acen Dread wrote:
Hi, i am currently trying to install Seat but it keeps throwing
PHP Fatal error:  require(): Failed opening required '/var/www/seat/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /va
  r/www/seat/bootstrap/autoload.php on line 17

halfway into executing
composer create-project eveseat/seat seat --keep-vcs --prefer-source --no-dev
.
I already did try
apt-get install php-pear
but it had no effect.
Does anyone have an idea how to fix/workaround that?


EDIT: I am trying to install on an ubuntu 14.04 Server. And I already had the old beta version of seat installed until i realize there was a new one.

EDIT: Ok, i'm stupid. I tried it again and followed the instructions and it worked... Probably


If you're still generating the error, try next composer parameter:

--no-scripts


Ex:

composer create-project eveseat/seat seat --keep-vcs --prefer-source --no-dev --no-scripts
.

Font: https://getcomposer.org/doc/03-cli.md#install
Jerppu3
Smurf Company
Initiative Associates
#55 - 2016-06-08 10:20:31 UTC  |  Edited by: Jerppu3
Acen Dread wrote:
Hi, i am currently trying to install Seat but it keeps throwing
PHP Fatal error:  require(): Failed opening required '/var/www/seat/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /va
  r/www/seat/bootstrap/autoload.php on line 17

halfway into executing
composer create-project eveseat/seat seat --keep-vcs --prefer-source --no-dev
.
I already did try
apt-get install php-pear
but it had no effect.
Does anyone have an idea how to fix/workaround that?


EDIT: I am trying to install on an ubuntu 14.04 Server. And I already had the old beta version of seat installed until i realize there was a new one.

EDIT: Ok, i'm stupid. I tried it again and followed the instructions and it worked... Probably


Could you point out the instructions which yo followed? I'm banging my head against the wall witht he same issue

EDIT: Added --no-script and did not get the error anymore. But got "Killed"


./ubuntu-14-04-x.sh: line 101: 31736 Killed                  composer create-project eveseat/seat seat --keep-vcs --prefer-source --no-dev --no-scripts
qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#56 - 2016-06-08 14:27:23 UTC
Jerppu3 wrote:


Could you point out the instructions which yo followed? I'm banging my head against the wall witht he same issue

EDIT: Added --no-script and did not get the error anymore. But got "Killed"


./ubuntu-14-04-x.sh: line 101: 31736 Killed                  composer create-project eveseat/seat seat --keep-vcs --prefer-source --no-dev --no-scripts


What are the specs of this server you trying to install on? Also, you will get help much faster if you hop onto Slack.

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

Jerppu3
Smurf Company
Initiative Associates
#57 - 2016-06-08 16:00:30 UTC
qu1ckkkk wrote:

What are the specs of this server you trying to install on? Also, you will get help much faster if you hop onto Slack.


Cheapest what you can get from Digital Ocean... I read that it might be the reason, upgrading now to see if that makes any difference.
Jerppu3
Smurf Company
Initiative Associates
#58 - 2016-06-08 16:43:11 UTC
With 1GB memory it somewhat worked. So bare minimum for system memory seem to be 1GB, during the setup 960MB was in use.

Now, when I add --no-scripts installer wont add .env file to /var/www/seat/ directory, so installer will fail


* Configuring SeAT itself

sed: can't read /var/www/seat/.env: No such file or directory


and when I remove --no-scripts I get


[RuntimeException]
  Error Output: PHP Warning:  require(/var/www/seat/bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in /var/www/seat/bootstrap
  /autoload.php on line 17
  PHP Fatal error:  require(): Failed opening required '/var/www/seat/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/
  www/seat/bootstrap/autoload.php on line 17



I haven't used Slack ever, no idea how it works. Seems that I would need to get an invite to be able to use it?
qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#59 - 2016-06-09 04:45:52 UTC
Jerppu3 wrote:
With 1GB memory it somewhat worked. So bare minimum for system memory seem to be 1GB, during the setup 960MB was in use.

Now, when I add --no-scripts installer wont add .env file to /var/www/seat/ directory, so installer will fail



Dont add the no-scripts flag. Its needed.

Jerppu3 wrote:


I haven't used Slack ever, no idea how it works. Seems that I would need to get an invite to be able to use it?


Get the invites/details here: http://seat-docs.readthedocs.io/en/latest/contact/#slack

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat

qu1ckkkk
The Warp Core Stabilizers
Goonswarm Federation
#60 - 2016-06-09 11:30:44 UTC
Acen Dread wrote:
Hi, i am currently trying to install Seat but it keeps throwing
PHP Fatal error:  require(): Failed opening required '/var/www/seat/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /va
  r/www/seat/bootstrap/autoload.php on line 17

halfway into executing
composer create-project eveseat/seat seat --keep-vcs --prefer-source --no-dev
.
I already did try
apt-get install php-pear
but it had no effect.
Does anyone have an idea how to fix/workaround that?


Make 10000% sure you have a PHP version above 5.5.14 to get the latest version! Preferably, just upgrade to PHP7 already.

https://github.com/eveseat/seat/blob/master/composer.json#L8

Proud developer of SeAT! A Simple Eve API & Corporation Management Tool.

Project Page: https://github.com/eveseat/seat