These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Information Portal

 
  • Topic is locked indefinitely.
 

New Beta EVE Launcher is Now Available for Mac

First post
Author
Bienator II
madmen of the skies
#21 - 2015-11-02 18:02:16 UTC
the rendering order needs some tweaks. If you open the settings the MOTD is rendered above the settings panel

http://i.imgur.com/5quWCL3.png

how to fix eve: 1) remove ECM 2) rename dampeners to ECM 3) add new anti-drone ewar for caldari 4) give offgrid boosters ongrid combat value

Raphendyr Nardieu
Avanto
Hole Control
#22 - 2015-11-02 18:05:01 UTC
Quote:

On Windows, the update has the following changes, fixes and additions:

  • Title bar is now transparent



This confuses me. It's hard to know whe I can drag the window to some other place. Could you revert this, or change that I can move the window by dragging it part of the background (no activable element/button where I drag). Kind of thinking that top border would be 100% of the height.

ps. Personally I don't like windows that don't use system borders (or theme), but that might be because I prefer KDE for my main desktop. On windows I think this is too common to have your own borders, so there it probable needs to be done in this way.
CCP Snorlax
C C P
C C P Alliance
#23 - 2015-11-02 18:14:10 UTC
Raphendyr Nardieu wrote:
Quote:

On Windows, the update has the following changes, fixes and additions:

  • Title bar is now transparent



This confuses me. It's hard to know whe I can drag the window to some other place. Could you revert this, or change that I can move the window by dragging it part of the background (no activable element/button where I drag). Kind of thinking that top border would be 100% of the height.

ps. Personally I don't like windows that don't use system borders (or theme), but that might be because I prefer KDE for my main desktop. On windows I think this is too common to have your own borders, so there it probable needs to be done in this way.

The underlying graphics will change in the near future, indicating a draggable title bar.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Ignatius Glick
Viziam
Amarr Empire
#24 - 2015-11-02 18:16:12 UTC
CCP Snorlax wrote:
Ignatius Glick wrote:

...


Same exact issue here.. tried all suggestions, tried deleting my client and nothing works :( can't login.

Can you download this file: https://binaries.eveonline.com/1d/1d34143a37d4b739_0c8c84e27d2626139e5ea6dcc694b14f ?

It should come out as 10MB file (10,371,702 bytes), and you should be able to open it in a text editor (that can handle large files). I'm seeing several logs where this file seems to fail, and it is crucial to starting up the client.


that link says it's 0 bytes..
CCP Snorlax
C C P
C C P Alliance
#25 - 2015-11-02 18:25:08 UTC
Ignatius Glick wrote:
CCP Snorlax wrote:
Ignatius Glick wrote:

...


Same exact issue here.. tried all suggestions, tried deleting my client and nothing works :( can't login.

Can you download this file: https://binaries.eveonline.com/1d/1d34143a37d4b739_0c8c84e27d2626139e5ea6dcc694b14f ?

It should come out as 10MB file (10,371,702 bytes), and you should be able to open it in a text editor (that can handle large files). I'm seeing several logs where this file seems to fail, and it is crucial to starting up the client.


that link says it's 0 bytes..

I'm starting to think this is an issue with the CDN. I'm invalidating this file (and one other) so it will be cached on all nodes from the original source. Try again in 30min or so. If that still doesn't work I'll need to dig into this with our provider.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Ignatius Glick
Viziam
Amarr Empire
#26 - 2015-11-02 18:29:36 UTC
CCP Snorlax wrote:
Ignatius Glick wrote:
CCP Snorlax wrote:
Ignatius Glick wrote:

...


Same exact issue here.. tried all suggestions, tried deleting my client and nothing works :( can't login.

Can you download this file: https://binaries.eveonline.com/1d/1d34143a37d4b739_0c8c84e27d2626139e5ea6dcc694b14f ?

It should come out as 10MB file (10,371,702 bytes), and you should be able to open it in a text editor (that can handle large files). I'm seeing several logs where this file seems to fail, and it is crucial to starting up the client.


that link says it's 0 bytes..

I'm starting to think this is an issue with the CDN. I'm invalidating this file (and one other) so it will be cached on all nodes from the original source. Try again in 30min or so. If that still doesn't work I'll need to dig into this with our provider.


when restarting the launcher i noticed it is trying to download 0/2 files and then goes right to ready and doesn't appear to download anything.. hopefully you're right!
Ignatius Glick
Viziam
Amarr Empire
#27 - 2015-11-02 19:44:59 UTC
still unable to get those two files, and the file above is still 0 bytes. :(
CCP Snorlax
C C P
C C P Alliance
#28 - 2015-11-02 19:47:13 UTC
Ignatius Glick wrote:
still unable to get those two files, and the file above is still 0 bytes. :(

Alright, I'll do some more investigations tomorrow. Thanks for helping, everybody, and thank you for your patience while we sort out these issues.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Ignatius Glick
Viziam
Amarr Empire
#29 - 2015-11-02 19:51:35 UTC
if i switch to singularity it starts downloading files..
Vincent Athena
Photosynth
#30 - 2015-11-02 20:41:03 UTC  |  Edited by: Vincent Athena
I tried the launcher and got an error message:

"File not found: C:\tq\code.ccp
File not found: C:\tq\resfileindex.txt"

So I checked the log:

2015.11.02 12:29:34.925 warning Couldn't copy file: "/Users/...../Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/cider-EveOnlinePremium-iso-010474-nodata-skel/EVE Online.app/Contents/Resources/transgaming/c_drive/tq/code.ccp"

2015.11.02 12:29:35.007 warning Couldn't copy file: "/Users/..../Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/cider-EveOnlinePremium-iso-010474-nodata-skel/EVE Online.app/Contents/Resources/transgaming/c_drive/tq/resfileindex.txt"

What now?

Edit: I checked: a file named "code.ccp" appears in

/EVE Online.app/Contents/Resources/transgaming/c_drive/duality
/EVE Online.app/Contents/Resources/transgaming/c_drive/sisi

but not in

/EVE Online.app/Contents/Resources/transgaming/c_drive/tq

This may have something to do with my almost exclusive use of clones. I don't log into tq, except with a clone. I'll keep doing stuff, and see.

Edit2: Nope, running the old launcher did not result in those files appearing.

Know a Frozen fan? Check this out

Frozen fanfiction

CCP Snorlax
C C P
C C P Alliance
#31 - 2015-11-02 20:53:37 UTC
Vincent Athena wrote:
I tried the launcher and got an error message:

"File not found: C:\tq\code.ccp
File not found: C:\tq\resfileindex.txt"

So I checked the log:

2015.11.02 12:29:34.925 warning Couldn't copy file: "/Users/...../Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/cider-EveOnlinePremium-iso-010474-nodata-skel/EVE Online.app/Contents/Resources/transgaming/c_drive/tq/code.ccp"

2015.11.02 12:29:35.007 warning Couldn't copy file: "/Users/..../Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/cider-EveOnlinePremium-iso-010474-nodata-skel/EVE Online.app/Contents/Resources/transgaming/c_drive/tq/resfileindex.txt"

What now?

Edit: I checked: a file named "code.ccp" appears in

/EVE Online.app/Contents/Resources/transgaming/c_drive/duality
/EVE Online.app/Contents/Resources/transgaming/c_drive/sisi

but not in

/EVE Online.app/Contents/Resources/transgaming/c_drive/tq

This may have something to do with my almost exclusive use of clones. I don't log into tq, except with a clone. I'll keep doing stuff, and see.

There is something going on on the backend - I´ll have to investigate this tomorrow. These files appear to be missing (or be corrupt) on some nodes on the CDN network, so it depends on where you are located whether you get those files or not. Nothing I can do at the moment, I´m afraid.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Vincent Athena
Photosynth
#32 - 2015-11-02 21:10:12 UTC
CCP Snorlax wrote:

There is something going on on the backend - I´ll have to investigate this tomorrow. These files appear to be missing (or be corrupt) on some nodes on the CDN network, so it depends on where you are located whether you get those files or not. Nothing I can do at the moment, I´m afraid.


I live in Southern California, if that is any help.

Know a Frozen fan? Check this out

Frozen fanfiction

Amanda Orion
WinterFel
#33 - 2015-11-02 21:34:08 UTC
CCP Snorlax wrote:
Anyone who's having trouble starting a regular TQ client with the new Mac launcher, could you try starting up a Singularity client and report back if that works?


Refresh did not help.

Mine still fails on TQ, but I just successfully logged into Singularity.
narthollis
Perkone
Caldari State
#34 - 2015-11-02 22:37:26 UTC
Would it be possible to display the currently selected settings profile on the account row again?

I have a number of different settings profiles (Windows, Main Screen, Secondary, Tertiary and a few others) and I it is currently rather annoying to see if I have the correct settings profile selected.
Erasmus Grant
Un4seen Development
Sev3rance
#35 - 2015-11-02 23:12:18 UTC
No problem getting on the test server, but no luck of getting on to TQ.
Bluemelon
ElitistOps
Goonswarm Federation
#36 - 2015-11-03 01:00:55 UTC

"File not found: C:\tq\code.ccp
File not found: C:\tq\resfileindex.txt"

getting this error for any and all clients

For all your 3rd party needs join my ingame channel Blue's 3rd Party!

https://forums.eveonline.com/default.aspx?g=posts&t=365230&find=unread

MedweSajtli
The Bear's Cave
#37 - 2015-11-03 05:50:50 UTC
Bluemelon wrote:

"File not found: C:\tq\code.ccp
File not found: C:\tq\resfileindex.txt"

getting this error for any and all clients



If you have any working client, copy the files and this solve a problem.
Malice Redeemer
The Black Crow Bandits
Brave Collective
#38 - 2015-11-03 05:56:12 UTC  |  Edited by: Malice Redeemer
You can just copy those two missing files from your other old client folder, or any folder where you ran the repair .exe. Me and a friend got it working that way at least.
Pete Toxcal
White Zulu
Scorpion Federation
#39 - 2015-11-03 10:28:24 UTC  |  Edited by: Pete Toxcal
"File not found: C:\tq\code.ccp
File not found: C:\tq\resfileindex.txt"

Pls use repair.exe.


I've deleted all former files from the old and new EVE client and installed the new client, but the problem persists.

When I switch to Singularity, the login process workd and after a about 20 ... 30 secs the station appears on the screen and I can fly like before.

Switching back to Tranquility shows the same problem as above.

Using it on MacBook pro.
CCP Snorlax
C C P
C C P Alliance
#40 - 2015-11-03 10:41:29 UTC
I found the missing files - hit refresh from the view menu to get those pesky files that were preventing the TQ client from starting up.

I will add safeguards to prevent this issue from happening again, sorry for the inconvenience.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/