These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Information Portal

 
  • Topic is locked indefinitely.
 

SCYLLA - Download On Demand Issues

First post
Author
Veliki Ritoznojcan
Veliki Ritoznojcan Corporation
#41 - 2015-03-24 14:22:38 UTC
CCP Maxwell wrote:
Ghaustyl Kathix wrote:
For those of us with sub-par internet at home, is there an install package for all of the resources? When I was playing with it on Singularity, it took a minute at least to load the model and various skins for a cruiser, let alone a station, I'd rather download the whole thing at school and install that on the desktop at home.


I'd recommend setting the "Download all the resource files" flag in the launcher settings. The launcher will then download everything. Better restart the launcher after changing this setting.



Trying to do this but launcher doesnt allow me to save new settings. I just reinstalled windows 7 32-bit after my hard drive went bye-bye.
CCP Atropos
C C P
C C P Alliance
#42 - 2015-03-24 14:35:42 UTC
Kudo Sarain wrote:
Hi,

I am currently getting this when I try to open my launcher.

I am running windows 8.1

http://pastebin.com/frYqa8qa

Some users have reported that if you try running the EVE Launcher as administrator, it will solve these issues. It's something we're currently investigating.
CCP Atropos
C C P
C C P Alliance
#43 - 2015-03-24 14:36:32 UTC
Veliki Ritoznojcan wrote:
CCP Maxwell wrote:
Ghaustyl Kathix wrote:
For those of us with sub-par internet at home, is there an install package for all of the resources? When I was playing with it on Singularity, it took a minute at least to load the model and various skins for a cruiser, let alone a station, I'd rather download the whole thing at school and install that on the desktop at home.


I'd recommend setting the "Download all the resource files" flag in the launcher settings. The launcher will then download everything. Better restart the launcher after changing this setting.



Trying to do this but launcher doesnt allow me to save new settings. I just reinstalled windows 7 32-bit after my hard drive went bye-bye.

Could you paste your logfile on pastebin, so we can take a look at it?
Veliki Ritoznojcan
Veliki Ritoznojcan Corporation
#44 - 2015-03-24 14:46:44 UTC  |  Edited by: Veliki Ritoznojcan
Cant find any logfile, found 2 launcher.exe set both as run as admin no difference. I can tag the flag in settings but i cant save it. When i return flag is gone
Natya Mebelle
Center for Advanced Studies
Gallente Federation
#45 - 2015-03-24 14:50:41 UTC
What if I do not WANT a shared resource folder? I'm running two installations of Eve from two separate harddrives (not partitions, physical hard drives!) because this improves my loading times a lot. If the game is going to pull all data from the same location, I'll be getting frustrated pretty soon...
Or is this only patch information the game downloads once, and then distributes it to the other clients so I no longer need to download things twice? If so, then all is good c:
CCP Atropos
C C P
C C P Alliance
#46 - 2015-03-24 15:00:12 UTC
Natya Mebelle wrote:
What if I do not WANT a shared resource folder? I'm running two installations of Eve from two separate harddrives (not partitions, physical hard drives!) because this improves my loading times a lot. If the game is going to pull all data from the same location, I'll be getting frustrated pretty soon...
Or is this only patch information the game downloads once, and then distributes it to the other clients so I no longer need to download things twice? If so, then all is good c:

There's no alternative; you have to have a shared resource cache unless you can fake access to the Windows registry (assuming you're on Windows) The only shared data is the game asset data such as art assets, videos, audio and such. The binaries are still located in individual installs.
CCP Atropos
C C P
C C P Alliance
#47 - 2015-03-24 15:01:17 UTC
Veliki Ritoznojcan wrote:
Cant find any logfile, found 2 launcher.exe set both as run as admin no difference. I can tag the flag in settings but i cant save it. When i return flag is gone

They should be located under the launcher install, within a folder named cache. They will then be called launcher.2015-03-24.log (with different dates per day). You can also try running eve.exe as administrator.
Wish Kaan
Society Of Cognitive Vigilance
#48 - 2015-03-24 15:02:29 UTC  |  Edited by: Wish Kaan
Hi,ticking download all resources begins a 5gig download for me and restarting the launcher doesn't help
Natya Mebelle
Center for Advanced Studies
Gallente Federation
#49 - 2015-03-24 15:04:49 UTC
CCP Atropos wrote:
There's no alternative; you have to have a shared resource cache unless you can fake access to the Windows registry (assuming you're on Windows) The only shared data is the game asset data such as art assets, videos, audio and such. The binaries are still located in individual installs.

Okay, that sounds like it's not going to affect my ingame performance by a lot. Except with "art assets" you mean all textures and 3d models...?
Veliki Ritoznojcan
Veliki Ritoznojcan Corporation
#50 - 2015-03-24 15:08:46 UTC
CCP Atropos wrote:
Veliki Ritoznojcan wrote:
Cant find any logfile, found 2 launcher.exe set both as run as admin no difference. I can tag the flag in settings but i cant save it. When i return flag is gone

They should be located under the launcher install, within a folder named cache. They will then be called launcher.2015-03-24.log (with different dates per day). You can also try running eve.exe as administrator.


did that, allowed eveything in firewall and finally let through, it started downloading 7G file
Frost Ikkala
Lab 23
#51 - 2015-03-24 15:11:15 UTC
After really short update of launcher ,game started without a problems ,
Then noticed small loading bar above time bar ,
After leaving station game was seriously lagging for about 5-8 sec everytime at same location whatever I do its loading again and same lag.


FPS at max no problem [ GPU > AMD R9 280x ]
CPU temperature increased for 8 to 10 c [CPU> Intel i5]
HDD [SSD 120 gb]
Network [ 60/10 mbs]
OS [win 8.1]

When I warp to asteroid field it lags for few sec and then I just appeared at warp in location ,
Same for POS, PI , Stargates , Exploration sites etc . . .

Its like Im downloading same thing all over again like my game is not at the harddrive

How Can I download full game , because this is not working at all , TY !
John WarpingSlow
#52 - 2015-03-24 15:15:22 UTC
Veliki Ritoznojcan wrote:


did that, allowed eveything in firewall and finally let through, it started downloading 7G file


That's what I eventually ended up having to do as well. This is really poor from a security standpoint.

CCP: Can we please get a complete list of IP ranges, protocols, and ports that need to be left open in order to properly update and run the game?






CCP Maxwell
C C P
C C P Alliance
#53 - 2015-03-24 15:19:48 UTC
Frost Ikkala wrote:
After really short update of launcher ,game started without a problems ,
Then noticed small loading bar above time bar ,
After leaving station game was seriously lagging for about 5-8 sec everytime at same location whatever I do its loading again and same lag.


FPS at max no problem [ GPU > AMD R9 280x ]
CPU temperature increased for 8 to 10 c [CPU> Intel i5]
HDD [SSD 120 gb]
Network [ 60/10 mbs]
OS [win 8.1]

When I warp to asteroid field it lags for few sec and then I just appeared at warp in location ,
Same for POS, PI , Stargates , Exploration sites etc . . .

Its like Im downloading same thing all over again like my game is not at the harddrive

How Can I download full game , because this is not working at all , TY !


Go to the launcher settings cog, select the download tab and tick the "Download all the resource files". Restart the launcher and the launcher will download all resources the client needs before you can log in.

CCP Maxwell - QA Engineer - Team RnB

Tarpedo
Incursionista
#54 - 2015-03-24 15:21:54 UTC
I believe download link on the front page of eveonline.com is older version. Is it?

If so - where to find newest launcher?

(checked all threads about new version - they do not have download link)
Natya Mebelle
Center for Advanced Studies
Gallente Federation
#55 - 2015-03-24 15:28:05 UTC
Okay, this does not look good.
No matter what I do, the game thinks I need to migrate 13 Gigabyte towards the shared folder. This means that multiple installations WILL be running from the same client, which WILL impact my performance and load times. Well great.

So while this process is going on, what do I do with my other two installations? I'm not keen on having several gigabyte worth of useless data. Will the clients be removing unnecessary data after moving?
If I open the other client to patch, will I have to migrate all those 13 Gigabyte AGAIN or will it be smart enough to detect the already detected folder?
Or does that mean I have no business any more with two separate installations and need to remove one because I will only run from one executable from now on?
If so, what am I going to do with all those locally stored files? Both clients use separate interface settings, separate market quickorders (dozens of them). Am I needing to rearrange and add EVERYTHING again?

I so don't look forward to this...
Samsara Toldya
Academy of Contradictory Behaviour
#56 - 2015-03-24 15:35:02 UTC
Just out of curiousity:

Download on demand enabled - early after a release is deployed.
Download server is busy and/or even might shut down / not accepting new requests.
I encounter something "new" which will force my client to download higher resolution files of this "new" thing.
Download server won't respond / request timeout:

a) client stops the download request and will only show low resolution of this "new" thing until I encounter it again
b) client might run into a "Socket Closed" because the requested file couldn't be downloaded (outstanding packets, packet loss, ..)

There is already someone in the german forum saying he got connection losses while flying through lowsec... my 2 ISK would be dod related...


CCP Atropos
C C P
C C P Alliance
#57 - 2015-03-24 15:35:15 UTC
Natya Mebelle wrote:
Okay, this does not look good.
No matter what I do, the game thinks I need to migrate 13 Gigabyte towards the shared folder. This means that multiple installations WILL be running from the same client, which WILL impact my performance and load times. Well great.

So while this process is going on, what do I do with my other two installations? I'm not keen on having several gigabyte worth of useless data. Will the clients be removing unnecessary data after moving?
If I open the other client to patch, will I have to migrate all those 13 Gigabyte AGAIN or will it be smart enough to detect the already detected folder?
Or does that mean I have no business any more with two separate installations and need to remove one because I will only run from one executable from now on?
If so, what am I going to do with all those locally stored files? Both clients use separate interface settings, separate market quickorders (dozens of them). Am I needing to rearrange and add EVERYTHING again?

I so don't look forward to this...

Yes, when you start up the second client you'll need to go through the migration steps again. This is an unfortunate consequence of having file names that are determined by the hash of the file content. During testing on Singularity we tried have it as an optional migrate, but we found that users were often not migrating their assets at all, and were then complaining about downloading gigabytes of data.

We decided that it was better to go through a one-time-per-install migration for everyone than to risk most people not migrating at all.

Once the migration process completes, it will delete the source .stuff files in the EVE installation, so you won't have to continually migrate the same installation. It's still possible to have multiple individual installations, although our long term plan is to remove the necessity of having them, simply to isolate your settings profiles.
CCP Atropos
C C P
C C P Alliance
#58 - 2015-03-24 15:36:39 UTC
John WarpingSlow wrote:
Veliki Ritoznojcan wrote:


did that, allowed eveything in firewall and finally let through, it started downloading 7G file


That's what I eventually ended up having to do as well. This is really poor from a security standpoint.

CCP: Can we please get a complete list of IP ranges, protocols, and ports that need to be left open in order to properly update and run the game?

The only new connection requests will be outbound to our CDN under the http://res.eveonline.ccpgames.com hostname.
Frost Ikkala
Lab 23
#59 - 2015-03-24 15:41:03 UTC
CCP Maxwell wrote:
Frost Ikkala wrote:
After really short update of launcher ,game started without a problems ,
Then noticed small loading bar above time bar ,
After leaving station game was seriously lagging for about 5-8 sec everytime at same location whatever I do its loading again and same lag.


FPS at max no problem [ GPU > AMD R9 280x ]
CPU temperature increased for 8 to 10 c [CPU> Intel i5]
HDD [SSD 120 gb]
Network [ 60/10 mbs]
OS [win 8.1]

When I warp to asteroid field it lags for few sec and then I just appeared at warp in location ,
Same for POS, PI , Stargates , Exploration sites etc . . .

Its like Im downloading same thing all over again like my game is not at the harddrive

How Can I download full game , because this is not working at all , TY !


Go to the launcher settings cog, select the download tab and tick the "Download all the resource files". Restart the launcher and the launcher will download all resources the client needs before you can log in.



Ty DEV client is stable now P
6ie
The Kiwis
#60 - 2015-03-24 15:49:25 UTC
Aria Tensus wrote:
If you call this a success I would hate to witness a failure.

The launcher is stuck on an endless loop of "Installing files" and "Downloading EVE launcher update" - those messages alternate rapidly and there is no progress.

If I close the launcher and restart it, then it downloads the update and closes itself, never to be seen again. After relaunching we're back to square one.


Same.
Fix was just to install:
http://cdn1.eveonline.com/EveOnlineLauncher/release/EVEOnlineLauncher_2_2_871265.exe