These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Probe

 
  • Topic is locked indefinitely.
 

Want to make a scene?

First post First post
Author
CCP Darwin
C C P
C C P Alliance
#81 - 2015-02-03 11:03:56 UTC
Lair Osen wrote:
Hey Darwin, you know the dna for Mordus Ships? Can't see them anywhere usingTriExporter :(

E: found them in the caldari folders



Yep, for example the frigate is

cf9_t1:mordus:caldari

At some point we will likely split out Mordu's Legion as their own race but it hasn't happened yet.

CCP Darwin  •  Senior Software Engineer, Art & Graphics, EVE Online  •  @mark_wilkins

Discomanco
We pooped on your lawn
#82 - 2015-02-03 11:36:35 UTC
Anything on my error, fix, something I missed? :(
EVE Probe works just fine, despite being laggy as hell *cough*, it's just opening exefile through the script that fails
CCP Darwin
C C P
C C P Alliance
#83 - 2015-02-03 11:45:20 UTC
Discomanco wrote:
Anything on my error, fix, something I missed? :(
EVE Probe works just fine, despite being laggy as hell *cough*, it's just opening exefile through the script that fails


The top two issues seem to be:

1) Misreading the directory where you start the program. You MUST set your current working directory to

C:\ProgramData\CCP\EVE\SharedCache\probe

and run with this command:

bin\exefile.exe /lib=code.ccp

Note that C:\ProgramData is hidden by default. Also, many people have been attempting to run it from inside the bin directory. This will not work.

CCP Darwin  •  Senior Software Engineer, Art & Graphics, EVE Online  •  @mark_wilkins

Discomanco
We pooped on your lawn
#84 - 2015-02-03 11:49:14 UTC
CCP Darwin wrote:
Discomanco wrote:
Anything on my error, fix, something I missed? :(
EVE Probe works just fine, despite being laggy as hell *cough*, it's just opening exefile through the script that fails


The top two issues seem to be:

1) Misreading the directory where you start the program. You MUST set your current working directory to

C:\ProgramData\CCP\EVE\SharedCache\probe

and run with this command:

bin\exefile.exe /lib=code.ccp

Note that C:\ProgramData is hidden by default. Also, many people have been attempting to run it from inside the bin directory. This will not work.

Nope no good :( The directory is \probe and the script is directly C/Pd still getting the error that it's not a valid Win32 application
http://gyazo.com/cf043332d0bf99a016a0ce6edb90f74d
CCP Darwin
C C P
C C P Alliance
#85 - 2015-02-03 12:12:49 UTC  |  Edited by: CCP Darwin
Discomanco wrote:

Nope no good :( The directory is \probe and the script is directly C/Pd still getting the error that it's not a valid Win32 application
http://gyazo.com/cf043332d0bf99a016a0ce6edb90f74d


I've verified that the executable is a 32-bit application, so it's not a case of a 64-bit exe file failing on your 32-bit system.

CCP Snorlax says that if the file is corrupted, you can re-run the launcher and it should be corrected.

CCP Darwin  •  Senior Software Engineer, Art & Graphics, EVE Online  •  @mark_wilkins

Lair Osen
#86 - 2015-02-03 12:40:34 UTC
Yeah my exefile seemed to get corrupted somehow and ended up as a 0kb file that returned the not valid win32 error. Running the probe launcher again fixed it.
Ragnar Sorlandschip
The Scope
Gallente Federation
#87 - 2015-02-03 13:32:03 UTC
Still can't figure out how to control which turrets to be fitted, if that's even possible atm. Can do "fit_random_launchers", but that will only add capital launchers regardless of ship size.

Can siege modes be activated?
CCP Snorlax
C C P
C C P Alliance
#88 - 2015-02-03 13:32:17 UTC
CCP Darwin wrote:
Discomanco wrote:

Nope no good :( The directory is \probe and the script is directly C/Pd still getting the error that it's not a valid Win32 application
http://gyazo.com/cf043332d0bf99a016a0ce6edb90f74d


I've verified that the executable is a 32-bit application, so it's not a case of a 64-bit exe file failing on your 32-bit system.

It's possible the binary is corrupted. I recommend deleting the SharedCache folder and then running the launcher from the shortcut in Program Files (x86) again. Be sure to allow EVE Probe to run through all the default scenes. This will re-download the contents of that folder and may resolve an issue with a corrupted file.

Deleting the shared cache folder is overkill - running from the launcher again should be enough.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

CCP Rave
C C P
C C P Alliance
#89 - 2015-02-03 13:42:37 UTC
l0rd carlos wrote:
TL;DR: around the lines 200 in main.py object_location_dict[ok] only has one key in the example, that key is "0", what does that stand for and what are "first" and "last" supposed to be?

[22:44] max12345 I don't think i can do this without comments or some help with the structuring
[22:44] max12345 the thing I'm stuck at right now is that it's looping through some location keys
[22:45] max12345 they are sorted by coordinate then by number they by datakey data pairs
[22:45] max12345 but I have no idea what the number stands for
[22:46] max12345 and they somehow need it for "first" and "last" variables
[22:46] max12345 but there is only 1 entry for the number
[22:46] max12345 so it'd be the same for the example case
[22:46] lord-carlos "Part of the problem is that xrange() is a Python 2.x built-in and I don't think is defined in 3.x. However, xrange() in 2.x has the same functionality as range() in 3.x. Looks like an oversight."
[22:46] lord-carlos https://forums.eveonline.com/default.aspx?g=posts&m=5457468#post5457468
[22:46] max12345 yes that's fine, I already changed that, I'm stuck somewhere else.
[22:47] max12345 this is almost making me resub
[22:47] max12345 :D
[22:48] max12345 he should hop on irc :D
[22:48] niki who is that awesome CCP Darwin guy
[22:49] max12345 idk but he's pretty cool releasing these tools at all imo

[22:53] max12345 around the lines 200 in main.py object_location_dict[ok] only has one key in the example, that key is "0", what does that stand for and what are "first" and "last" supposed to be?
[22:55] max12345 I'm sure these are issues he can solve much faster though


:)))))


The keys represent the order of location keys, starting with 0 for the first key.

If there were five keys, they would be 0, 1, 2, 3 and 4 (in order).

Each key actually maps to a dictionary that represents a Bezier (or possibly Hermite) curve. It has the following keys:
"start_time": The time from the beginning of the scene to the start of the animation curve.
"end_time": The time from the beginning of the scene to the end of the animation curve.
"start_value": The x,y,z location of the model at the start of the animation
"end_value": The x,y,z location of the model at the end of the animation
"control_1": First control point.
"control_2": First control point.

first and last should be the first and last of those dictionaries.
CCP Rave
C C P
C C P Alliance
#90 - 2015-02-03 13:49:38 UTC
CCP Darwin wrote:
Sarmatiko wrote:
BTW is the frame capture command works in this build?
I've tried "/capturefolder=c:\movie\" but it looks like this command was ignored by Probe.


I'm having some trouble getting this to work myself.

l0rd carlos wrote:

File "/usr/local/lib/python3.4/dist-packages/dae_to_red-0.0.0-py3.4.egg/dae_to_red/main.py", line 289, in _read_axis_keys_from_nodes
NameError: name 'xrange' is not defined


Someone in the #eve-dev IRC channel has the same trouble and tries to fix it.


Part of the problem is that xrange() is a Python 2.x built-in and I don't think is defined in 3.x. However, xrange() in 2.x has the same functionality as range() in 3.x. I'm not sure what the story is here.

Also:

I notice that if you use demo.yaml as your scene name, and you by mistake name your yaml file something else (like in my case demo.yaml.txt), it appears to find a demo.yaml that's in the shared cache. You apparently MUST use the extension ".yaml" and not ".yml" or anything else, and then it'll find the file correctly. The shared cache demo.yaml shows the Caldari battleships with default Caldari faction and the example from the docs uses the Guristas faction markings.


Correct. The project was written in Python 2.7. If someone were to upgrade it to be 3.x compatible and send a pull request on GitHub, that would make me happy.

And yes, all yaml files must have the .yaml extension.
Ragnar Sorlandschip
The Scope
Gallente Federation
#91 - 2015-02-03 15:52:51 UTC
Traceback (most recent call last):
    File "setup.py", line 9, in < module >
        reqs            = [str(ir.req) for ir in install_reqs]
AttributeError: 'str' object has no attribute 'req'


This is what I get when trying to install dae-to-red. Any ideas?
Midori Tsu
Viziam
Amarr Empire
#92 - 2015-02-03 16:28:58 UTC  |  Edited by: Midori Tsu
Is it possible to have the camera follow an animation path? (specifically when using _handle_bind_matching_dynamics) or does it need to follow a seperate file?

Also, how do i make sure the animation is scaled correctly?

Also, having a ship blow up, how is this hanndled?
CCP Snorlax
C C P
C C P Alliance
#93 - 2015-02-03 16:48:08 UTC
Midori Tsu wrote:
Is it possible to have the camera follow an animation path? (specifically when using _handle_bind_matching_dynamics) or does it need to follow a seperate file?

Also, how do i make sure the animation is scaled correctly?

Also, having a ship blow up, how is this hanndled?

The camera should be able to follow an animation path. Create a named camera, select that camera and make sure one of the animations refers to that same name.

Something like:

- [camera, main_camera, 1.57, 3.0, 100000.0]
- [select_camera, main_camera]
- [bind_matching_dynamics, 'animations.red']


There is an explosion_for_actor command:

- [explosion_for_actor, explosion, 'res:/fisfx/deathexplosion/death_h_amarr.red', actor_name, 0.1]

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Rollo Brinalle
Imaginary Rats.
#94 - 2015-02-03 17:35:45 UTC
I'm having an issues with getting a vindicator to load. I'm using 'gb2_t1:gallentebase:serpentis' I have it narrowed down to something with serpentis that is causing the issue. Can someone confirm if I'm doing something wrong or there is a different code for this ship.
CCP Darwin
C C P
C C P Alliance
#95 - 2015-02-03 18:29:03 UTC
Rollo Brinalle wrote:
I'm having an issues with getting a vindicator to load. I'm using 'gb2_t1:gallentebase:serpentis' I have it narrowed down to something with serpentis that is causing the issue. Can someone confirm if I'm doing something wrong or there is a different code for this ship.


Yes, the problem is that the third part of the ship DNA only controls the booster color, and there is no valid "serpentis" choice. Based on visual inspection, I think the correct ship DNA is:

gb2_t1:serpentis:gallente

Note that "serpentis" is not a full-blown race, it's considered a Gallente faction.

CCP Darwin  •  Senior Software Engineer, Art & Graphics, EVE Online  •  @mark_wilkins

CCP Rave
C C P
C C P Alliance
#96 - 2015-02-03 18:44:46 UTC
Ragnar Sorlandschip wrote:
Traceback (most recent call last):
    File "setup.py", line 9, in < module >
        reqs            = [str(ir.req) for ir in install_reqs]
AttributeError: 'str' object has no attribute 'req'


This is what I get when trying to install dae-to-red. Any ideas?


I don't know. Which versions of Python and PIP are you using ? I'm using Python 2.7.9 and PIP version 1.5.6 and it just works. As far as I know parse_reqirements should always return a list.
Rollo Brinalle
Imaginary Rats.
#97 - 2015-02-03 21:15:14 UTC
CCP Darwin wrote:
Rollo Brinalle wrote:
I'm having an issues with getting a vindicator to load. I'm using 'gb2_t1:gallentebase:serpentis' I have it narrowed down to something with serpentis that is causing the issue. Can someone confirm if I'm doing something wrong or there is a different code for this ship.


Yes, the problem is that the third part of the ship DNA only controls the booster color, and there is no valid "serpentis" choice. Based on visual inspection, I think the correct ship DNA is:

gb2_t1:serpentis:gallente

Note that "serpentis" is not a full-blown race, it's considered a Gallente faction.


Awesome! That's it.
Ragnar Sorlandschip
The Scope
Gallente Federation
#98 - 2015-02-03 21:32:14 UTC  |  Edited by: Ragnar Sorlandschip
CCP Rave wrote:
I don't know. Which versions of Python and PIP are you using ? I'm using Python 2.7.9 and PIP version 1.5.6 and it just works. As far as I know parse_reqirements should always return a list.


Python is 2.7.9 and PIP should be what came with it. Trying to re-install pip only results in a wall of red errors. Gonna try to clean out my current python installation since it may somehow be a complete mess.

EDIT: Yup, it's messed. This is when trying to uninstall python: http://i.imgur.com/bliXrAg.png
Sarmatiko
#99 - 2015-02-04 10:48:03 UTC
Rollo Brinalle wrote:
Awesome! That's it.

The easiest way to load ship properly (if you unsure in DNA) is to look at graphics.static contents.
"sofRaceName" is the booster color and "sofFactionName" is the base color.
Joshua Foiritain
Coreli Corporation
Pandemic Legion
#100 - 2015-02-04 20:41:39 UTC  |  Edited by: Joshua Foiritain
Two questions, when using _handle_empty_scene to render a scene without a nebula is it possible to change the black BG color to something else? (like green) I noticed the _handle_trinity_setting option but have no idea what kind of options we can change P

Also the capture option does not seem to work for me, this is the command line im running:
C:\ProgramData\CCP\EVE\SharedCache\probe>bin\exefile.exe /lib=code.ccp /windowed /width=512 /height=512 /scenes=test.yaml /capturefolder=D:\Movies

I've tried various folders, existing and none existent ones, different drives, trailing slash, no trailing slash, etc. Nothing jumps out in the error log. Any idea what im doing wrong?

The Coreli Corporation is recruiting.