These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

Kronos Macintosh Issues and Feedback

First post
Author
Eric Agerwal
Cryosoft
#141 - 2014-06-24 13:45:41 UTC
Also on the point of authentication hanging.... Why is it sometimes the progress bar renders as a hollow rectangular perimeter that fills up - and other times as a solid rectangle..
Not sure - but maybe the solid one is when it hangs....
Eric Agerwal
Cryosoft
#142 - 2014-06-24 13:50:40 UTC  |  Edited by: Eric Agerwal
Crap 200mb+ patch again - crashed 2 sessions immediately after trying to log second alt in.
CCP please get this sorted!!!
And.. multiple account logins also still locking up remaining sessions. Logged 3 in.. Logged 1 out -other 2 ok still responsive.
Logged 2nd out and remaining account now unresponsive - and shows 2nd account I just logged out in chat window - so service/presentation layer seems to be still messed up.
Helda Duvion
Sirius Syndicate
Federation of Respect Honor Passion Alliance.
#143 - 2014-06-24 17:39:59 UTC
Same problem as #141 - tried it with the Eve Repair Tool, but it creates one patch after the other, it's slow as hell (running over an hour now!), and no sign it'll work afterwards. Here's some log:

(4/7) Calculating patch: Initializing ...
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/_CodeSignature/CodeResources, missing 1 out of 1 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libcef.dylib, missing 2 out of 563 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libSteam.dylib, missing 1 out of 45 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libtier0_s.dylib, missing 2 out of 4 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libwx_osx_cocoau-2.9.4.0.0.dylib, missing 6 out of 798 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/Python.framework/Versions/2.7/Python, missing 7 out of 53 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/MacOS/launcher, missing 2 out of 2 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/MacOS/python, missing 1 out of 1 blocks
(4/7) Calculating patch: 100.0%, 00m00s
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Resources/lib/python2.7/site-packages.zip, missing 12 out of 89 blocks
(5/7) Loading cache: Initializing ...
(5/7) Loading cache: 100.0%, 00m00s
(6/7) Downloading patch: Initializing ...
(6/7) Downloading patch: 100.0%, 1.25 MB/1.25 MB, 40.24 KB/s, 11m51s
(7/7) Applying patch: Initializing ...
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/_CodeSignature/CodeResources
Warning: failed to add block - (-1100839393, 's\xec\xaa\xa3\xb6\x0c\xaa\xbb}\xe5l\xb7\xc5#D.')
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libcef.dylib
Warning: failed to add block - (323290578, '\rgq\x15Us\xc2\xed\x99\x8a5Fj\x15\xc9\t')
Warning: failed to add block - (-392904721, '\xa0\xee\x8b\x1f\x8e\xc9\xf4D\xc8\xc3=e\x15\x99\xd5S')
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libSteam.dylib
Warning: failed to add block - (-290520275, '}o?\xe9\xbf\x11\x93,\xcb\xb2\x90\x1af\xf7\x02S')
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libtier0_s.dylib
Warning: failed to add block - (-1694947024, 'i\x0b\xcfu\xc4kI\xdb\xdc]Q}_\x8f%\x08')
Warning: failed to add block - (-1928404439, '\xfa\xd8\xe2\x17G\xf9C=\xa1\xd4\x18?\xba\x9e\xf98')
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libwx_osx_cocoau-2.9.4.0.0.dylib
Warning: failed to add block - (-2138461643, '\xceR\x1c>\n\x8b\x88\x9cd\x19\x13\x199\x1e\xd5\x04')
Warning: failed to add block - (-716825900, '\x92\x83k6\xd8\x88r\xa0\xe3+B\xcfGH&\xcd')
Warning: failed to add block - (1823982450, '\xc1\x8a\xf6h\xb0+\xfdB\x9e\x0cvC\xcdh\xd9\x85')
Warning: failed to add block - (64320096, '4\xc5\x05\xbd^\xc2`\r\xeb]rf\xb5\xc8\x95\xc8')
Warning: failed to add block - (-221990693, '~\xda<\xa3 C\x943\xc2\x9d\x01\xbc\xf1l\x92\xf3')
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/Python.framework/Versions/2.7/Python
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/MacOS/launcher
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/MacOS/python
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Resources/lib/python2.7/site-packages.zip
(7/7) Applying patch: 100.0%, 00m02s
Deleting downloaded temporary data
(1/7) Downloading index: Initializing ...
(1/7) Downloading index: 100.0%, 46.03 KB/46.03 KB, 8.15 KB/s, 00m02s
(2/7) Hashing files: Initializing ...
(2/7) Hashing files: 100.0%, 00m00s
(3/7) Downloading recipes: Initializing ...
(3/7) Downloading recipes: 100.0%, 27.57 KB/27.57 KB, 5.51 KB/s, 00m05s
(4/7) Calculating patch: Initializing ...
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/_CodeSignature/CodeResources, missing 1 out of 1 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libcef.dylib, missing 2 out of 563 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libSteam.dylib, missing 1 out of 45 blocks
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libtier0_s.dylib, missing 2 out of 4 blocks
(4/7) Calculating patch: 100.0%, 00m00s
appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libwx_osx_cocoau-2.9.4.0.0.dylib, missing 5 out of 798 blocks
(5/7) Loading cache: Initializing ...
(5/7) Loading cache: 100.0%, 00m00s
(6/7) Downloading patch: Initializing ...
(6/7) Downloading patch: 100.0%, 305.52 KB/305.52 KB, 10.70 KB/s, 12m00s
(7/7) Applying patch: Initializing ...
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/_CodeSignature/CodeResources
Warning: failed to add block - (-1100839393, 's\xec\xaa\xa3\xb6\x0c\xaa\xbb}\xe5l\xb7\xc5#D.')
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libcef.dylib
Warning: failed to add block - (323290578, '\rgq\x15Us\xc2\xed\x99\x8a5Fj\x15\xc9\t')
Warning: failed to add block - (-392904721, '\xa0\xee\x8b\x1f\x8e\xc9\xf4D\xc8\xc3=e\x15\x99\xd5S')
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libSteam.dylib
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libtier0_s.dylib
Restoring: appdata/EVE Online-2.1.655130.macosx/EVE Online.app/Contents/Frameworks/libwx_osx_cocoau-2.9.4.0.0.dylib
(7/7) Applying patch: 100.0%, 00m01s
Deleting downloaded temporary data
(1/7) Downloading index: Initializing ...
(1/7) Downloading index: 100.0%, 46.03 KB/46.03 KB, 8.16 KB/s, 00m02s
(2/7) Hashing files: Initializing ...
(2/7) Hashing files: 100.0%, 00m00s
(3/7) Downloading recipes: Initializing ...
(3/7) Downloading...
Helda Duvion
Sirius Syndicate
Federation of Respect Honor Passion Alliance.
#144 - 2014-06-24 17:42:36 UTC
(6/7) Downloading patch: 11.7%, 7.87 KB/67.54 KB, 146 B /s, 06m56s

Good work seems to look different :-/
Helda Duvion
Sirius Syndicate
Federation of Respect Honor Passion Alliance.
#145 - 2014-06-24 18:02:46 UTC  |  Edited by: Helda Duvion
Now it finally failed Evil
Not even the Launcher starts now...
Helda Duvion
Sirius Syndicate
Federation of Respect Honor Passion Alliance.
#146 - 2014-06-25 09:49:23 UTC
On the forth try running Eve Online Repair i finally got it - after 5 hours or so? And no reply from the support team to my ticket by now, as usual Roll
Ragnar D IX
Shadow Flight
Dark Aviation
#147 - 2014-06-25 17:57:54 UTC
I get hung up on 'Authenticating' screen....

I have cleared cache
run Eve Repair utility
and did a complete remove/install x2.....

No joy.


Kai-Lo Darklighter
Conquering Darkness
#148 - 2014-06-26 17:47:53 UTC  |  Edited by: Kai-Lo Darklighter
" #104 Posted: 2014.06.08 18:01 | Report
2
Running Multiple Clients - When I quit one, it crashes the others!

Since updating to Kronos, the Mac EVE Client has worked better for me. I can actually run three clients in a fairly stable manner for long duration, even when outputting to a 1080p TV via HDMI.

The problem, however, is that if I quit one client, the other clients immediately freeze/lock up. Doesn't matter where I am or what I am doing, so as you can imagine this is an issue when in PvE, or PvP.

I am using an older release of Acrobat Flash Reader 11 because of the previous Launcher crash/issues with the latest Adobe Flash player 13.

Macbook Pro Laptop
15in Late 2008
2.53 Ghz Intel Core 2 Duo
4GB 1067mhz DDR3
NVIDIA GeForce 9600M GT 512 MB
OS X 10.9.3 w/ Latest Updates"


OP above.

Since the latest patch something broke. I was able to play multiple clients before, with one the only issue being the use of force quit to close a client since the closing issue has not yet been addressed.

I updated to the latest version of Adobe Flashplayer in the hope that it would fix the issues, but no luck. The only way I can get past the authentication screen after the launcher window closes, is to hit esc. and try the work around where you click full screen and apply. That randomly works, perhaps 1 out of 5 launches. Cannot launch more that one client, even after it takes me 20 minutes to get one successful client launch.

I pay real world money for multiple subscriptions, and also purchase PLEX to convert to ISK for projects. The lack of customer service, or a serious attempt to fix issues since the Adobe Flashplayer bug in April is starting to be a bit much given the real world money I pay to CCP.

CPP, are there any fixes or resolutions on the horizon?

Am I missing some other forum where CCP is more active in responding to the Mac client issues or is this thread it post Kronos?

Edit#1: Okay. I went back to an older version of Adobe flashplayer, version 11.700 something from early April, and I at least got the client and multiple instances to work. After I deleted and reinstalled the flash player and restarted I ran the Mac launcher clear cache and the client cache clear tools. Let's see how long this lasts!
Eric Agerwal
Cryosoft
#149 - 2014-06-26 21:22:26 UTC
I don't even have any Adobe plugins/apps installed on my Mac at the moment - and have all the issues. So it may be unrelated to that
zBluesky
Imperial Shipment
Amarr Empire
#150 - 2014-06-27 05:53:32 UTC
I run two clients but when I try to exit one the other client crashes. I signed up for the power of 2 special---but it is not working out to my satisfaction. I am just one more person to the list of many who are having the problem. Could a dev respond with an update?
CCP Sledgehammer
C C P
C C P Alliance
#151 - 2014-06-27 10:03:34 UTC
Hi folks,

Regarding the crash when you close one of multiple clients, I will be testing out what our partners have advised today and will update this thread with my findings.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

CCP Sledgehammer
C C P
C C P Alliance
#152 - 2014-06-27 13:43:16 UTC
Hey everyone.

I have spent the last couple of hours messing around with running/quitting multiple clients based on the suggestions of our partners so I wanted to update this thread with my findings.

Firstly, I took the precaution of again ensuring that the crash occurred for me when I quit one of the multiple clients, which it did.

With that confirmed, I navigated to /Library/Application Support and found the EVE Online folder and deleted it to ensure that when I created some clones I had fresh, default settings.

After that I grabbed our Clonemaker tool from here and then followed the instructions here to create multiple clones of my TQ installation.

Since then, I have had 3 clients running at the same time then quitting randomly from different scenes without any of the other clients crashing, and by looking at Activity Monitor (Applications > Utilities > Activity Monitor) confirmed that there were an equivalent number of "wineserver" processes to active EVE Clients.

I would really like people to try the above, especially including deleting your "...\Application Support\EVE Online" folder.

I would also like to draw people's attention to the other methods of setting up multiple clients listed here if this Clonemaker method does not work for you.

I must state that I have not personally tested the other methods there, and if you do try them out I would strongly advise deleting any existing clients and settings folders and try it from a fresh install so that everyone who tries has a baseline to work from and compare.

Please let me know how you get on!

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Seith Kali
Caldari Provisions
Caldari State
#153 - 2014-06-27 14:44:55 UTC
It can work for quite some time before you get crashes. I haven't been able to replicate it consistently but deleting all your settings again is a total PITA (we can't even use garpa to manage settings on OSX) and not really going to help if you already had to do it once for kronos. (I couldn't even launch the client without doing this initially - it was infuriating)

It has got to be a leak of the shutdown signal to other processes in some manner. There is some weirdness with window focus that can occur multiboxing (particularly on login - try having a client running opening another instance of the same one while and log in, continuing to interact with the first window) which could be related.

Far more likely is it is related to having the 'resource caching' graphic setting enabled and cutting the connection to that cache hits both if they have some shared resources. Anyways, deleting settings doesn't help its just more pain. I miss my market quickbar...

Apprentice Goonswarm Economic Warfare Consultant - Drowning in entitlement and privilege. 

Cade
Underworlds
#154 - 2014-06-27 15:04:54 UTC
wait wai wait, you need to clone your eve app to get multiple clients to work on mac?

why not just to use one launcher and eve as I do ?
CCP Sledgehammer
C C P
C C P Alliance
#155 - 2014-06-27 15:09:45 UTC
Cade wrote:
wait wai wait, you need to clone your eve app to get multiple clients to work on mac?

why not just to use one launcher and eve as I do ?


In a lot of cases we are seeing problems where closing one client while multiple clients are running at the same time will crash the other open clients.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Cade
Underworlds
#156 - 2014-06-27 15:37:28 UTC
CCP Sledgehammer wrote:
Cade wrote:
wait wai wait, you need to clone your eve app to get multiple clients to work on mac?

why not just to use one launcher and eve as I do ?


In a lot of cases we are seeing problems where closing one client while multiple clients are running at the same time will crash the other open clients.


I have same issue if I use ESC -> quit game, but if I use X (windowed mode) and use Quit game from popup, it works just fine for me. Been using with 1 to 5 clients at the time, thought heating issue if any sort of action with 5, 3 works pretty good and heat is the only issue this far with 3 or below.

using late 2013, i7, 16gb 15" mbp, cant remember the gpu but think it was NVIDIA 750 2gb or similar with 2gb, 10.9.3 os
Eric Agerwal
Cryosoft
#157 - 2014-06-27 17:19:03 UTC  |  Edited by: Eric Agerwal
I bit the bullet and heeded CCP Sledgehammers advice. I've trashed all the Eve application support folders after doing a backup first...
Since doing this I've been doing the setup of the ESC menu options for 7 accounts. Had no issues logging out and getting lock ups. Also the clone maker 5 created clones that didn't give me an immediate cider crash any more.
I've not had a single cider crash for things like logging 4 accounts in at once... or a triple undock from Jita.
So it's a pain - but at least i can start playing again - was on the brink of giving up.
Seith Kali
Caldari Provisions
Caldari State
#158 - 2014-06-27 18:00:52 UTC  |  Edited by: Seith Kali
I can replicate it consistently now it's got nothing to do with the settings.

To not crash you need to have another application higher in the priority cue for alt-tab.

To replicate


  1. Open eveclient1
  2. Open eveclient2
  3. Alt tab so that you are switching between the two with no other application in-between
  4. press cmd-q on eveclient1
  5. watch in horror as eveclient2 crashes


To not crash


  1. Open eveclient1
  2. Open eveclient2
  3. Open some other application
  4. Alt tab so that you are switching between all three
  5. press cmd-q on eveclient2
  6. as long as the other application gets window focus as you close eveclient2 eveclient1 does not crash

Apprentice Goonswarm Economic Warfare Consultant - Drowning in entitlement and privilege. 

Eric Agerwal
Cryosoft
#159 - 2014-06-27 18:41:25 UTC  |  Edited by: Eric Agerwal
Seith Kali - you may have a solution for multi session lockups then... but it would have still left me inundated with cider crashes. I have had none since doing my change. Although it's a pain - I prefer system stability ;-) I also don't have to get in habit of focusing windows - it works for whatever sequence of account I've jumped between.
Eric Agerwal
Cryosoft
#160 - 2014-06-28 10:51:10 UTC  |  Edited by: Eric Agerwal
CCP Sledgehammer. It took me about 4 hours to get a first cut at getting the UI setup again across 21 alts. I expect to tweak these more in the coming days... It was an extremely tedious thing to have to do. And I'm somewhat alarmed when I think about CCP's intention to do more minor releases rather than the occasional big one.
Source of concern:
http://www.ccpgames.com/en/public-relations/press-releases/article/77322/kronos-first-of-upgraded-eve-online-development-model/
On average 10 releases instead of 2 per year!
Does this mean I'll be needing to do this again?:
[
i) delete my Eve application support folders
ii create default app support folder again by launching app for one account.
iii) create all clones again with clone maker
]:
a) come July 22nd with the Crius release?
http://community.eveonline.com/news/dev-blogs/coming-in-crius-introducing-whats-in-eves-big-industry-release/
b) or any minor releases/patches before that?
c) Or is it only when cider changes that I will need to repeat this process?