These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Ships & Modules

 
  • Topic is locked indefinitely.
 

pyfa 1.15.0 (Vanguard)

First post First post First post
Author
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#101 - 2013-09-04 17:40:43 UTC
Invisusira wrote:
Unless I'm mistaken, fleet boosts no longer seem to be working? The fleet boosting interface is pretty bad (read: you pretty much have to google search it to figure out how to use it and even then you're not sure), so I could just be forgetting how to set them. If that could be improved in a later version (pop-up menus for fleet/wing/squad booster ship fits, like the pop-up menus for characters?), I'm sure everyone would be very happy. :)


Seem to be working for me.

Browse to your fit, then open it. Then browse to your boosting ship fit, right click -> set as whatever. Then choose character in the fleet panel.

Yes, the boosting interface is pretty bad. Hopefully work will start on a new one once the new engine in finished.
Sergeant Acht Scultz
School of Applied Knowledge
Caldari State
#102 - 2013-09-04 18:39:15 UTC
Thx for this update Kadesh, GJ.

removed inappropriate ASCII art signature - CCP Eterne

Invisusira
Escalated.
Project Gungnir.
#103 - 2013-09-05 02:43:24 UTC
Sable Blitzmann wrote:
Invisusira wrote:
Unless I'm mistaken, fleet boosts no longer seem to be working? The fleet boosting interface is pretty bad (read: you pretty much have to google search it to figure out how to use it and even then you're not sure), so I could just be forgetting how to set them. If that could be improved in a later version (pop-up menus for fleet/wing/squad booster ship fits, like the pop-up menus for characters?), I'm sure everyone would be very happy. :)


Seem to be working for me.

Browse to your fit, then open it. Then browse to your boosting ship fit, right click -> set as whatever. Then choose character in the fleet panel.

Yes, the boosting interface is pretty bad. Hopefully work will start on a new one once the new engine in finished.

Ahhh yes there we go. Was just doing it wrong.

Yeahhh please improve this interface.
Tetsuo Tsukaya
Perkone
Caldari State
#104 - 2013-09-05 22:39:25 UTC
Have been using this since I started playing EVE and most of our corp fittings wouldn't exist without Pyfa. You guys are awesome, thanks
Grombutz
The Scope
Gallente Federation
#105 - 2013-09-05 22:49:54 UTC
that warfare link interface is the worst piece of crap I've ever seen.

- 9003/10
Donbe Scurred
University of Caille
Gallente Federation
#106 - 2013-09-05 22:59:51 UTC
Grombutz wrote:
that warfare link interface is the worst piece of crap I've ever seen.

- 9003/10


Unbelievable, why don't you post constructively (how would you make it better?) instead of whining about a tool that someone puts their personal time into to produce for you to use for FREE.
Kargan Hent
OUT OF TAX
#107 - 2013-09-07 13:15:10 UTC
Hey there !

Nice to see Pyfa back again , thanks alot !


btw , i meet a lil' problem , i canot setup my API in Pyfa. When i open the character managment, Pyfa simply crash . :'(


Is there any Libs requirement or something that i miss installed ?
Symetre
Valentine Inc.
#108 - 2013-09-11 17:46:15 UTC
Thank you so much for this tool!

Just noticed the Kestrel will not load any fits, only ship I've noticed not working.
Kadesh Priestess
the king asked me to guard the mountain
Silent Company
#109 - 2013-09-12 15:33:00 UTC
Ogard Aumer wrote:
Tool is great but I was able to start it exactly one time after that I am not able to open it again.

I dont even get any error messages, does anyone have the same problem?

I am using Windows 7 OS.
Try launching it from console (start -> run -> cmd, cd to pyfa folder, pyfa.exe) and see if it prints there anything.

Donbe Scurred wrote:
Grombutz wrote:
that warfare link interface is the worst piece of crap I've ever seen.

- 9003/10


Unbelievable, why don't you post constructively (how would you make it better?) instead of whining about a tool that someone puts their personal time into to produce for you to use for FREE.
That's a poor excuse for doing obviously bad things (and fleet boost UI is one of the things i myself consider as bad). Good thing is that there're plans to rework it into something more usable, but not before engine supports all required features.

Symetre wrote:
Just noticed the Kestrel will not load any fits, only ship I've noticed not working.
I already fixed it in development version, Kestrel should be fine starting from next release.
Garviel Tarrant
Beyond Divinity Inc
Shadow Cartel
#110 - 2013-09-16 22:55:25 UTC
I like all the features.. i think its excellent

but why does overheating guns have like a 2 second latency?(just an example, everything is like that) Its really really slow...

BYDI recruitment closed-ish

Primo Theron
Violent Ambitions
#111 - 2013-09-20 20:48:13 UTC
Hey guys... there seems to be something wrong showing the velocity on the Vagabond with 10 MN modules

William Darkk
Garoun Investment Bank
Gallente Federation
#112 - 2013-09-21 00:40:19 UTC
I've noticed pyfa beachballing and crashing lately while editing fits. I know there's a directory in my home folder that I can delete to clear the settings that might be causing the problem, but will this delete my fits?

Using a mac.
Dirritat'z Demblin
Buntspecht GmbH und Co. KG
Black. Flag.
#113 - 2013-09-23 22:25:46 UTC  |  Edited by: Dirritat'z Demblin
Hey, is it just me, or is someone else havin trouble fiting a Kestrel in PYFA?

For some reason, I cant create Fits for the Kestrel. I can enter a Name, but no, no fitting-screen apearing. When I pick another ship (or just navigate somewhere else in the Ship tree for that mater) and come back to the Kestrel, it then shows me all the Fits I previously created. But when i Try to open/show that fit, the screen remains blank, not even showin Slots/CPU/Grid/etc... in the Sidebar.

As far as I can see, this seems to be a specific problem with the Kestrel. No other ship I tried showed that kinda... "buggy" behavior. Multiple re-installing and/or restarting of PYFA did not fix the problem.

[Edit:]

Ups... just seen, the problem is allready known and on the "fixed soon" list. Srry ^^

Note to Self; Read first, write thereafter.

BTW:
Thx for the Work :)
Louis Ferreira
Viziam
Amarr Empire
#114 - 2013-09-25 22:59:02 UTC
Anybody have any ideas why I keep getting "random" segfaults with pyfa? Its been happening for months on several different (gnu/linux) operating systems (such as Debian (currently running sid), Fedora, and Gentoo). It seems to happen most often when fiddling with drones but can happen whenever I do anything, such as add a module, change the status of a module, or open the character editor. The most recent gdb error is
Quote:

[New Thread 0x7fffdf7fe700 (LWP 2962)]
[Thread 0x7fffde7fc700 (LWP 2948) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffdf7fe700 (LWP 2962)]
0x00007fffe6f08f70 in sqlite3_value_type ()
from /usr/lib/x86_64-linux-gnu/libsqlite3.so.0

Is there anything I can do about this? I have all of the prerequisites specified in readme.txt.
Quote:

python 2.7.5 (package python2.7)
sqlalchemy 0.8.2 (package python-sqlalchemy)
numpy 1.7.1 (package python-numpy)
matplotlib 1.3.0 (package python-matplotlib)
wxpython 2.8.12.1 (package python-wxgtk2.8)

Reccaning Irwin
Deep Core Mining Inc.
Caldari State
#115 - 2013-09-26 01:57:12 UTC
Sorry if it's been mentioned. With the latest build of pyfa (1.1.16), Several of my friends and I are unable to fit a kestrel. The fitting will not come up and even if you can get it to come up it has no slots or stats.
Aivo Dresden
Caldari Provisions
Caldari State
#116 - 2013-09-27 08:43:14 UTC  |  Edited by: Aivo Dresden
Currently unable to download the tool. Link points to "This page can't be displayed".

EDIT: It might be the actual EVE hosting service, since everything on there is giving this error when I attempt to dwnload it. :P
Justin Perelta
Deep Core Mining Inc.
Caldari State
#117 - 2013-10-01 10:55:28 UTC  |  Edited by: Justin Perelta
First off, THANK YOU! Your work is appreciated.

But I have an issue with the Mac client not being about to load my previous .XML fitting file. I get the loading ping-pong graphic and it hangs there. Have to do a force quit to exit the app.


Justin
stoicfaux
#118 - 2013-10-01 19:19:36 UTC  |  Edited by: stoicfaux
I'm trying to hack in a Bastion module into pyfa's sqlite database. I duplicate the DCUII to create the module in the invtypes table (with attributeID of 40000.) The module gets created, I tweak the attribs and effects, but it's stuck as a passive module and has no effect on weapon ranges, shield boosting, etc..

Any suggestions? Am I missing something stupid?


edit2: Okay, pretty much figured it out. Here's the sql to add a faux bastion module to pyfa. The 100% repair shield/armor bonuses are always on, so you need to completely remove the module to see what your normal tank is.


delete from dgmtypeeffects where typeID = 400000;
delete from dgmtypeattribs where typeID = 400000;

INSERT or replace INTO "invtypes" VALUES ("400000","Bastion Module","Super transformy mode go!",null,"5","5000","0","1","706","3346","213");

--gunneryMaxRangeFalloffTrackingSpeedBonus (TC)
INSERT OR REPLACE INTO "dgmtypeeffects" (typeID, effectID) VALUES ("400000","4559");

-- armor repair bonus
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("806","100","400000");
INSERT OR REPLACE INTO "dgmtypeeffects" (typeID, effectID) VALUES ("400000","1281");
--INSERT OR REPLACE INTO "dgmtypeeffects" (typeID, effectID) VALUES ("400000","2868");


--capacitor need
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("6","10","400000");
--hp
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("9","40","400000");
--power
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("30","100","400000");
--cpu
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("50","10","400000");
--duration
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("73","60000","400000");
--requiredskill1
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("182","3394","400000");

INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("267","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("268","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("269","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("270","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("271","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("272","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("273","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("274","0.7","400000");
--requiredSkillLevel
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("277","4","400000");
--techLevel
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("422","2","400000");
--metaLevel
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("633","5","400000");
--maxGroupActive
-- INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("763","1","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("974","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("975","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("976","0.7","400000");
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("977","0.7","400000");
--maxGroupFitted
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("1544","1","400000");

--chargesize
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("128","0.1","400000");



-- shield boosting
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("548","100","400000");
-- armor repair bonus
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("806","100","400000");
-- falloffBonus (tc/te)
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("349","25","400000");
-- maxRangeBonus (tc/te)
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("351","25","400000");
--trackingSpeedBonus
INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("767","1","400000");


--dissallow assistance
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("854","1","400000");
--disallow early activation
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("906","1","400000");
--speed bonus
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("80","0","400000");
--aoe velocity bonus
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("847","0","400000");


--speedFactor
--INSERT OR REPLACE INTO "dgmtypeattribs" (attributeID, value, typeID) VALUES ("20","-100","400000");

--high power slot
INSERT OR REPLACE INTO "dgmtypeeffects" (typeID, effectID) VALUES ("400000","12");
--online effect
INSERT OR REPLACE INTO "dgmtypeeffects" (typeID, effectID) VALUES ("400000","16");

--damageControl
INSERT OR REPLACE INTO "dgmtypeeffects" (typeID, effectID) VALUES ("400000","2302");
--shieldBoostAmplifier
INSERT OR REPLACE INTO "dgmtypeeffects" (typeID, effectID) VALUES ("400000","1720");

Pon Farr Memorial: once every 7 years, all the carebears in high-sec must PvP or they will be temp-banned.

Sme Ematu
The Scope
Gallente Federation
#119 - 2013-10-03 09:25:45 UTC
Hey,

Could anyone explain to me how i add custom ships to pyfa or where i can read how to do it?
I want to add the new exploration ships with the stats from THIS thread.

thanks in advance

o/
stoicfaux
#120 - 2013-10-04 01:18:03 UTC
Sme Ematu wrote:
Hey,

Could anyone explain to me how i add custom ships to pyfa or where i can read how to do it?
I want to add the new exploration ships with the stats from THIS thread.

thanks in advance

o/

Try this and let me know if it works. I haven't had time to experiment with it yet: http://sourceforge.net/apps/trac/pyfa/wiki/Docs/Override

Pon Farr Memorial: once every 7 years, all the carebears in high-sec must PvP or they will be temp-banned.