These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Ships & Modules

 
  • Topic is locked indefinitely.
 

pyfa 1.15.0 (Vanguard)

First post First post First post
Author
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#341 - 2014-04-23 05:20:09 UTC  |  Edited by: Sable Blitzmann
Fittings in Pyfa do not currently have a cargo attribute -- this is going back to the cargo feature that I would like to implement but just haven't had time to work on.

I just commited this feature to my local branch. https://github.com/blitzmann/Pyfa/commit/943ddd3da1a715184a8d39d88c731054c62dec8d

The modules themselves have the charge information that we need, so as we loop through the modules, we collect that info and store in a dict. Then we simply loop that dict and add them to the XML file. You almost got it in your example. =) Feel free to continue to poke around and patch stuff!

I'm on my laptop without an EVE installation, so I cannot verify that it imports into EVE correctly. Once I can verify it, I'll push this commit upstream
Lord X3n0s Aeon
Deep Core Mining Inc.
Caldari State
#342 - 2014-04-23 05:25:30 UTC  |  Edited by: Lord X3n0s Aeon
Sable Blitzmann wrote:
Fittings in Pyfa do not currently have a cargo attribute -- this is going back to the cargo feature that I would like to implement but just haven't had time to work on.

I just commited this feature to my local branch. https://github.com/blitzmann/Pyfa/commit/943ddd3da1a715184a8d39d88c731054c62dec8d

The modules themselves have the charge information that we need, so as we loop through the modules, we collect that info and store in a dict. Then we simply loop that dict and add them to the XML file. You almost got it in your example. =) Feel free to continue to poke around and patch stuff!

I'm on my laptop without an EVE installation, so I cannot verify that it imports into EVE correctly. Once I can verify it, I'll push this commit upstream


Awesome! I've never worked in a dev environment (first internship this summer!) and thats the only code of yours I've looked at lol.

On your test XML as long as you have tags similar to this at the end it IS importable into Eve:

//hardware type="Nanite Repair Paste" slot="cargo" qty="50"/////hardware//

//hardware type="Scourge Rage Rocket" slot="cargo" qty="500"/////hardware//

I may or may not have exported fits from EVE to figure out how they organized it, then copy/pasted it in Pyfa exports to

// == "<" or ">" because GRR CCP forum filters lol.
Lord X3n0s Aeon
Deep Core Mining Inc.
Caldari State
#343 - 2014-04-23 05:42:22 UTC  |  Edited by: Lord X3n0s Aeon
On first try copy/psating your changes into the eos/fit.py didn't generate an XML output that had the cargo tags in it. No error messages or anything... just exported an XML without the tags.

Perhaps I made a mistake somewhere.

EDIT: Nope, pretty sure the code is exactly as your update had it. It successfully exports the XML... just doesn't had the charges.
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#344 - 2014-04-23 05:50:27 UTC  |  Edited by: Sable Blitzmann
Lord X3n0s Aeon wrote:
On first try copy/psating your changes into the eos/fit.py didn't generate an XML output that had the cargo tags in it. No error messages or anything... just exported an XML without the tags.

Perhaps I made a mistake somewhere.


works for me. http://pastebin.com/ULtkWy71

Make sure charges are added to the modules. Also, here's the raw file to avoid copy/paste errors: https://raw.githubusercontent.com/blitzmann/Pyfa/943ddd3da1a715184a8d39d88c731054c62dec8d/eos/saveddata/fit.py
Lord X3n0s Aeon
Deep Core Mining Inc.
Caldari State
#345 - 2014-04-23 05:56:22 UTC  |  Edited by: Lord X3n0s Aeon
Got the new file, here's an XML export:

http://pastebin.com/EspDtiMG

Weird... (I replaced my file with the one you uploaded)

Another pastebin with a new crow fit, just rocket launcher IIs, and scourge rage rockets on it and the new file fit.py in program files/pyfa/eos

http://pastebin.com/FbQ2yHqc

Screen shot of the fit pre-export:
http://imgur.com/nzc5B43
Lord X3n0s Aeon
Deep Core Mining Inc.
Caldari State
#346 - 2014-04-23 06:10:06 UTC  |  Edited by: Lord X3n0s Aeon
Also, imgur of the new file in-place:

http://imgur.com/aXbI0bc

I'm scratching my head at this one...

EDIT: DAMMIT I was putting the file in the wrong place :) My bad! One sec I'll test it now

EDIT2: Yep! It's all working now.

EDIT3: Just created a few fits with the new code and imported into EVE. Everything's working fine!
StinGer ShoGuN
Pragmatic Kernel
Shadow Cartel
#347 - 2014-04-23 11:07:48 UTC
Just wanted to submit a bug (or more exactly a missing code part I guess): charges in projected modules are not taken into account.

For instance, remote sensor boosters: if projected onto a fit, stats are modified correctly. But if you load let's say, a scan resolution script in it, stats remain unchanged compared to the non-scripted ones.
Hope what I'm saying makes sense.
Tested remote tracking computer as well, does not work neither.


I do not have time to dig it so I'm posting it here. If it ever happens that I can have a look at it, I will.
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#348 - 2014-04-23 14:33:09 UTC
StinGer ShoGuN wrote:
Just wanted to submit a bug (or more exactly a missing code part I guess): charges in projected modules are not taken into account.

For instance, remote sensor boosters: if projected onto a fit, stats are modified correctly. But if you load let's say, a scan resolution script in it, stats remain unchanged compared to the non-scripted ones.
Hope what I'm saying makes sense.
Tested remote tracking computer as well, does not work neither.


I do not have time to dig it so I'm posting it here. If it ever happens that I can have a look at it, I will.


This has been a known bug for quite a while. It's been "wontfix" because the new engine is being developed which would take care of this issue and Kadesh wanted full focus on that. I'm not a developer of the new engine (that's all Kadesh's handiwork), and so until the Pyfa rewrite starts and swings into full force I can devote my energy into working on the current codebase of Pyfa to try to fix these little things that have been stuck on "wontfix" status. I am not exactly sure why this particular issue happens but it is something I hope to look into soon
Blodhgarm Dethahal
Moist Towelettes.
#349 - 2014-04-24 13:44:15 UTC
Unsure if this has been mentioned but Pyfa does not calculate Siege Module effects correctly on guns, it is stating that my Revelation max skilled with 4 Faction Heatsinks only does 9900 approximately. In game my max skilled Revelation does 11k..

Please fix! I like your graphs way better than EFT :(
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#350 - 2014-04-24 14:05:13 UTC  |  Edited by: Sable Blitzmann
Blodhgarm Dethahal wrote:
Unsure if this has been mentioned but Pyfa does not calculate Siege Module effects correctly on guns, it is stating that my Revelation max skilled with 4 Faction Heatsinks only does 9900 approximately. In game my max skilled Revelation does 11k..

Please fix! I like your graphs way better than EFT :(


It's already been fixed and will be out with next release. If you wish to have a fixed version yourself, please apply this patch to the correct file: https://github.com/DarkFenX/Pyfa/commit/e00941b2c568915b6762a7416afdd129e3952727

Or, look here for recent builds: http://blitzmann.it.cx/pyfa-nightly/
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#351 - 2014-04-24 14:16:08 UTC
Also, projected modules no longer ignore charges: https://github.com/DarkFenX/Pyfa/commit/83c0bbe37b883ffaf21a80db55fdb4625680053a

I think this commit was just missed on last nights build, but should be included in tonights if anyone wants to give it a go. =)
NearNihil
Jump Drive Appreciation Society
#352 - 2014-04-24 21:38:46 UTC
Coolbeans! Nice to see a suggestion makes it though (the cargo one). Another suggestion/request: a compare tool like the one in-game. I find myself adding/removing modules on the same ship all the time just to see the differences (other than fitting cost).

Preferably something that can sort by all attributes the items have, but also include cost (something the in-game compare tool doesn't show).
StinGer ShoGuN
Pragmatic Kernel
Shadow Cartel
#353 - 2014-04-24 23:20:17 UTC
Sable Blitzmann wrote:
Also, projected modules no longer ignore charges: https://github.com/DarkFenX/Pyfa/commit/83c0bbe37b883ffaf21a80db55fdb4625680053a

I think this commit was just missed on last nights build, but should be included in tonights if anyone wants to give it a go. =)


Nice ! That one was fairly easy... :P
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#354 - 2014-04-25 04:35:49 UTC
StinGer ShoGuN wrote:
Sable Blitzmann wrote:
Also, projected modules no longer ignore charges: https://github.com/DarkFenX/Pyfa/commit/83c0bbe37b883ffaf21a80db55fdb4625680053a

I think this commit was just missed on last nights build, but should be included in tonights if anyone wants to give it a go. =)


Nice ! That one was fairly easy... :P


Yeah... I wasn't expecting it to be that easy. I guess no one ever looked into it >_>
StinGer ShoGuN
Pragmatic Kernel
Shadow Cartel
#355 - 2014-04-25 05:41:13 UTC
While I'm at it and as it seems you are a fast patcher P, I have another one for you.

If you project a fit that contains a remote effect, like a remote sensor booster, boosts seem to be applied twice.
In addition, if you project fit A on fit B, and add the same remote effect, like remote sensor booster again, on fit A, B seems to receive a double booster twice but stacking is taken into account.

Let me give an example, it will be clearer: project a remote sensor booster on fit A. Then, fit a remote sensor booster on fit A and enable it. Then, create fit B and project fit A on it. Fit B will be boosted as it received 4 remote sensor boosters ! Pirate

I'm talking about remote sebos because they're the one I spotted immediately, I've not tested if with other remote effects but I guess it would be affected the same way because it relies on the same piece of code.
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#356 - 2014-04-25 23:16:34 UTC
StinGer ShoGuN wrote:
While I'm at it and as it seems you are a fast patcher P, I have another one for you.

If you project a fit that contains a remote effect, like a remote sensor booster, boosts seem to be applied twice.
In addition, if you project fit A on fit B, and add the same remote effect, like remote sensor booster again, on fit A, B seems to receive a double booster twice but stacking is taken into account.

Let me give an example, it will be clearer: project a remote sensor booster on fit A. Then, fit a remote sensor booster on fit A and enable it. Then, create fit B and project fit A on it. Fit B will be boosted as it received 4 remote sensor boosters ! Pirate

I'm talking about remote sebos because they're the one I spotted immediately, I've not tested if with other remote effects but I guess it would be affected the same way because it relies on the same piece of code.


This is indeed a bug, thank you for pointing it out! I've confirmed it as well as confirmed that this seems to happen with all effects. https://github.com/DarkFenX/Pyfa/issues/84

As for speedy patches, it really depends on what kind of bug it is. This particular bug may be a little more involved, but on the surface it looks similar in theory to another bug that has a fix pending commit. Will look into it. =)
Krominal
Vigilance Training Bureau
Safety.
#357 - 2014-04-26 18:59:24 UTC
I'm running into an odd issue somewhat regularly with Pyfa lately - When I first install it it runs great for a few days/weeks - after some time though, Ill launch pyfa but nothing happens, the program just doesn't start, no errors or anything just "silence". It first started happening about a month ago when I was on Win7. I ended up formatting my comp and installing Win8 and installed Pyfa and it started working again, however as of today its gone back to just not doing anything when I go to launch it. I've tried downloading the latest releases zip package and overwriting everything in the pyfa directory, and I've also tried downloading the executable and installing pyfa, however pyfa just refuses to launch in both cases. Any ideas whats causing the issue?
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#358 - 2014-04-26 21:48:52 UTC  |  Edited by: Sable Blitzmann
Krominal wrote:
I'm running into an odd issue somewhat regularly with Pyfa lately - When I first install it it runs great for a few days/weeks - after some time though, Ill launch pyfa but nothing happens, the program just doesn't start, no errors or anything just "silence". It first started happening about a month ago when I was on Win7. I ended up formatting my comp and installing Win8 and installed Pyfa and it started working again, however as of today its gone back to just not doing anything when I go to launch it. I've tried downloading the latest releases zip package and overwriting everything in the pyfa directory, and I've also tried downloading the executable and installing pyfa, however pyfa just refuses to launch in both cases. Any ideas whats causing the issue?


Perhaps it's database corruption. Overwriting the pyfa directory won't fix this as user database and settings are saved in ~/.pyfa (on Windows, C:/Users/< user >/.pyfa). If there is something wrong with the database, then pyfa might fail silently

1) Backup .pyfa directory.
2) Look for any log files that might be here.
3) Upload saveddata.db somewhere. Since this contains potentially sensitive information (fittings, api details), I recommend sending me a mail ingame with a link to the upload for privacy, so that I may investigate
4) Delete directory and start Pyfa. Does it work now?

Let me know. =)
StinGer ShoGuN
Pragmatic Kernel
Shadow Cartel
#359 - 2014-04-27 10:59:08 UTC
Just posted some comments regarding fits projection on 2 currently open bugs on Github (1 of which is the one you open for me Lol).

Have a look at it Sable because I think you are reverting changes made after I reported a bug on former PyFa website (evefit.org). Blink
Sable Blitzmann
24th Imperial Crusade
Amarr Empire
#360 - 2014-04-27 16:00:06 UTC
Thanks for your comments. I'm still testing the various fixes, but would be interested in hearing feedback if you run into issues. I've responded with a test release here: https://github.com/DarkFenX/Pyfa/issues/84#issuecomment-41499332