These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

phpBB 3.x API Registration Mod v6+

Author
Go0fBall
Perkone
Caldari State
#921 - 2013-09-16 18:21:26 UTC
For the life of me, I can't seem to get Jabber external authentication to work on a Windows box. I've added and modified all the lines in the .cfg as per the posts above, but it still doesn't seem to work. I can register any account name/password remotely using Pidgin, which is obviously not very secure.

Is there a chance of getting some type of walk through to help us to get this to work? Much appreciated.
Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#922 - 2013-09-17 11:41:25 UTC
Go0fBall wrote:
For the life of me, I can't seem to get Jabber external authentication to work on a Windows box. I've added and modified all the lines in the .cfg as per the posts above, but it still doesn't seem to work. I can register any account name/password remotely using Pidgin, which is obviously not very secure.

Is there a chance of getting some type of walk through to help us to get this to work? Much appreciated.


If you don't want users to be able to self register, you have to disable mod_register in your ejabberd config. Just commenting out the mod should be sufficient.

If you are able to self-register an account AND THEN LOG IN WITH THAT ACCOUNT, it would seem that you are not using external authentication at all, but rather internal authentication: self-register is not supported in external authentication. You will never be able to login with a self-registered user when you are running external authentication.

Are you sure you restarted the ejabberd daemon? When you are trying to authenticate, do you see authentication requests coming into your logfile? (see /var/log/ejabberd/exauth_phpbb.log like I mentioned in my post)

I think my post on ejabberd integration is (sadly) the most complete documentation there is atm: https://forums.eveonline.com/default.aspx?g=posts&m=3539374#post3539374





Gizmo Tinker
Sebiestor Tribe
Minmatar Republic
#923 - 2013-09-18 09:58:18 UTC  |  Edited by: Gizmo Tinker
hey guys
want to be able to check characters api's for account expiry and remove them from the forum when they unsub (to workin with the current cron job)

is it possible?
Sugar Von MurdererTits
Sebiestor Tribe
Minmatar Republic
#924 - 2013-09-22 11:46:47 UTC
I have a small problem with changing the style from Prosilver to subsilver2. It's not a major issue as I can still use the forum, but I have a subsilver2 based style I want to install use and currently cannot.

I did a fresh install of phpBB 3.0.11 and am using the EVE_API_6.2.4_for_phpBB_3.x

When I go to apply the style changes on the automod tab, I have one error:

Quote:

styles/subsilver2/template/overall_footer.html

...


Find

< body

In-Line Find

< body

The In-Line Find specified by the MOD could not be found. The Find specified by the MOD could not be found

(added some spaces to avoid html).

If I force the style update, none of the Eve api changes are applied anyway.

Any ideas?
Wafou Ka'Djo
Yellow Box Ltd.
#925 - 2013-09-23 10:18:08 UTC
Perhaps I missed a post, is there an updated Odyssey 1.1 version of the mod?
Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#926 - 2013-09-23 14:46:32 UTC
Sugar Von MurdererTits wrote:
I have a small problem with changing the style from Prosilver to subsilver2. It's not a major issue as I can still use the forum, but I have a subsilver2 based style I want to install use and currently cannot.

I did a fresh install of phpBB 3.0.11 and am using the EVE_API_6.2.4_for_phpBB_3.x

When I go to apply the style changes on the automod tab, I have one error:

Quote:

styles/subsilver2/template/overall_footer.html

...


Find

< body

In-Line Find

< body

The In-Line Find specified by the MOD could not be found. The Find specified by the MOD could not be found

(added some spaces to avoid html).

If I force the style update, none of the Eve api changes are applied anyway.

Any ideas?


I encountered the same issue when upgrading from 6.2.2 to 6.2.4. Luckily I don't need subsilver.
Go0fBall
Perkone
Caldari State
#927 - 2013-09-23 18:20:02 UTC
Yugo Reventlov wrote:
Go0fBall wrote:
For the life of me, I can't seem to get Jabber external authentication to work on a Windows box. I've added and modified all the lines in the .cfg as per the posts above, but it still doesn't seem to work. I can register any account name/password remotely using Pidgin, which is obviously not very secure.

Is there a chance of getting some type of walk through to help us to get this to work? Much appreciated.


If you don't want users to be able to self register, you have to disable mod_register in your ejabberd config. Just commenting out the mod should be sufficient.

If you are able to self-register an account AND THEN LOG IN WITH THAT ACCOUNT, it would seem that you are not using external authentication at all, but rather internal authentication: self-register is not supported in external authentication. You will never be able to login with a self-registered user when you are running external authentication.

Are you sure you restarted the ejabberd daemon? When you are trying to authenticate, do you see authentication requests coming into your logfile? (see /var/log/ejabberd/exauth_phpbb.log like I mentioned in my post)

I think my post on ejabberd integration is (sadly) the most complete documentation there is atm: https://forums.eveonline.com/default.aspx?g=posts&m=3539374#post3539374







Yugo, between your write up and my experimenting, it took me a couple of days to figure it out as I am self-taught with all this, but finally got it working. First off, I could not get this to work on windows using the v2.1.11 release of ejabberd, I had to download and install v2.1.10.

I installed v2.1.10, and then followed all the steps in your post. I was having issues logging into the ejabberd web interface when I enabled external auth, so I did some poking around.

In Cyerus' "ejabberd_side.php" file, I changed the value of error reporting on line 4 to "error_reporting(1);"

Lines 13 & 14 to read:

private $_log = true;
private $_debug = false;

And finally line 15 to read:

private $_logfile = "c:/exauth_phpbb.log";

Take note of the file "exauth_phpbb.log" in line 15, as I had to manually create that using notepad and save it directly to the c:\ drive, for it to work and write to the log.

Also, the only other problem I seemed to run into is the fact I am running XAMPP, and even though my PHP Path is set in Windows, it did not seem to execute the "ejabberd_side.php" file. In my ejabberd.cfg file, towards line 202/203, this is what I had to enter in order to get it to work:

{auth_method, external}.
{extauth_program, "c:/xampp/php/php.exe C:/xampp/htdocs/forums/store/mods/eve_api_6/tools/ejabberd/ejabberd_side.php"}.

I am not the best at explaining things, but I do hope this helps my friends on Windows machines save some time and to get this mod up and running. This is an extremely valuable feature of this package and I thank all of you who helped develop it and have helped nubs like me to get it to work!

Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#928 - 2013-09-24 08:28:57 UTC
Yeah these issues you experienced are probably windows specific. My installation was on a Linux machine.
Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#929 - 2013-09-25 08:11:50 UTC
I don't know if anyone else is experiencing this, but since the upgrade to 6.2.4 I have suddenly a whole bunch of users each day getting an "Invalid API Key" error.

People checked those keys and they were still valid keys according to the Eve API management thing (or so they claim to me), but still the forum doesn't accept them and their accounts get disabled.

When they create a new API key and enter that, their accounts are enabled again.

Am I the only one here?
Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#930 - 2013-09-25 11:02:12 UTC
We need an update of the mod for Odyssey 1.1. Some of the modules changed names (specifically Logistics modules) and are no longer recognized in the EVEFIT thingie. e.g. "Large S95a Remote Shield Booster" etc.
Tara Campbell
Vulpayne Conglomerate
#931 - 2013-09-27 11:17:49 UTC
Greetings,
any chance the API Tool is working with the phpBB Style: SE Gamer Dark
https://www.phpbb.com/customise/db/style/se_gamer_dark/

Or maybe how to edit to make it working?

Thank you!

Yugo Reventlov
Keeping Up Appearances
Happy Cartel
#932 - 2013-09-27 12:15:17 UTC
Tara Campbell wrote:
Greetings,
any chance the API Tool is working with the phpBB Style: SE Gamer Dark
https://www.phpbb.com/customise/db/style/se_gamer_dark/

Or maybe how to edit to make it working?

Thank you!


If it is based on subsilver or prosilver you should be able to automatically mod it using AutoMod. Basically, go to Automod --> Eve API module --> "details" --> scroll to bottom: apply changes from (subsilver or prosilver) to SE Gamer Dark.

Else you have to edit the theme manually.
ISuper
State War Academy
Caldari State
#933 - 2013-09-27 23:59:39 UTC
2 Cyerus:
Hi!
Could you add to the admin panel an option to choose eve API mask to accept registration. For example my alliance need only the full API keys and i have to edit files each update.
Thank you very much for your work Big smile
night0wolfs
Siberian Alpha Fleet
Test Alliance Please Ignore
#934 - 2013-09-28 12:17:29 UTC
There is a problem, create a new group on the forum id put the group in the Teamspeak3, add users to this group, but the members of this group in the TS are not given rights. Tell me what could be wrong?
ChaseTheLasers
Ekchuah's Shrine Comporium
#935 - 2013-09-28 15:43:35 UTC
Sugar Von MurdererTits wrote:
I have a small problem with changing the style from Prosilver to subsilver2. It's not a major issue as I can still use the forum, but I have a subsilver2 based style I want to install use and currently cannot.

I did a fresh install of phpBB 3.0.11 and am using the EVE_API_6.2.4_for_phpBB_3.x

When I go to apply the style changes on the automod tab, I have one error:

Quote:

styles/subsilver2/template/overall_footer.html

...


Find

< body

In-Line Find

< body

The In-Line Find specified by the MOD could not be found. The Find specified by the MOD could not be found

(added some spaces to avoid html).

If I force the style update, none of the Eve api changes are applied anyway.

Any ideas?


Same issue. I just edited the bits out from the install files for now, as they aren't that important for my corp.
The proper way to do it would be to check the HTML tags in the files and see why it's not finding them, but I didn't have time when doing it.
Tara Campbell
Vulpayne Conglomerate
#936 - 2013-09-30 08:05:48 UTC  |  Edited by: Tara Campbell
....
Tara Campbell
Vulpayne Conglomerate
#937 - 2013-09-30 08:06:33 UTC
Yugo Reventlov wrote:
Tara Campbell wrote:
Greetings,
any chance the API Tool is working with the phpBB Style: SE Gamer Dark
https://www.phpbb.com/customise/db/style/se_gamer_dark/

Or maybe how to edit to make it working?

Thank you!


If it is based on subsilver or prosilver you should be able to automatically mod it using AutoMod. Basically, go to Automod --> Eve API module --> "details" --> scroll to bottom: apply changes from (subsilver or prosilver) to SE Gamer Dark.

Else you have to edit the theme manually.


Greetings, I did:
prosilver to SE Gamer Dark

Error install

ignored an installed it ... all the fields were merged or included

But: registration and modification (account settings) is still returning a "Bad request"

Error Profile


What?
Go0fBall
Perkone
Caldari State
#938 - 2013-09-30 21:40:41 UTC
Anyone know if this is compatible with phpBB 3.0.12 which was released earlier today? Don't want to take the plunge and fubar my forums lol o7.
Protoburger
The Scope
Gallente Federation
#939 - 2013-10-01 00:59:01 UTC
Is it possible to set a Forum Group based on the titles in EVE ?
Alexander Nighthawk
Deep Core Mining Inc.
Caldari State
#940 - 2013-10-01 23:05:33 UTC
Everything is up and running fine until I start to add users to multiple groups IE : Fleet Commander, CEO's, and other such groups. I have multiple groups for different positions and want to use them to limit access to certain forum areas pertaining to what they do. The Cron job though is going through and just removing them from those multiple groups and setting them back to the default forum group and this is translating across to teamspeak as well. Is there a work around this? Maybe a setting I am missing? Any help would be appreciated thanks!