These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
 

possible fix for Closed Socket error.

First post
Author
Maximus Arcarius
The Scope
Gallente Federation
#341 - 2012-11-03 12:15:55 UTC
Just found a possible fix on : http://community.eveonline.com/ingameboard.asp?a=topic&threadID=921650&page=52. Reave Tzash said hotspot shield (VPN) fixed the problem for him and got some positive feedback too. I'm trying it now and seems to be working so far. I was getting disconnected every 15 minutes and I have now been online for over an hour.
Max Chee
The Scope
Gallente Federation
#342 - 2012-11-04 11:25:07 UTC
I have already tried hotspot shield with no luck, today I resubscribed to eve again for 3 months just to get this bullshit all over me. Not to mention CCP just ignoring us and think it's our ISP problem I am from Malaysia and I am damn pissed about this problem. Fix it before it's too late.
Lord Fudo
Doomheim
#343 - 2012-11-04 18:01:43 UTC
I am in the United States using a DSL connection via AT&T. I have been having this problem since the previous 2 patch/updates. It is FRAKING ANNOYING!!!!

I can't PVP, PVE(mission/incursion), and I spend the majority of my time just logging back into the damn game.

I have tried to reinstall EVE from scratch. If this issue isn't fixed after Retribution comes out in December, I will cease to resubscribe all of my 6 accounts. This issue is fraking ridiculous.

If I lose a ship due to a DC from this socket BS, and CCP does not reimburse, I will most certainly stop playing EVE for a very long time.
MinefieldS
1 Sick Duck Standss on something
#344 - 2012-11-04 22:33:07 UTC  |  Edited by: MinefieldS
How hard can it be to make the client try to login w/ all the info it already has after the "socket closed" ****??????? No... the damn client must close, start again, load the STUPID USELESS ASTEROIDS splashscreen, load the STUPID USELESS ASTEROIDS IN 3D, enter password ..... authenticating blahblah oh wait are we authenticating or still loading asteroids?, select character again. WTF?
nikon56
UnSkilleD Inc.
#345 - 2012-11-05 10:50:42 UTC  |  Edited by: nikon56
Evocati Arelius wrote:
I had this issue a while back. I opened a ticket with CCP, and attached my Traceroute-info.
This is NOT ccp-related, nor a problem with their servers / firewall. It's completely about ISP and ISP Networks.
I remember reading something about a European network provider changing routers in the European networks, and subsequently caused a series of issues with routing traffic to England and GB (where CCP has servers).

There is info about this on the forums, search and the shall find it! :)

Be sure to attach your traceroute info too CCP when opening a ticket, as they forward this info to the ISP's.
My issue was solved in less than 24 hours due to that. Thanx for that CCP! :)

EDIT: https://forums.eveonline.com/default.aspx?g=posts&find=unread&t=145483

Evo - out!

sorry but no.

we have experienced it in my corp, all at the same time => socket error.

most of us are accros EU (France / belgium/switzerland/uk), but 2 are in Canada, and one in Asia.

everyone got socket error at the same time

-> NOT ISP RELATED

we were all on same TS server at that moment, no issue on TS
Jeff simply
Perkone
Caldari State
#346 - 2012-11-06 10:33:05 UTC
I have reported a bug for the same issue, this needs fixing with priority it literally kills the game for those affected.

FYI I have Steam but rarely have the process running. Nothing has changed on my computer in the past couple of months however I seem to be getting very frequent drops.
Johan Civire
Caldari Provisions
Caldari State
#347 - 2012-11-06 15:48:34 UTC
Garak n00biachi wrote:
Veritas Titan wrote:
I turned off VPN to test and was disconnected 10 minutes into the game. VPN fixes the problem, at least for me.


VPN should not fix your problem, the problem is with CCP.....dont patch things up for them.


i got zero issues to connect in eve. So its for sure its your internet provider. Dont spam or blame a company for some problems when there is for sure its your internet problem. Send report use bug report and let ccp see if the can fixs it on there side of the internet but i guess its yours internet
Max Chee
The Scope
Gallente Federation
#348 - 2012-11-07 04:00:37 UTC
Johan Civire wrote:
Garak n00biachi wrote:
Veritas Titan wrote:
I turned off VPN to test and was disconnected 10 minutes into the game. VPN fixes the problem, at least for me.


VPN should not fix your problem, the problem is with CCP.....dont patch things up for them.


i got zero issues to connect in eve. So its for sure its your internet provider. Dont spam or blame a company for some problems when there is for sure its your internet problem. Send report use bug report and let ccp see if the can fixs it on there side of the internet but i guess its yours internet


Please close your legs , a pungent smell is emitting from them. Can you not not see that everybody who is a affected here are from all over the world with different ISP, or is your tiny brain too infertile to comprehend them?
Naxirian
Sebiestor Tribe
Minmatar Republic
#349 - 2012-11-07 09:43:18 UTC  |  Edited by: Naxirian
If it was CCP's fault, everybody would have the error, and I know a good deal of people that have never once had the error.

I have found personally that running MSN in the background sometimes screws EVE if MSN disconnects/reconnects. Everything else stays connected, but when MSN does that, I get a socket closure. I can almost predict it every time. I sometimes get as many as 8 socket closures per day, and I live in the UK. My ISP is Orange Broadband (soon changing to Everything Everywhere, their parent company).

I didn't used to get them, I played for months with no problem, but I too have noticed that I only started getting them after Inferno was released. Before that, nothing. That's not to say it's CCP's fault though. I have a new machine since Inferno was released, and a new router, however, it's the same ISP as I have always used, just at a different home address.

Asus Crosshair VI Hero X370 Motherboard

AMD Ryzen 7 1700 @ 4GHz

2 x R9 290X 4GB Crossfire @ 1150MHz

Full EKWB Custom Watercooling Loop

16GB Corsair Vengeance LED Red DDR4 RAM @ 3000MHz

Max Chee
The Scope
Gallente Federation
#350 - 2012-11-07 11:49:52 UTC
People need to stop having this mentality that just because someone else who is facing a problem which he or she have never encountered before, naturally means it's 100% the other person's fault. That's just talking dumb. I expected a more intelligent response from EVE players like us not one a WOW player would have responded.

I am from Malaysia and I have tested this on two machines es with same result, however hotspot shield seem to have temporally fix the problem, HOWEVER CCP better fix this problem ASAP, this s not part of the service I was expecting from a P2 P game.
SAS Kinghtwing
Caldari Provisions
Caldari State
#351 - 2012-11-07 13:10:58 UTC
I get this ALL THE TIME when I first run EVE. Takes about 5-10 attempts to get in sometimes. Once I'm in its fairly stable but still occasionally get the sockets closed window.

South West UK, BT Internet
Coronary
Viziam
Amarr Empire
#352 - 2012-11-09 10:30:11 UTC
I run multiple accounts and this only happens with this specific Coronary character, all the others stay online.
blake fallout
Center for Advanced Studies
Gallente Federation
#353 - 2012-11-09 18:51:06 UTC
Just back a few days , have Had about 6-10 The Socket was Closed - Lest now i know what it is (D/C)
Havent had it on Any other game, Must be some line (cable) Damaged heading towards Iceland

(what i think it is anyway)

Nadzieijko Andrastile
Brutor Tribe
Minmatar Republic
#354 - 2012-11-13 15:38:33 UTC
I skimmed through most of the pages.

I've set up port forwarding rules for Eve
My ISP is Optimum Online (I've also had this issue with Comcast)
My router currently is a Netgear WNDR3400, most current firmware, and has been reset (Also happened on Linksys EA6500)

I generally run two accounts on the same computer and 75% of the time, they both close at the same time. Other times, only 1 will close and leave the other running (generally at the most inopportune time, in space)

Upon signing back in, I find several people having the exact same issues, some the next US state over, couple in other parts of the world, disconnecting at the same time.

What other info does CCP need? I'm pretty tired of disconnecting every single time. If it's something I can do to fix it, I need to know what it is.

Pretty frustrating to say the least...
Hatori Agrue
Garoun Investment Bank
Gallente Federation
#355 - 2012-11-14 02:48:46 UTC
Getting the same thing for a few weeks now. Almost never dc, now I get the double window socket lost constantly even if I am the only person in house on a computer. I thought it was being near Jita that was causing it but I am having it everywhere. I have lost a lot of drones and almost got blown up several times because of this. Please find out what changes in the Inferno release caused this to so many people.
Simply Transport
The Scope
Gallente Federation
#356 - 2012-11-17 14:50:33 UTC
This is getting realllly annoying.

I think there might be external influences affecting me here though (perhaps along with others). I was running Test server last night and 4 clients all DC at the same time (TS was still working though as people were telling me I had DC'd).

This morning I switched routers and logged my main in right after downtime, has not disconnected once. However every other client has had the socket closed error multiple times.

I have been running pings from my computer to Google DNS server and at the time of DC I will have 100% packet loss for about 8 seconds each time. I tried this on my Mac at the same time to eliminate my computer hardware and cabling to the router from the equation and the packet loss occured there too.

Really don't know where to go next, I can't imagine customer support at my ISP would be very helpful with a problem like this.
Chokichi Ozuwara
Perkone
Caldari State
#357 - 2012-11-19 02:52:46 UTC
Haven't played much the last few months, played this weekend, perpetual socket closed errors.

Anyone know if we can get a refund for this? I can't play the game if I get dropped all the time.

Tears will be shed and pants will need to be changed all round.

Vanguarder
Deep Core Mining Inc.
Caldari State
#358 - 2012-11-20 17:28:04 UTC
Sad

Can't play at all since this Socket closed issue started for me recently.

any work-arounds or fixes found lately?
Lujin Kring
Black Puppy
#359 - 2012-11-21 03:46:51 UTC  |  Edited by: Lujin Kring
New player here.

Get the 'socket was closed' quite consistently.

I play a lot of online video games, and I don't have issues like this in those games.

I cannot see continuing to play Eve Online after my current sub expires, if this is not resolved.
Disteeler
Perkone
Caldari State
#360 - 2012-11-21 19:48:53 UTC  |  Edited by: Disteeler
Same problem, Jazztel ISP from Spain.

2 popups with the socket error appear. This error only occurs me, while not always, when I return after alttabbing to windows to do stuff (since those weeks I'm learning python, it soetimes happens when I'm using with python(XY) software, but I don't think is has anything to do with this).