These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Client crashes on Ubuntu 11.10

First post
Author
Rei Za
GDMFSOB EVE Services Corporation
#161 - 2012-04-29 17:44:54 UTC
CCP Snorlax wrote:
I believe the next scheduled client update is on Monday and this fix will be included in that.



Appreciated, thanks.
Shiki Gami
Ryu-Tai
#162 - 2012-04-29 17:46:35 UTC
CCP Snorlax wrote:
My attempt at a fix is now on Sisi - please give it a go and report back.



Thank you sir
Bent Barrel
#163 - 2012-04-29 19:01:52 UTC
great ... finaly had time to test it myself (the crashes I mean), can't wait for the patch to get distributed.
Nora Smith
Fitzpatrick Royal Nuclear Products
#164 - 2012-04-29 19:16:17 UTC
Tested on Sisi with Wine 1.5.2 on x64 Gentoo, no more crashes with T3 cruisers.
Great work, keep it up - and a big Thank You to CCP Snorlax!
Indalecia
#165 - 2012-04-29 21:33:06 UTC
Ny Draconis wrote:
With CCP now fixing this issue (BIG thanks for that, CCP Snorlax!) I'm not sure wether I should post my somewhat very ugly temporary solution. It involves patching and recompiling wine from source and might break other windows apps (and possibly more).

But I was able to sit a Jita IV Station for at least 2 hours without a single crash. It might not work for you though. I didn't get feedback from the people in "Linux" so far.

http://pastebin.com/iMN6FT86

Nevertheless it would be much better if the problem gets fixed either by CCP or the wine devs.

Edit: The patch above was created against wine 1.4 but also might apply against newer versions.


Thank you for the patch!

Also, thanks to CCP Snorlax for helping the GNU/Linux community. I hope the fix is out tomorrow. Support is much appreciated!

https://o.smium.org/ — v0.13.5 — A browser-based fitting tool and loadout sharing platform

LiraNuna
Q.Q.
#166 - 2012-04-29 22:58:42 UTC
Thank you very much for the fix!
DJ Rubbie
W-Space IT Department
Test Alliance Please Ignore
#167 - 2012-04-30 11:25:32 UTC
Just got the new patch on Tranquillity, and I can switch into the Tengu, switch subsystems and preview without any issues.

Thanks very much CCP Snorlax for getting this staged live!
Calebus Phobeus
Eternal Seekers of Darkness
#168 - 2012-04-30 11:53:44 UTC
Confirming that it works for me as well. Kudos to CCP Snorlax for sorting out this issue so fast. Many thanks!
Indalecia
#169 - 2012-04-30 12:20:19 UTC
Calebus Phobeus wrote:
Confirming that it works for me as well. Kudos to CCP Snorlax for sorting out this issue so fast. Many thanks!


Same for me. Thank you!

https://o.smium.org/ — v0.13.5 — A browser-based fitting tool and loadout sharing platform

Peri Simone
Black Rebel Rifter Club
The Devil's Tattoo
#170 - 2012-04-30 12:46:03 UTC
Snorlax, you're a superhero. Hugely appreciated.
Bruce Blacky
Blacky Invention Research Development YinYang
#171 - 2012-04-30 13:35:30 UTC
todays client patch works for me as well.

great job

thansk a lot

Bruce BLacky
Toktok Sjade
Aeternus Enterprises
#172 - 2012-04-30 15:07:29 UTC
Thx for the patch
Jared Attor
Brutor Tribe
Minmatar Republic
#173 - 2012-04-30 15:31:43 UTC
Thanks a lot.
TWHC Assistant
#174 - 2012-04-30 15:59:13 UTC
I am still seeing hard freezes when EVE runs under WINE/Linux with today's update. Without it does it run stable and is also running stable under Windows Vista.

Hardware is AMD Phenom 9850 (quad-core, 2.5GHz), Nvidia GeForce GTX260, Linux kernel 3.2.12, 295.40 Nvidia driver. No heat issues, no over-clocking, all cables checked, power draw well below maximum. Best guess I have is it is a software lock-up in the kernel/gfx driver. Sad
Aphoxema G
Sebiestor Tribe
Minmatar Republic
#175 - 2012-04-30 17:06:30 UTC  |  Edited by: Aphoxema G
Thank you for this fix (I'm not using Ubuntu right now, I just appreciate support for it), even though whoever wrote the patch notes went passive-aggressive with their rude mention of the fix.

ISD Grossvogel suggested I come here and say something, by the way. https://forums.eveonline.com/default.aspx?g=posts&m=1219464#post1219464
Zor'katar
Matari Recreation
#176 - 2012-04-30 18:03:03 UTC
Aphoxema G wrote:
Thank you for this fix (I'm not using Ubuntu right now, I just appreciate support for it), even though whoever wrote the patch notes went passive-aggressive with their rude mention of the fix.

Can someone link the new patch notes? I can only find up to last Thursday.
Sarummay
Sebiestor Tribe
Minmatar Republic
#177 - 2012-04-30 18:28:15 UTC
EVE is working for me again, no more issues with T3.
Thank you very much.
Laurent Cookie
Peace of Corps
#178 - 2012-04-30 19:02:21 UTC
Huge Thanks for the patch CCP Snorlax !

Linux pilots <3 you Big smile

Chakra Linux 2012.02 Linux Kernel 3.2 Nvidia 295.33

Karak Terrel
Foundation for CODE and THE NEW ORDER
#179 - 2012-04-30 20:57:43 UTC
Huge thx CCP Snorlax! My favorite spaceship game works again!
Bent Barrel
#180 - 2012-04-30 21:37:33 UTC
no more crashes, I can finaly play.

however I noticed a GFX glitch, the engine trail (exhaust fumes for a lack of better word) now have clipping problems. I can see their origin points through the other side of my ishkur.

anybody has the same ?

it's not a big deal, just noticed it today.