These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Client crashes on Ubuntu 11.10

First post
Author
Hosedna
FumbleFamily Corp
#141 - 2012-04-27 19:45:28 UTC
I works if I remove all the quotes around file pathes and variable names... so no iskies :p But big thanks, because I couldn't get the previous inotify version to work :)
GlemSom Nardieu
The Relaxed
#142 - 2012-04-27 20:05:17 UTC
Hosedna wrote:
I works if I remove all the quotes around file pathes and variable names... so no iskies :p But big thanks, because I couldn't get the previous inotify version to work :)


I think you got your eveFolder variable escaped? (Escaping spaces)

You can do it both ways - but I usually prefer to quote stuff - as an wrongly escaped path might cause unecpected things ;)
Hosedna
FumbleFamily Corp
#143 - 2012-04-27 20:21:37 UTC
Yeah, I used some \ for spaces, so I had a funny effect when running the script with the quotes : it deleted the folder instead of it's content Cool
Toktok Sjade
Aeternus Enterprises
#144 - 2012-04-27 20:39:47 UTC
@GlemSom Nardieu

Your script works perfectly. Thx for that
NitricEster
Aliastra
Gallente Federation
#145 - 2012-04-27 21:21:24 UTC
Snorlax: I just wanted to say thanks for putting your time in on this. I'm a developer myself and if your job is anything like mine I know how very very little free time you have to work on fixes not sanctioned by the higher ups. THANK YOU!!!!

I'd hope any linux users will post their thanks in this thread too so CCP knows we're still out there!
Frazier
Isaziwa Industrial Resource and Service
#146 - 2012-04-27 21:28:16 UTC  |  Edited by: Frazier
Rising the number of Linux EVE players.
I'm on Debian 6 with wine 1.4 (compiled) in binary Nvidia 295.33.


Ny Draconis wrote:
With CCP now fixing this issue (BIG thanks for that, CCP Snorlax!) I'm not sure wether I should post my somewhat very ugly temporary solution. It involves patching and recompiling wine from source and might break other windows apps (and possibly more).

But I was able to sit a Jita IV Station for at least 2 hours without a single crash. It might not work for you though. I didn't get feedback from the people in "Linux" so far.

http://pastebin.com/iMN6FT86

Nevertheless it would be much better if the problem gets fixed either by CCP or the wine devs.

Edit: The patch above was created against wine 1.4 but also might apply against newer versions.


I will try this wine patch now to get over the weekend until the CCP update arrives. Thank you for that, Ny Draconis.

Man, thats the 4th separate wine version I'm patching and compiling today. Most of the time this works really well.

** Edit:
Patch works great on wine 1.4 on Debian Squeeze. Thanks very much.
Jack Malus
Priest Kings
#147 - 2012-04-27 23:44:49 UTC
Thanks for workarounds and the upcoming fix.

Also kudos to the person that figured out it was t3 ships causing the crash.
Buzzy Warstl
Quantum Flux Foundry
#148 - 2012-04-28 00:28:01 UTC
Ny Draconis wrote:
With CCP now fixing this issue (BIG thanks for that, CCP Snorlax!) I'm not sure wether I should post my somewhat very ugly temporary solution. It involves patching and recompiling wine from source and might break other windows apps (and possibly more).

But I was able to sit a Jita IV Station for at least 2 hours without a single crash. It might not work for you though. I didn't get feedback from the people in "Linux" so far.

http://pastebin.com/iMN6FT86

Nevertheless it would be much better if the problem gets fixed either by CCP or the wine devs.

Edit: The patch above was created against wine 1.4 but also might apply against newer versions.

Works with 1.5.2 git trunk on Debian sid.

Thanks.

http://www.mud.co.uk/richard/hcds.htm Richard Bartle: Players who suit MUDs

Fam Trinly
Russian SOBR
Dragon Empire.
#149 - 2012-04-28 04:47:08 UTC  |  Edited by: Fam Trinly
Sidra Necia wrote:
...not sure if it is the right guide though.

the guide is actual (in part of starting repair.exe with --server=sisi and starting eve.exe with /server:Singularity)

Tried today, found my mistake in command-line, successfully started Singularity client with
WINEDLLOVERRIDES="*msvcrt,*msvcr100,*msvcr90,*msvcr80=n,b" to patch
and then
env LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 WINEDLLOVERRIDES="*msvcrt,*msvcr100,*msvcr90,*msvcr80=b,n" wine explorer /desktop=EVE-singularity1,1920x1200 "c:\\Program Files\\Singularity1\\eve.exe" /server:Singularity
to run Eve,


ArrowI see that client is NOT crashing on SiSi when I click in ship info of tengu to see preview,

thank you CCP Snorlax !
Big smile
Isphirel
GoonWaffe
Goonswarm Federation
#150 - 2012-04-28 10:21:20 UTC
Ny Draconis wrote:
But I was able to sit a Jita IV Station for at least 2 hours without a single crash. It might not work for you though. I didn't get feedback from the people in "Linux" so far.

http://pastebin.com/iMN6FT86

Nevertheless it would be much better if the problem gets fixed either by CCP or the wine devs.

Edit: The patch above was created against wine 1.4 but also might apply against newer versions.


Patch applied against git master, and it works so far, it's pretty great. Thanks for this!
Talis Mahn
Aliastra
Gallente Federation
#151 - 2012-04-28 17:49:45 UTC
Seems there was a client patch today. I can fly my T3 in Tranquillity today! Yay CCP! And thanks for the help Snorlax! You rock!

One of the rare Linux Eve players

cargo2000
Sebiestor Tribe
Minmatar Republic
#152 - 2012-04-28 18:02:06 UTC
Talis Mahn wrote:
Seems there was a client patch today. I can fly my T3 in Tranquillity today! Yay CCP! And thanks for the help Snorlax! You rock!


With the client patch I crashed while previewing a proteus, but on the sisi server I was able to view a legion and tengu. Did the fix go live in this patch?
Talis Mahn
Aliastra
Gallente Federation
#153 - 2012-04-28 18:37:27 UTC  |  Edited by: Talis Mahn
It seems to have gone live, I'me sitting in my Legion in WH space right now


Ubuntu 11.10
Wine 1.5.2
Nvidia 295.40

One of the rare Linux Eve players

Talis Mahn
Aliastra
Gallente Federation
#154 - 2012-04-28 18:44:24 UTC  |  Edited by: Talis Mahn
Hmm, of course after I say that, I switch to my proteus and crash. But I logged back in and I can fly my proteus.

[edit]
Until another T3 lands on grid. Sight. Oh well waiting for Mondays patch

One of the rare Linux Eve players

Maquis196
Deep Core Mining Inc.
Caldari State
#155 - 2012-04-28 23:28:13 UTC
I'm looking forward to seeing the patch notes, would be great to see something like;

FIX: A python issue that prevented EVE client working on wine.

God damn love a patch like this. Snorlax you rock!
POS Trader
Merchants of Lore
#156 - 2012-04-29 03:14:53 UTC
CCP Snorlax wrote:
I believe the next scheduled client update is on Monday and this fix will be included in that.


Awesome! Looking forward to it.


Aside: my workaround that seems to work is just symlink of ships directory in cache to /dev/null.
Lairel Dallocort
Hot Lobster
#157 - 2012-04-29 04:04:28 UTC
POS Trader wrote:
CCP Snorlax wrote:
I believe the next scheduled client update is on Monday and this fix will be included in that.


Awesome! Looking forward to it.


Aside: my workaround that seems to work is just symlink of ships directory in cache to /dev/null.


That seems like a much better solution than the loop!
Bellista
JUST SET TIMES
#158 - 2012-04-29 04:23:23 UTC
Just want to add my name to the list. Ive crashed twice so far, but have only today got my Eve install working with Wine.

My crashes are happening in space, at jump gates both times, and with ships present but I didnt have time to see if there were any t3 ships present. I am willing to bet there was though. Hoping Monday patch fixes.

Ubuntu 11.10
Wine 1.4
Jack Cassidy
New Jovian Exploration Department
New Jovian Collective
#159 - 2012-04-29 06:16:55 UTC
Just wanted to add my 2 bob and say cheers to CCP Snorlax for working on a fix for an unsupported OS.
MrChipmunk Otsito
Poor Man Inc
#160 - 2012-04-29 10:11:02 UTC
POS Trader wrote:
CCP Snorlax wrote:
I believe the next scheduled client update is on Monday and this fix will be included in that.


Awesome! Looking forward to it.


Aside: my workaround that seems to work is just symlink of ships directory in cache to /dev/null.


Thanks very much for the simple fix. Works perfectly, except for the fact that I can't see T3 Cruisers, but who cares when there's an official fix coming!

Speaking of fixes, I just wanna say thank you CCP Snorlax for creating a fix for an unsupported OS! You'll probably be treated like a god among the Linux fanbase :)