These forums have been archived and are now read-only.

The new forums are live and can be found at

Issues, Workarounds & Localization

  • Topic is locked indefinitely.

Socket Closed

First post
Fifty Three
#1 - 2017-05-24 08:24:11 UTC
got disconnected 2 times tonight/this morning. Anyone else experiencing the same thing recently? I have to reconnect every time.
Caldari State
#2 - 2017-05-24 10:14:45 UTC
You'll get use to it, happens for weeks after new releases.
Lulu Lunette
Savage Moon Society
#3 - 2017-05-24 11:23:49 UTC
It's been a regular thing for me at least since December. It's so frequent it's my biggest danger now.


ISD Chanisa Nemes
ISD Community Communications Liaisons
#4 - 2017-05-24 13:51:00 UTC
Thread has been moved to Issues, Workarounds & Localization.

ISD Chanisa Nemes


Community Communication Liaisons (CCLs)

Interstellar Services Department

Mr Mieyli
#5 - 2017-05-24 14:17:10 UTC  |  Edited by: Mr Mieyli
Can any of you guys run a traceroute to one of the eve hosts and see if you get timeout problems there? If so try find out info about the IP address you get stuck at and let me know. I have a theory that there is some problem with a deal CCP has with Amazon over hosting, but it'd help to know more about other people's socket closed issues.

This post brought to you by CCP's alpha forum alt initiative. Playing the eve forums has never come cheaper.

Nasar Vyron
S0utherN Comfort
Test Alliance Please Ignore
#6 - 2017-05-24 16:02:27 UTC
I've had the same issues since right around December/January. It's almost a daily occurrence and it doesn't matter if I'm running one client or eight. When it happens it's horribly inconstant, different times of the day, number of clients socket closed on, time it takes to recognize the dropped connection.

I've started running Ping Plotter in the background to see if I cant detect anything live, since running a traceroute only tells you how the connection is at that moment. So far the only noteworthy packet loss has been on my 13th hop at any given time. All occurring on hops, the uk zayo backbone has yet to give any packet loss. The us however, I've seen it as high as 18%, which would be enough to start kicking people offline.

I'm not sure if those are tied to amazon in any way, but something is definitely up there. They're crap.

Also I'm 99.9% sure I'm correct, but if someone wants to correct me, I've been running it to:
Kenon Aurilen
Personal Protective Equipment
#7 - 2017-05-30 13:07:24 UTC
Thats is definitely the right address Nassar.

I've been having this problem since the weekend, but for me it's terrible, I can usually only make one jump before I'm disconnected, so you can imagine how frustrating it is trying to run a regular trade route.

So after doing a little investigation into this problem - searching through this forums and reading redit posts - I've discovered that this has been a reported problem for years ... since 2014 at least, maybe even before that, I don't know.

So now I find myself being incredibly disappointed with the lack of progress in finding a solution; or at least the root cause of the issue. I was considering subscribing to the game - I've only been playing for three weeks and up until this weekend I was enjoying it immensely. But now I have to say that it's not even worth dropping a mere $20 / month if stability issues like this have not been resolved after three years !

UK Trading
#8 - 2017-05-31 06:53:10 UTC  |  Edited by: Polco
The problem is CCP are in denial on this subject and when you contact support CCP blame your computer or ISP. Well answer me this CCP why doesn't any other game or application that uses the Internet on my computer ever receive a socket closed error?.
Strom DragonBane
Disonance and Co.
Unintentionally Traumatic
#9 - 2017-06-08 15:16:23 UTC
anyone find a workaround for this , getting socket closed 4 times in an hour is not fun. not renewing my subs if this keps up.
oTTo - NoRMaL
#10 - 2017-06-08 18:42:41 UTC
Strom DragonBane wrote:
anyone find a workaround for this , getting socket closed 4 times in an hour is not fun. not renewing my subs if this keps up.

same here in Germany, 1-2 socked closed in 1hour play every day. all other games, apps works absolutly fne, but in eve its only a pain :( i lost so many ships because this issue ... i hope they will fix that soon, or i lock for another game to play, sadly :(
Lux Nitor
#11 - 2017-06-11 15:56:28 UTC
TL;DR: When having this issue, try switching ISPs if possible.

I recently started playing again and after about three weeks I started running in to this issue. Thanks to my networking skills and unusual setup i've been able to gather some data to share as well as a possible solution for myself. Unfortunately it probably won't be applicable to most people.

Located in Los Angeles, CA, we have three separate internet connections available to our network:
Primary: Fiber - Spectrum
Secondary: Fixed Wireless - Aerio Connect
Tertiary: Cellular - Sprint

Socket Closed issues started occurring for me on the Primary connection, so I successfully routed Eve over to the Secondary connection and it worked fine. Ran a MTR (glorified traceroute) on eve from the Primary connection to find it dying at the end of a Spectrum route, then hopped back over once it was back.

Once this happened a second time I started a long term light weight trace route to Eve's launcher address on the Primary & Secondary connections (no point in logging Sprint cellular, we all know it will be sad.) After accounting for scheduled down times, the Spectrum connection had an average failure rate of 0.18%, while Aerio had less than 0.01%. The connection usually dies at (a Spectrum reverse DNS server) before reaching Amazon's (CloudFront?) servers like it should.

My conclusion from this very limited test is that my Spectrum internet connection is occasionally suffering some sort of routing issue to Eve's AWS servers.

For now I have all my Eve traffic running over the Secondary connection and haven't had an issue in three days.
oTTo - NoRMaL
#12 - 2017-06-12 10:19:46 UTC
iam not so skillt at networks, but thats what happend to me, if i MTR to

maybe you can tell me something about it.

| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
| - 12 | 6004 | 5291 | 1 | 11 | 102 | 10 |
| - 12 | 6004 | 5291 | 9 | 11 | 102 | 10 |
| - 12 | 6004 | 5291 | 13 | 14 | 49 | 14 |
| - 12 | 6001 | 5287 | 12 | 13 | 61 | 14 |
| - 12 | 6004 | 5291 | 13 | 20 | 114 | 22 |
| - 12 | 6005 | 5292 | 12 | 13 | 56 | 13 |
| - 12 | 6004 | 5291 | 13 | 14 | 61 | 18 |
| No response from host - 100 | 1781 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 1781 | 0 | 0 | 0 | 0 | 0 |
| No response from host - 100 | 1781 | 0 | 0 | 0 | 0 | 0 |
| - 0 | 8827 | 8827 | 12 | 13 | 53 | 13 |
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
The League of Magnificent Explorer's
#13 - 2017-06-14 20:29:25 UTC
Today the 14/6 I get disconnects all the time, I can keep the client in the air for around 10-15 minutes, then a disconnect. My old modem broke down today, so have installed a new one recieved from my ISP, to begin with I thought these disconnects was caused by bad hardware, but now reading this post, it seems to be something else.

Anyone have disconnects alot today ???
The League of Magnificent Explorer's
#14 - 2017-06-14 21:20:16 UTC
I tried to run two accounts at the same time, after 10 minutes, one of the accounts closed down with "Socket closed", the other one ran fine for a longer time.