These forums have been archived and are now read-only.

The new forums are live and can be found at


  • Topic is locked indefinitely.

Running WINE and a mouse disfunction.

Lying Bastard
#1 - 2016-06-15 18:12:20 UTC
First off, let me say thanks!. I've never really like wine since I could never get it to work well. It was a real pleasant experience to switch to wine, wait awhile, relaunch the launcher, wait awhile more and WOW! Graphics were a lot smoother, more detailed and it all worked fantastically. However, several hours in and the mouse(game?) started not working properly.

I can and could still click, control click, command click and select and all the normal mouse stuff. However, trying to drag my view around stopped. It is like I try and move, but the view slightly bumps in the direction i moved then slides back. All other mouse usage remains normal, just moving my view. The only way I've found to correct it was to quit the game and log back in. I've not had this issue in Cider.

I was having an issue with the kernel task ramping my cpu's to 600 and 700 percent. I thought that may have been the issue. After resolving that, I still had the issue with the view.

Anyone with ideas?

MacBook Pro Late 2011
Quad Core
AMD Radeon HD 6750M 512 MB

Mhzentul Lafarius
Caldari State
#2 - 2016-06-28 01:05:45 UTC
I am experiencing the same issue on a Mac Pro. I find that minimizing the window and maximizing again sometimes resolves the issue temporarily.

Vincent Athena
#3 - 2016-06-28 18:37:52 UTC
I find a similar issue now and then. Things that sometimes fix it:
Tap all the modifier keys: Shift, control, option, command.
Hold down the shift key and drag the space scene. Doing this once seems to reset something.
Dock and undock.

Know a Frozen fan? Check this out

Frozen fanfiction

Skilled Refugees
#4 - 2016-07-01 10:50:16 UTC
I have the same issue on the Mac - It happens when I use a mouse click to set focus. I have found that when it happens everything works except the dragging of windows around within the EvE client.

I have found the absolute reliable fix is to use CMD-tab to set focus to another window and then set it back to the EvE client. It has worked every time for me.
Project Gungnir.
#5 - 2016-07-02 02:07:55 UTC  |  Edited by: Invisusira
Yeah this happens to me all the time. I'm running windowed with a second monitor, so I just click into another program like the Finder or Chrome and then click back into EVE and it's fixed.

But yeah. Been happening to me for a while.
Lying Bastard
#6 - 2016-07-06 23:49:57 UTC
Thanks for the responses. Clicking out and back in has been working flawlessly for me. I still can't figure out if it is a Wine problem or Eve problem or even if it is the Mac. I do not believe it is the Mac since I've had no issues with this outside the game. I hope CCP looks into this...

Thanks again,

LUH-3417 Ormand
Gallente Distribution Manufacturing Mining
#7 - 2016-08-05 05:54:06 UTC
I'm having the same issue. Been happening since I made the switch to Wine.
#8 - 2016-08-05 16:59:51 UTC
Yep, I've been having the same issue all the time now too. Clicking out and then back into the program seems to rest something and fixes it for a bit.
Liza Ellecon
The Scope
Gallente Federation
#9 - 2016-10-04 15:37:17 UTC
Same problem here, running on 10.12.
Project Gungnir.
#10 - 2016-10-06 20:41:14 UTC  |  Edited by: Invisusira
edit: wow I just replied to a thread I already replied to
Amarisen Gream
Pleasant Peninsula Productions
Cauldron of Ecstasy
#11 - 2016-10-13 20:27:35 UTC
The problem from what I can tell is ether A) a modifier key sticks or B) wine loses focus.

I have been working on getting Snorlax a bunch of loglite files via google drive. I think I am up to 18 or 20 (pretty much one a day when I have more than 5 minutes to play)
The sixth log is the only one we're the game crashed on me.

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs